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ERS Interferometry Tutorial 
The goal of this tutorial is to provide novice and experienced remote sensing users with step-by-step 
instructions on interferometric processing of ERS products to estimate surface deformation.  
 

Background 

What is Interferometry? 

Interferometric synthetic aperture radar (InSAR) exploits the phase difference between two complex radar 
SAR observations taken from slightly different sensor positions and extracts information about the earth’s 
surface. 
 
A SAR signal contains amplitude and phase information. The amplitude is the strength of the radar 
response and the phase is the fraction of one complete sine wave cycle (a single SAR wavelength). The 
phase of the SAR image is determined primarily by the distance between the satellite antenna and the 
ground targets. 
 
By combining the phase of these two images after coregistration, an interferogram can be generated whose 
phase is highly correlated to the terrain topography. The remaining variation in the interferogram can be 
attributed to surface changes which occurred between the two image acquisition dates, as well as unwanted 
atmospheric effects. In this tutorial, surface changes which occurred between two image acquisitions are 
estimated using radar interferometry.  
 
For an introduction to interferometric concepts, please see ESA’s InSAR Principles: Guidelines for SAR 
Interferometry Processing and Interpretation (ESA TM-19). 
 
 

ERS Stripmap Products 

The European Remote Sensing Satellites (ERS) are two spaceborne radar sensors which were launched 
in July 1991 (ERS-1) and April 1995 (ERS-2) by the European Space Agency (ESA).  
 
Besides other instruments, such as radar altimeters or wind scatterometers, both systems operate a C-
band wavelength (5.3 GHz) synthetic aperture radar (SAR) for the formation of images at an azimuth 
resolution of 6 to 30 meters and a range resolution of 36 meters. Each image covers a footprint of 
approximately 100 x 100 kilometers.  
 
The repeat cycle, defined as the interval at which the satellite is able to acquire another image from the 
exact same position (same track) is 35 days. Between March 1995 and June 1996 both sensors were 
operating in a tandem phase, allowing same track temporal baselines of one day to reduce temporal 
decorrelation and increase the interferometric potential of the missions (Duchossois & Martin 1995).  
 
ERS-1 and ERS-2 operated at VV polarization until March 2000 and June 2003 respectively, clearly 
exceeding their initially expected lifetimes. Together with ENVISAT ASAR (2002-2012) which was flying in 
the same orbital plane, they achieved over 20 years of consistent and global coverage of radar imagery.  
 
More information on ERS products is provided here: https://directory.eoportal.org/web/eoportal/satellite-
missions/e/ers-1 and here https://directory.eoportal.org/web/eoportal/satellite-missions/e/ers-2.  
 
  

http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esapub/bulletin/bullet83/duc83.htm
https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/envisat/instruments/asar
https://directory.eoportal.org/web/eoportal/satellite-missions/e/ers-1
https://directory.eoportal.org/web/eoportal/satellite-missions/e/ers-1
https://directory.eoportal.org/web/eoportal/satellite-missions/e/ers-2
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Study area 

The data used in this tutorial is a part of a ERS acquisition in the US state of California and covers a footprint 
of around 16 x 27 km (Figure 1, blue line). It belongs to Kern county and covers parts of the Lost Hills Oil 
Field, one of many oil fields in California. Two ERS images from April and May 1995 are used in this tutorial 
to estimate deformation rates in this area.  

 
 

  

Figure 1: Extent and location of the data 

 
This tutorial is based on a study of Fielding, Blom and Goldstein: 
 
Fielding, E.J.; Blom, R.G.; Goldstein, R.M. (1998): Rapid subsidence over oil fields measured by SAR 
interferometry. Geophysical Research Letters 25(17), 3215-3218. https://doi.org/10.1029/98GL52260.  
 
The reference study makes use of more than one image pair to analyze the sensitivity of image 
combinations on the observed deformation: They use temporal baselines between one day and 26 months 
to assess surface subsidence at different temporal scales and to get  the maximum deformation rate.  
 
In this tutorial, only one image pair is used with a temporal baseline of 35 days and a perpendicular baseline 
of 20 meters, but all results could be replicated with the additional images listed in Table 1 of the study.   
 

https://en.wikipedia.org/wiki/Lost_Hills_Oil_Field
https://en.wikipedia.org/wiki/Lost_Hills_Oil_Field
https://doi.org/10.1029/98GL52260
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Preparation 

Download the Data 

The data used in this tutorial can be downloaded from the ESA Online Dissemination Service:  
https://esar-ds.eo.esa.int/oads/access/ 
 
An ESA Earth Observation Users' Single Sign On (EO-SSO) login is required, but it can be freely registered 
here: https://earth.esa.int/web/guest/general-registration  
 
Once you are logged in, navigate to Collections and select SAR_IMS_1P - Level 1 product for ERS SAR. 
IMS represents the Single Look Complex product which contains the real and imaginary part of the complex 
radar signal. This is required for SAR interferometry. Accordingly, it is important not to select IMP which is 
a Precision Image product, only containing backscatter intensity (more information on product specifications 
is given here).  
 
Although there are many ways to find the products, the easiest is via the Catalogue search. Enter the 
parameters as specified below and displayed in Figure 2:  
 

• Acquisition date: from 1995-04-21  to 1995-05-26 

• Track:    from 163   to 163 

• Frame:    from 703  to 703 
 

 

Figure 2: Search for suitable ERS images  

https://esar-ds.eo.esa.int/oads/access/
https://earth.esa.int/web/guest/general-registration
https://esar-ds.eo.esa.int/oads/access/collection
https://esar-ds.eo.esa.int/oads/access/collection/SAR_IMS_1P
https://earth.esa.int/web/sppa/mission-performance/esa-missions/ers-1/sar/products-and-algorithms/products-information
http://esar-ds.eo.esa.int/socat/SAR_IMS_1P
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Execute the query by clicking “Search”. it yields exactly two products which are located in the study area 
(Figure 3).  
 
#1  SAR_IMS_1PNESA19950421_061616_00000015G145_00163_19690_0000.E1 
#2  SAR_IMS_1PNESA19950526_061620_00000015G146_00163_20191_0000.E1 
 
 

 

Figure 3: Result of the query 

 
Download them by clicking on the corresponding download link in the results list below the map. Note that 
a separate window opens, and it can take some minutes until the download starts. It is therefore important 
not to close this page before.  
 
As some of the required steps are computationally intensive, it is good to store the data at a location which 
offers good reading and writing speed. If your computer has an internal SSD, processing should be done 
there to ensure best performance. Network drives or external storage devices are not recommended. Also, 
paths which include special characters should be avoided. In this tutorial, the data is stored under 
C:\Temp\ERS\Fielding\. 

 
 
Note: The ESA Online Dissemination Service also allows to search for specific interferometric 
configurations using the Interferometric search. It allows to define the maximum temporal baseline (e.g. to 
find image pairs of ERS-1 and ERS-2 acquired during the tandem phase) or to identify pairs with ideal 
perpendicular baselines. Recommendations on the selection of suitable image pairs are given in ESA TM-
19B, chapter 1.4).  

  

https://en.wikipedia.org/wiki/Solid-state_drive
http://esar-ds.eo.esa.int/socat/SAR-ASA_IMS_1P/pair_search
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
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Install snaphu 

This tutorial can entirely be done within SNAP. Yet, as an external software package, snaphu (statistical-
cost network-flow algorithm for phase unwrapping) has to be installed separately. For more information on 
this tool, please visit https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/. 
 
To install the plugin in SNAP, go to Plugins (under the Tools menu, Figure 4) and search for “SNAPHU 
Unwrapping” in the Available Plugins tab. Select it and click Install. 
 

 

Figure 4: The Plugins interface 

 
You will be asked to proceed with “Next” and restart SNAP (Figure 5). This creates a menu entry for snaphu 
unwrapping in the Interferometry menu. 

  

Figure 5: Installation of the snaphu plugin  

https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/
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After you have restarted SNAP, you need to install the snaphu bundles as well. Go to Manage External 

Tools in the Tools menu. Select “Snaphu-unwrapping” and click Edit the selected operator   to open 
the configuration (Figure 6). Select a suitable Target Folder (here C:\GIS) where snaphu will be installed 

and proceed with Download and Install Now. You will then get a confirmation “Bundle was installed in 
location C:\GIS\snaphu-v1.4.2_win64” (this may differ according to version, path and operating system).  
 

 

Figure 6: Installation of the snaphu bundles  
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Open the Products 

Use the Open Product button in the top 
toolbar and browse for the location of the 
downloaded data. Select the two files ending 
with *.E1 file located in your working directory 

and press Open Product.  
 
In the Products View you will see the opened 
products. Each ERS product consists of a 

number of metadata  , tie-point grids and 

raster entries. The radar information is stored 
in the i and q raster as the real and imaginary 

parts of the complex signal and the resulting 
backscatter intensity as demonstrated in  Figure 
6. 
 
Double-click on “Abstracted Metadata” to view 
the most important parameters of the imaging 
system. For example, the native resolution of 
the raster is given by  

• range_spacing (7.9 m) and 

• azimuth_spacing (3.98 m)  

as shown in Figure 8. 
 
Double-click on the Intensity band to view 

the raster data (Figure 9). Depending on the 
capabilities of your computer, this might take a 
while.  
 
The footprint of the radar image is displayed in 
the World View or World Map. It shows that both 
images cover the same track (required for 
interferometry) and frame.  
 
Because of the side looking geometry of the 
SAR system and the smaller resolution in 
azimuth direction, the squared footprint of the 
image is displayed rectangular in the image 
view 
  

 

Figure 7: Product Explorer and World Map 

  

 
 

 

Figure 8: Metadata of the imported product 
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Figure 9: Preview of the ERS-1 product 

 
 

Applying Orbit Information 
Orbit auxiliary data contain information about the 
position of the satellite during the acquisition of 
SAR data. 
 
They are automatically downloaded for ERS 
products by SNAP and added to its metadata with 
the Apply Orbit File (under the menu point Radar) 
operator. More information on the orbit files 
provided for ERS products is given here: 
https://earth.esa.int/web/guest/-/prare-precise-
orbit-product  
 
Execute the operator for both split products as 
generated in the previous step (Figure 10). 

 

Figure 10: Apply Orbit File 

 
Use suitable output names for the target products. In this tutorial, the products are named: 
 

• 19950421_Orb.dim 

• 19950526_Orb.dim 

 

The output products are written in the BEAM DIMAP format which conserves all metadata required for the 
later processing steps.  

https://earth.esa.int/web/guest/-/prare-precise-orbit-product
https://earth.esa.int/web/guest/-/prare-precise-orbit-product
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Coregistration 
To exploit the phase difference of the acquisitions, a stack containing both products must be created first. 
Coregistration makes use of image statistics to align both products at sub-pixel accuracy. Conventional 
Stripmap radar products can be coregistered the Coregistration operator (under Radar > Coregistration).  
 
Load the two products (with orbit files applied) to the ProductSet-Reader tab (Figure 11, left). Depending 
on the quality of the orbit files, the difference in Doppler centroid, and the image content of the radar image, 
it might be necessary to increase the Number of GCPs in the Cross-Correlation tab. In this case, the 
standard parameters are sufficient.  
 
To increase the chances to find many usable ground control points, it is advisable to coregister the full 
images and make a subset later.  
 
Enter ERS_Orb_Stack as target name and click Run to start the coregistration. Depending on the size of 

the products and the number of GCPs, this can take a while.  
 

 

Figure 11: Coregistration of ERS products 

 
After the coregistration is completed, it is advisable to visually check the quality of the stack. This can be 
done by an RGB representation of the reference and secondary1 product which shows if the images are 
correctly aligned. Select red and green for the reference and blue for the secondary image (Figure 12) 2.  
 

 

Figure 12: Generation of an RGB image  

 
1 We support the statement of the executive committees of WInSAR and COMET to exchange the inappropriate terminology in all 

InSAR-related fields. Accordingly, the former "master/slave" will be replaced by "reference/secondary" in future versions of SNAP. 
2 https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/  

https://comet.nerc.ac.uk/about-comet/insar-terminology/
https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/
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Zoom in to an area with distinct surfaces, for example the tree plantations and almond orchards in the 
middle of the scene. The borders of the fields, as well as the roads should be sharply separable by the 
human eye. In the example below black lines indicate successful coregistration. Areas which have not 
changed between the first and the second image are displayed in black or white. These are mostly urban 
areas or bare land. Changes in backscatter intensity are indicated by yellow (red + green; decrease of 
backscatter intensity) or blue (decrease of backscatter intensity).  
 

 

Figure 13: Successful coregistration in an RGB image 
 

To furthermore check the accuracy of the coregistration, the InSAR Stack tool  can be selected from the 
menu. A new window opens on the right side with the tab “Coregistration Residuals”. As the initial 
distribution of GCPs is random, these results can differ with every run. In this case, 130 ground control 
points remained which had the required tolerance (defined in the Cross-Correlation tab of the coregistration 
module). In the summary, rms stands for “root mean square” determining the average difference of the 
ground control point to the selected polynomial. The average rms of 0.26 meters confirms coregistration 
accuracy at the sub-pixel level.  
 

 

Figure 14: Coregistration quality  
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Create a Subset 
To reduce the coregistered stack 
data to the area of interest, select 
each of the two products and 
open the open the Subset 
operator (under Raster). A 
separate window might open 
(“Creating thumbnail image”), but 
this takes quite a long time, so it 
is ok to Cancel this window.  
Enter the pixel coordinates as 
shown in Figure 15 and confirm 
with OK.  
 
▪ Scene start X: 500 

▪ Scene start Y:  12500 

▪ Scene end X: 1100 

▪ Scene end Y:  18000 

 
A new product occurs in the 

Product Explorer, starting with 

subset_0_of_. This product is 

only of temporary nature and lost 

after SNAP is closed.  
Figure 15: Creating a subset 

 
To permanently store this subset, right-click on the 
product, select Save Product As… and save it in BEAM 
DIMAP format under ERS_Orb_Stack_subset.dim. 

 
Again, because of the different spatial pixel widths in 
azimuth and range direction, the subset appears as a 
rectangle but will have a more quadratic shape when it is 
converted to ground range after proper geocoding. This is 
also shown in the World Map tab when comparing the 
original product with the subset (Figure 16).  
 
Generally, it is advisable for InSAR analyses to work in the 
slant range domain as long as possible to preserve the 
phase information. Conversion to ground range is done 
after computation of the final results as the last step.   
 
Creating a subset has several advantages: Firstly, the 
dimensions of the raster can be reduced to accelerate the 
later processing steps. Secondly, cropping the image to a 
smaller extent is advisable to reduce the risk of 
unwrapping errors which occur in areas of low coherence 
and potentially introduce faulty patterns in the 
interferogram. The smaller the area of interest, the lower 
is the risk of unwrapping errors propagating over the 
image.   
 

  

Figure 16: Extent of the full image  
(white) and the subset (red) 
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Interferogram Formation and Coherence Estimation 
An interferogram is formed by cross multiplying the reference image with the complex conjugate of the 
secondary. The amplitude of both images is multiplied while the phase represents the phase difference 
between the two images. 
 
The interferometric phase of each SAR image pixel would depend only on the difference in the travel paths 
from each of the two SARs to the considered resolution cell. Accordingly, the computed interferogram 
contains phase variation ϕ from several contributing factors, most importantly the flat-earth phase ϕflat (earth 
curvature), the topographic phase ϕDEM (topographic surface of the earth), atmospheric conditions ϕatm 
(humidity, temperature and pressure change between the two acquisitions), and other noise ϕnoise (change 
of the scatterers, different look angle, and volume scattering ), and lastly the eventual surface deformation 
ϕdisp which occurred between the two acquisitions (Equation 1).  
 
A more detailed explanation is given by Roca et al. (1997), and in the documents compiled by ESA: InSAR 
Principles: Guidelines for SAR Interferometry Processing and Interpretation (ESA TM-19). 
 
 

 ϕ = ϕDEM + ϕflat + ϕdisp + ϕatm + ϕnoise  (1) 

 
 

 

Figure 17: Contributors to SAR interferometric phase 

 
Differential SAR interferometry tries to estimate the contribution from the earth’s surface (ϕflat and ϕDEM) 
which is considered equal for both image acquisitions and remove them from the interferogram so that the 
remaining phase variation can be attributed to surface elevation changes between both image acquisitions 
(Equation 2; ESA TM-19A, chapter 2.3). This works best if atmospheric contributions and other noise is 
kept as small as possible because they are hard to model. It is therefore advisable to use images from the 
dry season and with small perpendicular baseline. More hints on the selection of suitable image pairs are 
given in ESA TM-19B, chapter 1.4) 
 

 

 ϕdisp + ϕatm + ϕnoise = ϕ - ϕDEM - ϕflat (2) 

 
 

Besides the interferometric phase, the coherence between the reference and the secondary image is 
estimated as an indicator for the quality of the phase information. Basically, it shows if the images have 
strong similarities and are therefore usable for interferometric processing. Loss of coherence can produce 
poor interferometric results and is caused by temporal (over vegetation and water bodies), geometric (errors 
or inaccuracies in the orbit metadata) and volumetric decorrelation (potential scattering mechanisms of 
voluminous structures, such as complex vegetation or dry surfaces).  
 
 

Accordingly, repeat-pass interferometry (phase difference of images of two different 
acquisition dates) will rarely lead to usable results over dense vegetation, especially with  
C-band SAR data of ERS which has a wavelength of around 5.5 cm). 

https://earth.esa.int/workshops/ers97/program-details/speeches/rocca-et-al/
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esapub/tm/tm19/TM-19_ptA.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
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Coherence is calculated as a separate raster band and shows how similar each pixel is between the 
secondary and reference images in a scale from 0 to 1. Areas of high coherence will appear bright. Areas 
with poor coherence will be dark. In the image, vegetation is shown as having poor coherence and buildings 
have very high coherence. 
 
To compute the interferogram and the coherence bands, apply the Interferogram Formation operator (under 
Radar > Interferometric > Products). Select the subset created in the previous step as an input and make 
sure to check the boxes: 
 

▪ Subtract flat-earth phase: The flat-earth phase is the phase present in the interferometric signal 
due to the curvature of the reference surface. The flat-earth phase is estimated using the orbital 
metadata information and subtracted from the complex interferogram. 

 
▪ Subtract topographic phase: Flat terrain should produce a series of regularly spaced, parallel 

fringes. Any deviation from a parallel fringe pattern can be interpreted as topographic variation. If 
you want this topographic variation (e.g. for the derivation of a digital elevation model), you do not 
subtract the topographic phase. As this workflow is interested in the surface displacement 
(Equation 2), topographic phase removal is applied by selecting the SRTM 1Sec HGT (Auto 
Download). 

  
▪ Include coherence estimation: This produces a coherence band in the output calculated based 

on a window of 10x55 pixels in range/azimuth direction based on equation 1.13 in ESA TM-19C.  
 
The resulting product will contain the 
interferogram (Phase_ifg_) and the 

coherence (coh_) as separate bands 

(Figure 19). Double click them to check for 
their quality. Both products still contain the 
black seamlines separating the single 
bursts. They will be removed in the 
following step. 
 
As topographic phase removal was 
applied, the interferogram should now only 
contain variations from displacement, 
atmosphere and noise. It is displayed in a 
rainbow color scale ranging from -π to +π. 
The patterns, also called “fringes” 
represent a full 2π cycle and appear in an 
interferogram as cycles of arbitrary colors, 
with each cycle representing half the 
sensor’s wavelength. Relative ground 
movement between two points is later 
derived by counting the fringes and 
multiplying by half of the wavelength. The 
closer the fringes are together, the greater 
the strain on the ground.  
 

 

Figure 18: Interferogram Formation 

 
Areas of high coherence (bright) indicate where the phase information is coherent, which means that it can 
be used to measure deformation (as in this tutorial) or topography (without removing the topographic 
phase). In this case, these are mostly urban areas and bare lands without much vegetation cover.  
 
In turn, low coherence is observed over the orchard fields which are covered by trees during the time of 
acquisition. Growth and movement of the trees between the first and the second image causes a change 

https://www.esa.int/esapub/tm/tm19/TM-19_ptC.pdf
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in surface scattering mechanisms, leading to low coherence and phase decorrelation. If low coherence 
areas are too dominant in the image, the later unwrapping will fail and produce faulty or random results. As 
shown in Figure 19, areas of high coherence have clear patterns in the interferogram while areas of low 
coherence have random phase. The overall distribution of coherence is shown in the histogram (Figure 21).  
 

 

Figure 19: Interferogram (left) and coherence (right) 

 
As shown in Figure 20, the oil fields are mostly bare areas or covered by metal objects. These surfaces 
produce a stable phase return for reliable analyses. In turn, the almond orchards are dominated by volume 
scattering. Interferometric phase cannot be exploited here because of temporal and volume decorrelation.  
 

 

Figure 20: Photograph from the oil fields (left, credit to Eric Fielding, JPL)  
and the orchards (right, image From Google Street View)  
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Figure 21: Histogram of interferogram (left) and coherence (right) 

 

Goldstein Phase Filtering 
Interferometric phase can be corrupted by noise from temporal and geometric decorrelation, volume 
scattering, and other processing errors. Phase information in decorrelated areas cannot be restored, but 
the quality of the fringes existing in the interferogram can be increased by applying specialized phase filters, 
such as the Goldstein filter which uses a Fast Fourier Transformation (FFT) to enhance the signal-to-noise 
ratio of the image.  
 
A filtered phase image is required for a proper unwrapping in the subsequent step. A detailed description 
of this filter and its parameters is given in the publication of Goldstein & Werner (1998).  
 
Apply the Goldstein Phase Filtering (under Radar > Interferometric > Filtering) to the inteferogram image. 
The output is a filtered phase image (Figure 22) with a clearly reduced amount of noise. But it is also shown 
in the image that filtering can only improve the interferogram quality in areas of good coherence. It cannot 
restore fringes of completely decorrelated areas. Furthermore, coherence is not affected by the filtering and 
cannot be increased accordingly.  
 

 
Figure 22: Interferogram before (left) and after (right) Goldstein phase filtering  

https://agupubs.onlinelibrary.wiley.com/doi/abs/10.1029/1998GL900033
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Phase Unwrapping 
In the interferogram, the interferometric phase is ambiguous and only known within the scale of 2π. To be 
able to relate the interferometric phase to the topographic height, the phase must first be unwrapped. The 
altitude of ambiguity is defined as the altitude difference that generates an interferometric phase change of 
2π after interferogram flattening. 
 
Phase unwrapping solves this ambiguity by integrating phase difference between neighboring pixels. After 
deleting any integer number of altitudes of ambiguity (equivalent to an integer number of 2π phase cycles), 
the phase variation between two points on the flattened interferogram provides a measurement of the actual 
altitude variation (Figure 23). Accordingly, unwrapped results should be interpreted as a relative 
height/displacement between pixels of two images.  
 
 
 

 

Figure 23: Principle of phase unwrapping 

 
 
The quality and reliability of unwrapped results very much depends on the input coherence. Reliable results 
can only be expected in areas of high coherence. Although no definite threshold exists, a minimum 
coherence of 0.3 is suggested.  
 
Unwrapping in SNAP follows three distinct steps:  
 

1. Export of the wrapped phase (and definition of the parameters)  
2. Unwrapping of the phase (performed outside SNAP by snaphu) 
3. Import of the unwrapped phase back into SNAP 

 
Because snaphu is an independent software (see under “Preparation” > “Install snaphu”), the unwrapping 
is executed outside SNAP, but the plugin allows to call this execution, so no command line processing is 
required any longer.  
 
Depending on the capabilities of the system, the unwrapping can take a considerable amount of time. 
However, snaphu supports multi-threading which means that the computation can be distributed over 
multiple processor cores. This has to be defined during the export.  
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Export 

The Export operator (under Radar > Interferometric > Unwrapping) converts the interferogram (as the 
wrapped phase) into a format which can be read by snaphu. Furthermore, a couple of parameters can be 
selected which affect the unwrapping process and stored in a configuration file which is accessed by 
snaphu.  
 
The source product is the subset created in the previous step. In the SnaphuExport tab, select your working 
directory as the target folder (here: C:\Temp\ERS\Fielding). If the selection of the directory does not 

work, simply copy and paste the path of your working directory into the text field. Select TOPO as Statistical-
cost mode and select 200 pixels for Row Overlap and Column Overlap (Figure 24). Depending on the 
number of processors of your computer, you can also increase the Number of Processors variable.  
 
Note: You can neglect the eventual error message (Error: [NodeId: SnaphuExport Please add a target 

folder]. It will go away once you switch tabs or hit Run, as long as you have entered a valid target folder.  

 
To learn about the meaning and impact of all parameters, please consult the official documentation.  
 
 

 

Figure 24: Snaphu export 

 
 
Hit Run to start the export. A directory is created in your working directory with the same name as the 
product you selected as an input (here: ERS_Orb_Stack_subset_ifg_flt). Inside this folder, you find:  

 
▪ the coherence: image (*.img) and metadata (*.hdr) 

▪ the wrapped phase: image (*.img) and metadata (*.hdr) 

▪ the unwrapped phase: only the metadata (*.hdr), because the image (*.img) is first to be created 

by snaphu in the next step.  
▪ a configuration file (snaphu.conf) containing the parameters defined in the export operator 

https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/snaphu_man1.html
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Unwrapping with snaphu 

Once the product is exported correctly, the unwrapping can be started from within SNAP, by calling the 
Snaphu-unwrapping operator (under Radar > Interferometric > Unwrapping). As an input product, select 
the subset which was created before the export from the drop-down menu. For the output folder in the 
Processing Parameters tab you can activate Display execution output and select the folder which was 
created during the export (here: 20181227_20190108_Orb_Stack_ifg_ML_flt). To start the 

unwrapping, click Run. SNAP then sends the command stored in snaphu.conf to the snaphu.exe which 

creates the raster image belonging to the unwrapped phase metadata.  
 

 

Figure 25: Unwrapping with the snaphu plugin 

 
Note: If the tool is not executed by clicking Run, go to Manage External Tools in the Tools menu. Select 
“Snaphu-unwrapping” and click Edit the selected operator  to open the configuration and enter the 
export directory in the variable USERPROFILE under the System Variables tab. Confirm with OK and start 
the Snaphu-unwrapping operator again.  
 

 
Figure 26: System variables of the snaphu plugin  
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Note that unwrapping can take a considerable amount of time. To break the raster into smaller chunks, 
snaphu divides it by standard into 10 rows and 10 columns, leading to a total of 100 tiles to be unwrapped. 
These tiles are merged afterwards based on the selected pixel overlap (here 200 pixels). A progress bar 
will inform you about the remaining time (Figure 27). The calculation is completed when the progress 
reaches 100% and the output states “Finished tool execution in … seconds”. You can then close the 
operator.  
 

 

Figure 27: Progress of the unwrapping 

 
Alternative option: If the unwrapping does not work with the plugin from within SNAP, snaphu can also be 
started from the command line. It can be downloaded from the following page which also contains 
instruction for its manual execution: https://step.esa.int/main/third-party-plugins-2/snaphu/  
 

Import 

The opened unwrapped phase does not have any metadata or geocoding. The Snaphu import (under Radar 
> Interferometric > Unwrapping) converts the it back into the BEAM DIMAP format and adds the required 
metadata from on the wrapped phase product as they have the same geometry. The Snaphu import needs 
the following tabs:  
 

▪ 1-Read-Phase: Here, you select the subset of the interferogram (before the export) from the drop-
down menu. 

▪ 2-Read-Unwrapped-Phase: Select the  icon to open a file menu and navigate to the export 
directory. Select the *.hdr file of the unwrapped phase (in this study it is called 
UnwPhase_ifg_21Apr1995_26May1995.snaphu.hdr). Note: The error message will then 

vanish if you proceed to the next tab.  
▪ 3-SnaphuImport: Leave the option “Do NOT save Wrapped interferogram in the target product” 

unchecked, because it is required in the later step.  
4-Write: To store the imported unwrapped band in a separate product (recommended), add ‘_unw’ 
to the output name (here: ERS_Orb_Stack_subset_ifg_flt_unw) and click Run. 

 
 
 
A new product is added to the Product Explorer which contains the wrapped interferogram (Phase_ifg_), 

the coherence (coh_) and the unwrapped phase generated with snaphu (here: 

Unw_Phase_ifg_21Apr1995_26May1995).  

 
Double click on the unwrapped phase to see if the unwrapping was successful. It should be a smooth raster 
with little variation except for the areas of expected deformation (Figure 28). All fringe patterns are 
summarized to absolute changes (Figure 23). Unwrapping errors can occur in areas of low coherence and 
in urban areas with many vertical objects.  
 
If you notice strange grid-like patterns in your unwrapped results, you can change the amount of tile columns 
and rows in the export (or directly in the snaphu.conf file) and run the unwrapping again. Just make sure 

https://step.esa.int/main/third-party-plugins-2/snaphu/
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you delete the unwrapped phase (UnwPhase_ifg_[…].img) and the temporary files in the export 

directory before you restart the unwrapping. Sometimes it is also favorable to switch the statistical cost-
mode from DEFO to SMOOTH or the initial method from MCF to MST and compare the outputs.  
 
As shown in Figure 28, the unwrapped phase no longer shows recurring colors but only a general trend 
from purple (low values) to blue (high values). At areas of noisy phase (bottom right) smaller unwrapping 
errors can be observed as purple patches with values outside the common trend.  
 

 

Figure 28: Phase before (left) and after (right) unwrapping 

 

Phase to Displacement 
The unwrapped phase is now a continuous raster but not yet a metric measure. To convert the radian units 
into absolute displacements, the Phase to Displacement operator (under Radar > Interferometric > 
Products) is applied. It translates the phase into surface changes along the line-of-sight (LOS) in meters. 
The LOS is the line between the sensor and a pixel. Accordingly, positive values mean uplift and negative 
values mean subsidence of the surface (if the reference image is the earlier acquisition date).  
 
The Phase to Displacement operator has no parameters and is applied to the unwrapped phase which was 
imported in the last step. It produces an output which looks similar to the unwrapped phase (slightly different 
predefined color ramp), but now each pixel has a metric value indicating its displacement (Figure 29). The 
spikes in the histogram result from constant values introduced at the right margin of the product.  
 

 

Figure 29: Histogram of unwrapped phase (left) and LOS displacement (right)  
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Include coherence 
The original phase and coherence bands are not automatically copied into the resulting raster of the Phase 
to Displacement operator. If they are needed in the final product, they can be imported from a previous 
product via the Band Maths operator (right-click on the displacement product and select Band Maths).  
 
Call the new raster which is to be generated coherence and uncheck the “Virtual” option (Figure 30, left). 

Open the Band Maths Expression Editor by clicking Edit Expression. You can now switch between 
products which have the same dimensions (rows and columns) in the Band Maths Expression Editor and 
double-clicking the coherence band of a previous product to add it to the expression window. Confirm with 
OK (twice) to apply the calculation.  
 

 

Figure 30: Transfer of bands between products 

 
The coherence band is now part of the displacement product as shown in Figure 31. Save the made 
changes by selecting File > Save Product in the menu.   
 
This allows to geocode both the displacement and coherence rasters in the next step. This makes sense 
whenever there are larger areas of low coherence which should be masked out in the final result for reasons 
of transparency.  
 

 
Figure 31: Displacement and Coherence in one product  
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Terrain Correction 
Terrain Correction will geocode the image by correcting SAR geometric distortions using a digital elevation 
model (DEM) and producing a map projected product. 
 
Geocoding converts an image from slant range or ground range geometry into a map coordinate system. 
Terrain geocoding involves using a Digital Elevation Model (DEM) to correct for inherent geometric 
distortions, such as foreshortening, layover and shadow (Figure 32). More information on these effects is 
given in the ESA radar course materials.  
 
 

 

Figure 32: Geometric distortions in radar images (Braun 2019) 

 
Open the Range Doppler Terrain Correction operator 
(under Radar > Geometric > Terrain Correction). Select 
the displacement product as an input in the first tab.  
 
In the Processing Parameters tab, select SRTM 1Sec 
HGT (AutoDownload) as input DEM.  
 
As shown in the dialogue, the resolution of 3.98 meters in 
range direction and 22 meters in azimuth direction is finally 
resampled to an output resolution of 22 x 22 m using 
bilinear interpolation.  
 
If you want to export the data as a KMZ file to view it in 
Google Earth WGS84 must be selected as Map 
Projection. It is based on geographic coordinates (latitude 
and longitude). For the later use in a geographic 
information system (GIS) a metric map projection, such as 
UTM (Automatic) could be selected as well.  
 
If no Source Band is selected, all bands of the input 
product are geometrically corrected.  
 
Click on Run to start the terrain correction and open the 
resulting geocoded displacement raster (Figure 34). 

 

Figure 33: Range Doppler Terrain Correction 

https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-3/-/asset_publisher/mQ9R7ZVkKg5P/content/radar-course-3-slant-range-ground-range
hdl.handle.net/10900/91317
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Figure 34: Terrain corrected and geocoded displacement raster  
before (left) and after (right) masking of low coherence areas 

 

Mask out low coherence pixels  

Sometimes it is good to mask out image parts with low coherence to prevent misinterpretation of patterns 
which resulted from phase decorrelation. Therefore the coherence was transferred into the displacement 
product in the previous step.  
 
To mask them out, right-click on the geocoded displacement band and select Properties. In the Valid-
Pixel Expression, enter the term coherence_VV > 0.2 (Figure 35). All pixels with a coherence value 

below 0.2 are now made transparent in SNAP. 
 

 

Figure 35: Masking of low coherence pixels  
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Check and correct for offsets 

You can digitize a line  and use the Profile Plot tool   to visualize single displacement patterns 
and their ranges (Figure 36). This is also a good way to check also the amount of noise in the data and test 
for a general offset.  
 

 

Figure 36: Profile plot for the displacement band across the subsidence craters 

 
In this case, the line shows a clear decrease through the 
observed craters. However, areas with zero subsidence 
currently range around a value of -0.03 (≙ 3 cm per year). As 
this is very unlikely for the entire image, this offset has to be 
corrected.  
Note: Depending on your unwrapping, this offset can be slightly 
different.  
 
Right-click on the terrain corrected displacement product and 
open the Band Maths. Enter displacement_cor as name 

for the target raster. You can optionally enter a unit which will 
later be displayed in the legend of the raster when it is exported 
to Google Earth. 
 
Uncheck the “Virtual” option and enter the following expression:  
 
displacement_VV + 0.03 
 
Confirm with Run and make the changes permanent by 
selecting File > Save Product in the menu.  
 
The created product is 0.03 meters higher so that the areas of 
no expected change have zero displacement and the actual 
LOS displacement values of the craters are more reliable.  

 

Figure 37: Adjustment of the offset 
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Export to Google Earth 

All geocoded products (projected to WGS84) can be exported as a KMZ file to view them in Google 
Earth.  
 
Select a suitable color scale and color ramp in the Color Manipulation tab and then chose File > Export > 
Other > View As Google Earth KMZ 
 
Select an output directory and a suitable filename and confirm with Safe.  Open the kmz file in Google 
Earth to view the location of the displacement patterns on the satellite image base map (Figure 38).  
 

 

Figure 38: Result exported to Google Earth 

 

 
 
 
 

  

https://www.google.com/earth/download/gep/agree.html
https://www.google.com/earth/download/gep/agree.html
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For more tutorials visit the Sentinel Toolboxes website 
 

http://step.esa.int/main/doc/tutorials/ 
 
 

 
 

Send comments to the SNAP Forum 
 

http://forum.step.esa.int/ 
 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/

