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Electronic Documents for Mexico 
This document describes how to implement and use electronic documents with SAP Business One. 
The software for electronic documents is relevant for companies that run SAP Business One with 
localization for Mexico. This is document is relevant for SAP Business One 8.81, patch level 07 (PL07) 
and higher.  

Scope and Limitations 
The electronic marketing document, also known as Comprobante Fiscal Digital (CFD), is a legal 
change of the Fiscal Federal Code of Mexico (Código Fiscal de la Federación). An evolutionary model 
of the CFD is the Comprobante Fiscal Digital por Internet (CFDI) model, which describes similar 
electronic marketing document management with an additional valid online certification. The valid 
online certification is relayed by the local tax authorities of Mexico (SAT) to officially designated 
suppliers, PAC (Proveedor Autorizado de Certificación de CFDI).  
As of January 1, 2011, all companies in Mexico are required to provide taxpayers with digital 
marketing documents (CFD or CFDI) that contain the digital seal of the issuing tax payer, which must 
be covered by a certificate. 
The procedures described in this how-to guide refer to the CFD and the CFDI model, which are 
supported in SAP Business One by new functionality for the above-mentioned releases. For both 
models, the SAT issues a certificate for a requesting company with private and public keys. As part of 
the certification, the company using the CFD model also receives numbering ranges for electronic 
documents with approval to use them. Per the CFDI model, companies send the XML files of the 
documents to the PAC to receive certification and document numbering. 
SAP Business One supports the requirement for electronic documents with additional software, 
settings, and reports that cover the following accounts receivables (A/R) documents: A/R invoice, A/R 
down payment invoice, A/R credit memo, and A/R debit memo. 
In addition to the software changes to support electronic documents, SAP Business One includes 
runtime and designer functionality for managing electronic files. As part of the releases mentioned 
above, SAP provides Electronic File Manager (EFM), originally developed for SAP Business One 8.81, 
as a replacement of an add-on format definition tool for creating and editing electronic file formats. 
As part of the CFDI model, SAP Business One Integration Framework is used to manage sending and 
receiving electronic documents via the Internet to and from PAC. 

Glossary 
Term Description 

certificate Electronic document that uses a digital signature to 
bind together a key with an identity. The certificate 
can be used to verify that a key belongs to an 
individual or a company. 

digital signature Security mechanism for protecting digital data 

electronic document Digital marketing document or digital marketing 
receipt, such as an invoice 

For More Information 
For more information about Electronic File Manager, see the online help, SAP Note 1531223, and 
How to Design an Electronic File Format in Electronic File Manager: Format Definition in the 
documentation area of SAP Business One Customer Portal at 
http://service.sap.com/smb/sbocustomer/documentation.  

https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=1531223�
http://service.sap.com/smb/sbocustomer/documentation�
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For more information about B1i, see the Administrator’s Guide for the Integration Component in the 
Documentation folder on your product DVD, or visit the Channel Partner Portal 
(http://channel.sap.com/sbo/innovations.) 

http://channel.sap.com/sbo/innovations�
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Using Electronic Documents (CFD Model) 
This section describes how to use electronic documents according to the CFD model. 
 

Getting Ready to Use Electronic Documents (CFD Model) 
To enable the generation of electronic documents, the SAP Business One key user or administrator 
must ensure that the software has been installed with the appropriate configuration and settings by: 

• Assigning a certificate received from the taxing authority SAT to an SAP Business One 
company database. The certificate is stored in Microsoft Windows certificate storage. 

• Selecting the default electronic document export format and defining a folder for electronic 
document files. 

• Creating at least one document numbering series for electronic documents based on the 
numbering ranges received from the taxing authority SAT. 

 

Assigning a Certificate to the SAP Business One Database 
Certificates received from the taxing authority SAT usually have a validity timeframe of one or two 
years. Assigning a certificate is done only when a new certificate is received, when a current certificate 
expires, or when a certificate is no longer valid. 
C... 

Prerequisites 
Certificate from SAT is available in the Microsoft Windows certificate storage of each Windows user 
that creates electronic documents. 
Procedure 
...  
...  

1. In the SAP Business One Modules tab, choose Administration → System Initialization → 
Document Settings. 
The Document Settings window appears. 

2. Choose the El. Documents tab. 
 
 

NOTE 
The certificate information shown in this document is used to illustrate user interface 
features only. The information is from a certificate that SAT provided for testing purposes 
only. 
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3. To the right of the Certificate for Electronic Documents field, click the […] icon. 

The certificate selection window appears with a list of available certificates. 

 
4. To select a certificate, click the relevant certificate and then click the OK button. 

Information about the certificate is copied to the Certificate for Electronic Documents field. 
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Selecting Default Electronic Document Export Format and Defining a 
Folder for Electronic Documents 
The taxing authority SAT requires you to generate two types of files: 

• XML files for A/R invoices, A/R down payment invoices, A/R credit memos, and A/R debit 
memos 

• TXT file for reporting all electronic documents generated during one calendar month 
SAT defines the specific structure of the XML file for electronic documents and the TXT file for the 
monthly report.  
SAP Business One includes the default format files for electronic documents and the default format file 
for the report, which are created with Electronic File Manager.  

NOTE 
You can modify the default format definition file for electronic documents or for the 
monthly report with additional fields or create a new format definition file for specific 
business partners (see Creating and Modifying Format Definition Files). 

C... 

Prerequisites 
A certificate is linked to the SAP Business One company database.  
Several format definition files from SAP are available in a directory that you define in Administration → 
Setup → General → Electronic File Manager → Setup (format for local currency documents, format for 
foreign currency documents, format for input message, and format for report of electronic documents). 
Procedure 
...  
...  

1. In the SAP Business One Modules tab, choose Administration → System Initialization → 
Document Settings. 
The Document Settings window appears. 

2. Choose the El. Documents tab. 
3. To select the default format file for electronic documents, select the format file to the right of the 

El. Document Export Format field and click OK. 
This format file is now valid for all relevant marketing documents (invoices, down payment 
invoices, credit memos, and debit memos). 

4. To define a folder in which XML files generated for electronic documents are stored, choose 
Administration → System Initialization → General Settings. 

5. In the Path tab, specify a folder in the relevant field. 

Creating a Document Numbering Series for Electronic Documents 
In addition to providing your company a certificate for generating electronic documents, the taxing 
authority SAT provides numbering series that you use when creating electronic documents. To 
generate electronic documents, you must define at least one numbering series for electronic 
documents. You can specify a default numbering series and change the default value, for example, 
when the original default series reaches the last number. 
The primary key for numbering electronic documents is a prefix plus a number defined in a numbering 
series. Because the prefixes are different, numbers can be repeated and can overlap in several series. 
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Prerequisites 
A certificate is linked to the SAP Business One company database, a default file format for electronic 
documents is selected for your company, and a folder has been defined to store XML files created for 
electronic documents. 
Procedure 
...  
...  

1. In SAP Business One Module tab, choose Administration → System Initialization → Document 
Numbering. 
The Document Numbering - Setup window appears. 

2. To access the Electronic Series - A/R Invoices - Setup window, double-click the series name in 
both the Document Numbering - Setup window and the Series - A/R Invoices - Setup window. 

 
3. In the Electronic Series - A/R Invoices - Setup window specify the following: 

Field Description 

Name Name of numbering series 

First No. Starting number of the series 

Next No. Next number to be used in the series; calculated automatically as for 
standard numbering functionality 

Last No. Final number of the series 
If the last number is reached during the generation of an electronic 
document, the system does not automatically assign a number from a 
different numbering series. An error message appears that the last 
number has been reached. You can specify another numbering series, if 
one exists, or create a new numbering series. 

Prefix Optional: Prefix of the numbering series 
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Field Description 

Approval Year Year when the taxing authority approved the numbering series 

Approval Number Number of the approval for the numbering series from the taxing authority 

Remarks Comments about the numbering series 

Set as Default If more than one numbering series exists for electronic documents, 
determines that this numbering series is used as default when an 
electronic document is created. 

4. To save the electronic numbering series, click the OK button. 
Result 
Once you have created at least one numbering series for electronic documents, you can generate 
electronic documents for your company.  
When you generate an electronic document SAP Business One assigns an internal number and an 
electronic document series number (prefix of the numbering series and a number) to the document. 
The electronic document number assigned to each created electronic document continues as per the 
numbering series. Any gap in the internal number, which may be due, for example, to the manual 
creation of an electronic document, does not change or influence the assignment of the numbers for 
the electronic document. 
Example 
Internal numbering series is “Primary” with numbers from 1–10. For internal number 5 and internal 
number 8, the electronic documents have already been created, with electronic invoice number XX-
1001 and electronic invoice number XX-1002 respectively. 
Electronic numbering series is “Electronic” with Prefix XX and Next No.1003. 
The following documents are created: 

Internal No. Electronic No. 

1 XX-1003 

2 XX-1004 

3 XX-1005 

4 XX-1006 

6 XX-1007 

7 XX-1008 

9 XX-1009 

10 XX-1010 
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Assigning a File Format to a Specific Business Partner 
You can modify the default format file for electronic documents or create a new format definition file to 
meet the needs of specific business partners. You then assign the modified or new file to one or more 
business partners. 
Prerequisites 
A new .spp format definition file has been created using Electronic File Manager, is stored in the 
folder that has been defined for format definition files, and is uploaded to EFM (see Creating and 
Modifying Format Definition Files). 
Procedure 
...  
...  

1. In the SAP Business One Modules tab, choose Business Partners → Business Partner Master 
Data. 
The Business Partner Master Data window appears. 

 
2. In the General tab, for the El. Doc. Export Format field, select the BP-specific EFM format 

definition file and click Update. 
This new format file is now valid for the business partner. 
When generating an electronic document for an invoice, down payment invoice, credit memo, or 
debit memo, SAP Business One uses the format definition file specified on the document 
(Electronic Document tab). As a default value system first checks the existence of a default 
format definition file for a specific business partner and then checks if a format definition file 
exists for whole company. 

Creating and Modifying Format Definition Files 
You can enhance the default format definition file for electronic documents and for the monthly report 
that you file with the taxing authority. For example, the taxing authority may require additional fields 
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that are specific to your type of business or your industry. Your parent company may require you, as a 
subsidiary, to create an XML file with additional company-specific information. You can also create 
new format definition files to meet the business needs of specific business partners. 
For more information about Electronic File Manager, see the online help, SAP Note 1531223, and 
How to Design an Electronic File Format in Electronic File Manager: Format Definition in the 
documentation area of SAP Business One Customer Portal at 
http://service.sap.com/smb/sbocustomer/documentation. 
... 

1. To modify the default format definition files or to create a new file, you use the Electronic File 
Manager: Format Definition add-on. 

2. To make the modified file or the new file available to SAP Business One, use EFM file 
management functionality. To access this functionality, in the SAP Business One Modules tab 
choose Administration → Setup → General → Electronic File Manager. 
The Electronic File Manager - Setup window appears. It contains the default document format 
file and the default report file. 

 
For each report the Format Type column displays one of two formats; both have an .spp file 
extension. 

 Electronic Document is used for the creation of electronic files from marketing 
documents. There can be multiple items of this type. 

 Electronic Authority Report is used for the report to the taxing authority that summarizes 
the electronic documents created within a specific month. There can be only one item of 
this type. 

3. To upload the modified file or the new file, right-click the Name column and select Upload. 
4. Specify a description and select Update. 

 

NOTE 
The system files cannot be replaced, so it is necessary to make a copy, adjust, save and 
upload new file. 

 

https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=1531223�
http://service.sap.com/smb/sbocustomer/documentation�
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Result 
After format definition files are created and available in the Electronic File Manager, they can be used 
for creating the XML file for documents and for generating the monthly report to the taxing authority. 

NOTE 
The data source for EFM mapping includes all the information from the source 
documents. However, different documents are stored in different tables in SAP Business 
One. For this reason a general naming convention was created, as shown in the 
following example. 

Data Source A/R Invoice A/R Credit Memo 

ODOC OINV ORIN 

DOC1 INV1 RIN1 

DOC2 INV2 RIN2 

… … … 

 Note 
The data source includes all database fields and user-defined fields related to the 
database tables of marketing documents. If the database structure is updated, you can 
regenerate the data source and update it in the Electronic File Manager. To regenerate 
the data source, choose Tools → Customization Tools → Generate EFM XML 
Datasource in the menu bar. 

 

Generating Electronic Documents 
SAP Business One supports electronic document generation for A/R invoices, A/R down payment 
invoices, A/R credit memos, and A/R debit memos. 
You can generate electronic documents: 

• Automatically when you manually create and post invoices, down payment invoices, credit 
memos, and debit memos 

• In a batch run after the accounting posting of the relevant documents 
• During the creation of documents using the Document Generation Wizard together with the 

accounting posting of the relevant documents 
 

NOTE 
If a document is generated also as an electronic document, a “standard” folio number 
cannot be assigned to the document. Standard folio numbering functionality is available 
only for documents printed on paper and marked as “not relevant” for electronic 
document creation. 
In general, if an electronic document is created then you cannot print the document as a 
paper document. You can, however, print the electronic document using a specific print 
layout with specific information as required by the taxing authority SAT. 
In case that document has status “Not Relevant” and Manual Folio Number is assigned it 
is not possible to change the status to “Generate Later” and create electronic document. 

 
The Electronic Document tab for the invoice, down payment invoice, credit memo, and debit memo 
contains the Generation Type field in which you specify when and if electronic documents are 
generated. The following table provides details about the three options. 
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Option Action Result Comment 

Generate Create an 
electronic 
document  

Electronic document 
number is assigned and 
XML file is created and 
stored in XML directory 
when invoice, down 
payment invoice, credit 
memo, or debit memo is 
added. 

If the standard document (invoice, 
down payment invoice, credit 
memo, or debit memo) is created 
in the standard series with a 
defined and linked electronic 
document numbering series, then 
the default value is set to 
Generate. You can change the 
default value to Generate or Not 
Relevant. 
Once the XML file is generated 
automatically you cannot modify 
any input fields. 

Generate later Defer the 
creation of an 
electronic 
document to a 
batch run 

Electronic document 
number is not assigned 
and XML file is not 
generated when the 
document is added.  
 
Electronic number is 
assigned and XML file is 
created later when you 
use the document printing 
functionality. 

This is the default setting when 
using Document Creation Wizard.  
As long as the XML file is not 
generated you can change the 
following fields: Generation Type, 
Electronic Doc. Number, El. 
Document Export Format, Orig. 
Input Message, and Encrypted 
Char. Chain. 
Once the XML file is generated 
automatically you cannot modify 
these fields. 

Not relevant Do not create an 
electronic 
document 

This is the default value 
when no electronic 
numbering series has 
been defined. Once you 
have defined an electronic 
numbering series, you can 
change this value. 
When the invoice, down 
payment invoice, credit 
memo, or debit memo is 
generated, the standard 
folio number is assigned 
and no XML file is 
generated.  

If a document is added without 
creating an XML file then the 
Generation Type field is not 
blocked for editing. Between the 
time that the original document is 
added and an electronic document 
file is generated, you can change 
the option from Not Relevant to 
Generate - Later. 

You can specify a default value for the generation type. To do so, choose Administration → System 
Initialization → Document Settings and make your selection for the Default Generation Type field. 
 
Prerequisites 
A certificate is linked to the SAP Business One company database, a default file format for electronic 
documents is selected for your company, and a folder has been defined to store XML files created for 
electronic documents. 
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Generating an Electronic Document When You Create a Standard Document 
When you create an A/R invoice, A/R down payment invoice, A/R credit memo, or A/R debit memo, 
you can decide if you want to create an electronic document immediately, at a later time, or not at all. 
The following procedure describes an example of electronic document creation for an A/R invoice. The 
procedure for A/R down payment invoices, credit memos, and debit memos is similar. 
... 
...  

1. In the SAP Business One Modules tab, choose Sales → AR Invoice. 
The A/R Invoice window appears. 

 
2. In the Electronic Document tab, review and modify the following fields as required: 

a. Generation Type displays the default option for generating an electronic document. You 
can change this option to better suit your needs. 

b. Electronic Doc. Number displays the automatically assigned number as defined by the 
default electronic numbering series (see Creating a Document Numbering Series for 
Electronic Documents).  
If you have defined more than one electronic numbering series, you can change this 
default number. To do so, select a different electronic series name from the dropdown 
list. When you select a different electronic series name, the next available number (from 
the Next No. field) is filled in the second part of the Electronic Doc. Number field. 

c. El. Document Export Format displays the default export file format. If you have defined a 
BP-specific export file format or another export file format, select that file from the list. 

d. Orig. Input Message is blank and is not editable. After you select the Add button (and 
you have “Generate” status selected), it displays the digital signature of the original 
document. 

e. Encrypted Char. Chain is blank and is not editable. After you select the Add button (and 
you have “Generate” status selected), it displays the encrypted digital signature of the 
original document. 

3. Select Add. 
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If the Generation Type field displays the Generate option, SAP Business One takes the 
following actions: 

 The digital signature is created from the original document and displayed in the Orig. 
Input Message field. It is then encrypted and displayed in the Encrypted Char. Chain 
field. 

 The XML file is created based on the default format definition file (see Selecting Default 
Electronic Document Export Format and Defining a Folder for Electronic Documents) 
unless you have specified a different format definition file for the electronic document or 
for the business partner (see Assigning a File Format to a Specific Business Partner). 

 The XML file for the electronic document is generated in the standard path for XML files, 
which is defined in Administration → System Initialization → General Settings → Paths 
tab. The file name consists of your RFC and the electronic document number. 

 EXAMPLE 
The file name for electronic document XX-1004 for taxpayer (RFC) XXXX010101000 is 
XXXX010101000XX1004.xml. 

 
Generating Electronic Documents in a Batch Run 
If the Generation Type field for an invoice, down payment invoice, credit memo, or debit memo is set 
to Generate - Later when the document was created originally, you use the document printing 
functionality to print the electronic document. 
The standard functionality for printing documents provides several options for generating electronic 
documents: 

• Generate documents for the first time (new XML documents are created). 
• Re-create documents that were generated previously (XML documents were created already 

and you need to re-create the originally generated document). 
• Re-create documents finished with errors (XML documents were generated with errors and you 

need to re-create the documents) 
• Mark documents as faulty (to mark a large number of documents as faulty and be able to re-

create these documents) 
To create or re-create electronic documents using the document printing functionality: 
In ...  

1. In the SAP Business One Modules tab, choose Sales → Document Printing. 
The Document Printing - Selection Criteria window appears. 
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2. The following fields are relevant for generating or regenerating electronic documents: 

Field Description 

Generate 
electronically 

To generate documents electronically, select the radio button. From the 
dropdown list select Only Documents Still to Be Generated.  
To re-create previously generated electronic documents, select the radio 
button. From the dropdown list select Re-generate Only. 
To re-create documents that have not been generated successfully, 
select the radio button. From the dropdown list select Re-create 
Documents Finished with Errors. 
To mark a large number of documents as faulty, select the radio button. 
From the dropdown list select Mark as Faulty. 

Electronic Series  Displays the default electronic numbering series. If more than one 
numbering series is defined, you can change the numbering series to use 
when generating electronic documents; the next number in the numbering 
series is assigned. 

3. Click OK. 
The Print A/R Invoices window appears with a list of documents ready to be generated as 
electronic documents. 

4. Select the documents for which you want to generate electronic invoices and click Generate.  
An electronic document number is assigned automatically from the numbering series specified 
in the Electronic Series field to each document generated.  
For more information about what happens when electronic documents are created, see step 3 in 
the procedure “Generating an Electronic Document When You Create a Standard Document.” 

 
Generating Electronic Documents When Using the Document Generation Wizard 
When you use the Document Generation Wizard to create invoices you have the option to specify that 
electronic documents should be generated when the relevant documents are posted. 
In the second step of the Document Generation Wizard, when you select the target document type 
(A/R invoice, for example), you specify two additional fields related to the generation of electronic 
documents: 
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• Generation Type – Displays the default value for generating electronic documents using the 

Document Generation Wizard, which is Generate - Later. You can change to one of the other 
options for this field: Generate or Not Relevant.  

• Electronic Series – Displays the default electronic numbering series. If more than one 
numbering series is defined, you can change the numbering series to use when generating 
electronic documents; the next number in the numbering series is used. 

Creating the Report of Generated Invoices 
The taxing authority SAT requires companies to send a monthly list of generated electronic 
documents. SAT has specified the format and required content. 
SAP Business One provides the standard format definition file for creating the report file (TXT file) for 
the taxing authority. You can adjust the format (see Creating and Modifying Format Definition Files). 
You can add user-defined fields (UDFs) from a marketing document header to the result screen of the 
report. The UDFs are also part of the export if they are defined in the respective EFM format definition 
file. 
Procedure 
...  

1. In the SAP Business One Modules tab, choose Reports → Financials → Accounting → 
Electronic Documents Report. 
The Electronic Documents Report - Selection Criteria window appears. 

 
2. Specify the criteria for generating the report: 
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 To generate a report for all electronic documents (A/R invoices, A/R down payment 
invoices, A/R credit memos, and A/R debit memos) generated for the month, from the 
Electronic Document dropdown list select All Documents. 

 To identify the reporting period (month), in the Posting Date From field specify the first 
day of the month and in the To field specify the last day of the month. 

NOTE 
If you specify a date range that is less than a month, you can generate a report (see step 
3) but you cannot export the report (see step 4). You may want to generate a report 
without exporting it to review all electronic documents generated for a week, for example. 

3. To generate the report, click OK. 
A report is generated and displayed. 
The following columns appear in the report by default.  

Column Description 

Electronic 
Document 

Displays the type of documents you specified in the selection field.  

Date From 
Date To  

Displays the time period during which the electronic documents were 
created.  

RFC of Customer Fiscal ID of business partner 

Series Prefix code derived from the document numbering series 

Folio of Tax 
Voucher 

Electronic document number assigned when the electronic document was 
generated, based on an electronic numbering series 

Approvals Number Approval number of the certificate issued by the taxing authority 

Date and Hour of 
Issue 

System time and date when the electronic document was created 

Operation Amount Total amount of the electronic document in local currency (LC) 

Tax Amount Amount of value-added tax of the electronic document in local currency 

State of the 
Voucher 

Status of the electronic document. The status is always “1”, which is 
“active.” 

 
4. To export the report, click Export. 

Fields on the result screen are exported to a TXT file.  
If one of the following conditions occurs, the fields are not exported to the results file (TXT file): 

 The field is available on the result screen of the report but is not defined in the EFM 
format definition file. 

 The field is defined in the EFM format definition file but is not in the result screen of the 
report. 

Result 
The TXT file is created and saved in the standard XML folder. The file name consists of:  

• The number 1 (The number 2 is reserved for those who issue electronic documents through 
third-party providers.) 

• RFC  
• Month and the year of the report, formatted as MMYYYY 
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 EXAMPLE 
The file name of the November 2010 report for RFC XXXX010101000 is 
1XXXX01010100012006.txt. 
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Using Electronic Documents (CFDI Model) 
This section describes how to use electronic documents according to the CFDI model. 

 Note 
SAP Business One supports the major authorized CFDI certification suppliers (PAC) in 
Mexico. To see which PAC are supported, choose Administration → System Initialization 
→ Document Settings. The dropdown list to the right of the PAC field, shows the 
suported PAC. 

PAC called “XML” is a virtual PAC for a specific case when company wants to generate 
only unsigned document and the process of official certification via official PAC is handled 
outside SAP Business One system. As a result of “XML” PAC system creates and stores 
electronic document as xml file on the hard drive.  

 
Prerequisite 
To be able to use electronic documents according to the CFDI model, you must have SAP Business 
One 8.81 PL07 or higher installed. 
 

Getting Ready to Use Electronic Documents (CFDI Model) 
To enable the generation of electronic documents, the SAP Business One key user or administrator 
must ensure that the software has been installed with the appropriate configuration and settings by: 

• Selecting an electronic documents process 
• Assigning a certificate received from the taxing authority SAT to an SAP Business One 

company database. The certificate is stored in Microsoft Windows certificate storage. 
• Specifying the company responsible for handling electronic documents 
• Selecting the default electronic document export format and defining a folder for electronic 

document files. 
• Creating at least one document numbering series for electronic documents based on the 

numbering ranges received from the taxing authority SAT. 
To enable communication between SAP Business One and the PAC Web service, the SAP Business 
One key user or administrator must ensure that the B1 integration framework and platform has been 
installed with the appropriate configuration and settings. For more information, see the Administrator’s 
Guide for the Integration Component in the Documentation folder on your product DVD, or visit the 
Channel Partner Portal (http://channel.sap.com/sbo/innovations.) 
 

Selecting an Electronic Documents Process 
Companies can provide taxpayers with digital marketing documents according to the CFD or CFDI 
model.  
... 

1. In the SAP Business One Modules tab, choose Administration → System Initialization → 
Document Settings. 
The Document Settings window appears. 

2. Choose the El. Documents tab. 
3. Under Electronic Documents Process, select whether to use the CFD or CFDI model. 
4. To save your selection, choose the OK button. 

 

http://channel.sap.com/sbo/innovations�
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Assigning a Certificate to the SAP Business One Database 
Certificates received from the taxing authority SAT usually have a validity timeframe of one or two 
years. Assigning a certificate is done only when a new certificate is received, when a current certificate 
expires, or when a certificate is no longer valid. 
C... 

Prerequisites 
Certificate from SAT is available in the Microsoft Windows certificate storage of each Windows user 
that creates electronic documents. 
Procedure 
...  
...  

1. In the SAP Business One Modules tab, choose Administration → System Initialization → 
Document Settings. 
The Document Settings window appears. 

2. Choose the El. Documents tab. 
 

 Note 
The certificate information shown in this document is used to illustrate user interface 
features only. The information is from a certificate that SAT provided for testing purposes 
only. 

 
3. To the right of the Certificate for Electronic Documents field, click the […] icon. 

The certificate selection window appears with a list of available certificates. 
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4. To select a certificate, click the relevant certificate and then click the OK button. 

Information about the certificate is copied to the Certificate for Electronic Documents field. 
 
 

Test Mode 
Currently SAP supports three PACs: Edicom, Levicom, and Tralix. The connection requirements to 
each test environment are described below. 
Prerequisites 

• The B1 company and the PAC have agreed on the testing period. 
• The PAC has agreed to provide the B1 company with certification of their electronic documents.  
• The PAC has agreed to provide the test package (link to the Web service, user name, 

password, testing certificate, and so on). 
 

 Recommendation 
To set up and test the connection, and to transfer documents, create a test copy of a real 
productive database of the B1 company and select the Test Mode checkbox in the 
Document Settings window. 

 

The B1i package includes a prepared connection to the test environments of the three PACs that SAP 
supports, in the following way: 

• Edicom: Edicom uses the testing interface to its WS. The package includes a specific link to the 
testing environment, but the test user name and password should be specified in the B1i 
environment. 

• Levicom and Tralix: The testing environment is identified only according to the test user and its 
password. This setting needs to be defined in B1i scenario settings. In test mode, the Test user 
and password are verified, and then the document is certified for testing purposes only. 

 

Note 
When a document is created, it is possible to see whether it was created in “Test Mode”. 
As such, the response from PAC is not official and the certification of the document is not 
real, so such a document is officially not signed. However, such a document is still 
displayed in the system, for example, in reports. 
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Specifying the Authorized CFDI Certification Supplier (PAC) 
When using the CFDI process, you must specify the authorized CFDI certification supplier (PAC) that 
your company uses for handling electronic documents and communicating with the taxing authority 
SAT. 
Procedure 
...  
...  

1. In the SAP Business One Modules tab, choose Administration → System Initialization → 
Document Settings. 
The Document Settings window appears. 

2. Choose the El. Documents tab. 
3. In the PAC field, select the name of the company responsible for handling electronic documents. 

 Recommendation 
SAP Business One provides a mock PAC, called XML PAC, which can be used to 
support third-party products that send and receive the electronic documents to and from 
the PAC to the company. 

4. To save your settings, choose OK. 
 

Defining an XML Repository for Electronic Documents 
The taxing authority SAT requires you to generate XML files for A/R invoices, A/R down payment 
invoices, A/R credit memos, and A/R debit memos and defines the specific structure of the XML file for 
electronic documents.  
SAP Business One includes the default format files for electronic documents and the default format file 
for the report, which are created with Electronic File Manager.  

 Note 
You can modify the default format definition file for electronic documents with additional 
fields or create a new format definition file for specific business partners (see Creating 
and Modifying Format Definition Files). 

C... 

Prerequisites 
A certificate is linked to the SAP Business One company database.  
The two format definition files from SAP are available in a directory that you define in Administration → 
Setup → General → Electronic File Manager → Setup (Electronic Invoice v3.0 (System) and 
Electronic Invoice v3.0 Input Message (System)). 
Procedure 
...  
...  

1. In the SAP Business One Modules tab, choose Administration → System Initialization → 
Document Settings. 
The Document Settings window appears. 

2. Choose the El. Documents tab. 
3. To select the default format file for electronic documents, select the format file to the right of the 

El. Document Export Format field and click OK. 
This format file is now valid for all relevant marketing documents (invoices, down payment 
invoices, credit memos, and debit memos). 

4. To define a folder in which XML files generated for electronic documents are stored, choose 
Administration → System Initialization → General Settings. 
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 Note 
This is only relevant for XML files generated by XML PAC. 

5. In the Path tab, specify a folder in the relevant field. 

Enabling Numbering Series for Electronic Documents 
You must specify whether a numbering series is relevant for the generation of electronic documents.  
Prerequisites 
A numbering series has been defined. 
A certificate is linked to the SAP Business One company database and a default file format for 
electronic documents is selected for your company. In addition, if you generate XML files using XML 
PAC a folder has been defined to store XML files created for electronic documents. 
Procedure 
...  
...  

1. In SAP Business One Module tab, choose Administration → System Initialization → Document 
Numbering. 
The Document Numbering - Setup window appears. 

2. To access the Electronic Series - A/R Invoices - Setup window, double-click the series name in 
both the Document Numbering - Setup window and the Series - A/R Invoices - Setup window. 

 
3. In the Electronic Series - A/R Invoices - Setup window, select the Digital Series checkbox for the 

numbering series that are relevant for electronic document generation. 
4. To save your settings, click the OK button. 

 

NOTE 
If a company switches from the CFD to the CFDI model, the standard numbering series 
with electronic series, the Digital Series checkbox will be automatically enabled. 
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Assigning a File Format to a Specific Business Partner 
You can modify the default format file for electronic documents or create a new format definition file to 
meet the needs of specific business partners. You then assign the modified or new file to one or more 
business partners. 
Prerequisites 
A new .spp format definition file has been created using Electronic File Manager, is stored in the 
folder that has been defined for format definition files, and is uploaded to EFM (see Creating and 
Modifying Format Definition Files). 
Procedure 
...  
...  

1. In the SAP Business One Modules tab, choose Business Partners → Business Partner Master 
Data. 
The Business Partner Master Data window appears. 

 
2. In the General tab, for the El. Doc. Export Format field, select the BP-specific EFM format 

definition file and click Update. 
This new format file is now valid for the business partner. 
When generating an electronic document for an invoice, down payment invoice, credit memo, or 
debit memo, SAP Business One uses the format definition file specified on the document. As a 
default value system first checks the existence of a default format definition file for a specific 
business partner and then checks if a format definition file exists for whole database. 
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Setting Up SAP Business One integration (B1i) 
 
SAP Business One Integration (B1i) is a component enabling communication between SAP Business 
One and the PAC Web service The SAP Business One key user or administrator must ensure that the 
B1 integration framework and platform has been installed with the appropriate configuration and 
settings. For more information, see the Administrator’s Guide for the Integration Component in the 
Documentation folder on your product DVD, or visit the Channel Partner Portal 
(http://channel.sap.com/sbo/innovations.) 
 
After successful standard installation of B1i user can manually setup/adjust all relevant connections to 
the database and PAC via Integration Framework interface. 
 
Steps: 

1) Run Tomcat server setup from "c:\Program Files\SAP\SAP Business One 
Integration\B1iServer\Tomcat\bin\tomcat6w.exe". Change JVM to default (Java->Use Default 
(default path is C:\Program Files (x86)\Java\jre6\bin\client\jvm.dll) 

 
For 64bit platform need to setup manually to 64bit Java, standard path should be: C:\Program 
Files\Java\jre6\bin\server\jvm.dll. 

 
2) Import PAC's CA certificates and Copy cacerts from attachment cacerts.zip in SAP Note 

1580236 to "c:\Program Files\Java\jre6\lib\security" (valid for standard JAVA installation path). 
Restart the SAP Integration Server service 

 
3) The B1i eInvMX scenario package com.sap.eInvMX.1.0.0.zip is available as part of B1i 

installation. 
a. Check Company DB SLD via SLD tab (after setup, try the Testing buttons to recheck 

the connection). 
See example for demo database MX_DEMO2: 

http://channel.sap.com/sbo/innovations�
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b. Check PAC's SLD (after setup try Testing button to recheck the connection) The 

example of the setup of SLD data for testing environment of three delivered PACs is 
following (Please note that the real connection data will be provided by your PAC): 

i. Edicom 
Type  H.AnySystem 
Name  <name> (e.g. WS-Edicom) 
destProtocol https 
destHost cfdiws.sedeb2b.com 
destPort 443 
destPath /EdiwinWS/services/CFDi 
method  POST 
 
See example: 
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ii. Tralix 
Type  H.AnySystem 
Name  <name> (e.g. WS-Tralix) 
destProtocol https 
destHost pruebastfd.tralix.com 
destPort 7070 
destPath / 
method  POST 
 

iii. Levicom 
Type  H.AnySystem 
Name  <name> (e.g. WS-Levicom) 
destProtocol http 
destHost wwwsqa.cen.biz 
destPort 80 
destPath /monitor/cfdiwebservice/CFDIService.asmx 
method  POST 
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c. Setup eInvMsg scenario package Properties Scenarios->Setup->[Choose sap.eInvMX 
Package]->[Data Mgt.]->Properties->[Select] 

Property Value 

SLDCompanyDB SLD ID of Company DBs (in case of 
more DBs separate each ID by 
comma) 

SLDEdicomWS SLD ID of Edicom SLD 

SLDLevicomWS SLD ID of Levicom SLD 

SLDTralixWS SLD ID of Tralix SLD 

SMTPMailFrom Error message sender e-mail 

SMTPPassword SMTP Authentication password if 
required 

SMTPPort SMTP Server port number 

SMTPServer SMTP Server hostname 

SMTPUser  SMTP Authetication user name if 
required 

WSUserName PAC's WebService Authentication user 
name if required (EDICOM) 

WSUserNameTest PAC's WebService Authentication user 
name if required (EDICOM) 

WSUserPass PAC's WebService Authentication user 
password if required (EDICOM) 

WSUserPassTest PAC's WebService Authentication user 
password if required (EDICOM) 

XMLPath Final XML storage path 

 
See example: 
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4) Press All Activate, All Generate and Save. 

a. Activate the eInvMX package in Scenarios → Control. 
The scenario package and also some additional information is available in SAP Note 1580236.  
 
The XML files that are created when saving a document are sent to PAC for verification and are sent 
back to the company with the appropriate certificate and numbering. Sending and receiving the 
documents is handled in the background by the integration framework. SAP Business One integration 
(B1i) saves the documents received from PAC in the database. 
If an error occurs in the processing of electronic document or in the connection with PAC, B1i sends 
an e-mail or alert to the user who created the problematic XML file if specified in the Document 
Settings. The user e-mail must be defined in the User – Setup window. If no user emails are defined, 
the notification is sent to all superusers defined in the database. 
... 

 

Creating and Modifying Format Definition Files 
You can enhance the default format definition file for electronic documents. For example, the taxing 
authority may require additional fields that are specific to your type of business or your industry. Your 
parent company may require you, as a subsidiary, to create an XML file with additional company-
specific information. You can also create new format definition files to meet the business needs of 
specific business partners. 
For more information about Electronic File Manager, see the online help, SAP Note 1531223, and 
How to Design an Electronic File Format in Electronic File Manager: Format Definition in the 
documentation area of SAP Business One Customer Portal at 
http://service.sap.com/smb/sbocustomer/documentation. 
... 

1. To modify the default format definition files or to create a new file, you use the Electronic File 
Manager: Format Definition add-on. 

https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=1531223�
http://service.sap.com/smb/sbocustomer/documentation�
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2. To make the modified file or the new file available to SAP Business One, use EFM file 
management functionality. To access this functionality, in the SAP Business One Modules tab 
choose Administration → Setup → General → Electronic File Manager. 
The Electronic File Manager - Setup window appears. It contains the default document format 
file. 

 
3. To upload the modified file or the new file, right-click the Name column and select Upload. 
4. Specify a description and select Update. 

Result 
After format definition files are created and available in the Electronic File Manager, they can be used 
for creating the XML file for documents. 

NOTE 
The data source for EFM mapping includes all the information from the source 
documents. However, different documents are stored in different tables in SAP Business 
One. For this reason a general naming convention was created, as shown in the 
following example. 

Data Source A/R Invoice A/R Credit Memo 

ODOC OINV ORIN 

DOC1 INV1 RIN1 

DOC2 INV2 RIN2 

… … … 

 

Generating Electronic Documents 
SAP Business One supports electronic document generation for A/R invoices, A/R down payment 
invoices, A/R credit memos, and A/R debit memos. 
You can generate electronic documents: 

• Automatically when you manually create and post invoices, down payment invoices, credit 
memos, and debit memos 

• In a batch run after the accounting posting of the relevant documents 
• During the creation of documents using the Document Generation Wizard together with the 

accounting posting of the relevant documents 
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NOTE 
If a document is generated also as an electronic document, a “standard” folio number 
cannot be assigned to the document. Standard folio numbering functionality is available 
only for documents printed on paper and marked as “not relevant” for electronic 
document creation. 
In general, if an electronic document is created then you cannot print the document as a 
paper document. You can, however, print the electronic document using a specific print 
layout with specific information as required by the taxing authority SAT. 
In case that document has status “Not Relevant” and Manual Folio Number is assigned it 
is not possible to change the status to “Generate Later” and create electronic document. 

 
The Electronic Document tab for the invoice, down payment invoice, credit memo, and debit memo 
contains the Generation Type field in which you specify when and if electronic documents are 
generated. The following table provides details about the three options. 

Option Action Result Comment 

Generate Create an 
electronic 
document  

A temporary XML file is 
stored in the database 
when an invoice, down 
payment invoice, credit 
memo, or debit memo is 
added. At certain intervals, 
which you can define 
based on your company’s 
needs, B1i sends the 
generated XML file to the 
PAC Web service. PAC 
validates the files, sends 
the certificate and 
document number or an 
error message, if any 
errors occur. The certified 
XML file is saved in the 
database and a copy is 
saved in the XML folder 
defined by the properties 
in B1i. 

If the standard document (invoice, 
down payment invoice, credit 
memo, or debit memo) is created 
in the standard series with a 
defined and linked electronic 
document numbering series, then 
the default value is set to 
Generate. You can change the 
default value to Generate or Not 
Relevant. 
Once the XML file is generated 
automatically you cannot modify 
any input fields. 

Generate later Defer the 
creation of an 
electronic 
document to a 
batch run 

XML file is not generated 
when the document is 
added.  
 
XML file is created later 
when you use the 
document printing 
functionality. 

This is the default setting when 
using Document Creation Wizard.  
As long as the XML file is not 
generated you can change the 
following fields: Generation Type, 
Electronic Doc. Number, El. 
Document Export Format, Orig. 
Input Message, and Encrypted 
Char. Chain. 
Once the XML file is generated 
automatically you cannot modify 
these fields. 
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Option Action Result Comment 

Not relevant Do not create an 
electronic 
document 

This is the default value 
when no electronic 
numbering series has 
been enabled. Once you 
have enabled an electronic 
numbering series, you can 
change this value. 
When the invoice, down 
payment invoice, credit 
memo, or debit memo is 
generated, the standard 
folio number is assigned 
and no XML file is 
generated.  

If a document is added without 
creating an XML file then the 
Generation Type field is not 
blocked for editing. Between the 
time that the original document is 
added and an electronic document 
file is generated, you can change 
the option from Not Relevant to 
Generate - Later. 

You can specify a default value for the generation type:  
Choose Administration → System Initialization → Document Settings and make your selection for the 
Default Generation Type field. 
 
Prerequisites 
A certificate is linked to the SAP Business One company database, a default file format for electronic 
documents is selected for your company, and a folder has been defined to store XML files created for 
electronic documents. 
Generating an Electronic Document When You Create a Standard Document 
When you create an A/R invoice, A/R down payment invoice, A/R credit memo, or A/R debit memo, 
you can decide if you want to create an electronic document immediately, at a later time, or not at all. 
The following procedure describes an example of electronic document creation for an A/R invoice. The 
procedure for A/R down payment invoices, credit memos, and debit memos is similar. 
... 
...  

1. In the SAP Business One Modules tab, choose Sales → AR Invoice. 
The A/R Invoice window appears. 
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2. In the Electronic Document tab, review and modify the following fields as required: 

a. Generation Type displays the default option for generating an electronic document. You 
can change this option to better suit your needs. 

b. El. Document Export Format displays the default export file format. If you have defined a 
BP-specific export file format or another export file format, select that file from the list. 

c. Orig. Input Message is blank and is not editable. After you select the Add button (and 
Generation Type is “Generate”), it displays the digital signature of the original document. 

d. Encrypted Char. Chain is blank and is not editable. After you select the Add button (and 
Generation Type is “Generate”), it displays the encrypted digital signature of the original 
document. 

3. Select Add. 
If the Generation Type field displays the Generate option, SAP Business One takes the 
following actions: 

 The digital signature is created from the original document and displayed in the Orig. 
Input Message field. It is then encrypted and displayed in the Encrypted Char. Chain 
field. 

 The XML file is created based on the default format definition file (see Selecting Default 
Electronic Document Export Format and Defining a Folder for Electronic Documents) 
unless you have specified a different format definition file for the electronic document or 
for the business partner (see Assigning a File Format to a Specific Business Partner). 

 The XML file for the electronic document is sent to PAC. If you use XML PAC, the XML 
file is generated in the standard path for XML files, which is defined in Administration → 
System Initialization → General Settings → Paths tab. The file name consists of your 
RFC and the electronic document number (UUID). 
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 EXAMPLE 
The file name for electronic document XX-1004 for taxpayer (RFC) XXXX010101000 is 
5916E86F-7E57-48D6-ABF3-0969D86D6914.xml (related to the screen 
above). 

 
Note: Field Electronic Doc. Number includes the following information: 

• Information about status of the processing 
o “Waiting for processing” – if document is waiting in the queue to be send to PAC 
o “Processing” – if the document is processed by B1i 

• Error code and description of the error in the tooltip if the error in processing occurred 
• Electronic Document Number - UUID – if the document was successfully processed by PAC 

 
Generating Electronic Documents in a Batch Run 
If the Generation Type field for an invoice, down payment invoice, credit memo, or debit memo is set 
to Generate - Later when the document was created originally, you use the document printing 
functionality to print the electronic document. 
The standard functionality for printing documents provides the following options for generating 
electronic documents: 

• Generate documents for the first time (new XML documents are created). 
• Re-create documents that were generated previously (XML documents were created already 

and you need to re-create the originally generated document). 
• Re-create documents finished with errors (complete regeneration of the XML file, which will be 

sent to PAC again). Errors may occur in the following cases: 
 In the documents or 
 In the communication with PAC 
 

 Recommendation 
If any errors occur in the communication with PAC, we recommend the following: 
 Analyze the error based on the error code (see examples below) 
 Analyze the error together with PAC if not clarified in point 1 (e.g. error code 999 – 

Unexpected error below) 
 Correct the error if it is possible in SAP Business One (e.g. adjust RFC in case of 

error code 402 below) 
 Re-create document via the Document Printing functionality 

 
 Examples of error codes include: 

 301 – The XML doesn’t use the standard of W3C or it’s not constructed by the 
rules defined in the XSD  

 302 – The CSD of the user it’s invalid 
 303 – The RFC in the CSD and the RFC in the invoice doesn’t match  
 304 – The CSD has been revoked 
 305 – The date of creation established in the invoice doesn’t match with the 

period of the CSD 
 306 – The invoice is using the FIEL, instead of the CSD 
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 307 – The invoice already has a node “TimbreFiscalDigital” 
 308 – The CSD used in the invoice was not been generated by the SAT 
 401 – The invoice is older than 72 hours 
 402 – The RFC doesn’t appear in the authorized list published by the SAT 
 403 – The date in the invoice is before of January 1st 2011   
 901 – The creator of the invoice is not registered in the system  
 902 – We cannot sign the invoice 
 999 – Unexpected error 

 
 
To create or re-create electronic documents using the document printing functionality: 
In ...  

1. In the SAP Business One Modules tab, choose Sales → Document Printing. 
The Document Printing - Selection Criteria window appears. 

 
2. The following fields are relevant for generating or regenerating electronic documents: 

Field Description 

Generate 
electronically 

To generate documents electronically, select the radio button. From the 
dropdown list select Only Documents Still to Be Generated.  
To re-create previously generated electronic documents, select the radio 
button. From the dropdown list select Re-generate Only. 
To re-create documents that have not been generated successfully, 
select the radio button. From the dropdown list select Re-create 
Documents Finished with Errors. 

3. Click OK. 
The Print A/R Invoices window appears with a list of documents ready to be generated as 
electronic documents. 

4. Select the documents for which you want to generate electronic invoices and click Generate.  
For more information about what happens when electronic documents are created, see step 3 in 
the procedure “Generating an Electronic Document When You Create a Standard Document.” 
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Generating Electronic Documents When Using the Document Generation Wizard 
When you use the Document Generation Wizard to create invoices, down payment invoices, credit 
memos, and debit memos, you have the option to specify that electronic documents should be 
generated when the relevant documents are posted. 
In the second step of the Document Generation Wizard, when you select the target document type 
(A/R invoice, for example), you specify two additional fields related to the generation of electronic 
documents: 

 
• Generation Type – Displays the default value for generating electronic documents using the 

Document Generation Wizard, which is Generate - Later. You can change to one of the other 
options for this field: Generate or Not Relevant.  
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Copyrights, Trademarks, and Disclaimers 
© Copyright 2011 SAP AG. All rights reserved. 
 
The current version of the copyrights, trademarks, and disclaimers at 
http://service.sap.com/smb/sbocustomer/documentation is valid for this document. 
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