
SAMSUNG LYNK™ REACH 4.0 is a solution that allows you to configure content settings on hotel TVs. 

Using SAMSUNG LYNK™ REACH 4.0, customize information and content settings required to watch TV or search 
hotel information, according to the types of guests. Remotely control TVs in rooms to conveniently manage them.
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01 Before getting started

About the solution

SAMSUNG LYNK™ REACH 4.0 is a solution that allows you to configure content settings on hotel TVs. 

Using SAMSUNG LYNK™ REACH 4.0, customize information and content settings required to watch TV or search hotel information, 
according to the types of guests. Remotely control TVs in rooms to conveniently manage them.

Solution default modes

SAMSUNG LYNK™ REACH 4.0 can be used in two modes. Available modes vary, depending on the server configuration method 
used.

▪▪ RF mode: This mode supports DTV coaxial based one-way communications and is available when LYNK™ REACH 4.0 is 
installed on the REACH server.

▪▪ IP mode: This mode supports network based two-way communications and is available when LYNK™ REACH 4.0 is installed 
on the server PC.

<< Note

Screen displays, fixed menus and features may be provided, depending on the mode in use. 

SAMSUNG LYNK™ REACH 4.0
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Installation requirements

Hardware

■■ SAMSUNG LYNK™ REACH Server 

■■ Samsung Hotel TV (REACH 4.0-supported models)

Required software

■■ Microsoft Visual C++ 2010 Redistributable Package (x86)

■■ Microsoft Visual C++ 2008 Redistributable (x86)

■■ MySQL Server 5.5

■■ Apache HTTP Server 2.4

■■ When installing SW-HWRE02A-1002.5 or an earlier version of REACH 4.0 on Windows Server 2008 and Windows Server 2012 
systems, .NET Framework 3.5 must be installed and activated. 

For further information, refer to the following:

–– Using Windows Server 2008 OS .NET Framework 3.5  ► Link

–– Using Windows Server 2012 OS .NET Framework 3.5  ► Link

<< Note

When installing SW-HWRE02A-1100.15 or a higher version of REACH 4.0, .NET Framework 4.5 must be installed. .NET Framework 4.5 is automatically 
installed when you install REACH 4.0.

System requirements for IP mode

<< Note

•	 Computers where REACH 4.0 will be installed must meet the following requirements.

•	 The following is the minimum requirements based on 500 TVs. 

•	 Capacity equivalent to a server is recommended. 

•	 Using Chrome or FireFox is recommended when launching REACH 4.0. If launched with other browsers, you will not be able to use all features.

■■ CPU: Octa Core 3.4 GHz greater

■■ RAM: 8 GB greater 

■■ HDD: 500 GB 

■■ SSD: 256 GB 

■■ OS: Windows 7(for testing), Windows Server 2008 R2 (64-bit), 2012 (64-bit)

■■ Network Bandwidth: 100 Mbps greater 

https://blogs.msdn.microsoft.com/sqlblog/2010/01/08/how-to-installenable-net-3-5-sp1-on-windows-server-2008-r2-for-sql-server-2008-and-sql-server-2008-r2/
https://msdn.microsoft.com/windows/hardware/commercialize/manufacture/desktop/enable-net-framework-35-by-using-the-add-roles-and-features-wizard
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Rules used in this user guide

 Solution and device names are written as follows in this user guide.

■■ SAMSUNG LYNK™ REACH 4.0		  →	 REACH 4.0

■■ SAMSUNG LYNK™ REACH Server 	 →	 Server

■■ Hotel TV				    →	 TV

<< Note

•	 This user guide assumes that IP mode is being used.

•	 This user guide assumes you have general user privileges, except for when it describes administrator menus. For further information, refer to the 
following:  ► Account privileges and available features

Installing/uninstalling REACH 4.0

Installing REACH 4.0

<< Note

•	 Running the REACH 4.0 install file automatically installs the Apache HTTP Server, My SQL and Microsoft Visual C++ programs, in this order. These 
programs are needed to run REACH 4.0. Make sure to install them properly in the correct order.

•	 If the programs are installed in an order that is not correct, REACH 4.0 may not run properly.

•	 When the REACH 4.0 install file is run for the first time, anti-virus programs may recognize the file as ransomware. If this occurs, resolve the issue 
as follows.

–– Example: The REACH 4.0 install file is recognized as ransomware by Bitdefender

–– How to resolve: Protection > View Modules > Trusted Applications > Add > select the REACH 4.0 install file > OK

1	 Run the REACH 4.0 install file with an administrator account.
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2	 The install window appears. Read the instructions and click Next.

3	 Read the license agreement thoroughly and click I Agree.
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4	 Set the destination folder and click Next.

5	 Set the folder name and click Install.

6	 After REACH 4.0 install is complete, click Finish.
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Updating REACH 4.0

1	 Download the REACH 4.0 update program from the license server at https://v3.samsunggsbn.com.

2	 The install window appears. Read the instructions and click Next.

3	 The select install type screen appears. Select Update and click Next.

4	 After update is complete, click Finish.
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Uninstalling REACH 4.0

1	 Open the uninstall screen using Control Panel or the list of startup applications. Click Uninstall.

2	 After the program uninstall is complete, click Finish. 
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02 Tutorial

Tutorial - RF Mode
Follow these steps to learn how to configure the settings required to use REACH 4.0 in RF mode, create and distribute TV content 
using REACH4.0, and remotely control TVs.

<< Note

In RF mode, REACH Home Channel must be tuned from the TV to enable real-time data transfer.

Launching REACH 4.0

Open a web browser and connect to https://localhost:443.

<< Note

For alternatives to launch REACH 4.0, refer to the following:  ► Running the webpage

Registering a free license

Register a free license in the license registration window. Registration is required only once, when the software runs for the first 
time after install.

<< Note

For details on how to register a free license, refer to the following:  ►Registering a free license

1	 On the license screen, click Add > Free Licence.

2	 Enter free license information.

3	 After entering the required information, click Activate.

4	 An activation confirmation window appears. Click OK.

SAMSUNG LYNK™ REACH 4.0
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Logging in

On the login screen, enter your ID and password and click SIGN IN.

▪▪ When you run REACH 4.0 for the first time, the default administrator account (ID: qaadmin, password: qaadmin and the 
default user account (ID: sample, password: qwerty) will be provided. Make sure to change the password to ensure security.

<< Note

For details on login and accounts, refer to the following:  ►Logging in

Main screen

On the REACH 4.0 main screen, view the available menu items and room information. 

<< Note

For details on each menu item, refer to the following:  ►Main screen

Configuring the REACH 4.0 settings

To use REACH 4.0, configure settings from the Modulator menu and the TV.

REACH channel setup

<< Note

For details on how to configure REACH channels, refer to the following:  ►REACH channel setup

1	 From the menus at the top, click  > Settings > Modulator.

2	 Configure the Modulator settings required to connect to the TV. 

3	 After configuring the required settings, click Apply.
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Initial TV setup

<< Note

For details on how to configure settings from the TV, refer to the following:  ►Initial TV setup

1	 Select REACH Solution from the initial TV setup menus.

2	 Set REACH for the Orsay model and REACH RF Mode for the Tizen model to ON. 

3	 Set REACH IP Mode to OFF.

4	 Select Group ID and choose a group ID. 

5	 To automatically update TV configuration or TV software, use the REACH Update Time option to customize the time or set 
REACH Update Immediate to ON. 

6	 Set Room Number for the Orsay model and Room Number for the Tizen model. Enter the room number.

7	 Turn off the TV and then on again.

Configuring room information

Manually register TV information from REACH 4.0.

Registering room info

<< Note

For details on how to register and manage room information, refer to the following:  ► Managing room info

1	 From the menus at the top, click MANAGEMENT > Room.

2	 Click New.

3	 Enter room information and click OK.

Monitoring room TVs

<< Note

For details on how to monitor TVs, refer to the following:  ► Monitoring room TVs

On the top menus, click MONITORING to monitor the TV connection and room occupancy.
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Creating/configuring a project

Create a project to use as TV content. 

<< Note

For details on how to create a project, refer to the following:  ► Creating a new project

1	 From the menus at the top, click PROJECT > New.

2	 Select a project template type and click OK.

3	 From the edit screen, configure a project, using the following features.

<< Note

For details on how to configure a project, refer to the following:  ► Configuring a project

4	 After editing the project as desired, click FILE > Save.

5	 A confirmation window appears. Click Yes.

6	 Save specified settings and then click FILE > Close to close the project. 

Distributing a project

Distribute the project, configured from REACH 4.0, to the TVs. 

<< Note

For details on how to distribute a project, refer to the following:  ► Distributing a project

Configuring TV settings

From REACH 4.0, configure TV information for each room, including basic TV settings, as well as channel, DRM, ticker, and reset 
value settings. 

<< Note

For details on how to configure or manage TV settings, refer to the following:  ► Configuring TV settings, Managing registered TV configuration
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Distributing TV configuration

TV configuration created using REACH 4.0 can be distributed to TVs. 

<< Note

For details on how to distribute TV configuration, refer to the following:  ► Distributing TV configuration

Updating TV configuration

TV configuration distributed using REACH 4.0 can be updated from TVs.

<< Note

For details on how to update TV configuration, refer to the following:  ► Updating in RF mode

Update TV configuration, using either of the following options: 

Option 1  �To update manually, select Support > SW Update from the TV settings menu or select System > SW Update from the 
initial TV menu, and then follow the displayed instructions. For details, refer to the following: ► Manual update

Option 2 � To update automatically, in the initial TV menu, select REACH Solution > REACH Update Time or REACH Solution > 
REACH Update Immediate, and then restart the TV. For details, refer to the following: ► Enabling automatic update, 
Automatic update

Registering TV software

Upload TV software from your computer to REACH 4.0.

<< Note

For details on how to register and manage TV software, refer to the following:  ► Registering TV software, Managing registered TV software

1	 From the menus at the top, click MANAGEMENT > TV Software.

2	 Click Import.

3	 Configure TV software information.

4	 After configuring the required settings, click OK.
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Distributing TV software

Distribute TV software, registered on REACH 4.0, to the TVs.

<< Note

For details on how to distribute TV software, refer to the following:  ► Distributing TV software

1	 From the menus at the top, click DEPLOYMENT.

2	 Click NEW and select TV Software.

3	 Select TV software from the dropdown list and configure the distribution settings.

4	 Click Deploy.

Updating TV software

Update the TV with TV software distributed from REACH 4.0.

<< Note

•	 For details on how to update TV software, refer to the following:  ► Updating in RF mode

•	 SMART TV models released after 2017 do not support TV software updates using a server (RF mode).

Update TV software, using either of the following options:

Option 1  �To update manually, select Support > SW Update from the TV settings menu or select System > SW Update from the 
initial TV menu, and then follow the displayed instructions. For details, refer to the following: ► Manual update

Option 2  �To update automatically, in the initial TV menu, select REACH Solution > REACH Update Time or REACH Solution > 
REACH Update Immediate, and then restart the TV. For details, refer to the following: ► Enabling automatic update, 
Automatic update
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Tutorial - IP Mode
Follow these steps to learn how to configure the settings required to use REACH 4.0 in IP mode, create and distribute TV content 
using REACH 4.0, and remotely control TVs.

Launching REACH 4.0

Open a web browser and connect to either http://localhost:7001 or https://localhost:7002, based on your protocol settings.

<< Note

For alternatives to launch REACH 4.0, refer to the following:  ► Running the webpage

Logging in

On the login screen, enter your ID and password and click SIGN IN.

■■ When you run REACH 4.0 for the first time, the default administrator account (ID: qaadmin, password: qaadmin and the 
default user account (ID: sample, password: qwerty) will be provided. Make sure to change the password to ensure security.

<< Note

For details on login and accounts, refer to the following:  ►Logging in

Registering a license

Register a paid or free license in the license registration window.

<< Note

For details on how to register a license, refer to the following:  ►Registering a license

Main screen

On the REACH 4.0 main screen, view the available menu items and room information.

<< Note

For details on each menu item, refer to the following:  ►Main screen
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Configuring a protocol

In IP mode, you can customize the method of communication between the server and the TVs. The default protocol is HTTPS.

<< Note

For details on how to configure protocol settings, refer to the following:  ► Configuring a protocol

1	 From the menus at the top, click  > Settings > System.

2	 Select a communication method from Communication Protocol.

3	 After configuring the required settings, click Apply.

Initial TV setup

To use REACH 4.0, configure settings from the TV.

<< Note

For details on how to configure settings from the TV, refer to the following:  ►Initial TV setup

1	 Select REACH Solution from the initial TV setup menus.

2	 Set REACH for the Orsay model and REACH RF Mode for the Tizen model to ON.

3	 Set REACH IP Mode to ON.

4	 Select Server IP Setting for the Orsay model and Server URL Setting for the Tizen model.

5	 When the Reach server's IP address configuration screen appears, fill in the address input field with the appropriate IP 
address for the address protocol setting, and then select Done.

–– Enter "http://REACH IP address/content" if the protocol was set to HTTP.

–– Enter "https://REACH IP address:443/content" if the protocol was set to HTTPS.

6	 Set Room Number for the Orsay model and Room Number for the Tizen model. Enter the room number.

7	 Turn off the TV and then on again.



19

Tutorial

Configuring room information

From REACH 4.0, manually register TV information or view TV information automatically registered for each room.

Registering room info

<< Note

For details on how to register and manage room information, refer to the following:  ► Managing room info

1	 From the menus at the top, click MANAGEMENT > Room.

2	 Click New.

3	 Enter room information and click OK.

Monitoring room TVs

<< Note

For details on how to monitor TVs, refer to the following:  ► Monitoring room TVs

On the top menus, click MONITORING to monitor the TV connection and room occupancy.

Creating/configuring a project

Create a project to use as TV content. 

<< Note

For details on how to create a project, refer to the following:  ► Creating a new project

1	 From the menus at the top, click PROJECT > New.

2	 Select a project template type and click OK.

3	 From the edit screen, configure a project, using the following features.

<< Note

For details on how to configure a project, refer to the following:  ► Configuring a project

4	 After editing the project as desired, click FILE > Save.

5	 A confirmation window appears. Click Yes.
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Distributing a project

Distribute the project, configured from REACH 4.0, to the TVs. 

<< Note

For details on how to distribute a project, refer to the following:  ► Distributing a project

Configuring TV settings

Use REACH 4.0 to configure settings for TVs in rooms, including initial configuration values, basic information, and information 
related to channels, DRM, and tickers. 

<< Note

For details on how to configure or manage TV settings, refer to the following:  ► Configuring TV settings, ► Managing registered TV 
configuration

Distributing TV configuration

TV configuration created using REACH 4.0 can be distributed to TVs. 

<< Note

For details on how to distribute TV configuration, refer to the following:  ► Distributing TV configuration

Updating TV configuration

TV configuration distributed using REACH 4.0 can be updated from TVs.

Turn off the TV to perform an update and then turn on the TV again.

Registering TV software

Upload TV software from your computer to REACH 4.0.

<< Note

For details on how to register and manage TV software, refer to the following:  ► Registering TV software, Managing registered TV software

1	 From the menus at the top, click MANAGEMENT > TV Software.

2	 Click Import.
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3	 Configure TV software information.

4	 After configuring the required settings, click OK.

Distributing TV software

Distribute TV software, registered on REACH 4.0, to the TVs.

<< Note

For details on how to distribute TV software, refer to the following:  ► Distributing TV software

1	 From the menus at the top, click DEPLOYMENT.

2	 Click NEW and select TV Software.

3	 Select TV software from the dropdown list and configure the distribution settings.

4	 Click Deploy.

Updating TV software

Update the TV with TV software distributed from REACH 4.0.

Turn off the TV to perform an update and then turn on the TV again.

▪▪ If there is distributed TV software on the server, an update is performed when the TV is turned off.

▪▪ Controlling the TV power during the update may cancel the update.

Remotely controlling TVs

<< Note

For details on how to monitor and remotely control TVs, refer to the following:  ► Monitoring room TVs

On the top menus, click MONITORING to monitor the TV connection and room occupancy as well as to control the selected TV 
remotely.
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03 Launching REACH 4.0

Running the webpage

1	 Launch REACH 4.0, using either of the following options: 

Option 1  Click Start > All Programs > REACH 4.0 > REACH 4.0.

Option 2  Open a web browser and access the REACH 4.0 website.

–– In IP mode, access the website via either http://localhost:7001 or https://localhost:7002, based on the protocol 
settings.

–– In RF mode, access the website via https://localhost:443.

Option 3  Double-click  on the desktop.

<< Note

REACH 4.0 is compatible with IE (9.0 or higher), Chrome and Firefox.

2	 If the security error page appears, click Advanced > Add Exception and add the REACH 4.0 website to the security exception 
list.

<< Note

•	 The security error page appears differently, depending on the browser you are using. This tutorial assumes that you are using FireFox.

•	 Adding the website to the security exception list is required only once when the software runs for the first time after install.

Registering a license

When you run REACH 4.0 for the first time after install, you will be prompted to register your product license. Use the program by 
registering the license key that came with the product or obtaining a free license key.

<< Note

•	 In RF mode, only a free license can be registered. Registering a license is needed only once when launching the software for the first time after 
installation. 

•	 In RF mode, the license window appears automatically as soon as a connection to REACH 4.0 is established. 

•	 In IP mode, a paid or free license can be registered. The license should be updated if the expiration date or the maximum number of devices that 
can be registered is exceeded.

SAMSUNG LYNK™ REACH 4.0
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•	 In IP mode, you can manage a registered license. For further information, refer to the following:  ►Managing your REACH 4.0 licenses

•	 To add or manage licenses in IP mode, go to  > Settings > License > License.

Registering a free license

After installing the program, obtain a free license and then use the program.

<< Note

•	 In RF mode, you can obtain a free license and use the program without an expiration date.

•	 In IP mode, obtain a free Trial license and use all features in the program for 30 days.

1	 Run REACH 4.0.

–– For further information, refer to the following:  ► Launching REACH 4.0

2	 On the license screen, click Add > Free Licence.

3	 Enter free license information.

1

Select the desired free license type. Make sure that IP mode is in use.

▪▪ Trial: Access all features in REACH 4.0 for 30 days.

▪▪ IPTV Only: Access MANAGEMENT > TV Configuration only for unlimited time.

TV and IPTV channel configurations can be exported to a USB device and used on a TV via Clone USB to 
TV.

1

2

3

5

4
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2

Set the Internet connection state to Connected.

<< Note

To register a license with no Internet connection, select Disconnected. Download and register a license from another 
computer with an available Internet connection. For further information, refer to the following:  ► Manually registering a 
license

3 The obtained free license key is shown.

4 Enter user information.

5
Select the checkbox to agree to the terms and conditions. Click Terms and Conditions to view specific terms 
and conditions.

4	 After entering the required information, click Activate.

5	 An activation confirmation window appears. Click OK.

–– The REACH 4.0 main screen appears.

–– If incorrect license information is entered, a warning prompt will appear. If this occurs, correct the information.

Registering a paid license

In IP mode, register the license key that came with the product and then use the program.

1	 Run REACH 4.0.

–– For further information, refer to the following:  ► Launching REACH 4.0

2	 On the license screen, click Add > Paid Licence.

–– The license server address is automatically set when REACH 4.0 is installed.
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3	 Enter paid license information.

1

Set the Internet connection state to Connected.

<< Note

To register a license with no Internet connection, select Disconnected. Download and register a license from another 
computer with an available Internet connection. For further information, refer to the following:  ► Manually registering a 
license

2 Enter the license key that came with the product.

4	 After entering the required information, click Activate.

5	 An activation confirmation window appears. Click OK.

–– The REACH 4.0 main screen appears.

–– If you change the board of a TV that has a registered license, the previous license and TV information is registered again. 
As a result, the message "License is not verified" will appear. After replacing the board of a TV, make sure to update the TV 
information configured for the room and license. For further information, refer to the following:  ► Managing TV info

1

2



26

Launching REACH 4.0

Manually registering a license

If an Internet connection is not available on your computer, obtain and register a license from another computer with an available 
Internet connection

<< Note

If an Internet connection is available on your computer, select Connected and obtain a license from your computer. For further information, refer to 
the following:  ►Registering a license

1	 Run REACH 4.0.

–– For further information, refer to the following:  ► Launching REACH 4.0

2	 On the license screen, click Add > Paid Licence or Free Licence.

3	 Set Internet Connection to Disconnected.

4	 Download the license activation file from another computer, following the displayed instructions.

5	 Click Read Activation Key.

–– Search for a license activation file stored on your computer.

6	 If a license activation file is not found on the computer, the select file window appears. Select a mode from the options 
below and import a license file from another computer.

–– Browse: Open a file browser window and select the path of the license file. 
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–– Enter Manually: Manually enter the license activation key stored in the Activation.key file.

–– Close: Close the confirmation window.

7	 A notification window appears when activation is successful. Click OK.

–– The REACH 4.0 main screen appears.

–– If incorrect license information is entered, a warning prompt will appear. If this occurs, correct the information.

Logging in

After license activation is complete, access the REACH 4.0 website to manage client information or configure TV content settings.

1	 Run REACH 4.0.

–– For further information, refer to the following:  ► Launching REACH 4.0

2	 On the login screen, enter your ID and password and click SIGN IN.

<< Note

•	 REACH 4.0 is accessible only to administrators and users approved by administrators to sign up.

•	 To log in after launching REACH 4.0 with the initial administrator account (ID: gaadmin / password: qaadmin) or initial user account (ID: sample / 
password: qwerty), make sure to change the password. Make sure to change the password to ensure security.

•	 If the password is entered incorrectly five times in succession, the current account will become locked and can no longer be used. To unlock the 
account, log in by entering a CAPTCHA response.

•	 Note that you are automatically logged out if REACH 4.0 is left idle for one hour.
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Registering a user

1	 On the login screen, click CREATE AN ACCOUNT.

2	 Enter account information.

3	 After entering the required information, click OK.

–– Once sign-up is approved by the administrator, the user can log in with their ID and use REACH 4.0. 

<< Note

•	 Fields with * cannot be left blank.

•	 For further information on sign-up approval, refer to the following:  ► Approving users for sign up

•	 User IDs can also be registered by administrators. For further information, refer to the following:  ► Adding users

Account privileges and available features

REACH 4.0 provides different screen displays, fixed menus and features depending on the privileges assigned to the logged in ID. 
Check the availability of features assigned to your account privileges before using REACH 4.0.

User Administrator

Template management X O

Project creation O X

Project management O X

Project distribution O O

TV settings management O O

Group management settings O O

Room monitoring O O

User management X O

Access details management X O

<< Note

•	 Administrator privileges can be assigned to general users as well as administrators. For further information, refer to the following:  ► Managing 
user info

•	 Administrators can distribute all the projects registered on the server. General users can distribute only the projects they have created. 
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Main screen

The main screen of REACH appears as soon as you log in after activating the product license. 

<< Note

Screen layout and fixed menus that are provided can differ from the user guide, depending on the privileges of the logged in ID.

1 The REACH main screen appears.

2
The currently logged in ID is shown. Click the ID to view the user name, account privileges, and the last login time. 
Edit the user information or log out.

3 View details of notifications, such as received messages or changes to account details.

4

Access specific menu items.

▪▪ Settings: Configure REACH settings. For further information, refer to the following:  ► Solution settings

▪▪ Help: Display help information for REACH.

▪▪ About: View the REACH version and copyright details.

1 234

5

6
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5

View room information for each info item.

▪▪ Occupancy: View the room occupancy.

▪▪ Groups: View the number of rooms by the group. In IP mode, you can select the category to which a group 
belongs.

▪▪ Channel Bank: View the number of configured REACH channels and check whether channels are in use.

6 View details of recent management tasks.

Configuring the REACH 4.0 settings

REACH channel setup

In RF mode, to manage a TV via REACH 4.0 or use content created using REACH 4.0 from a TV, set up the REACH channels first.

<< Note

This feature is not available in IP mode.

1	 From the menus at the top, click  > Settings > Modulator.

2	 Configure the Modulator settings required to connect to the TV. 
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Status Status of whether the server is active is shown. To activate the server, click Start.

Modulation Type
Select the appropriate cable type for your region. If you are using the solution 
in Europe, select DVB-C. Select DVB-C (6MHz) for Taiwan and Philippines, and 
OpenCable for the US.

Frequency
Select a channel frequency from the dropdown list. Each channel number is initially 
assigned a unique frequency. Change the frequency and then set an appropriate 
channel.

Constellation

Select a frequency modulation type. 

>> Caution

Selecting QAM64 is required to use REACH 4.0 properly.

Signal Level Adjust the signal intensity for each REACH Server model.

Symbol Rate Set the frequency modulation speed.

Maximum Bitrate Set the maximum transfer rate when sending data from REACH to the TV. 

Update Seed Stream

▪▪ Add multiple channels to Seed Stream: Include multiple streams in the REACH 
Seed channel. You can also enter a URL and then use real-time streaming.

–– The REACH Seed channel can include a maximum of four streams.

–– The channel can include only one real-time streaming feature that uses URL.

–– The real-time streaming feature is compatible with RTP multicasting format 
only.

▪▪ Browse for One Seed Stream: Include one stream in the REACH Seed channel.

3	 After configuring the required settings, click Apply.

<< Note

•	 Make sure the REACH channel info configured on the server is identical to the channel info on the room TV. For details on how to set the REACH 
channel on TVs, refer to the following:  ►REACH channel setup

•	 By default, the REACH channel is set to 87 and the frequency is set to 603 MHz. For more information on frequencies and channels, refer to the 
following:  ► Channels and frequencies

•	 Set the maximum transfer rate to 3 Mbps if you are using HA series TV models or if a TV group includes HA series models.

•	 To use with Seed Stream, files 
- cannot exceed the transport stream bit rate 20 Mbit/s 
- must be in mpegts format. 
- video codec: h264 and mpeg2video  
- audio codec: ac3 and mp2 
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Initial TV setup

To import server info from a TV or update TV software, initial setup is required on the TV. 

<< Note

Displayed initial TV setup menus can vary depending on the TV model. This user guide is based on the initial TV settings menu on the Orsay model.

Activating REACH 4.0 and configuring mode
To manage a TV via REACH 4.0 or use content created using REACH 4.0 from the TV, activate REACH 4.0 on the TV.

1	 Select REACH Solution from the initial TV setup menus.
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2	 Configure connection mode settings.

–– To connect to the Orsay model in RF mode, set REACH to ON and REACH IP Mode to OFF. 

To connect in IP mode, set REACH to ON and REACH IP Mode to ON.

–– To connect to the Tizen model in RF mode, set REACH RF Mode to ON and REACH IP Mode to OFF. 

To connect in IP mode, set REACH RF Mode to OFF and REACH IP Mode to ON.

3	 Turn off the TV and then on again.

–– Changes will be applied to the TV.
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REACH channel setup
Set up the REACH channel from a TV.

<< Note

To use REACH 4.0 in conjunction with a TV properly, make sure the REACH channel info configured on the TV and server is identical to one another. 
For details on how to set the REACH channel on the server, refer to the following:  ►REACH channel setup

REACH channel setup in North America

1	 From the initial TV setup menus, select Channel > Channel Setup.

–– The channel setup menu items will appear.

2	 Select Broadcasting > Auto Program.
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3	 Select Start. 

4	 Select Cable from the list of automatic search modes.

5	 Select Scan.

–– Channel search will start.

6	 If retrieved channels are listed, use the TV remote control to select a channel that displays the default playback screen.

REACH channel setup in Europe

1	 From the initial TV setup menus, select Channel > Channel Setup.

–– The channel setup menu items on the TV will appear.
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2	 Select Broadcasting > Auto Tuning > Auto Tuning.

3	 Select Start.

4	 Set automatic search mode, using the following options.

–– Aerial: Set the channel search type. Select Cable.

–– Channel Type: Set the transmission mode for the channel to search for. Select Digital.

–– Scan Mode: Set the search mode. Select Full.

5	 Select Scan.

–– Channel search will start.

6	 If retrieved channels are listed, use the TV remote control to select a channel that displays the default playback screen.
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Room number settings
Set a room number from a TV.

<< Note

To use REACH 4.0 in conjunction with RTV EACH 4.0 properly in RF mode, make sure the room info configured on the TV and server identical to 
each another. For details on how to set room numbers on the server, refer to the following: ► Managing rooms by room

1	 From the initial TV setup menus, select REACH Solution > Room Number.

2	 Enter a room number using the displayed virtual keyboard.

3	 Turn off the TV and then on again.

–– Changes will be applied to the TV.
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Group ID settings
From room TVs, group the TVs to assign a group ID to them.

<< Note

•	 Configure group ID settings only when connecting to RF mode. 

•	 To use REACH 4.0 in conjunction with a TV properly, make sure the group info configured on the TV and server is identical to one another. For 
details on how to register room TV groups on the server, refer to the following:  ► Managing rooms by group

1	 From the initial TV setup menus, select REACH Solution > Group ID.

2	 Select a group ID. 

<< Note

Group IDs can be set in the 1 to 99 range.

3	 Turn off the TV and then on again.

–– Changes will be applied to the TV.

Enabling automatic update
Configure settings so that TV settings or software automatically update at a specified time or when the TV is turned off.

<< Note

•	 Automatic update is available only when RF mode is in use.

•	 For details on how to perform automatic update, refer to the following:  ► Automatic update
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1	 Select REACH Solution from the initial TV setup menus.

2	 To automatically update TV settings or software at a specified time, select REACH Update Time and specify the time.

3	 To automatically update TV settings or software when the TV is turned off, set REACH Update Immediate to ON.

4	 Turn off the TV and then on again.

–– Changes will be applied to the TV.

Configuring IP mode settings
If IP mode is in use, use the initial TV menu to configure TV network settings, enable REACH 4.0, and then set the IP address for the 
REACH server.

<< Note

The TV network must be identical to the network of the computer where REACH 4.0 is installed.

1	 From the initial TV setup menus, select Network > Network Setup.

2	 The network settings menu appears. Select Network > Network Settings.

3	 On the network settings screen, specify the network type (wired or wireless) and select Connect.

4	 The network connection settings screen appears. Select IP Settings.

5	 Use the IP settings screen to configure the IP address and subnet mask, and other IP settings for the TV.

<< Note

We recommend that the IP address be manually specified by selecting Enter manually from IP Setting.

6	 Select OK to save specified IP settings.

–– Configuring TV network settings is complete.
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7	 Select REACH Solution from the initial TV setup menus.

8	 Set REACH IP Mode to ON.

9	 Select Server IP Setting for the Orsay model and Server URL Setting for the Tizen model.

10	 When the Reach server's IP address configuration screen appears, fill in the address input field with the appropriate IP 
address for the address protocol setting, and then select Done.

–– Enter "http://REACH IP address/content" if the protocol was set to HTTP.

–– Enter "https://REACH IP address:443/content" if the protocol was set to HTTPS.

<< Note

Protocol must be configured using the same method applied in REACH 4.0. For details on how to configure a protocol in REACH 4.0, refer to the 
following:  ► Configuring a protocol

11	 Turn off the TV and then on again.

–– Changes will be applied to the TV.



41

04 Creating TV content

Creating a new project

Create a project to use as TV content.

1	 From the menus at the top, click PROJECT > New.

<< Note

To go to the project list when another project is running, click FILE > Open.

2	 Select a project template type and click OK.

–– The edit screen for a new project with the selected template applied will be displayed.

1 View available template types.

2

▪▪ Type: Select a theme color for the selected template. If a A~G Type-type template is selected, only Default 
colors are supported.

▪▪ Apps Area: Activate or deactivate the application area in the template. This feature is available only when 
you are logged in under IP mode.

2

1

SAMSUNG LYNK™ REACH 4.0
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3	 From the edit screen, configure a project, using the following features.

–– Available edit features can vary depending on the selected element type. For further information, refer to the 
following:  ► Configuring a project

1 Use this menu to manage files. Clicking the menu will display sub-menu items.

2 Configure the project preview, element addition, page navigation and project language settings.

3 The name of the current project is shown.

4 This is the project toolbar section. Available functions vary, depending on the selected element.

5
Set properties of an element clicked from the edit section. Available tools are enabled according to the 
element. Tools that are not available will appear disabled.

6 Zoom in or out on the edit project screen.

4	 After editing the project as desired, click FILE > Save.

–– To save under another name, click FILE > Save as.

5	 A confirmation window appears. Click Yes.

–– The project will be saved.

<< Note

Default templates can be set only by administrators. For further information, refer to the following:  ►Managing templates

1 2

6

5

3

4
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Configuring a project
Configure a project using various edit features of REACH 4.0.

Opening the edit project screen

1	 From the menus at the top, click PROJECT.

<< Note

To go to the project list when another project is running, click FILE > Open.

2	 Click the name of the project to edit.

–– The edit screen for the project will be displayed.

–– If there is no project registered, create a new project. For further information, refer to the following:  ► Creating a new 
project

Editing TV menus

Set a virtual menu that will give you quick access to a specific menu item on the TV. 

1	 On the edit project screen, click a TV menu element.
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2	 Set the element properties using the properties toolbar.

–– Layout: Set the element and menu display type for the shortcut menu.

–– : Set the menu background color.

–– Default: Set the menu font. 

–– : Delete a TV menu.

<< Note

Double-click the text and image of a TV menu to edit the menu details, if required. For further information, refer to the following:  ► Editing text, 
Editing images

Editing default menu items

Set the default REACH 4.0 menu items for TV content.

1	 On the edit project screen, click a default menu element.

2	 Set the element properties using the properties toolbar.

–– Page Type: Select a page type from Standard(Hotel Menu)/Widget/Weather/TV Menu.

–– : Set the menu background color.

–– Default: Set the menu font.

–– : Go to the page where the menu is linked.
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<< Note

•	 You can edit the text and image of a basic menu. For further information, refer to the following:  ► Editing text, Editing images

•	 Page types provided in the properties toolbar differ by project type:

–– 2014 Type: Standard/Weather/TV Menu

–– 2015 Type: Hotel Menu/Widget/TV Menu

•	 Chromecast under TV Menu is available for 2015 type projects only.

•	 For 2014 type projects, Chromecast can be found in TV menu element > Action > Type: Launch Native App.

Adding pop-ups

Add pop-ups to a project.

1	 On the edit project screen, click SETTINGS > Page View.

2	 From the list below PAGE VIEW, click  and select Pop-up.

–– Alternatively, right-click on the page list and select New Page > Pop-up.

<< Note

For details on how to edit a pop-up, refer to the following:  ► Configuring pop-up settings
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Editing page properties

Adding pages

1	 On the edit project screen, click SETTINGS > Page View.

2	 From the list below PAGE VIEW, click  and select Blank Page.

–– Alternatively, right-click on the page list and select New Page > Blank Page.

1 Change the mode to view pages.

2 Access a new page that has been added.

1

2
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Adding ad pages
Add ad pages to a project.

<< Note

To add an ad page, first activate the ad pop-up function. For further information, refer to the following:  ► Ad page settings

1	 On the edit project screen, click SETTINGS > Page View.

2	 From the list below PAGE VIEW, click  and select Advertisement.

–– Alternatively, right-click on the page list and select New Page > Advertisement.

<< Note

For details on how to edit an ad page, refer to the following:  ► Ad page settings 
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Adding a Chromecast page
Add a Chromecast page to a project.

<< Note

•	 For 2014 type projects, Chromecast can be found in TV menu element > Action > Type: Launch Native App.

•	 For 2015 type projects, Chromecast can be found in default menu element > TV Menu.

1	 On the edit-project screen, click either a TV menu element or default menu element.

2	 Select TV menu element > Action > Type: Select Chromecast, or select default menu element > TV Menu > Chromecast, 
and then specify the Type.

<< Note

For details on how to edit a Chromecast page, refer to the following:  ► Configuring Chromecast page settings
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Adding a sub page

1	 On the edit project screen, click SETTINGS > Page View.

2	 Click a page from the list below PAGE VIEW.

3	 Click .

–– A new page will be added under the selected page. 

1 Change the mode to view pages.

2 View the upper-level page of the added page.

3 Access a new sub page that has been added.

3

2

1
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Deleting a page

1	 On the edit project screen, click SETTINGS > Page View.

2	 From the list below PAGE VIEW, click  for a page.

–– Alternatively, right-click on a page and select Delete Page.

3	 A confirmation window appears. Click Yes.

–– The page will be deleted.

Navigating through pages

1	 On the edit project screen, click SETTINGS > Page View.

2	 Click a page from the list below PAGE VIEW.

–– You will be redirected to the corresponding page.

–– To go to the uppermost project page, click .

3	 To close the list of pages, click .
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Rearranging pages

1	 On the edit project screen, click SETTINGS > Page View.

2	 From the list below PAGE VIEW, click and drag the page to rearrange to the desired position.

Changing a page name

1	 On the edit project screen, click SETTINGS > Page View.

2	 From the list below PAGE VIEW, click a page to rename.

3	 Right-click on the page and select Rename.

4	 Enter a new name and press Enter on the keyboard. 

–– The new name will be applied to the Page View list.

Inserting an audio file
Insert an audio file in a page to set the background music.

1	 On the edit project screen, click SETTINGS > Page View.

2	 Click a page from the list below PAGE VIEW.

3	 Click .

–– Alternatively, right-click on a page and select Insert Audio.

4	 Select an audio file to insert and click OK.
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1 Search for an audio file name.

2 Upload an audio file to the server.

3 Change the mode to view audio files.

4 Audio files saved on the server are listed.

Sub-menu layout settings

1	 On the project edit page, click a basic menu and select .

1

4

2 3



53

Creating TV content

2	 On the displayed sub-page, click a menu item to change the layout for.

3	 Select a layout from the Sub type dropdown list on the toolbar.

–– The selected element layout will be changed.

<< Note

The Sub type dropdown list will not appear on the toolbar if the clicked basic menu does not contain sub-menu items.
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Configuring pop-up settings
Configure pop-up messages and button functions.

1	 On the edit project screen, click SETTINGS > Page View.

2	 In the list under PAGE VIEW, select the desired Pop-up screen.

1 2

1 Enter button names under Button Settings, and specify functions of the buttons.

2 Select the text and image sections, and configure a pop-up screen.
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Ad page settings
Enable or disable pop-up ad mode and configure settings to use pop-up ads.

1	 On the edit project screen, click SETTINGS > Page View.

2	 From the list below PAGE VIEW, select the Advertisement Popup checkbox.

3	 Click  to configure settings to use pop-up ads.

1

2

3
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1

Configure pop-up ad settings, using the following features.

▪▪ Action: Set features to run in pop-up ads.

▪▪ Select Page: Set pages to be connected to pop-up ads. This option is available when Action Type is set to 
Go to page.

▪▪ RCN Major: Enter a primary channel number displayed on the TV when Tune to Channel is selected for 
Action Type. 

▪▪ RCN Minor: Enter a secondary channel number displayed on the TV when Tune to Channel is selected for 
Action Type.

<< Note

Enter -1 if the channel to set consists of a primary channel number. For example, to set a channel numbered 11, enter -1 in 
RCN Minor and 11 in RCN Major.

2
Set the time to display a pop-up ad. Enter a start time and click ADD to add the time to the list. This option is 
disabled if the pop-up ad is set to appear repeatedly at specific intervals.

3

Set the pop-up ad to appear repeatedly at specific intervals. This option is disabled if the pop-up ad time 
setting is configured.

▪▪ Ad Duration (sec): Set the duration to display a pop-up ad.

▪▪ Repeat: Select whether to repeat a pop-up ad. 

▪▪ Cycle (min): Set the time intervals to display the pop-up ad.

4	 After configuring the required settings, click OK.

5	 Click Advertisement Popup from the PAGE VIEW list and configure pop-up pages.

<< Note

You can configure a variety of ads by adding ad pages. For further information, refer to the following:  ► Adding ad pages
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Configuring Chromecast page settings
Configure Chromecast page contents and screen transition settings.

<< Note

To configure Chromecast page settings, first add a Chromecast page.  ► Adding a Chromecast page

1	 On the edit project screen, click SETTINGS > Page View.

2	 In the list under PAGE VIEW, select CHROMECAST PAGE and configure a Chromecast page.

3	 Click Change Source to Chromecast, and then select Action to specify the Source for screen transition.
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Welcome page settings
Select whether to use a welcome message. Set the message details.

1	 On the edit project screen, click SETTINGS > Page View.

2	 Select the Welcome page checkbox in the PAGE VIEW list.

3	 Click Welcome page and then configure a welcome page.

IPG settings
Set the IPG layout displayed on the channel screen.

1	 On the edit project screen, click SETTINGS > Page View.

2	 In the list under PAGE VIEW, select IPG.

3	 Click IPG and configure IPG.

<< Note

•	 IPG under Project supports SMART TVs released after 2017.

•	 Broadcaster Logo displays broadcaster logos of channels configured in TV Configuration > Channel Map.

•	 For details on configuring Broadcaster Logo settings, refer to the following:  ► Channel info settings



59

Creating TV content

Configuring Channel Banner settings
Set the banner layout displayed on the channel screen.

1	 On the edit project screen, click SETTINGS > Page View.

2	 In the list under PAGE VIEW, select CHANNEL BANNER.

3	 Click CHANNEL BANNER and configure a channel banner.

<< Note

•	 Channel Banner  under Project supports SMART TVs released after 2017.

•	 Broadcaster Logo displays broadcaster logos of channels configured in TV Configuration > Channel Map.

•	 For details on configuring Broadcaster Logo settings, refer to the following:  ► Channel info settings



60

Creating TV content

Element property settings

Editing text

1	 On the edit project screen, double-click the text of the element to edit. 

2	 Edit the text using the toolbar.

–– To view all the tools in the toolbar, click .
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Editing images

1	 On the edit project screen, click the image to edit.

2	 Edit the image using the toolbar. 

–– : Open the content library. For further information, refer to the following:  ► Using the content library

–– : Add a slideshow.

–– : Adjust the image size.

–– Effect: Adjust the image brightness.

–– : Delete an image

<< Note

For further information on the content library, refer to the following:  ► Using the content library
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Configuring a slideshow

Configure a slideshow by adding various image files to the image section.

1	 On the edit project screen, click the image to edit.

2	 Click  from the toolbar.

–– The edit slideshow window will appear.

3	 Configure a slideshow using the following features.

1 View the slideshow images. To add an image, click .

2 Set the image transition time.

3 Set the image transition effect.

4 Preview a configured slideshow.

4	 After configuring the slideshow, click OK.

<< Note

Some features in the slide show may not be supported on a TV with substandard specifications. 

2

4

1

3
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Using quick edit menu items
Right-clicking on an element displays quick edit menu items. 

1	 On the edit project screen, right-click on an element.

2	 Edit using the following features.

–– Cut: Cut the selected element.

–– Copy: Copy the selected element.

–– Paste: Paste an element that has been copied or cut.

–– Delete: Delete the selected element.

–– Arrange: Set the order of the selected element.

–– Align: Align the selected elements using a desired mode. This option is enabled only when multiple elements are 
selected.

–– Group: Group the selected elements. This option is enabled only when multiple elements are selected.

<< Note

•	 To go to the page linked to a basic menu, right-click on the menu and select Go to transition.

•	 To select multiple elements simultaneously, click one element after another while holding the Shift key down on the keyboard.



64

Creating TV content

Using the toolbar

Access functions to edit projects, preview projects, change theme colors and add elements.

Using the edit tools
Use the toolbar to conveniently make additional changes to a project being edited.

1	 Click an element from the edit screen.

2	 Edit using the following features.

––  Preview: Preview the project in full screen.

––  Reset: Reset changes made to the project.

––  Undo: Undo changes to restore to the previous state.

––  Redo: Redo changes.

––  Cut: Cut the selected element.

––  Copy: Copy the selected element.

––  Paste: Paste an element that has been copied or cut.

––  Arrange: Set the order of the selected element.

––  Group: Group the selected elements. This option is enabled only when multiple elements are selected.

––  Align: Align the selected elements using a desired mode. This option is enabled only when multiple elements are 
selected.
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Grouping elements
Select multiple elements from the edit page to group and edit the elements simultaneously.

1	 Select elements, using one of the following options:

Option 1  Select elements while holding down the Shift key on the keyboard.

Option 2  Drag the mouse to select elements.

2	 Select  > Group from the toolbar at the top.

<< Note

Another way to group elements is to use the quick edit menu.

Adding elements
Add an element to a project being edited.

1	 Click an element from the toolbar.

2	 Drag the element to the edit section. You can adjust the element size, if necessary.

–– The element will be added to the edit section.

 Text 

Add text. To edit text, double-click an element and edit using the toolbar. For further information on editing text, refer to the 
following:  ► Editing text

 Rectangle

Add rectangle elements. Select the added element and configure the detailed element settings using the toolbar, if necessary.

 Button

Add elements used to perform additional functions using buttons on the TV remote control. Available additional functions 
include navigating through pages, quickly accessing channels with shortcuts, and changing languages. 

▪▪ Select the added element and configure the detailed element settings using the toolbar, if necessary.

▪▪ To set the action of a button on the TV remote control, click Action from the toolbar.

Type Select a function to run when the button is pressed.

Select Page
Specify a page to connect to when the button is pressed after the Go to page function is 
selected.

RCN Minor
Enter a primary channel number displayed on the TV when the Tune to Channel function 
is selected.
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RCN Major

Enter a secondary channel number displayed on the TV when the Tune to Channel 
function is selected.

<< Note

Enter -1 if the channel to set consists of a primary channel number. For example, to set a channel 
numbered 11, enter -1 in RCN Minor and 11 in RCN Major.

Select App
Select an application to run when the button is pressed after the Launch native app 
function is selected.

Change Language
Select a language to switch to when the button is pressed after the Change Language 
function is selected.

 Remote Control Guide 

Add an element used to quickly access a specific function by pressing a shortcut button on the TV remote control.

▪▪ Select the added element and configure the detailed element settings using the toolbar, if necessary.

▪▪ If you select , , or  the basic function assigned to a button on the remote control is performed.

▪▪ If you select , , , , or , you can specify an action to perform when a button is pressed on the TV remote 
control. To specify a button action, click Action on the toolbar.

 Image 

Add image elements. Select the added element and configure the detailed element settings using the toolbar, if necessary. For 
further information on editing images, refer to the following:  ► Editing images

 Audio 

Add audio files. For further information, refer to the following:  ► Inserting an audio file

 Home Channel Viewer 

Add an element that gives you direct access to Seed Stream in REACH. Select the added element and configure the detailed 
element settings using the toolbar, if necessary.

▪▪ It is possible to configure channels in IP mode. Selecting off disables the home channel setting option. To set the home 
channel when this option is disabled, specify a channel.

<< Note

Enter -1 if the channel to set consists of a primary channel number. For example, to set a channel numbered 11, enter 11 in RCN Minor and -1 in 
RCN Major.
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 Information 

Add variable elements such as weather information, time settings, welcome messages and client names.

Channel Information

Add an element that shows information on the channel currently playing on the TV. Select the added element and configure the 
detailed element settings using the toolbar, if necessary.

Check-in Message

Add welcome messages. 

Click Info > Check-in Message and configure message settings.

▪▪ Select the added element and configure the detailed element settings using the toolbar, if necessary.

Settings

Configure the welcome message settings.

▪▪ Start Time: Set the time to start the welcome message.

▪▪ End Time: Set the time to end the welcome message.

▪▪ Message: Set the welcome message type.

Date/Time

Add an element that shows the current date and time to a page. Select the added element and configure the detailed element 
settings using the toolbar, if necessary.

Type Set the date and time display mode.

Path

Add the full path of the current page to the page. For example, if you add this element to the Sauna page under Spa in the HOTEL 
SERVICE menu, the page will display the full path to the page, which is HOTEL SERVICE > Spa > Sauna. Select the added element 
and configure the detailed element settings using the toolbar, if necessary.

Guest Name

Add an element that shows the room guest names entered in the server to a page. Select the added element and configure the 
detailed element settings using the toolbar, if necessary.

Room Number (or Room Name)

Add an element that shows the room number (room name) to a page.
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TV SoftAP Information

Add an element that shows the TV SoftAP information of the room to a page.

Version

Add an element that shows the version info of a project. Select the added element and configure the detailed element settings 
using the toolbar, if necessary.

Pay-per-view Remaining Time

Add an element that shows the duration of room occupancy to a page. Select the added element and configure the detailed 
element settings using the toolbar, if necessary.

 Widget 

Add an element that shows the language selection screen, flight info or wake-up call status, in the form of a widget.

Billing Information

Add a widget element that shows details of hotel bills. 

▪▪ Select the added element, and then use the toolbar to delete the element or change the element font and layout, if 
necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

▪▪ To configure detailed image settings for an element using the toolbar, select the image section of the element.

<< Note

 IP mode includes Express check out button that allows check-out by guests in their room. Click Edit message at the bottom of the widget 
component to add a messages to a display whether check out is enable.

Flight Information

Add a widget element that provides flight information. 

▪▪ Select the added element, and then use the toolbar to delete the element or change the element font, if necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

▪▪ To use the flight info widget, first set the flight info API on the server. For further information, refer to the 
following:  ► Flight widget settings

Language

Add a widget element used to change the language of a project on TVs. 

▪▪ Select the added element, and then use the toolbar to delete the element or change the element font and the number of 
languages to display on the element, if necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

Wake-Up call

Add a widget element that shows wake-up call settings including whether a wake-up call is enabled. 

▪▪ Select the added element, and then use the toolbar to delete the element or change the element font, if necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.
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Weather in Detail

Add a widget element that shows today's weather and upcoming weather forecast to a page. 

▪▪ Select the added element, and then use the toolbar to delete the element or change the font and the date and time display 
mode, if necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

▪▪ To use the weather widget, first set the weather API in REACH. For further information, refer to the following:  ► Weather 
widget settings

Weather Summary

Add a widget element that shows the current weather to a page. 

▪▪ Select the added element, and then use the toolbar to delete the element or change the font, if necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

▪▪ To use the weather widget, first set the weather API in REACH. For further information, refer to the following:  ► Weather 
widget settings

Message

Add a widget element used to view received messages. 

▪▪ Select the added element, and then use the toolbar to delete the element, if necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

<< Note

This feature is available in IP mode only.

Message Counter

Add a widget element that shows the number of new messages.

▪▪ Select the added element, and then use the toolbar to delete the element, if necessary.

▪▪ To configure detailed image settings for an element using the toolbar, select the image section of the element.

IPG

Add an IPG widget element displayed on the channel screen.

▪▪ Select the added element, and then use the toolbar to delete the element or change the font, if necessary.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

▪▪ Select the hotel logo section of the new element, and insert a hotel logo image.

<< Note

•	 IPG under Project supports SMART TVs released after 2017.

•	 Broadcaster Logo displays broadcaster logos of channels configured in TV Configuration > Channel Map.

•	 For details on configuring Broadcaster Logo settings, refer to the following:  ► Channel info settings
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 Menu Bar 

Add a shortcut element for a TV menu item. A maximum of three to five shortcut items can be added.

Click Menu Bar, and specify the number of applications to be displayed and the display mode.

▪▪ To edit the menu icon, double-click the icon section of the element.

▪▪ To edit the menu name, double-click the text section.

▪▪ Select the added element and configure the detailed element settings using the toolbar, if necessary. For further 
information, refer to the following:  ► Editing TV menus

TV Menu Specify menu items to display.

Select type Select a menu display mode.

 Apps 

Add a widget element used to run applications installed on TVs.

▪▪ Select the added element, and then use the toolbar to delete the element or change the layout, background color or font, if 
necessary.

▪▪ Use the layout to specify the number of applications, installed on TVs, to be displayed on the screen and how the 
applications will be displayed.

▪▪ To configure detailed text settings for an element using the toolbar, select the text section of the element.

<< Note

•	 For Type 1, use the layout to specify the number of applications and the display mode. Actual applications are displayed on TVs, according to the 
order they were installed on the TVs.

•	 For Type 2, use the layout to specify the number of applications. The layout can also be used to select the delete-user info option and SMART 
Hub app menu option. After an element is added, the user can select Editor > App Title and then specify the application to be displayed on the 
screen by entering the name of an application installed on the TV.
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Page background settings

1	 Set the page background using one of the following options.

Option 1  On the toolbar, click  Background.

Option 2  On the edit screen, right-click on the page section and select Background.

2	 Select a background mode.

1 Set the background color.

2

Set the background image. To select an image file, click Add Image.

<< Note

Adding a new image is not possible if another image is already applied to the background. Click  to delete the current 
image first.

3 Apply the default theme settings.

4

Set the background audio. To select an audio file, click Add Audio.

<< Note

Adding a new audio file is not possible if another audio file is already applied to the background. Click  to delete the 
current audio file first.

5 Apply the current settings to all pages.

1

2

3

4

5
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3	 After configuring the required settings, click OK.

Theme settings 
Set the color theme that highlights a selected page menu item.

<< Note

This feature is not available for templates that do not support themes. 

1	 On the toolbar, click  Themes.

2	 Click a theme color.

–– The theme color that highlights a selected menu item will be updated.
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Configuring project settings

Configure page navigation and project language settings.

Using the content library
Upload or download content in the content library on the server.

1	 Click SETTINGS > Content Management.

2	 Use the following features in the content library.

1 Close the content library menu.

2 Search for content names.

1
2

3
4
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3

You can manage content.

▪▪ : Upload content saved on your computer to the library.

▪▪ : Download the selected content to your computer.

▪▪ : Create a virtual folder where you can manage files.

▪▪ : Delete the selected content from the library. Default content items which are locked can be deleted 
only by administrators.

<< Note

Supported file formats are shown below.

•	 Image: jpg, jpeg, png / Audio: m2a, mp3 

4 View content by types.

Adding fonts
In addition to basically provided fonts, add custom fonts.

<< Note

•	 Supported font files include true type (.ttf) and open type (.otf) files.

•	 To use an additional font, make sure to name the file using "SamsungSmart_font name.ttf" as the format.

1	 On the edit screen, click SETTINGS > Font > Font Management.

–– The Font Management screen will appear.

2	 Click NEW.

3	 Click Browse and go to the path where your fonts are saved.

4	 Select a font and click OPEN.

5	 Click OK.
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6	 In the Font Management screen, configure the font settings using the following features.

1 Delete the selected font.

2 Added fonts are listed.

3 Change the file name of the selected font. Enter a file name and click Change font name.

4

Add or manage bold or italic font files required for each font. For example, the Arial font requires Arialbd.ttf, 
which is a bold font file, in addition to the basic font file. You can add these additional font files to use specific 
variations of a font.

Changing the system font
Change the font used for all Project pages.

1	 On the edit screen, click Settings > Font > Change All Fonts.

2	 Select the desired font

–– New font is applied to all Project pages.

1

2

3

4
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Setting the default display language for TV content

1	 Click SETTINGS > Language. 

2	 Select the desired language.

–– The selected language will be displayed by default when TV content plays.

Setting supported languages for TV content

1	 Click SETTINGS > Language. 

2	 Click Language Settings.

3	 Set supported languages, using the following features.
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1 Add supported languages. Select a language from the dropdown list and click New.

2 View supported languages that have been added.

3
Add translations for a supported language. For further information, refer to the following:  ► Adding 
translations for supported languages

4	 After configuring the required settings, click OK.

1

2

3
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Adding translations for supported languages
Add translations for a supported language.

1	 Click SETTINGS > Language > Language Settings.

2	 Click Translation.

3	 Add translations, using the following features.

1 Select a language for translation. Only a language added in Language Settings can be selected.

2 View text translated into English.

3 View text translated into the language selected in step 1. To edit translated text, click it.

4

Import or export translations.

▪▪ Import: Import translations in .xls format from the computer.

▪▪ Export: Export translations as an Excel file.

1

4

2 3
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4	 To edit translated text, select a language from the dropdown list and click the text.

5	 Enter a new translation in the Translation window.

1 Set the background color.

2 Configure detailed text settings.

3 View text translated into English.

4 Enter translations for the specified language.

6	 Click Save.

1 12

43
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Edit settings
Change the guideline settings for the edit section.

1	 Configure the editing environment, using one of the following options.

Option 1  Click SETTINGS > Canvas View.

Option 2  On the edit screen, right-click on the page section and select Canvas.

2	 Change the edit settings, using the following features.

1 Display or hide the grid in the edit section.

2 Change the grid color.

3 Change the grid size. Select a size from the dropdown list.

4 Set elements dragged by the mouse to be positioned automatically based on the grids.

5 Display or hide the ruler in the edit section.

6 Reset the grid settings for the edit section.

3	 To save the configured settings, click OK.

1

2

3

5

6

4
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Setting the default project

Set a previously saved project as the default project.

When a new TV connects to the server, the default project is automatically distributed to the TV.  ► Configuring Auto Deploy 
Project settings

<< Note

•	 This feature is available in IP mode only.

•	 When a new TV connects to the server, the default project is distributed to the TV only when there is no project previously distributed through 
Group ID : All.

1	 On the top menu bar, click PROJECT and select Edit.

2	 From the project list, select a project to be used as the default project and click Set as Default Project.

3	 Select a language for the default project, and click Continue.

4	 Select Enable Auto Deploy Project to turn on automatic distribution of the default project when a new TV connects to the 
server, and then click Build Now.

5	 After the project is built, click OK. In the list of project thumbnails, you can see that the built project has been set as the 
default project.

Saving a configured project

1	 After editing the project as desired, click File > Save.

–– To save under another name, click File > Save as.

2	 A confirmation window appears. Click Yes.

–– The project will be saved to the list of projects.
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Managing projects

Edit or delete a stored project.

1	 Click PROJECT from the top menus and select a project name.

<< Note

To go to the project list when another project is running, click File > Open.

2	 Click FILE and manage the project using the following functions.

–– New: Start a new project.

–– Open: Edit a project. For further information, refer to the following:  ► Configuring a project

–– Rename: Change a project name.

–– Save: Save the current project.

–– Save as: Save the current project as another name.

–– Import: Import a project from your computer to the server.

–– Export: Export a project to your computer from the server.

–– File Information: View the name, the last saved time and the user ID of the current project.

–– Close: Close the current project.
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Distributing a project

1	 From the menus at the top, click PROJECT.

2	 In the project list, click Deploy for the project to be distributed.

3	 Use the Deploy pop-up window to configure distribution settings.

1

2

3

4

1

Configure the settings to distribute the project. To display the project on the TV immediately after it is 
distributed, select the Force the Hotel TV app to restart after the update. checkbox.

▪▪ Group ID: Set a TV group to distribute the project to.

▪▪ Version: Set the project version. If you distribute a project to a TV that already has a newer version of 
project, the project on the TV will not be updated. If you set the project version to 0, the project will be 
distributed irrespective of the previously distributed project version. The version will be reset.

▪▪ Language: Set the display language for the project.

2

Set the distribution schedule. If Deploy Immediately is selected, the project is distributed immediately. To 
distribute the project at a specified time, select Schedule Deploying.

▪▪ Start: Set the time to start distribution.

▪▪ End: Set the time to end distribution.

<< Note

To distribute a project on an ongoing basis without an end time, select the Unlimited checkbox.
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3 Set the distribution date.

4

Set the distribution time. Click on  or a blank time slot.

▪▪ Drag the selected section to move to another time slot. Alternatively, drag the arrow on the border to 
adjust the time.

4	 After configuring the required settings, click Deploy.

5	 If a window appears prompting to confirm deleting the existing project, click OK.

6	 When a notification window appears after distribution is complete, click OK.

<< Note

It is possible to distribute a project together with TV configuration or TV software. For details, refer to the following:  ► Parallel distribution

Deleting a distribution project

1	 From the menus at the top, click DEPLOYMENT.

2	 Click Delete.

3	 Select a project checkbox from the Deploy Management list and click Delete.
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Managing room info

Managing rooms by room

Register and manage a room.

Registering room info

1	 From the menus at the top, click MANAGEMENT > Room.

2	 Click New.

3	 Enter room info and click OK.

–– *Room Number: Enter the room number.

–– *IP Address: Select IPv4 or IPv6, and enter the IP address for a room’s TV. Make sure that IP mode is in use.

–– *Mac Address: Enter the MAC address for a room's TV. Make sure that IP mode is in use.

–– Channel Bank: Using the dropdown list, set the channel type accessible to the room TV.

–– Start Date: Set the date and time to start viewing channels.

–– End Date: Set the date and time to end viewing channels. The duration of use of a TV is automatically calculated based on 
the specified date and time.

–– Apps Area: Enable or disable the application area on TV content.

–– Project Language: Select a display language for TV content.

–– Guest Name: Enter the guest name. If more than one guest is staying in the room, click ADD GUEST to add input fields.

–– Company Name: Enter the group name of the guest.

SAMSUNG LYNK™ REACH 4.0
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<< Note

•	 * Required information for room registration (MAC Address not required for RF mode)

•	 Set PMS info and simultaneously upload all the room info registered in the PMS, if required. For further information, refer to the 
following:  ► Managing room info

•	 If an Excel file containing room info is available, import the file to upload all the room info simultaneously. For further information, refer to the 
following:  ► Managing room info

•	 Make sure the room number is identical to the room number on the TV. For further information, refer to the following:  ► Room number 
settings

•	 In channel group settings, group 1 refers to a group of free channels that are accessible from any room. Groups 2 and 3 refer to groups of paid 
channels. If group 2 or 3 is selected, the group will automatically switch to group 1 after a specified viewing period. If a channel group is not 
specified, paid channels are accessible from the room. For further information, refer to the following:  ► Managing registered channel info

•	 If you configure a channel bank for a room without configuring a channel bank for each channel, all channels configured for the TV may 
disappear.

Managing the room info list

1	 From the menus at the top, click MANAGEMENT > Room.

2	 Manage room info, using the following features. 

1

5

32 4

6

1
▪▪ Import: Import a room info file from your computer to register the info on the server simultaneously.

▪▪ Export: Export room info as an Excel file to your computer from the server.

2
Click PMS Settings and configure IP address and port for REACH API Server and Property Management System 
(PMS) to sync REACH 4.0 and PMS. This allows the management of rooms registered in REACH 4.0 via PMS.

3 Delete room information.
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4 Search for a room number.

5 Rearrange room numbers in ascending or descending order.

6 Click repeatedly to switch the room status between check-in and check-out.

Managing rooms by group

Group rooms to simplify the steps required to manage rooms.

Registering a group

1	 From the menus at the top, click MANAGEMENT > Room Group.

2	 Click New.

3	 Set group info and click OK.

1

2

3

4
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1

Select a group category.

<< Note

This feature is available in IP mode only.

2 Set the group ID. Select a number from the dropdown list.

3 Type a memo or brief description about the group.

4

Select room TVs to assign to the group. 

▪▪ All Rooms: Room TVs registered on the server are listed. Select TVs from the list and click  to move 
the TVs to the group.

▪▪ Selected Rooms: Room TVs registered in the group are listed. Select TVs from the list and click  to 
delete the TVs from the group. The TVs will no longer belong to any group.

<< Note

•	 Fields with * cannot be left blank.

•	 In RF mode, make sure the group ID is identical to the group ID on the TV. For further information, refer to the following:  ► Group ID settings
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Managing registered groups

1	 From the menus at the top, click MANAGEMENT > Room Group.

2	 Manage room info, using the following features.

1 Delete group information.

2

Select a group category to view the group list.

<< Note

This feature is available in IP mode only.

3 Search for a group ID.

4 Rearrange the list by item in ascending or descending order.

5 View the list of registered groups.

4
5

1 2 3
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Monitoring room TVs

View room TV connections and room occupancy.

1	 From the menus at the top, click MONITORING.

2	 Monitor rooms, using the following features.

1 The last update time is shown. 

2 View a list of rooms by the group or the room state.

3

Remotely control TVs in selected rooms. To remotely set features, date and time, select a room from the list and 
click the button.

▪▪ Command: Selectable features include power on/off, restart, and change external input source on the TV. 
Select a feature from the dropdown list.

▪▪ Execution Schedule > Run Immediately: Select to run the feature selected in Command immediately.

▪▪ Execution Schedule > Specify Date and Time: Select to run the feature selected in Command on 
specified date and time.

▪▪ Execution Schedule > Repeated Schedule: Select to run and repeat the feature selected in Command on 
specified day(s) of the week and time. 

<< Note

This feature is available in IP mode only.

4 View state information by the icon.

3

6
2

9

8

7

1

54
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5 Change the view mode.

6 Rearrange the list by item in ascending or descending order. To change the criteria to sort the list, click .

7 Registered rooms are listed. 

8

View software update status after deploying it from REACH 4.0.

View TV information for all rooms with a software update history, or only the rooms where the update failed. 
Redeploy TV software to rooms with an unsuccessful update history. Remotely control TVs in selected rooms. 
To remotely set features, date and time, select a room from the list and click the button.

<< Note

This feature is available in IP mode only.

9

View records of remote control events performed in REACH 4.0.

<< Note

This feature is available in IP mode only.
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Managing TV configuration

Configuring TV settings

Configure settings for TVs in rooms.

Registering basic TV model info

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click New.

3	 Enter TV model information to be registered, and click OK.

–– *Configuration Title: Enter a unique name for the TV to register.

–– *Year: Set the year the TV was manufactured.

–– *Region: Set the TV region. This option is enabled if the manufacture date is set.

–– *Series: Set the TV series. This option is enabled if the manufacture date is set.

–– *Model No.: Set the TV model name. This option is enabled if the manufacture date is set.

–– *S/W Name: Automatically enters the name of the software supported on the configured TV model.

<< Note

•	 Fields with * cannot be left blank.

•	 When required information is entered, the TV configuration screen automatically appears. 
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Extracting and registering TV configuration

1	 Select Cloning from the initial TV setup menus.

2	 Select Clone TV to USB to save TV configuration to a USB device.

3	 Insert the USB device containing TV configuration into the computer where REACH 4.0 is installed.

4	 On the top menus in REACH 4.0, click MANAGEMENT > TV Configuration.

5	 Click Import.

6	 On the Import Room List screen, specify import conditions and click Browse.

7	 Select the TV configuration file.

8	 Click OK.

Channel info settings
Set channel information for the selected TV.

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click the desired TV configuration name.

3	 Click Channel Map.

–– Channels available on the TV will be listed.

4	 Click New.
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5	 In the displayed add channel window, fill in the input fields and click OK.

–– Channel Category: Select a channel type such as air or cable. You can also select a signal type for each channel type. 
Available items for configuration vary, depending on the selected channel type (Air, Cable or IP) and signal type (Analog, 
Digital or External) for the channel type. 

–– Channel Name: Set the channel name.

–– Program No.: In Europe, enter a channel number that can be viewed from rooms. In the US, set the program number for 
channel.

–– Display No.: This has a function similar to Program No. in Europe.

–– IP Address: This option appears only when the channel type is set to IP. Enter an IP address to which to connect.

–– Port: This option appears only when the channel type is set to IP. Enter port information for the IP to which to connect.

–– Associate with Program Guide: This option appears only when the channel type is set to IP. To use this feature, first 
activate the program guide. For further information, refer to the following:  ► Setting up a program guide

–– Frequency: This option appears only when the signal type is set to Digital. Set the channel frequency.

–– Service ID: This option appears only when the signal type is set to Digital. Enter a service ID for a channel.

–– Color System: This option appears only when the signal type is set to Analog. Set the color output mode for a TV.

–– Sound System: This option appears only when the signal type is set to Analog. Set the sound output mode for a TV.

–– PTC No.: This is an actual channel number that is used during communication between broadcast stations and the server. 
It is different from Display No..

–– Modulation: This option appears only when the signal type is set to Digital. Set the channel encoding type.

–– Bandwidth: This option appears only when the signal type is set to Digital. Set the channel bandwidth.

–– Symbol Rate: This option appears only when the signal type is set to Digital. Set the channel modulation speed.

–– External Source: This option appears only when the channel type is set to External. Set the external input source type.

–– PLT ID: This option appears only when the channel and signal type is set to a combination of Air + Digital.

–– Broadcaster Logo: Set the broadcaster logo for a channel. Only .png files smaller than 20 kb can be set as logos.

6	 After configuring the required settings, click Save.

–– To save under another name, click Save as.

<< Note

•	 Ensure that all the input fields are filled in.

•	 IP channels can only be configured for TVs that support REACH IP Mode. To configure an IP channel, first create a TV configuration from the 
REACH Server to ensure availability of the channel on the TV. For further information, refer to the following: ► Distributing TV configuration 

•	 For the US and Canada, configuring program information is a simple process that involves setting up a program guide. For further information, 
refer to the following:  ► Configuring channel information using a program guide

•	 For further information on how to manage registered channels, refer to the following:  ► Managing registered channel info
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Configuring channel information using a program guide

For the US and Canada, set up a program guide and easily configure channel information using data contained in the program 
guide. 

<< Note

To configure channel information using a program guide, first set up the program guide. For further information, refer to the following:  ► Setting 
up a program guide

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click a TV information item.

3	 Click Channel Map.

4	 Click Import > Program Guide.

<< Note

The load-program guide feature is displayed only in TV configuration for North America and Canada.

5	 Click YES.

Registering a ticker
Register ticker information in the selected TV. Ticker refers to a service that displays weather conditions, stock prices and other 
information on the TV. Tickers appear at specified time intervals. 

<< Note

TV models released after 2016 do not support the ticker feature.

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click a TV information item.

3	 Click Ticker.

4	 Click NEW.

5	 Enter ticker information and click OK.

–– Message: Enter text to display along with the ticker.

–– Image: Set the ticker image. Click Add Image and select an image. To delete a registered image, click .
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6	 Click Options.

7	 Configure detailed settings for the ticker and click OK.

–– Repeat: Set the frequency to display the ticker on the TV screen.

–– Ticker Interval(mins): Set the interval in minutes to display the ticker on the TV screen.

–– Text Color: Set the color of the text to display along with the ticker. To change the color, click Choose to select a color and 
click Close.

–– Background Color: Set the ticker background color. To change the background color, click Choose to select a color and 
click Close.

8	 After configuring the required settings, click Save.

–– To save under another name, click Save as.

Managing channel DRM
Manage IPTV channel DRM for the selected TV configuration.

<< Note

DRM (Digital Rights Management) is used to restrict the use of content to specific purposes intended by the copyright holder.

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click a TV information item.

3	 Click Channel DRM.

4	 Enter DRM information.

–– DRM TYPE: Select a DRM type.

<< Note

REACH provides two types of DRMs ideal for management of Hotel Smart TV services: Verimatrix VCAS and Samsung SCAS. Series models 690 and 
890 released in North America after 2014 support IP Pro:idiom.
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–– COMPANY NAME: Enter a DRM provider's company name.

–– DRM IP: Enter a DRM IP.

5	 After entering the required information, click Save.

–– To apply settings, click Apply.

Changing TV configuration
Use REACH 4.0 to change or manage configuration menus provided on TVs.

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click a TV configuration name from the list.

–– The TV configuration screen appears.

–– If no TV is found in the list, register a TV first. For further information, refer to the following:  ► Configuring TV settings

3	 Click the Hospitality tab.

4	 Click REACH Solution from the list of menu items.

5	 Configure TV settings required to interact with REACH 4.0.

–– REACH IP Mode: Select On if IP mode is in use. If RF mode is in use, select Off. If REACH IP Mode is set to On, configure 
Server IP Setting. If REACH IP Mode is set to Off, configure REACH Server Channel / REACH Channel, Ticker, REACH 
Update Time, and REACH Update Immediate.

–– REACH IP Setting: Enter "REACH 4.0 IP." For further information, refer to the following:  ►Initial TV setup

–– REACH Server Channel / REACH Channel: Configure the REACH channel settings on the TV. Make sure the settings are 
identical to the REACH channel settings on the server. For further information, refer to the following:  ►REACH channel 
setup

–– Ticker: It is possible to turn on or off ticker on TV models released in 2016 or earlier. For further information, refer to the 
following:  ► Registering a ticker

–– REACH Update Time: Set the time to sync the TV with the server when the TV is turned off. The time can either be a 
specific time or repeat interval.

–– REACH Update Immediate: Enable or disable the mode to manually sync the TV with the server when the TV is turned off.
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<< Note

If REACH Update Immediate is set to On, 1hour and 2hours under REACH Update Time are disabled.

6	 From other configuration menus, click the desired sub-menu item and configure settings.

7	 After configuring the required settings, click SAVE.

–– The TV settings will be saved on the server.

–– To save under another TV configuration, click SAVE AS.

8	 To apply saved configuration values to TVs, the TV configuration must be distributed from the server. For further information, 
refer to the following:  ► Distributing TV configuration

<< Note

•	 The displayed menu items are the same as the menu items on the TV. For details on initial configuration menus, refer to the following:  ►Initial 
TV setup 

•	 To manage a TV using REACH 4.0 or use REACH 4.0 on the TV, make sure to turn on REACH in the initial TV configuration menu. For further 
information, refer to the following:  ► Activating REACH 4.0 and configuring mode

•	 To specify a particular channel in Hospitality Mode > Power On > Power On Channel Num, the channel must be included in Room 
Type:Default.
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Managing registered TV configuration

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Manage TV info, using the following options.

1

Register new TV information. You can also manage registered information.

▪▪ Import: Import TV info from your computer to the server.

▪▪ Delete: Delete TV information.

2 Search TV information.

3 Rearrange the list by item in ascending or descending order.

4 Distribute TV information. For further information, refer to the following:  ► Distributing TV configuration

5
Export TV info saved on the server to your computer or a removable disk. Exported info can be copied to a TV 
using a removable disk.

1

3

2

4 5
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Managing registered channel info
Edit or delete channel information of the selected TV.

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click a TV information item.

3	 Click Channel Map.

–– Channels available on the TV will be listed.

1 Search registered channels. Select a search criterion from the dropdown list.

2

▪▪ Import: Import channel information and a program guide to the server. For further information on the 
program guide, refer to the following:  ► Setting up a program guide

▪▪ Export: Export channel info to your computer from the server.

▪▪ Edit: Edit channel information.

3 View the program guide.

4

Sort registered channels by channel type. Select a type from the dropdown list.

<< Note

To delete or edit TV information, first categorize the channel type. Follow this same step when changing the display order for 
information items.

5 Rearrange the list by item in ascending or descending order.

6

Registered channels are shown. 

▪▪ Use the scroll bar to view related information.

▪▪ Configure a channel bank for each channel.

▪▪ To use the channel bank feature configured for each channel in a room, make sure a TV configuration is 
applied to the room.

1

2

5
6

3
4
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4	 After configuring the required settings, click Save.

–– To save under another name, click Save as.

Managing registered ticker info

<< Note

TV models released after 2016 do not support the ticker feature.

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click a TV information item.

3	 Click Ticker.

1 Delete a ticker.

2 Configure detailed settings for a ticker such as the display frequency/duration and the text color.

3 Edit a ticker.

4	 After configuring the required settings, click Save.

–– To save under another name, click Save as.

1 2

3
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Distributing TV configuration

Distribute TV configuration to TVs.

<< Note

Check the following before distributing TV configuration.

•	 TV configuration should be distributed to the same TV models with the same TV firmware version.

•	 It is best to update all TVs to the latest TV software version before distributing TV configuration.

1	 From the menus at the top, click MANAGEMENT > TV Configuration.

2	 Click Deploy for the TV configuration to be distributed.

3	 Use the Deploy pop-up window to configure distribution settings.

1

2

3

4

1

Configure settings for distributing TV configuration.

▪▪ Group ID: Specify a target TV group to distribute the TV configuration.

▪▪ Version: Set the TV configuration version. If a TV configuration version being distributed is older than 
the version on a TV, the TV will not perform an update. If setting the TV version to 0, the TV configuration 
is distributed, irrespective of the version of the previous configuration on the TV, and resets the 
configuration on the TV.

▪▪ Opiton: To distribute along with an applied ticker, select the Ticker checkbox.
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2

Set the distribution schedule. If Deploy Immediately is selected, TV configuration is distributed immediately. 
To distribute TV configuration at a specified time, select Schedule Deploying.

▪▪ Start: Set the time to start distribution.

▪▪ End: Set the time to end distribution.

<< Note

To continuously distribute TV configuration without specifying the end time, select Unlimited.

3 Set the distribution date.

4

Set the distribution time. Click on  or a blank time slot.

▪▪ Drag the selected section to move to another time slot. Alternatively, drag the arrow on the border to 
adjust the time.

4	 Click Deploy.

5	 When a notification window appears after distribution is complete, click OK.

<< Note

•	 After distribution of TV configuration in RF mode, manual update should be performed from TVs or automatic update should be turned on. For 
further information, refer to the following:  ► Updating in RF mode

•	 After distribution of TV configuration in IP mode, an update automatically takes place when TVs are turned off. To check to see that TV 
configuration has been distributed properly, turn off the TVs and then on again.

•	 It is possible to distribute TV configuration together with a project. For details, refer to the following:  ► Parallel distribution

Canceling distribution of TV configuration

1	 From the menus at the top, click DEPLOYMENT.

2	 Click Delete.

3	 Select the TV configuration to cancel, and then click Delete.
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Managing TV software 

Registering TV software

Upload TV software from your computer to the server. 

1	 From the menus at the top, click MANAGEMENT > TV Software.

2	 Click Import.

3	 Configure TV software information.

–– TV Software Title: Enter a TV software name.

–– Software: Import TV software from your computer. Click Browse to open a path and select a TV software file.

<< Note

File formats shown below can be added as TV software:

•	 RF mode: OTA format

•	 IP mode: BEM format

4	 After configuring the required settings, click OK.

–– The file is uploaded to the server.
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Managing registered TV software

1	 From the menus at the top, click MANAGEMENT > TV Software.

2	 Manage software, using the following features.

1 Delete TV software.

2 Search registered TV software.

3 Rearrange the list by item in ascending or descending order.

4 Distribute TV software to TVs.

5 Export TV software to your computer from the server.

1

4 5
3

2
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Distributing TV software

Distribute registered TV software to TVs.

1	 From the menus at the top, click MANAGEMENT > TV Software.

2	 Click Deploy for the TV software to be distributed.

3	 Use the Deploy pop-up window to configure distribution settings.

1

2

3

1

Set the distribution schedule. If Deploy Immediately is selected, TV software is distributed immediately. To 
distribute TV software at a specified time, select Schedule Deploying.

▪▪ Start: Set the time to start distributing the project.

▪▪ End: Set the time to end distributing the project.

<< Note

To distribute TV software on an ongoing basis without an end time, select the Unlimited checkbox.

2 Set the distribution date.

3

Set the distribution time. Click .

▪▪ Drag the selected section to move to another time slot. Alternatively, drag the arrow on the border to 
adjust the time.
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4	 Click Deploy.

5	 When a notification window appears after distribution is complete, click OK.

<< Note

•	 In RF mode, distributed TV software needs to be manually updated from the TV. For further information, refer to the following:  ► Updating TV 
configuration or TV software

•	 In IP mode, you can deploy TV software to up to 10 TVs at once. Distributed TV software automatically updates when the TV is turned off. To 
check to see that TV software has been successfully distributed, turn the TV off and on, and then click Management > Room in REACH 4.0. Use 
the Main Firmware and Submicom Firmware Column menu items to check the distribution results.

•	 It is possible to distribute TV configuration together with a project. For details, refer to the following:  ► Parallel distribution

Parallel distribution
Distribute a project together with registered TV software and TV configuration created using the REACH 4.0 server.

1	 From the menus at the top, click DEPLOYMENT.

2	 Click Add and select the TV Information tab.

3	 Select either TV Configuration or TV Software.

4	 Use the dropdown list to select the TV Configuration or TV Software to be distributed, and configure distribution settings.

5	 To distribute a project together, click the Project tab.

6	 Select a project from the dropdown list and configure the distribution settings.

7	 After configuring the required settings, click Deploy.

8	 When you are prompted to confirm that you want to remove the previous distribution, click OK. 

<< Note

•	 To distribute either TV Configuration or TV Software only, select the TV Information tab, configure distribution settings for the TV 
Configuration or TV Software, and then click Deploy.

•	 To distribute a project only, select the Project tab, configure distribution settings for the project, and then click Deploy.
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Configuring additional information
Configure weather, flight, event and ad information.

Weather widget settings

Configure settings for the weather widget provided on TVs.

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Weather Infofmation.

3	 Configure detailed settings.

–– Weather API: Select a weather widget type. 

–– Country & City: Set the area to display weather info. 

–– Temperature Scale: Set the unit to display temperatures.

–– Update Cycle: Set the interval to update weather info.

–– Language: Set the display language for weather information.

4	 After configuring the required settings, click Apply.

Flight widget settings

Configure settings for the widget that provides flight info. 

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Flight Information.

–– Widget ON/OFF: Select whether to use a flight widget.

–– Flight API: Select a flight widget type. 

–– Country & City: Set a region to display flight info. 

–– Airport: Set airports to display flight info.

–– App ID: Enter information in App ID format obtained from FLIGHTSTATS.

–– App Key: Enter a license key obtained from FLIGHTSTATS.

–– Update Cycle: Set the time interval to update flight info (unit: seconds).

3	 After configuring the required settings, click APPLY.

<< Note

Flight widget licenses can be obtained from the following webpage:

https://www.flightstats.com/developers/bin/view/Account+Services/account_types
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Adding messages and notices

Add a message or notice to display on TVs. Messages and notices are displayed only when general TV channels are viewed.

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Message.

3	 Click New and select a message type.

4	 Configure detailed settings.

–– Title: Enter a message or notice title.

–– Recipient Type: Select a recipient type to which to send the message or notice.

–– Group ID/Room Number: Select a group or room to which to send the message or notice.

–– Message: Enter the content of the message or notice.

–– Image: Add image(s) to the message or notice.

–– Sending Options: Configure the time options for sending the message or notice.

–– Closing Option: Configure the options to close the notice window.

5	 After configuring the required settings, click Send.

Deleting a message or notice

Delete messages or notices. It is not possible to delete messages or notices that have already been sent.

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Message.

3	 Click Delete and select the message or notice to delete.

4	 Click Delete.
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Registering events or ads

Register an event or ad to display on TVs at a specified time. Events and ads are displayed only when general TV channels are 
viewed.

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Event & Ads.

3	 Select a room group tab.

–– To register an event or ad to TVs in all rooms, select All.

<< Note

For further information on groups, refer to the following:  ► Managing rooms by group

4	 Click New.

–– The add event screen will be displayed.
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5	 Configure event or ad settings, using the following options.

1 Enter an event or ad title.

2

Select an ad type.

▪▪ L Shape: Organize an ad with images or text.

▪▪ Ticker: Organize an ad with text.

3

▪▪ Templates: Specify the position of an image or text to insert in the template. The template section on the 
right changes according to the selected option.

▪▪ Fill: Select an element type to insert in the area next to the TV screen section. This option is available 
when L Shape is selected. 

4

Use this image box to insert image files. Click  to import the desired image from the content library.

<< Note

This section turns into a text box if you select Text from Fill.

5 Use this text box to input text. You can configure detailed text settings using the toolbar.

1

3 4

5

2
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6	 After entering the required details, click Next and configure the ad time settings.

1 Select days of the week to run an event or ad. Select the checkboxes of desired days of the week.

2

Set the time slot to display an event or ad. If you click on  or a blank time slot, the time slot is highlighted in 
blue. Drag the selected section with the mouse to move to another time slot. Alternatively, drag the arrow on 
the border to adjust the time.

<< Note

To deselect a time slot, right-click on the time slot highlighted in blue and select Delete.

3
Set the time to start and end an event or ad. Click the arrows to set the start and end times. To play an event or 
ad all day, select the All day checkbox.

7	 After configuring the required settings, click Done.

<< Note

In RF mode, the event and ad pages can be updated only when a room's TV is set to the REACH channel. 

1

2

3
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Importing events or ads

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Event & Ads.

3	 Click a room group tab to which to add an event or ad.

4	 Click IMPORT.

5	 On the Import Event & Ads screen, specify import conditions and click Browse.

6	 Select an event or ad file.

7	 Click OK.

Editing events or ads

Edit registered events or ads by time slot.

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Event & Ads.

3	 Click a room group tab where the event or ad to edit is saved.

4	 Double-click the colored section.

–– Alternatively, right-click on the section and select Edit page.

–– The edit screen, where you can edit events or ads assigned to the time slot, appears.

5	 Edit the details, using the following features.

–– Edit specific details using the same method when adding events or ads. For details, refer to the following:  ► Registering 
events or ads

6	 After editing as desired, click OK.

–– The register screen will be displayed.

7	 To save changes, click APPLY.
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Copying event and ad schedule

Copy events and ads from a specific room group and apply them to other room groups.

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Event & Ads.

3	 Click a room group tab where the event or ad to copy is saved.

4	 Right-click on the highlighted section and select Copy to.

5	 Select the room group to paste the event or ad.

–– To register the event and ad to TVs in all rooms, select All.

6	 Click OK.

–– The copied event and ad will apply to selected room group(s). 

Exporting events or ads

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Event & Ads.

3	 Click a room group tab to which to export an event or ad.

4	 Right-click on the event or ad to export and select Export.

5	 On the Export screen, click Select Location.

6	 Specify a path to export the event or ad.

7	 Click Export.
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Distributing events or ads

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click the Event & Ads tab.

3	 Select a room group tab to which to distribute an event or ad. 

–– To register an event or ad to TVs in all rooms, select All.

4	 Under Schedule, select an event or ad and click DEPLOY.

–– The event or ad will be distributed to the TVs under the selected group and automatically displayed on the TVs at the 
specified start time. 

Blocking the initial TV setup menus

Block access to the initial TV setup menus to prevent room TV users from changing the settings.

<< Note

In IP mode, this feature can be run from the Remote Control menu. For further information, refer to the following:  ► Monitoring room TVs

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Factory Lock.

3	 Select whether to block access to initial setup menus, using the following options.

–– Enabled: Disable user access to initial menu items.

–– Disabled: Enable user access to initial menu items. 

4	 After configuring the required settings, click Apply.
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Enabling/disabling Auto Power On/Off

Automatically turn on or off the room TV when a guest checks in or out of a room.

<< Note

This feature is available in IP mode only.

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Auto Power On/Off.

3	 Configure required settings, and click Apply.

Setting up a program guide

Import and add EPG info of a previously used channel to the channel info configured on the server. 

1	 From the menus at the top, click MANAGEMENT > Common Settings.

2	 Click Program Guide.

3	 Set up a program guide, using the following options.

–– Auto Update: Update the program guide automatically.

–– Browse: Set the mode to import EPG info of a previously used channel map. 

•	 From local machine: Import and use a file in .xml format that contains EPG info from your computer.

•	 From server: Import EPG info from Guest-tek. 

–– *Server URL: View the path of Guest-tek to import EPG info. This option appears only when Browse is set to From server.

–– User name: Set the administrator name that will manage EPG info. This option appears only when Browse is set to From 
server.

–– Password: Set the password for the administrator that will manage EPG info. This option appears only when Browse is set 
to From server.

–– *File Path: This option appears only when From local machine is selected under Browse. Manually enter the path to the 
.xml file containing the EPG information saved on the actual REACH 4.0 server. For example, "C:\temp\Epg\samsung_epg.
xml" can be manually entered.

–– Update Cycle: Set the time interval to import EPG info automatically from the specified path.
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4	 After configuring the required settings, click Apply.

5	 Click  to view loaded EPG data.

6	 If you are using Samsung EPG Broker, click Monitoring to monitor information related to EPG Broker Service, On TV Server 
status, EPG settings, and EPG data update.

<< Note

•	 The program guide feature is available in North America, Canada, and Europe (IPTV) only.

•	 Fields with * cannot be left blank.

•	 You can register channel information using a program guide. For further information, refer to the following:  ► Configuring channel 
information using a program guide

•	 To use the Monitoring available in the program guide, you must have Samsung EPG Broker version 0.01.037 or higher fully installed and 
configured.

Updating TV configuration or TV software
TV configuration or TV software distributed from the REACH 4.0 server can be updated from TVs. 

<< Note

•	 For details on how to register and manage TV configuration from the REACH 4.0 server, refer to the following:  ► Configuring TV settings, 
Managing registered TV configuration

•	 For details on how to register and manage TV software from the REACH 4.0 server, refer to the following:  ► Managing TV software 

Updating in RF mode

Manual update

1	 Open the TV configuration or TV software update window, using either of the following options:

–– Searching TV configuration or TV software previously distributed from the server to room TVs will start. 

Option 1  From the TV settings menu, select Support > SW Update.

–– To access the TV settings menu, press the menu button on the TV remote control.

Option 2  From the initial TV setup menus, select System > SW Update.

2	 Select OK.

–– TV configuration or TV software is updated.

–– Controlling the TV power during the update may cancel the update.
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Automatic update

1	 Configure automatic update settings from the TV. For details, refer to the following:  ► Enabling automatic update

2	 Turn off the TV to perform an update and then turn on the TV again.

<< Note

•	 If you specify the REACH Update Time, make sure that the TV is turned off at the specified time to ensure that an update performs.

•	 Controlling the TV power during the update may cancel the update.

Updating in IP mode

Turn off the TV to perform an update and then turn on the TV again.

▪▪ If there is distributed TV settings or TV software on the server, an update is performed when the TV is turned off. 

▪▪ Controlling the TV power during the update may cancel the update.
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Managing my info

View or edit information on the logged in ID.

1	 Click the user ID at the top menu bar.

2	 When the account information window appears, click Account. 

3	 View or edit information, and then click OK.

<< Note

•	 Fields with * cannot be left blank.

•	 ID and Name cannot be edited.

•	 To change the password, click Change Password.

SAMSUNG LYNK™ REACH 4.0
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Solution settings

Configure REACH 4.0 settings. 

Configuring system settings

Specify a display language for REACH 4.0 and configure REACH settings.

1	 From the menus at the top, click   > Settings > System.

2	 Customize system settings.

–– Language: Change the display language of REACH.

–– Auto Show Project: Specify how to run the REACH contents. To automatically play TV media when the TV is turned on, 
select ON. To play TV media when the Home button on the remote control is pressed after the TV is turned on, select OFF.

–– Auto Deploy Project: Configure settings for distributing the default project when a TV connects to the server for the first 
time. To automatically distribute the default project, select ON. To prevent the default project from automatic distribution, 
select OFF.

3	 After configuring the required settings, click Apply.

–– Changes are applied to REACH 4.0.

Configuring Auto Deploy Project settings
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Managing your REACH 4.0 licenses

Obtain a paid or free license, and manage your license.

<< Note

•	 This feature is available in IP mode only.

•	 Registering the same license twice will not renew or update the existing license while the pop-up message Activation was successful. is still 
visible.

1	 From the menus at the top, click  > Settings.

2	 Click Licence > Licence.

3	 Manage your licenses, using the following menu options:

1
Add a license. For further information, refer to the following:  ►Registering a free license, Registering a paid 
license

2 Delete a registered license.

3 Registered licenses are shown. To deactivate a license, click Deactivate.

12

3
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Managing TV info

View and manage information about TVs registered in REACH 4.0.

<< Note

This feature is available in IP mode only.

1	 From the menus at the top, click  > Settings.

2	 Click Licence > TV Licence.

3	 Manage TV information, using the following menu items.

1 Delete TV information.

2 Import TV information automatically or manually.

3 TV information is shown.

1 2

3
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Downloading the user guide

1	 From the menus at the top, click  > Help.

2	 When the help window appears, view details. 

–– To download the user guide, click the provided URL. 

Viewing version info

View the version and copyright details of REACH 4.0 and the required software.

1	 From the menus at the top, click  > About.

2	 View the info and click Close. 
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Administrator menus
Use the REACH administrator menus. To use administrator menus, first log in with an administrator account.

<< Note

•	 When you run REACH 4.0 for the first time, the default administrator account (ID: qaadmin, password: qwerty) will be provided. Make sure to 
change the password to ensure security.

•	 For further information on administrator privileges, refer to the following:  ► Account privileges and available features

SAMSUNG LYNK™ REACH 4.0
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Configuring a protocol
In IP mode, customize the method of communication between the server and TVs.

<< Note

The default protocol is HTTPS.

1	 From the menus at the top, click  > Settings > System.

2	 Select a communication method from Communication Protocol.

<< Note

Make sure that this setting is identical to the setting for the TV. For details on how to configure protocol settings from the TV, refer to the 
following:  ►Configuring IP mode settings

3	 After configuring the required settings, click Apply.

Managing access records

Manage access records for REACH 4.0.

<< Note

This feature is accessible only to administrators. For further information on administrator privileges, refer to the following:  ► Account privileges 
and available features

1	 From the menus at the top, click   > Settings > Logs.

2	 Manage access records, using the following features.
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1 Delete access records.

2 Select a period to view access records for.

3 Search access records. To change the search criterion, click the dropdown list and select another criterion.

4 Rearrange the list by item in ascending or descending order.

1 2 3

4
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Managing users

Manage information on REACH 4.0 users.

Approving users for sign up

REACH 4.0 is accessible only to administrators and administrator-approved users. View the information on a user that applied to 
sign up and approve the sign up.

1	 From the menus at the top, click  > Settings > Users.

2	 Click Approve for the desired user account.

–– The selected IDs will be approved for sign up.

<< Note

Users with approved IDs can access REACH 4.0 immediately after logging in.

Canceling sign-up approval
Cancel approval of IDs to prevent specific users from accessing REACH 4.0, if required.

Click Reject for the desired user account.

▪▪ Sign-up approval for the IDs will be canceled. Users with canceled IDs can no longer log in.

<< Note

Sign-up approval status for each ID can be found under Status in the list.
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Adding users

The administrator can create an ID to add a user.

1	 From the menus at the top, click  > Settings > Users.

2	 Click New.

3	 Enter account information.

4	 After entering the required information, click OK.

–– The user can access REACH 4.0 after logging in with their ID.

<< Note

•	 Fields with * cannot be left blank.

•	 Users added by the administrator also require an approval process. For further information on sign-up approval, refer to the 
following:  ► Approving users for sign up

Managing user info

Manage information on users that have signed up. Assign administrator privileges to users.

1	 From the menus at the top, click  > Settings > Users.

2	 Manage users, using the following features.

1
4

2 3
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Using the administrator menus

1 Delete a user.

2 View the number of user accounts that have been approved or rejected for sign-up.

3 Search user information. To change the search criterion, click the dropdown list and select another criterion.

4 Registered user information is shown. Rearrange the list by item in ascending or descending order.

Managing templates

Add templates that will be provided to REACH 4.0 users by default. Change the layouts of templates.

Adding a template 

1	 From the menus at the top, click TEMPLATE > New.

<< Note

To go to the project list when another project is running, click FILE > Open.

2	 Select a template type and click OK.

–– The edit screen with the selected template applied will be displayed.

1

2

3
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Using the administrator menus

1 View available template types.

2
Select a theme color for the selected template. Available colors to select can vary depending on the template 
type.

3

Enable or disable TV applications.

<< Note

This feature is available in IP mode only.

3	 Select a template type and click OK.

–– The edit screen will be displayed.

–– Templates can be configured using the same method as configuring projects. For further information, refer to the 
following:  ► Configuring a project

4	 To save the template, click File > Save.

5	 A confirmation window appears. Click Yes.

–– The template will be added to the list of templates and provided to the user as a basic template. 
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Summary of features

Features
REACH 4.0 RF (Pre 2015 

models)
REACH 4.0 RF (models 

released after 2016)
REACH 4.0 IP

REACH project ✓ ✓ ✓

Events and ads ✓ ✓ ✓

Events and ads (ticker) X ✓ ✓

Ticker ✓ X X
Auto Show Project X ✓ ✓

REACH channel ✓ ✓ X (Not required)

Access REACH projects from any channel
X (Accessible from 

REACH channels only)
X (Accessible from 

REACH channels only)
✓

Update REACH data from any channel
X (Available from 

REACH channels only)
X (Available from 

REACH channels only)
✓

FHD resolution X ✓ ✓

Flight and weather info ✓ ✓ ✓

Hybrid IP channel X ✓ ✓

TV settings and software update ✓ ✓ ✓

Virtual Standby X X ✓

Message and notice widget info X ✓ ✓

Availability of the SMART Hub app within REACH 
projects

✓  (Only for models in 
EU and ASIA)

✓ ✓

Activation of the SMART Hub app within REACH 
projects

✓  (Only for models in 
EU and ASIA)

✓ ✓

Mouse input X ✓ ✓

Real-time monitoring X X ✓

Factory settings lock ✓ ✓ ✓

Remote control command X X ✓

Auto-detect connected TVs X X ✓

Open API ✓ ✓ ✓

Express Checkout X X ✓

Evaluation license X X ✓

IPTV only license X X ✓

Multi-channel spooling X ✓ X
Auto-set TV time ✓ ✓ ✓

Home Channel Viewer (view REACH channels) ✓ ✓
✓  (specific channels 

can be selected)

Appendix

SAMSUNG LYNK™ REACH 4.0
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Appendix

Features
REACH 4.0 RF (Pre 2015 

models)
REACH 4.0 RF (models 

released after 2016)
REACH 4.0 IP

Launch web browser(s)
✓  (Only for models in 

EU and ASIA)
✓ ✓

Change input source ✓ ✓ ✓

SSL ✓ ✓ ✓

Channels and frequencies
Table A.1

Channel and frequency table (cable STD [J.83B] - open cable type)

CH Freq.
1 75
2 57
3 63
4 69
5 79
6 85
7 177
8 183
9 189

10 195
11 201
12 207
13 213
14 123
15 129
16 135
17 141
18 147
19 153
20 159
21 165
22 171
23 219
24 225
25 231
26 237
27 243
28 249
29 255
30 261

CH Freq.
61 447
62 453
63 459
64 465
65 471
66 477
67 483
68 489
69 495
70 501
71 507
72 513
73 519
74 525
75 531
76 537
77 543
78 549
79 555
80 561
81 567
82 573
83 579
84 585
85 591
86 597
87 603
88 609
89 615
90 621

CH Freq.
31 267
32 273
33 279
34 285
35 291
36 297
37 303
38 309
39 315
40 321
41 327
42 333
43 339
44 345
45 351
46 357
47 363
48 369
49 375
50 381
51 387
52 393
53 399
54 405
55 411
56 417
57 423
58 429
59 435
60 441

CH Freq.
91 627
92 633
93 639
94 645
95 93
96 99
97 105
98 111
99 117

100 651
101 657
102 663
103 669
104 675
105 681
106 687
107 693
108 699
109 705
110 711
111 717
112 723
113 729
114 735
115 741
116 747
117 753
118 759
119 765
120 771

CH Freq.
121 777
122 783
123 789
124 795
125 801
126 807
127 813
128 819
129 825
130 831
131 837
132 843
133 849
134 855
135 861
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Table A.2

Channel and frequency table (cable [DVB-C_256QAM] type)

CH Freq.
01 114
02 122
03 130
04 138
05 146
06 154
07 162
08 170
09 178
10 186
11 194
12 202
13 210
14 218
15 226
16 234
17 242
18 250
19 258
20 266
21 274
22 282
23 290
24 298
25 306
26 314
27 322
28 330
29 338
30 346

CH Freq.
61 594
62 602
63 610
64 618
65 626
66 634
67 642
68 650
69 658
70 666
71 674
72 682
73 690
74 698
75 706
76 714
77 722
78 730
79 738
80 746
81 754
82 762
83 770
84 778
85 786
86 794
87 802
88 810
89 818
90 826

CH Freq.
31 354
32 362
33 370
34 378
35 386
36 394
37 402
38 410
39 418
40 426
41 434
42 442
43 450
44 458
45 466
46 474
47 482
48 490
49 498
50 506
51 514
52 522
53 530
54 538
55 546
56 554
57 562
58 570
59 578
60 586

CH Freq.
91 834
92 842
93 850
94 858
95 866
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Table A.3

Channel and frequency table (cable DVB-C [6MHz] type)

CH Freq.
01
02 57
03 63
04 69
05 79
06 85
07 177
08 183
09 189
10 195
11 201
12 207
13 213
14 123
15 129
16 135
17 141
18 147
19 153
20 159
21 165
22 171
23 219
24 225
25 231
26 237
27 243
28 249
29 255
30 261

CH Freq.
61 447
62 453
63 459
64 465
65 471
66 477
67 483
68 489
69 495
70 501
71 507
72 513
73 519
74 525
75 531
76 537
77 543
78 549
79 555
80 561
81 567
82 573
83 579
84 585
85 591
86 597
87 603
88 609
89 615
90 621

CH Freq.
31 267
32 273
33 279
34 285
35 291
36 297
37 303
38 309
39 315
40 321
41 327
42 333
43 339
44 345
45 351
46 357
47 363
48 369
49 375
50 381
51 387
52 393
53 399
54 405
55 411
56 417
57 423
58 429
59 435
60 441

CH Freq.
91 627
92 633
93 639
94 645
95 93
96 99
97 105
98 111
99 117

100 651
101 657
102 663
103 669
104 675
105 681
106 687
107 693
108 699
109 705
110 711
111 717
112 723
113 729
114 735
115 741
116 747
117 753
118 759
119 765
120 771

CH Freq.
121 777
122 783
123 789
124 795
125 801
126 807
127 813
128 819
129 825
130 831
131 837
132 843
133 849
134 855
135 861
136 867
137 873
138 879
139 885
140 891
141 897
142 903
143 909
144 915
145 921
146 927
147 933
148 939
149 945
150 951
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09 Open Source 
Announcement

To send inquiries and requests for questions regarding open sources, contact Samsung via Email (oss.request@samsung.com).

▪▪ This product uses some software programs which are distributed under the GPLv2

▪▪ This product uses some software programs which are distributed under the LGPLv2.1.

GPL software: CutyCapt

LGPL software : FFmpeg, phpexcel, fancy-settings, gettext

GNU GENERAL PUBLIC LICENSE
Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.

51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General 
Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all 
its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose 
authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License 
instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure 
that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source 
code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you 
can do these things.

SAMSUNG LYNK™ REACH 4.0
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To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the 
rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it. For 
example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you 
have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know 
their rights.

We protect your rights with two steps: 

(1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify 
the software. Also, for each author's protection and ours, we want to make certain that everyone understands that there is no 
warranty for this free software. 

 

If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, 
so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. 

We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the 
program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not 
licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0)	� This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be 
distributed under the terms of this General Public License. The “Program”, below, refers to any such program or work, and a 
“work based on the Program” means either the Program or any derivative work under copyright law: that is to say, a work 
containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. 
(Hereinafter, translation is included without limitation in the term “modification”.) Each licensee is addressed as “you”.

	� Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The 
act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work 
based on the Program (independent of having been made by running the Program). Whether that is true depends on what 
the Program does.

1)	� You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided that 
you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; 
keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the 
Program a copy of this License along with the Program. You may charge a fee for the physical act of transferring a copy, and 
you may at your option offer warranty protection in exchange for a fee.

2)	� You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and 
copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these 
conditions:

	 a)	� You must cause the modified files to carry prominent notices stating that you changed the files and the date of any 
change.

	 b)	� You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or 
any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.
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	 c)	� If the modified program normally reads commands interactively when run, you must cause it, when started running for 
such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright 
notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute 
the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program 
itself is interactive but does not normally print such an announcement, your work based on the Program is not required to 
print an announcement.)

	 These requirements apply to the modified work as a whole. 

	� If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and 
separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as 
separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the 
distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire 
whole, and thus to each and every part regardless of who wrote it.

	� Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent 
is to exercise the right to control the distribution of derivative or collective works based on the Program.

	� In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the 
Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3)	� You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the 
terms of Sections 1 and 2 above provided that you also do one of the following:

	 a)	� Accompany it with the complete corresponding machine-readable source code, which must be distributed under the 
terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

	 b)	� Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost 
of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be 
distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

	 c)	� Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative 
is allowed only for noncommercial distribution and only if you received the program in object code or executable form 
with such an offer, in accord with Subsection b above.)

	� The source code for a work means the preferred form of the work for making modifications to it. For an executable work, 
complete source code means all the source code for all modules it contains, plus any associated interface definition files, 
plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source 
code distributed need not include anything that is normally distributed (in either source or binary form) with the major 
components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself 
accompanies the executable.

	� If distribution of executable or object code is made by offering access to copy from a designated place, then offering 
equivalent access to copy the source code from the same place counts as distribution of the source code, even though third 
parties are not compelled to copy the source along with the object code.

4)	� You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt 
otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under 
this License. However, parties who have received copies, or rights, from you under this License will not have their licenses 
terminated so long as such parties remain in full compliance.

5)	� You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to 
modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. 
Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this 
License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6)	� Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license 
from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not 
impose any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible for enforcing 
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compliance by third parties to this License.

7)	� If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent 
issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of 
this License, they do not excuse you from the conditions of this License. 

	� If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent 
obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not 
permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the 
only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

	� If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is 
intended to apply and the section as a whole is intended to apply in other circumstances.

	� It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity 
of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which 
is implemented by public license practices. Many people have made generous contributions to the wide range of software 
distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if 
he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

	� This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8)	� If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, 
the original copyright holder who places the Program under this License may add an explicit geographical distribution 
limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such 
case, this License incorporates the limitation as if written in the body of this License.

9)	� The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such 
new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. 

	� Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies 
to it and “any later version”, you have the option of following the terms and conditions either of that version or of any later 
version published by the Free Software Foundation. 

	� If the Program does not specify a version number of this License, you may choose any version ever published by the Free 
Software Foundation. 

10)	�If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write 
to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free 
Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the 
free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11)	�BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT 
PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER 
PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT 
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE 
RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, 
YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12)	�IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY 
OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR 
DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR 
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE 
OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER 
PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
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END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to 
make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively 
convey the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is 
found.

<one line to give the program's name and a brief idea of what it does.>

Copyright (C) <year> <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as 
published by the Free Software Foundation; either version 2 of the License, or(at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty 
of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 

See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software 
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author Gnomovision comes with ABSOLUTELY NO WARRANTY; for details 
type ‘show w’.

This is free software, and you are welcome to redistribute it under certain conditions; type ‘show c’ for details.

The hypothetical commands ‘show w’ and ‘show c’ should show the appropriate parts of the General Public License. Of course, the 
commands you use may be called something other than ‘show w’ and ‘show c’; they could even be mouse-clicks or menu items--
whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the 
program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program ‘Gnomovision’ (which makes passes at compilers) written 
by James Hacker.

<signature of Ty Coon>, 1 April 1989

Ty Coon, President of Vice
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This General Public License does not permit incorporating your program into proprietary programs. 

If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. 
If this is what you want to do, use the GNU Lesser General Public License instead of this License

GNU LESSER GENERAL PUBLIC LICENSE

Version 2.1, February 1999 

Copyright (C) 1991, 1999 Free Software Foundation, Inc.

51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library Public License, version 2, 
hence the version number 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General 
Public Licenses are intended to guarantee your freedom to share and change free software--to make sure the software is free for 
all its users. 

This license, the Lesser General Public License, applies to some specially designated software packages--typically libraries--of 
the Free Software Foundation and other authors who decide to use it. You can use it too, but we suggest you first think carefully 
about whether this license or the ordinary General Public License is the better strategy to use in any particular case, based on the 
explanations below. 

When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed to make 
sure that you have the freedom to distribute copies of free software (and charge for this service if you wish); that you receive 
source code or can get it if you want it; that you can change the software and use pieces of it in new free programs; and that you 
are informed that you can do these things. 

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to surrender 
these rights. These restrictions translate to certain responsibilities for you if you distribute copies of the library or if you modify it. 

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we 
gave you. You must make sure that they, too, receive or can get the source code. 

If you link other code with the library, you must provide complete object files to the recipients, so that they can relink them with 
the library after making changes to the library and recompiling it. And you must show them these terms so they know their 
rights. 

 

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this license, which gives you 
legal permission to copy, distribute and/or modify the library. 

To protect each distributor, we want to make it very clear that there is no warranty for the free library. 

Also, if the library is modified by someone else and passed on, the recipients should know that what they have is not the original 
version, so that the original author's reputation will not be affected by problems that might be introduced by others. 

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company 
cannot effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. Therefore, we insist 
that any patent license obtained for a version of the library must be consistent with the full freedom of use specified in this 
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license. 

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. 

This license, the GNU Lesser General Public License, applies to certain designated libraries, and is quite different from the ordinary 
General Public License. We use this license for certain libraries in order to permit linking those libraries into non-free programs. 

When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking 
a combined work, a derivative of the original library. The ordinary General Public License therefore permits such linking only if the 
entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria for linking other code 
with the library. 

We call this license the “Lesser” General Public License because it does Less to protect the user's freedom than the ordinary 
General Public License. It also provides other free software developers Less of an advantage over competing non-free programs. 
These disadvantages are the reason we use the ordinary General Public License for many libraries. However, the Lesser license 
provides advantages in certain special circumstances. 

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it 
becomes a de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more frequent case is that 
a free library does the same job as widely used non-free libraries. In this case, there is little to gain by limiting the free library to 
free software only, so we use the Lesser General Public License. 

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body 
of free software. For example, permission to use the GNU C Library in non-free programs enables many more people to use the 
whole GNU operating system, as well as its variant, the GNU/Linux operating system. 

 

Although the Lesser General Public License is Less protective of the users’ freedom, it does ensure that the user of a program that 
is linked with the Library has the freedom and the wherewithal to run that program using a modified version of the Library. 

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between 
a “work based on the library” and a “work that uses the library”. The former contains code derived from the library, whereas the 
latter must be combined with the library in order to run.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0)	� This License Agreement applies to any software library or other program which contains a notice placed by the copyright 
holder or other authorized party saying it may be distributed under the terms of this Lesser General Public License (also called 
“this License”). Each licensee is addressed as “you”. 

	� A “library” means a collection of software functions and/or data prepared so as to be conveniently linked with application 
programs (which use some of those functions and data) to form executables. 

	� The “Library”, below, refers to any such software library or work which has been distributed under these terms. A “work based 
on the Library” means either the Library or any derivative work under copyright law: that is to say, a work containing the 
Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into another language. 
(Hereinafter, translation is included without limitation in the term “modification”.) 

	� “Source code” for a work means the preferred form of the work for making modifications to it. For a library, complete source 
code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used 
to control compilation and installation of the library. 

	� Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The 
act of running a program using the Library is not restricted, and output from such a program is covered only if its contents 
constitute a work based on the Library (independent of the use of the Library in a tool for writing it). Whether that is true 
depends on what the Library does and what the program that uses the Library does. 
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1)	� You may copy and distribute verbatim copies of the Library’s complete source code as you receive it, in any medium, provided 
that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; 
keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy of this License 
along with the Library. 

	� You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in 
exchange for a fee. 

2)	� You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy 
and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these 
conditions: 

	� a)	� The modified work must itself be a software library. 

	� b)	� You must cause the files modified to carry prominent notices stating that you changed the files and the date of any 
change. 

	� c)	� You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License. 

	� d)	� If a facility in the modified Library refers to a function or a table of data to be supplied by an application program that 
uses the facility, other than as an argument passed when the facility is invoked, then you must make a good faith 
effort to ensure that, in the event an application does not supply such function or table, the facility still operates, and 
performs whatever part of its purpose remains meaningful. (For example, a function in a library to compute square roots 
has a purpose that is entirely well-defined independent of the application. Therefore, Subsection 2d requires that any 
application-supplied function or table used by this function must be optional: if the application does not supply it, the 
square root function must still compute square roots.) These requirements apply to the modified work as a whole. If 
identifiable sections of that work are not derived from the Library, and can be reasonably considered independent and 
separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as 
separate works. 

	� But when you distribute the same sections as part of a whole which is a work based on the Library, the distribution of the 
whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to 
each and every part regardless of who wrote it. Thus, it is not the intent of this section to claim rights or contest your rights 
to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective 
works based on the Library. In addition, mere aggregation of another work not based on the Library with the Library (or with a 
work based on the Library) on a volume of a storage or distribution medium does not bring the other work under the scope of 
this License. 

3)	� You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the 
Library. To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU General Public 
License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU General Public License 
has appeared, then you can specify that version instead if you wish.) Do not make any other change in these notices. Once 
this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all 
subsequent copies and derivative works made from that copy. 

	� This option is useful when you wish to copy part of the code of the Library into a program that is not a library. 

4)	� You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form 
under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding machine-
readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used 
for software interchange. 

	� If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to 
copy the source code from the same place satisfies the requirement to distribute the source code, even though third parties 
are not compelled to copy the source along with the object code. 

5)	� A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being 
compiled or linked with it, is called a “work that uses the Library”. Such a work, in isolation, is not a derivative work of the 
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Library, and therefore falls outside the scope of this License. 

	� However, linking a “work that uses the Library” with the Library creates an executable that is a derivative of the Library 
(because it contains portions of the Library), rather than a “work that uses the library”. 

	� The executable is therefore covered by this License. Section 6 states terms for distribution of such executables. 

	� When a “work that uses the Library” uses material from a header file that is part of the Library, the object code for the work 
may be a derivative work of the Library even though the source code is not. Whether this is true is especially significant if the 
work can be linked without the Library, or if the work is itself a library. The threshold for this to be true is not precisely defined 
by law. 

	� If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small 
inline functions (ten lines or less in length), then the use of the object file is unrestricted, regardless of whether it is legally a 
derivative work. (Executables containing this object code plus portions of the Library will still fall under Section 6.) 

	� Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 
6. Any executables containing that work also fall under Section 6, whether or not they are linked directly with the Library itself. 

6)	� As an exception to the Sections above, you may also combine or link a “work that uses the Library” with the Library to produce 
a work containing portions of the Library, and distribute that work under terms of your choice, provided that the terms permit 
modification of the work for the customer’s own use and reverse engineering for debugging such modifications. 

	� You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are 
covered by this License. You must supply a copy of this License. If the work during execution displays copyright notices, you 
must include the copyright notice for the Library among them, as well as a reference directing the user to the copy of this 
License. Also, you must do one of these things: 

	 a)	� Accompany the work with the complete corresponding machine-readable source code for the Library including 
whatever changes were used in the work (which must be distributed under Sections 1 and 2 above); and, if the work is 
an executable linked with the Library, with the complete machine-readable “work that uses the Library”, as object code 
and/or source code, so that the user can modify the Library and then relink to produce a modified executable containing 
the modified Library. (It is understood that the user who changes the contents of definitions files in the Library will not 
necessarily be able to recompile the application to use the modified definitions.) 

	 b)	� Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (1) uses at run 
time a copy of the library already present on the user’s computer system, rather than copying library functions into the 
executable, and (2) will operate properly with a modified version of the library, if the user installs one, as long as the 
modified version is interface-compatible with the version that the work was made with. 

	 c)	� Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified in 
Subsection 6a, above, for a charge no more than the cost of performing this distribution. 

	 d)	� If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to copy the 
above specified materials from the same place. 

	 e)	� Verify that the user has already received a copy of these materials or that you have already sent this user a copy. For an 
executable, the required form of the “work that uses the Library” must include any data and utility programs needed for 
reproducing the executable from it. However, as a special exception, the materials to be distributed need not include 
anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so 
on) of the operating system on which the executable runs, unless that component itself accompanies the executable. 

	� It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally 
accompany the operating system. Such a contradiction means you cannot use both them and the Library together in an 
executable that you distribute. 

7)	� You may place library facilities that are a work based on the Library side-by-side in a single library together with other library 
facilities not covered by this License, and distribute such a combined library, provided that the separate distribution of the 
work based on the Library and of the other library facilities is otherwise permitted, and provided that you do these two things: 
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	 a)	� Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library 
facilities. This must be distributed under the terms of the Sections above. 

	 b)	� Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and explaining 
where to find the accompanying uncombined form of the same work. 

8)	� You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any 
attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically terminate your 
rights under this License. However, parties who have received copies, or rights, from you under this License will not have their 
licenses terminated so long as such parties remain in full compliance. 

9)	� You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to 
modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this License. 
Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your acceptance of this 
License to do so, and all its terms and conditions for copying, distributing or modifying the Library or works based on it. 

10)	�Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from 
the original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may not 
impose any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible for enforcing 
compliance by third parties with this License. 

11)	�If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent 
issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of 
this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously 
your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the 
Library at all. For example, if a patent license would not permit royalty-free redistribution of the Library by all those who 
receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be 
to refrain entirely from distribution of the Library. If any portion of this section is held invalid or unenforceable under any 
particular circumstance, the balance of the section is intended to apply, and the section as a whole is intended to apply in 
other circumstances. 

	� It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity 
of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system which 
is implemented by public license practices. Many people have made generous contributions to the wide range of software 
distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if 
he or she is willing to distribute software through any other system and a licensee cannot impose that choice. This section is 
intended to make thoroughly clear what is believed to be a consequence of the rest of this License. 

12)	�If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces, the 
original copyright holder who places the Library under this License may add an explicit geographical distribution limitation 
excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this 
License incorporates the limitation as if written in the body of this License. 

13)	�The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time to 
time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or 
concerns. 

	� Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies 
to it and “any later version”, you have the option of following the terms and conditions either of that version or of any later 
version published by the Free Software Foundation. If the Library does not specify a license version number, you may choose 
any version ever published by the Free Software Foundation. 

14)	�If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with 
these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write 
to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of 
preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally. 
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NO WARRANTY

15) BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED 
BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE 
THE LIBRARY “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY 
AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL 
NECESSARY SERVICING, REPAIR OR CORRECTION. 

16) IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY 
OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, 
INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE 
THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED 
BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR 
OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public, we recommend making it 
free software that everyone can redistribute and change. You can do so by permitting redistribution under these terms (or, 
alternatively, under the terms of the ordinary General Public License). 

To apply these terms, attach the following notices to the library. It is safest to attach them to the start of each source file to most 
effectively convey the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to where the full 
notice is found. 

one line to give the library’s name and an idea of what it does.

Copyright (C) year name of author

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License 
as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty 
of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

See the GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free 
Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

Also add information on how to contact you by electronic and paper mail. 

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the 
library, if necessary. Here is a sample; alter the names: 
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Yoyodyne, Inc., hereby disclaims all copyright interest in the library ‘Frob’ (a library for tweaking knobs) written by James 
Random Hacker.

Signature of Ty Coon, 1 April 1990 Ty Coon, President of Vice

That’s all there is to it!

Apache License, Version 2.0

Foundation Projects People Get Involved Download Support Apache Home ≫ Licenses

Apache License Version 2.0, January 2004

http://www.apache.org/licenses/ 

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1.	� Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this 
document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under 
common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the 
direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the 
outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, 
documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not 
limited to compiled object code, generated documentation, and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a 
copyright notice that is included in or attached to the work (an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and 
for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of 
authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link 
(or bind by name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions 
to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright 
owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this 
definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its representatives, 
including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems 
that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding 
communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution."
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"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by 
Licensor and subsequently incorporated within the Work.

2.	� Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a 
perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative 
Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object 
form.

3.	� Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a 
perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to 
make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those 
patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of 
their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any 
entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the 
Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for 
that Work shall terminate as of the date such litigation is filed.

4.	� Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or 
without modifications, and in Source or Object form, provided that You meet the following conditions:

You must give any other recipients of the Work or Derivative Works a copy of this License; and

You must cause any modified files to carry prominent notices stating that You changed the files; and

You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution 
notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a 
readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any 
part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative 
Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated 
by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for 
informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works 
that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution 
notices cannot be construed as modifying the License. You may add Your own copyright statement to Your modifications and 
may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for 
any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the 
conditions stated in this License.

5.	� Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion 
in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms 
or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license 
agreement you may have executed with Licensor regarding such Contributions.
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6.	� Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or product names of 
the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the 
content of the NOTICE file.

7.	� Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each 
Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, 
either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, 
MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness 
of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License.

8.	� Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, 
unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor 
be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character 
arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of 
goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses), even if such 
Contributor has been advised of the possibility of such damages.

9.	� Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may choose to offer, 
and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with 
this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not 
on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for any 
liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional 
liability.

END OF TERMS AND CONDITIONS

APPENDIX: How to apply the Apache License to your work

To apply the Apache License to your work, attach the following boilerplate notice, with the fields enclosed by brackets "[]" 
replaced with your own identifying information. (Don't include the brackets!) The text should be enclosed in the appropriate 
comment syntax for the file format. We also recommend that a file or class name and description of purpose be included on the 
same "printed page" as the copyright notice for easier identification within third-party archives.

	� Copyright [yyyy] [name of copyright owner]

	� Licensed under the Apache License, Version 2.0 (the "License"); 
you may not use this file except in compliance with the License.  
You may obtain a copy of the License at

	� http://www.apache.org/licenses/LICENSE-2.0

	� Unless required by applicable law or agreed to in writing, software	  
�distributed under the License is distributed on an "AS IS" BASIS, 
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. 
See the License for the specific language governing permissions and 
limitations under the License.
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