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C H A P T E R  1  

Welcome to Parallels Desktop 

Congratulations on purchasing Parallels Desktop 7 for Mac. You no longer have to choose between 
the Mac or the PC―Parallels Desktop lets you use Windows side-by-side with Mac OS X on your 
Mac. 

Use this guide to quickly set up and start using Parallels Desktop. 

 

In This Chapter 

What You Can Do .................................................................................................... 9 
Set Up Your Mac to Use Windows Programs ........................................................... 9 
Other Operating Systems ......................................................................................... 10 
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Welcome to Parallels Desktop 
 

What You Can Do 
With Parallels Desktop, you can: 

• Open Windows programs side-by-side with your Mac OS X applications, without having to 
restart 

• Copy and paste text and drag and drop objects between Mac applications and Windows 
programs 

• Run Windows games and other 3D programs 

• Transfer all your data from a PC and use it on your Mac 

• Purchase, download, and install a new copy of Windows directly from Parallels Desktop 

• Easily share files, devices, and other resources between Windows and the Mac 

• Install other operating systems, such as Linux, Google Chrome OS, Mac OS X Lion, and Mac 
OS X Server, and use them together 

• And much more 
 

Set Up Your Mac to Use Windows Programs 
After just a few steps, you can begin using Windows programs on your Mac. Setting up your Mac 
to run Windows programs involves the following steps: 

Step 1: Install Parallels Desktop (p. 11). 

Step 2: Install Windows on your Mac (p. 18). 

Step 3: Install your Windows programs (p. 46). 

You only need to follow these steps once. Then you can open and use your Windows programs on 
your Mac anytime you like, just as you do with your Mac applications.  
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Welcome to Parallels Desktop 
 

Other Operating Systems 
Important: This guide is focused on using Parallels Desktop with Windows XP or Windows 7. 

Using Parallels Desktop 7 for Mac you can run several other kinds of operating systems (p. 114) on 
your Mac, such as several flavors of Linux and Unix, Mac OS X Server, older versions of Windows, 
and more. 

Finding Information On Running Other Operating Systems 

You can find much more information and details on using Parallels Desktop to run other operating 
systems on your Mac by checking the resources listed in More Resources (p. 206). 

Additionally, though not explicitly stated, many of the instructions presented in this guide also apply 
to supported operating systems other than Windows XP and Windows 7. And some important 
instructions relating to other operating systems are in the Advanced Topics (p. 113) section. 
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Install or Upgrade Parallels Desktop 

Follow the instructions in this chapter to install or upgrade Parallels Desktop. 

Note: You can either purchase a boxed version of Parallels Desktop 7 or download it from the the 
Parallels website. 

In This Chapter 

What You Need ........................................................................................................ 12 
Install Parallels Desktop ............................................................................................ 13 
Upgrade Parallels Desktop........................................................................................ 15 
Set the Language ..................................................................................................... 17 
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Install or Upgrade Parallels Desktop 
 

What You Need 
To install and set up Parallels Desktop 7 for Mac, you need: 

• A Mac computer with: 

• An Intel Core 2 Duo processor or better 

• At least 2GB of RAM (4GB recommended to run Windows 7) 

Note: Your Mac must have enough RAM memory to use Mac OS X and its applications plus the 
memory required for each additional operating system (and its programs) that you want to use 
simultaneously. 

• At least 1.4GB of space available on the boot volume (the volume that has Mac OS X) for 
Parallels Desktop installation 

• 15 GB of available disk space for Windows 

• Mac OS X Lion 10.7 or later, Mac OS X Snow Leopard v10.6.8 or later, or Mac OS X 
Leopard v10.5.8 or later 

To identify your computer's processor, memory, and Mac OS X version, choose Apple 
menu > About This Mac. 

• Internet connection required for select features and online updates 

• One of the following: 

• A Windows installation disc, or other installation media for the operating systems you want 
to use alongside Mac OS X 

• A major credit card or PayPal account to purchase Windows online 

For a list of operating systems that Parallels Desktop supports for use with your Mac, see 
Supported Guest Operating Systems (p. 114) or go to 
http://www.parallels.com/products/desktop/system-requirements/. 
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Install Parallels Desktop 
You can be up and running with Parallels Desktop in a few easy steps: 

1 Make sure you have the latest version of Mac OS X by choosing Apple menu > Software 
Update (you must have an Internet connection).  

If a later version of Mac OS X is available, select it and click Install. 

2 Do one of the following: 

• If you downloaded Parallels Desktop from the Parallels website, double-click the disk image 
file, most likely in your Downloads folder (the file has the extension ".dmg" at the end). 

• If you purchased a boxed copy of Parallels Desktop, insert the installation disc. 

3 Double-click the Install icon. 
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Install or Upgrade Parallels Desktop 
 

If your computer is connected to the Internet, Parallels Desktop checks for available updates. If 
an update is available, click "Download and install new version" to get the latest version of 
Parallels Desktop. 

4 Follow the onscreen instructions to install Parallels Desktop. 

Activate Parallels Desktop 

Once the installation is finished, you must enter your Product Activation Key to activate Parallels 
Desktop. 

If you purchased Parallels Desktop from the Parallels Online Store or downloaded a trial copy, a key 
was sent to the email address you provided. If you bought a boxed copy, you can find your key 
printed on the installation disc sleeve. 

Note: If you bypass the activation dialog, you can activate Parallels Desktop later by choosing Parallels 
Desktop > Activate Product and entering your Product Activation Key. 

If You Don't Have A Product Activation Key 

If you don't have a key already, you can get one by choosing Parallels Desktop > Activate 
Product. Then, to get a free trial Product Activation Key so you can try out Parallels Desktop for a 
limited time, click Get Trial. Or to purchase a key that lets you use Parallels Desktop permanently, 
click Buy. 

Register Parallels Desktop 

After activation, you're presented with the opportunity to register Parallels Desktop. Registering 
allows you to: 

• Automatically download and install the latest Parallels Desktop updates. 

• Create a backup copy of the product key on the Parallels web server and restore it at any time. 

• Easily contact the Parallels support team, using the support code. 

• Stay informed about Parallels news and announcements. 

Note: If you choose not to register Parallels Desktop during installation, you can register anytime by 
choosing Parallels Desktop > Register Product when the application is open. 
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Upgrade Parallels Desktop 
If you already have Parallels Desktop 5 or 6 follow these steps to upgrade to Parallels Desktop 7. 

1 If you haven't already done so, purchase and download a "Parallels Desktop 7 for Mac 
Upgrade," available from the Parallels Online Store at www.parallels.com/buyonline. 

A Product Activation Key is sent to the email address you provide. 

2 If Parallels Desktop is open, quit Parallels Desktop. 

3 Follow the instructions to install Parallels Desktop 7. See Install Parallels Desktop (p. 13). 

During installation, the previous version of Parallels Desktop is automatically removed from your 
computer. 

4 Open Parallels Desktop and enter your upgrade Product Activation Key. 

If you were using a trial version of Parallels Desktop or you purchased a previous version but 
haven't installed it on your computer, you will also be prompted to enter a full or upgrade key 
for that version. 

Note: To upgrade from Parallels Desktop 2, 3, or 4 you must purchase Parallels Desktop 7 at full retail 
price. 

Solving Problems 

If you have any problems upgrading Parallels Desktop, you can find troubleshooting information at 
www.parallels.com/support/free/troubleshooter or by opening Parallels Desktop and choosing 
Help > Troubleshooting Guide. 
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Install Software Updates 

Periodically, Parallels provides free software updates to improve Parallels Desktop.  

By default, Parallels Desktop is configured to automatically check for and download available 
software updates once a week. When an update is available, Parallels Desktop prompts you to 
install it. Simply follow the onscreen instructions. 

Adjust Software Update Settings 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Preferences, and 
then click General. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences, and then click General. 
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Install or Upgrade Parallels Desktop 
 

 

2 Do one of the following: 

• To adjust the frequency that Parallels checks for software updates, choose Never, Once a 
Day, Once a Week, or Once a Month from the Check for Updates menu.  

• To choose whether you want Parallels Desktop to download updates automatically, select 
or deselect Download updates automatically. 

If you choose not to download updates automatically, Parallels Desktop notifies you when 
an update is available and asks whether you want to download it. 

Check for an Update Manually 

• Follow the instructions in step 1 above and then click Check Now. You can also choose 
Check for Updates from the Parallels Desktop application menu. 

Note: To check for updates and download them, your Mac must be connected to the Internet and you 
must register your copy of Parallels Desktop (p. 13). 

 

Set the Language 
You can set which language the Parallels Desktop interface uses by doing the following: 

1 Quit Parallels Desktop. 

2 Choose Apple menu > System Preferences, click Language & Text, and then click 
Language. 

3 Drag the language you want to the top of the list. If you don't see the language you want to use 
in the list, click Edit List. 

4 Open Parallels Desktop. 

If the primary language you chose is supported by Parallels Desktop, the menus and interface 
text appear in that language. If the primary language you selected isn't supported, menus 
appear in the first language listed that Parallels Desktop supports. 
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Install or Import Windows 

There are a few ways to get Windows up and running on your Mac: 

• Download, and install Windows (p. 19) (US and Canada only) 

• Install Windows from a Windows installation disc (p. 21) 

• Import your data from a Windows PC (p. 22) 

• Use Windows that you already have installed from a Boot Camp partition (p. 36) 

• Import Windows from a previous version of Parallels Desktop or other virtualization software (p. 
37) 

In This Chapter 

Download and Install Windows .................................................................................19 
Install Windows from an Installation Disc ...................................................................21 
Import Your Data from a PC .....................................................................................22 
Use Boot Camp with Parallels Desktop.....................................................................36 
Import from an Earlier Parallels Desktop or Other Virtualization Application................37 
Download and Install the Windows 8 Developer Preview...........................................38 
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Download and Install Windows 
If this is your first time using Parallels Desktop and you don't have a copy of Windows, you can 
purchase, download, and install Windows directly from Parallels Desktop. Your Mac must be 
connected to the Internet. 

To purchase, download, and install Windows: 

1 Open Parallels Desktop (in the Applications folder) and choose File > New. 

2 Click Buy Windows 7. 

3 Select a version of Windows. You can choose the Home Premium, Professional, or Ultimate 
edition. 

To learn more, click Compare versions on Microsoft web site.  

4 Click Continue and follow the onscreen instructions to purchase and download Windows.  

Note: You can use a major credit card to purchase Windows. 

5 In the Windows Product Key window, be sure to leave Express installation selected. 

Note: If you deselect Express installation, you'll need to install Parallels Tools (p. 196) after the 
installation to allow the most seamless operation between Windows and Mac OS X.  

It is also recommended that you use the 64-bit version of Windows, but if you want to use the 
32-bit version, deselect 64-bit Windows version. When ready, click Continue. 

6 Select how you want to use Windows: 

• Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. 
Documents and media from Mac OS X and Windows are kept together on your Mac. 

• Like a PC: The Windows desktop and programs appear in a single window, separate from 
Mac applications. You can drag and drop objects between Windows and the Mac. 

7 Choose where you want to store Windows from the Location menu. 

By default, Parallels Desktop stores Windows in your Documents > Parallels folder. To allow all 
users of your computer to have access to this installation of Windows, select Share with other 
users of this Mac. 

8 If you want to pre-set things like how much memory Windows uses or whether it starts 
automatically when you open Parallels Desktop, select Customize settings before 
installation. You can also adjust these settings after the operating system is installed. 

9 Click Create. Once the download starts, you can pause it anytime by clicking Pause. To 
resume the download, click Resume. Once the download is complete, the installation of 
Windows starts automatically. The Parallels Wizard finishes the installation of Windows. You 
should expect this operation to take an hour or more, and your virtual machine may restart 
several times during this operation. 



20 
 

Install or Import Windows 
 

Once Windows is installed, you can start it up by opening a Windows program (p. 42) or by clicking 

the power button  in the Parallels Virtual Machines list. 

Important: The first time you start Windows, Parallels Tools are installed to allow seamless operation 
between Windows and Mac OS X. Once Parallels Tools are installed, you're prompted to restart 
Windows.  

If you didn't select Express installation in step 5 above, you must install Parallels Tools manually (p. 
196). 

When you install Windows, Parallels Desktop creates an administrator account with a blank 
password. Once the installation is complete, it is recommended that you change this password. 
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Install Windows from an Installation Disc 
If you have a Windows installation DVD and a valid Windows product key, you can install Windows 
from the disc and use it with Parallels Desktop. 

To install Windows: 

1 Open Parallels Desktop (in the Applications folder) and choose File > New. 

2 Insert the Windows installation disc. 

3 Click Install Windows from DVD or image file. 

4 Select the Windows installation disc from the Install from menu. 

5 Be sure to leave Express installation selected. 

Note: If you deselect Express installation, you'll need to install Parallels Tools (p. 196) after the 
installation to allow the most seamless operation between Windows and Mac OS X.  

6 If you are installing a recent version of Windows, select how you want to use Windows: 

• Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. 
Documents and media from Mac OS X and Windows are kept together on your Mac. 

• Like a PC: The Windows desktop and programs appear in a single window, separate from 
Mac applications. You can drag and drop objects between Windows and the Mac. 

7 Choose where you want to store Windows from the Location menu. 

By default, Parallels Desktop stores Windows in your Documents > Parallels folder. To 
allow all users of your computer to have access to this installation of Windows, select Share 
with other users of this Mac. 

8 If you want to pre-set things like how much memory Windows uses or whether it starts 
automatically when you open Parallels Desktop, select Customize settings before 
installation. You can also adjust these settings after the operating system is installed. 

9 Click Continue. 

The assistant installs Windows. 

Once Windows is installed, you can start it up by opening a Windows program (p. 42) or by clicking 
the power button in the Parallels Virtual Machines list. 
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Important: The first time you start Windows, Parallels Tools are installed to allow seamless operation 
between Windows and Mac OS X. Once Parallels Tools are installed, you're prompted to restart 
Windows. 

If you didn't select Express installation in step 5 above, you must install Parallels Tools manually (p. 
196). 

When you install Windows, Parallels Desktop creates an administrator account with a blank 
password. Once the installation is complete, it is recommended that you change this password. 

Note: You can also install Windows from a disk image file of an installation disc. Simply choose the disk 
image file in step 4 above. 

 

Import Your Data from a PC 
You can import all your data from a Windows PC to Parallels Desktop on your Mac. Then you can 
continue to work with all your Windows programs, files, and data, side-by-side with Mac OS X. 
 

Overview of Methods for Importing 

You can import your data using one of the following: 

• Parallels USB cable (p. 24): If you have Parallels Desktop 7 Switch to Mac Edition™, you can 
use the included Parallels USB cable. This is the simplest way to import your data. The 
Windows PC and your Mac must be close to one another. 

• Network (p. 27): If both the Windows PC and your Mac are connected to a network, you can 
import your data over the network. 

• External storage device (p. 30): You can transfer the data from a Windows PC to an external 
storage device, such as an external hard drive. Then, you can connect the device to your Mac 
and import your data into Parallels Desktop. 
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Requirements for Importing Your Data 

To import your data to your Mac, you need a Windows computer with: 

• Windows XP with Service Pack 2 or later, Windows Vista, or Windows 7. 

Note: You can also use a computer running Windows Server 2008 R2 (64-bit only), Windows Server 
2008, or Windows 2000 Professional (32-bit only). 

• An Intel or AMD (700 MHz or higher) x86 or x64 processor 

• At least 256 MB of RAM 

• At least 70 MB of hard disk space for installing Parallels Transporter Agent 

• One of the following: 

• An Ethernet port for transferring your data over network 

• A USB port for transferring your data using the Parallels USB cable 

• An external storage device, such as a USB hard disk 

Note: Parallels Desktop does not support migrating Windows dynamic volumes. These are volumes 
which size is not fixed as in basic volumes. They are migrated as data disks only. You can later add them 
(p. 169) to an already existing virtual machine. 

 

Step 1: Install Parallels Transporter Agent on Your Windows PC 

To import your data you must first install the Parallels Transporter Agent software on the Windows 
PC. 

To install Parallels Transporter Agent: 

10 Do one of the following: 

• If you purchased a physical copy of Parallels Desktop, insert the Parallels Desktop 
installation DVD into your Windows PC. If the installation doesn't start automatically, locate 
and double-click the Parallels Transporter Agent.exe file on the disc. 

• Download Parallels Transporter Agent for Windows from the Parallels website at 
http://www.parallels.com/download/desktop/ and double-click the installation file. 

If your computer is connected to the Internet, Parallels Transporter Agent checks for available 
updates. If an update is available, click Download and Install New Version. 

11 Follow the onscreen instructions to install Parallels Transporter Agent. 
 

Step 2: Import Your Data 

Follow one of the methods below to import your data from your PC to your Mac. 
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Using a Parallels USB Cable 

Important: After importing your data from your PC, you may need to reactivate some of your Windows 
programs using the activation keys you received when you purchased the programs. 

The Parallels USB cable required for this method is included with Parallels Desktop Switch to Mac 
Edition. If you don't have the Parallels USB cable, import your data using one of the other methods. 

To import your data from your PC using the Parallels USB Cable: 

1 Turn on your Mac and your Windows PC and log in to both computers. 

2 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing 
All Programs > Parallels > Parallels Transporter Agent. 
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3 Connect the Parallels USB cable to your Windows PC and to your Mac. 

4 If the Windows PC is running Windows XP, the Found New Hardware wizard opens. In this 
wizard: 

a Select Yes, this time only, and click Next. 

b Select Install the software automatically (Recommended), and click Next. 

c A Hardware Installation warning appears. Click Continue Anyway. 

d Drivers for the Parallels USB cable are installed. Click Finish to exit the wizard. 

5 On your Mac, open Parallels Desktop and choose File > New. 

6 Select Migrate from a PC and click Continue. 

7 Select Parallels USB cable and click Continue. Parallels Transporter starts collecting the 
information about the source computer. 
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8 If the Windows Installation Files window appears, insert the Windows installation disc into 
your Mac and click Continue. 

9 If you don't want to log in to Windows automatically whenever you start up Windows, select Do 
not enable Automatic Logon. When ready, click Continue. 

10 Choose whether you want to migrate all your files and data or only Windows applications. 
When ready, click Continue. 

11 Select how you want to use Windows: 

• Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. 
Documents and media from Mac OS X and Windows are kept together on your Mac. 

• Like a PC: The Windows desktop and programs appear in a single window, separate from 
Mac applications. You can drag and drop objects between Windows and the Mac. 

12 Choose where you want to install your data. You can also click Customize and select which 
Windows volumes to migrate. 
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When ready, click Continue. 

13 In the next step there's a warning about Windows activation that might be required when you 
start using it. To proceed, read this message, select I want to continue and click Continue. 

14 Once the migration is complete, click Done. 

15 Start Windows (p. 41). 

16 Once Windows starts up, choose Virtual Machine > Install Parallels Tools and follow the 
onscreen instructions. 

Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator. 
 

Over a Network 

Important: After importing your data, you may need to reactivate some of your Windows programs 
using the activation keys you received when you purchased the programs. 

To import your data from a PC over a network: 

1 Turn on your Mac and your Windows PC and log in. Make sure that the computers are 
connected over the same network. 

2 Make sure that Windows Firewall (p. 34) is turned off. You can turn it on again after the import is 
finished. 

3 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing 
All Programs > Parallels > Parallels Transporter Agent. 
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4 On your Mac, open Parallels Desktop and choose File > New. 

5 Select Migrate from a PC and click Continue. 

6 Select Network and click Continue. 

7 Find the passcode displayed in Parallels Wizard on your Mac and enter it in Parallels 
Transporter Agent on your Windows PC. 

You can also connect to the source Windows PC using its name or IP address. To do so, click 
Use IP address instead, select the Windows PC name from the list or type the IP address, 
and click Continue. 
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8 If you have chosen to use the computer name or IP address, provide the Windows 
administrator credentials. Parallels Desktop connects to Parallels Transporter Agent and starts 
collecting information about the source computer. 

9 If the Windows Installation Files window appears, insert the Windows installation disc into 
your Mac and click Continue. 

10 If you don't want to log in to Windows automatically whenever you start up Windows, select Do 
not enable Automatic Logon. When ready, click Continue. 

11 Choose whether you want to migrate all your files and data or only Windows applications. 
When ready, click Continue. 

12 Select how you want to use Windows: 

• Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. 
Documents and media from Mac OS X and Windows are kept together on your Mac. 

• Like a PC: The Windows desktop and programs appear in a single window, separate from 
Mac applications. You can drag and drop objects between Windows and the Mac. 

13 Choose where you want to install your data. You can also click Customize and select which 
Windows volumes to migrate. 
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When ready, click Continue. 

14 In the next step there's a warning about Windows activation that might be required when you 
start using it. To proceed, read this message, select I want to continue and click Continue. 

15 Once the migration is complete, click Done. 

16 Start Windows (p. 41). 

17 When Windows boots up, choose Virtual Machine > Install Parallels Tools and follow the 
onscreen instructions. 

Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator. 
 

Using an External Storage Device 

Important: After importing your data, you may need to reactivate some of your Windows programs 
using the activation keys you received when you purchased the programs. 

To import your data from a PC using an external storage device: 

1 Connect an external storage device to your Windows PC. 

2 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing 
All Programs > Parallels > Parallels Transporter Agent. 

3 Click the external storage device icon. 
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4 Click Next. Parallels Transporter Agent collects information about the Windows PC. 

5 If you don't want to log in to Windows automatically whenever you start up Windows, select Do 
not enable Automatic Logon. When ready, click Next. 

6 Choose whether you want to migrate all your files and data or only Windows applications. 
When ready, click Next. 

7 Choose where you want to store your data. You can also click Customize and select which 
Windows volumes to migrate. 
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When ready, click Next. 

8 In the next step there's a warning about Windows activation that might be required when you 
start using it. To proceed, read this message, select I want to continue and click Next. 

9 Once the migration is complete, click Done to quit Parallels Transporter Agent. 

10 Disconnect the storage device from the Windows PC and connect it to your Mac. 

11 On your Mac, open Parallels Desktop and choose File > New. 

12 Select Migrate from a PC and click Continue. 

13 Select External Storage Device and click Continue. 

14 Click Choose and locate where you chose to store your data in step 7. Then click Continue. 

15 Select how you want to use Windows: 

• Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. 
Documents and media from Mac OS X and Windows are kept together on your Mac. 

• Like a PC: The Windows desktop and programs appear in a single window, separate from 
Mac applications. You can drag and drop objects between Windows and the Mac. 

16 Choose where you want to install Windows and your data, and then click Continue. 

17 Once the migration is complete, click Done. 

18 Start Windows (p. 41). 

19 When Windows boots up, choose Virtual Machine > Install Parallels Tools and follow the 
onscreen instructions. 

Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator. 
 

Solving Problems 

Read this section if you have problems importing  your data from a Windows PC. 
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General Tips 

This section provides solutions to some errors that may occur during the import process. 

Parallels Transporter Agent Doesn't Work Correctly 

If you experience any problems while importing, make sure that the snapman.sys driver is 
installed in C:\WINDOWS\system32\drivers\. 

If the snapman.sys driver is not installed, follow these steps: 

1 Uninstall Parallels Transporter Agent. 

2 Restart your Windows PC. 

3 Reinstall Parallels Transporter Agent. 

4 Restart your Windows PC again. 

5 Try to import Windows and your data again. 

Import is Interrupted by an Error 

If the import process is interrupted by an error, do the following: 

1 From the Start menu, choose My Computer. 

2 In the Hard Disk Drives pane, right-click the volume you want to import, and choose 
Properties.  

3 In the Properties pane, click the Tools tab, and in the Error Checking section, click the 
Check Now button.  

4 In the Check Disk window, select Automatically fix file system errors and Scan for and 
attempt recovery of bad sectors, and then click Start. 

5 Wait till the disk is scanned and errors are fixed. 

Dynamic Volumes are not Imported 

Only basic volumes can be imported. You can't import dynamic volumes using Parallels Desktop. 

The only way to import the data stored on a dynamic disk is to copy the data to a basic disk on 
your Mac and then import the basic disk. 
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If Your Mac Fails to Connect with Parallels Transporter Agent 

Firewall applications may block connections between your Mac and Parallels Transporter Agent on 
the Windows PC. 

Firewall problems in Mac OS X 

If your Mac fails to connect with Parallels Transporter Agent on your Windows PC, the reason may 
be that the built-in Mac firewall blocks the connection to Parallels Transporter Agent. 

To enable connections between your Mac and Parallels Transporter Agent and prevent further 
blocking, you can configure the firewall settings in Mac OS X by doing the following: 

1 From the Apple menu, choose System Preferences, and then click Security. 

2 Click the Firewall tab. 

3 Configure the necessary settings. 

If you try to search for Parallels Transporter Agent by typing the Windows PC IP address manually, 
you may receive a message saying that Parallels Transporter Agent is blocked. Click the Unblock 
button. 

Firewall problems in Windows 

Microsoft Windows operating system has a built-in firewall that blocks connections to and from 
other computers. When starting Parallels Transporter Agent for the fist time, you may see a 
message saying that Windows Firewall has blocked some features of the program. 

To enable the connection between your Mac and Parallels Transporter Agent, click Unblock. 

To prevent this problem from happening again, add Parallels Desktop and/or Parallels Transporter 
Agent to the firewall exceptions (the list of applications allowed to communicate through the 
firewall): 

1 From the Start menu, choose Control Panel > Network Connections. 

2 In the Network Tasks pane, click Change Windows Firewall Settings. 

3 Add Parallels Desktop and/or Transporter Agent to the firewall exceptions list. 
 

If Parallels Doesn't Detect Windows Correctly 

If Parallels Desktop detects the source operating system (Microsoft Windows XP or Windows Vista 
computer) incorrectly, make sure that neither of your Windows programs are running in 
compatibility mode - a special mode of Windows allowing you to run applications that are 
incompatible with your version of Windows. 

See Windows Help for more information. 
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Problems Using a Program After an Import 

Programs that depend on specific hardware may not work in Parallels Desktop. 

If you import from several source volumes, the disk drive letters are changed. Make sure that the 
program paths are set correctly. See Windows Help for more information. 
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Use Boot Camp with Parallels Desktop 
Boot Camp is a feature of Mac OS X that lets you start up your Mac in Windows. If you have 
already installed Windows 7, Windows Vista, or Windows XP on your Mac using Boot Camp, you 
can set Parallels Desktop to work with Boot Camp using either of these two options: 

• Set Parallels Desktop to run Windows from the Boot Camp partition: Changes you make in 
Windows programs either while working in Mac OS X or when you start up your Mac in 
Windows using Boot Camp will be reflected in both places. 

Windows running from Boot Camp has the following limitations: 

• It can't be paused 

• It can't be saved as a snapshot (p. 126) 

• It can't run in Safe Mode 

• It can't be compressed 

• Import Windows and your data from Boot Camp into Parallels Desktop: Windows running 
from Parallels Desktop doesn't have the above listed limitations. Boot Camp and Parallels 
Desktop are separate. Changes you make in Windows programs while working in Mac OS X 
are not reflected when you start up your Mac in Windows using Boot Camp. 

Set Parallels Desktop to run Windows from the Boot Camp Partition 

1 Open Parallels Desktop (in the Applications folder) and choose File > New. 

2 Click Boot Camp, and then follow the onscreen instructions. 

Note: If you plan to start up in Windows using Boot Camp, it is recommended that you shut down 
Windows in Parallels Desktop rather than suspending Windows. 

Import Windows and Your Data from Boot Camp into Parallels Desktop 

1 Set Parallels Desktop to use Boot Camp, as described in the steps above. 

2 Right-click (Control-click) the Boot Camp version of Windows in the Parallels Virtual Machines 
list and choose Import Boot Camp. 

Note: Windows must be shut down. 

3 Click Import. 

4 Locate where you want to store Windows and your data, and then click Choose. 

Windows and all your data are imported from Boot Camp. You can still use the original Boot 
Camp Windows installation, separately from Parallels Desktop. 
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Important: The first time you start Windows after setting Parallels Desktop to work with Boot Camp, 
Parallels Tools are installed to allow seamless operation between Windows and Mac OS X. Once Parallels 
Tools are installed, you're prompted to restart Windows.  

 

Import from an Earlier Parallels Desktop or Other 
Virtualization Application 
With Parallels Desktop 7 for Mac you can use Windows that you set up using earlier versions of 
Parallels Desktop, as well as VMware Fusion, Microsoft Virtual PC, and Virtualbox: 

1 Open Parallels Desktop (in the Applications folder) and choose File > Open. 

2 Select the Windows data file you want to import, then click Open. 

• Parallels Desktop data files end with .pvm. 

• VMware files end with .vmx. 

• Virtual PC files end with .vmc. 

• VirtualBox files end with .xml or .vbox. 

You can also simply drag a Parallels .pvm file to the Parallels Virtual Machines list to add it to 
Parallels Desktop. 

3 Start Windows (p. 41). 

4 Choose Virtual Machine > Install Parallels Tools and follow the onscreen instructions. 
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Download and Install the Windows 8 Developer 
Preview 
Parallels Desktop allows you to download and install the Windows 8 Developer Preview. It is a free 
pre-beta version of Windows 8 for developers. Your Mac must be connected to the Internet. 

To download and install the Windows 8 Developer Preview: 

1 Open Parallels Desktop (in the Applications folder) and choose File > New. 

2 Click Download the Windows 8 Developer Preview. 

3 Select a version of Windows. You can choose the Windows 8 Developer Preview (32- and 64-
bit) or the Windows 8 Developer Preview with SDK (64-bit only). 

4 Click Continue and follow the onscreen instructions to download Windows. 

5 In the Windows Product Key window, be sure to leave Express installation selected. 

Note: If you deselect Express installation, you'll need to install Parallels Tools (p. 196) after the 
installation to allow the most seamless operation between Windows and Mac OS X. 

If you're downloading the Windows 8 Developer Preview without SDK, it is also recommended 
that you use the 64-bit version of Windows, but if you want to use the 32-bit version, deselect 
64-bit Windows version. When ready, click Continue. 

6 Select how you want to use Windows: 

• Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. 
Documents and media from Mac OS X and Windows are kept together on your Mac. 

• Like a PC: The Windows desktop and programs appear in a single window, separate from 
Mac applications. You can drag and drop objects between Windows and the Mac. 

7 Choose where you want to store Windows from the Location menu. 

By default, Parallels Desktop stores Windows in your Documents > Parallels folder. To allow all 
users of your computer to have access to this installation of Windows, select Share with other 
users of this Mac. 

8 If you want to pre-set things like how much memory Windows uses or whether it starts 
automatically when you open Parallels Desktop, select Customize settings before 
installation. You can also adjust these settings after the operating system is installed. 

9 Click Continue. Once the download starts, you can pause it anytime by clicking Pause. To 
resume the download, click Resume. Once the download is complete, the installation of 
Windows starts automatically. The Parallels Wizard finishes the installation of Windows. You 
should expect this operation to take an hour or more, and your virtual machine may restart 
several times during this operation. 
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Once Windows is installed, you can start it up by opening a Windows program (p. 42) or by clicking 

the power button  in the Parallels Virtual Machines list. 

Important: The first time you start Windows, Parallels Tools are installed to allow seamless operation 
between Windows and Mac OS X. Once Parallels Tools are installed, you're prompted to restart 
Windows. 

If you didn't select Express installation in step 5 above, you must install Parallels Tools manually (p. 
196). 

When you install Windows, Parallels Desktop creates an administrator account with a blank 
password. Once the installation is complete, it is recommended that you change this password. 

 



 

C H A P T E R  4  

Use Windows on Your Mac 

Read this chapter to find out all about using Windows programs on your Mac. Learn how to get 
started using Windows programs, set how Windows programs work with Mac OS X, share 
applications, files, and folders between Mac OS X and Windows, connect devices, print, customize 
your keyboard, and more. 
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Get Started 
In this section, learn how to start Windows, open a Windows program, install more Windows 
programs, and shut down or suspend Windows. 

In This Section 

Start Windows.......................................................................................................... 41 
Open a Windows Program ....................................................................................... 42 
Install Windows Programs ........................................................................................ 46 
Shut Down or Suspend Windows............................................................................. 47
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Start Windows 

To use Windows programs on your Mac, Windows must be running. 

The simplest way to start Windows is to open a Windows program (p. 42). If Windows isn't already 
running when you open a Windows program, it starts automatically in Coherence mode (p. 51).  

Important: If Windows was previously shut down, you may need to enter your Windows password. 

You can also start Windows by doing the following: 

1 Open Parallels Desktop. 

2 In the Parallels Virtual Machines window, click the Power Button next to Windows. 

 

3 Click anywhere in the Windows window that appears. 

Windows starts and you can begin using Windows programs alongside Mac OS X. 
 



42 
 

Use Windows on Your Mac 
 

Open a Windows Program 

Opening a Windows program is as easy as opening a Mac application. Here are several ways to 
open Windows programs: 

• From the Windows Applications folder in the Dock 

• From the Windows Start menu 

• From the Mac OS X Finder 

• From the Dock 

• Using Spotlight searching 

• Using Launchpad (if you are using Mac OS X Lion) 

Note: All Windows program icons can be easily identified by the Parallels Desktop symbol  in the 
lower-right corner of the icon. 

Windows Applications Folder 

If you opted to use Windows "Like a Mac" when you first installed Windows, a Windows 
Applications folder is in the Mac OS X Dock. 

This folder contains all your Windows programs. As you install more programs, they are 
automatically added. 
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To open a Windows program using the Windows Applications folder: 

• Click the folder, and then choose a program. 

To add the Windows applications folder to the Dock: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 Click Options and then click Applications. 

3 Be sure Share Windows applications with Mac is selected, and then select Show Windows 
applications folder in Dock. 

Windows Start Menu 

To open a Windows program from the Start menu: 

1 Click the Parallels icon  in the menu bar and choose Windows Start Menu. 
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Note: You can also Command-click or Right-click the Parallels icon. 

2 Click the program you want. 

Mac OS X Finder 

You can also open a program by double-clicking its icon in the Finder.  

To find Windows programs in the Finder: 

• Double-click the Windows volume on the desktop, and then open the Program Files folder. 
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Note: To show the Windows volume on the desktop, the Mac OS X Finder must be enabled to show 
connected servers. Click anywhere on the desktop and choose Finder > Preferences, and then select 
Connected servers. 

You can make an alias for a Windows program on the Mac OS X desktop, then double-click it 
anytime to open the program. 

To make an alias for a Windows program on the Mac OS X desktop: 

• Select the program in the Finder and choose File > Make Alias. Then drag the alias icon to the 
desktop. 

Program Icon in the Dock 

When you open a Windows program, its icon appears in the Mac OS X Dock at the bottom of the 
screen. By default when you close the program, the icon disappears from the Dock. Keeping a 
program's icon in the Dock provides a quick way to open the program anytime. 

To keep a Windows program's icon in the Dock, do one of the following: 

• Right-click or Control-click the Windows program icon in the Dock and choose Keep in Dock 
from the shortcut menu. 

• Drag the program's icon from the Finder to the Dock. 

Now you can open the program again anytime by clicking the icon in the Dock. 

Spotlight 

You can search for and open Windows programs using Spotlight: 

• Click the Spotlight icon in the upper-right corner of your screen, or press Command-Space bar 
on your keyboard. Then type the name of the program and select it from the list. 

Launchpad 

If you're using Mac OS X Lion, you can see a full screen display of all your Windows programs and 
Mac applications using Launchpad. Just click the Launchpad icon (looks like a rocket) in the Dock. 
You can then click any Mac OS X application to open it. To open a Windows program, click the 
Windows folder and then click the program you want. 

Note: The Windows folder is available in Launchpad only if sharing Windows programs (p. 69) is 
enabled. 

To move a Windows program from the Windows folder to a main Launchpad page, do one of the 
following: 

• From Launchpad, click the folder containing your Windows programs and drag a program to 
the Launchpad icon in the Dock. 
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• Start the Windows program you want, right-click its icon in the Dock, and choose Add to 
Launchpad. 

To remove a Windows program from Launchpad, start the program, right-click its icon in the Dock, 
and choose Remove from Launchpad. 
 

Install Windows Programs 

You install Windows programs on your Mac just as you would on a Windows PC. The two most 
common ways of installing programs are: 

• Using a CD or DVD installation disc  

• Downloading the program or installation file from the Internet or a network 

Install a Program from a CD or DVD Installation Disc 

1 Start Windows (p. 41). 

2 Insert the installation disc. 

3 In most cases, an AutoPlay dialog opens. Click the option to run a setup or install file, then 
follow the onscreen instructions. 

For more information about using CD and DVD discs with Parallels Desktop, see CD/DVD-ROM (p. 
180). 

Install a Program from the Internet or a Network 

• Download the program or installation file and follow the instructions from the program's source. 

In most cases, you can either run the installation file and follow the onscreen instructions, or simply 
open the downloaded program. 

For more information about connecting to the Internet and networks, see Connect to the Internet or 
a Network (p. 99). 
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Shut Down or Suspend Windows 

When you're finished using Windows programs, you can leave Windows running in the background 
as you work with your Mac applications. Or you may want to stop Windows from running so more 
of your computer's resources are available for your Mac applications. There are a few ways to stop 
Windows. You can: 

• Suspend Windows 

• Pause Windows 

• Shut down Windows 

• Stop Windows 

Suspend Windows 

Suspending Windows conveniently freezes all running Windows programs and settings in their 
current state. 

Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Actions > Suspend. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > 
Suspend. 

The next time you start Windows or open a Windows program, you resume your progress from 
exactly where you left off. 

When Windows is suspended, you can safely quit Parallels Desktop and resume your progress 
later. 

Note: If you are using Mac OS X Lion and you shut down or restart your computer, or quit Parallels 
Desktop, Windows is automatically suspended. The next time you start up Parallels Desktop, you can 
resume working with Windows from where you left off. If your Windows is encrypted (p. 98), you will have 
to resume it manually. 

Pause Windows 

You can temporarily pause from using Windows and free your computer's resources, such as RAM 
and processor cycles, to be used by your Mac applications by doing one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Actions > Pause. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > 
Pause. 

To resume using Windows after pausing it, do one of the following: 
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• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Actions > Resume. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > 
Resume. 

If you quit Parallels Desktop while Windows is paused, you're prompted to either Suspend or Stop 
Windows first. 

Shut Down Windows 

Shutting down Windows in Parallels Desktop is just like shutting down Windows on a PC. All 
Windows programs close, giving you the opportunity to save your progress if necessary, and 
Windows stops running. 

To shut down Windows, do one of the following. 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Actions > Shut Down. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > 
Shut Down. 

Stop Windows 

To stop Windows and all open Windows programs immediately, do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Actions > Stop. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > 
Stop. 

Important: When you stop Windows this way, none of your data or progress is saved. 

Window Menu 

If Windows is set to appear in a separate window, you can also choose any of the above options 
from the menu at the bottom of the window: 
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Startup and Shutdown Settings 

Using Startup and Shutdown settings, you can: 

• Set whether Windows starts automatically when you open Parallels Desktop 

• Set which view mode (Coherence, Window, or Full Screen) Windows starts up in when you 
open it from the Parallels Virtual Machines list. 

• Set what happens when you shut down Windows 

• Set what happens when you close the Parallels Desktop window 

To access Startup and Shutdown settings: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 Click Options and select Startup and Shutdown. 

Set Whether Windows Starts Automatically 

Choose one of the following from the Start Automatically menu: 

• Never: Windows never starts automatically. 

• When window opens: Windows starts automatically when you open it from the Parallels 
Virtual Machines list. 

• When Parallels Desktop starts: Windows starts automatically when you start Parallels 
Desktop. 

Note: Windows starts when you open a Windows program (p. 42) regardless of this setting. 

Set the Startup View 

This setting affects the Windows view mode only when you open Windows from the Parallels 
Virtual Machines list. If you start Windows by opening a Windows program, it always starts in 
Coherence view. 

• From the Startup View menu, choose Coherence, Window, Full Screen, Modality or Same 
as last time. 

Set What Happens When You Shut Down Windows 

Choose one of the following from the On Shutdown menu: 

• Keep window open: If Windows is set to appear in a separate window, the window stays open 
when you stop or shut down Windows. 
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parate window. 

ac OS X. For 

st like Mac applications, 

• Close window: If Windows is set to appear in a separate window, the window closes when 
you stop or shut down Windows. 

• Quit Parallels Desktop: Parallels Desktop quits when you stop or shut down Windows. 

Set What Happens When You Close the Parallels Desktop Window 

These settings affect what happens only when Windows is set to appear in a se

From the On Window Close menu, choose Suspend, Force to stop, or Ask me what to do. 
 

Set How Windows Works with Mac OS X 
Parallels Desktop 7 for Mac allows you to work seamlessly between Windows and M
example, you can cut and paste text, and share files, between the two. 

There are a number of ways that you can set the level of integration between Windows and Mac 
OS X. For example, you may want your Windows programs to behave ju
appearing side-by-side with them on the Mac desktop. Or you may wish to keep the Windows 
desktop and programs in a separate window. 

Read on to learn more about setting how Windows works together with Mac OS X. 
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Merge Windows and Mac OS X 

You can set Windows and Mac OS X to work seamlessly together, as if they were part of a single 
operating system. In this mode, called Coherence mode, Windows programs appear on the Mac 
desktop next to your Mac applications, and documents from Windows programs and Mac 
applications are stored in the same folders. 
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If you opted to use Windows "Like a Mac" when you first installed Windows, Parallels Desktop is 
already set to Coherence mode.  

Switch to Coherence Mode 

To switch from Window mode to Coherence mode, do one of the following: 

• Choose View > Enter Coherence. 

• Press Control-Command-Return. 

To switch from Full Screen mode to Coherence mode, do one of the following: 

• Press Control-Option (Alt), click the View menu and select Exit Full Screen. Then open the 
View menu and click Enter Coherence. 

• Move the pointer to the upper-left corner of the screen until the corner peels back and click 
Exit Full Screen. Then choose View > Enter Coherence. 

 

Note: To enable the Coherence view mode, Parallels Tools must be installed (p. 196). In most cases, 
Parallels Tools are installed by default. 

Parallels Menu 

When in Coherence mode, the Parallels menu  appears in the menu bar at the top of the screen.  
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Use the menu for these common functions: 

• Click the Parallels icon  to open a basic menu that  provides the following items: 

• Windows Start Menu: Access the Windows Start menu. 

• Devices: Manage hardware devices like printers and DVD drives. 

• Exit Coherence: Switch to Window mode 

• Request Support: Fill out a problem report and request support from Parallels Desktop. 

• Parallels Desktop Help: Access onscreen help. 

• Quit: Quit Parallels Desktop. 

• Right-click the icon to open the Windows start menu. 

• Option-click (Alt-click) the icon to open an extended menu. The extended menu includes 
additional options, including Report a Problem, Configure, Preferences, and many others. 

Important: When in Coherence mode, to quit Parallels Desktop, click the Parallels icon  in the menu 
bar and choose Quit Parallels Desktop. 

Windows System Tray 

When Parallels Desktop is in Coherence mode, the Windows system tray icons are in the Mac OS 
X menu bar at the top of the screen. 

 

You can use the system tray icons just as you would from the Windows Desktop. 

Move Windows Programs Between Desktops (Spaces) 

When Windows is working in Coherence, you can easily move windows of guest OS programs 
between Mac OS X desktops (spaces). 

• Click the title bar of the window you want to move and while holding down the mouse button, 
press Control-# (# is the number of the desktop (space) you want to move the window to). 

 



54 
 

Use Windows on Your Mac 
 

Adjust Coherence Settings 

You can customize how Windows appears and behaves when in Coherence mode. 

To customize Coherence mode: 

3 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure, and then 
click Options. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Configure, and then click Options. 

4 Click Coherence. 
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5 Select or deselect any of the following: 

• Use Crystal Mode:Deselect to disableCrystal mode. With Crystal mode disabled, the 
Parallels Desktop menu bar becomes visible, and the level of integration between Mac OS X 
and Windows is reduced. 

• Show Windows notification area in menu bar: Select to display the Windows system tray 
icons in the Mac OS X menu bar. 

• Allow applications to switch to full screen: Some programs, most notably 3D games, 
work best when running at full screen. Select this option to allow such programs to take 
over the full screen when you open them while in Coherence mode. 

• Disable Windows Aero: The Windows Aero theme includes elements such as translucent 
title bars and animations. Select this option to disable the Aero theme, for better 
performance. 

 

Set Windows to Appear in a Single Window 

You can set the Windows and programs to appear together in their own window. If you opted to 
use Windows "Like a PC" when you first installed Windows, Parallels Desktop is already set to 
Window mode.  
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To switch to Window mode from Coherence mode, do one of the following: 

• Click the Parallels icon  in the menu bar, then choose Exit Coherence. 

• Press Control-Command-Return. 

To switch to Window mode from Full Screen mode, do one of the following: 

• Press Command-Control-F. 

• Press Control-Option (Alt), click the View menu and select Exit Full Screen. 
 

Status Bar 

When using Parallels Desktop in Window mode, the status bar at the bottom of the window shows 
clickable icons. The icons are shortcuts that let you control various functions. Most of the icons let 
you connect and disconnect hardware devices to and from Windows. 
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Note: If you don't see the status bar, click the triangle next to the gear icon. 

The following devices have the icons on the status bar: 

• Keyboard  

• Floppy disk drive  

• CD/DVD drive  

• Hard disk  

• Network adapter  

• Sound card  

• USB controller  

• Shared folders  

• Serial port  

• Parallel port  

If the  icon appears in the status bar, Parallels Tools are installed. 

To connect or disconnect a device, such as the DVD drive, from Windows, click the device icon to 
display its shortcut menu and select the command. 

 

You can also connect images of discs to Windows as if they were physical DVDs, CDs, or floppy 
disks. To do so, drag the image file over the CD/DVD-ROM drive or floppy disk icon on the status 
bar. 

Hide/Show Status Bar 

If you don't need the status bar while working with Windows, you can hide it (click View > Hide 
Status Bar) and make visible again when necessary (click View > Show Status Bar). 
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Adjust Window Mode Settings 

You can customize how Parallels Desktop appears and behaves when in Window mode. 

Set Whether Windows Programs Show in the Dock: 

You can choose whether or not to show icons for Windows programs in the Mac OS X Dock when 
in Window mode. If you prefer to work with programs by manipulating them on the Windows 
desktop, you may not want to be distracted by seeing them in the Dock alongside your Mac OS X 
application icons. 

6 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

7 Click Options and then click Applications. 

8 To show Windows program icons in the Dock when in Window mode, deselect Show Dock 
icons in Coherence only. 

Set Whether Animations are Used for Some Actions 

By default when you pause, suspend, or shut down Windows, the Parallels Desktop window 
becomes animated. If you find this distracting, you can turn off the animations. 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Preferences, and 
then click General. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences, and then click General. 

2 Select or deselect Use animations. 
 

Monitoring Windows in a Scalable Window 

You can set Windows to appear in a window that can be resized to any size so that the content 
scales in size with the window. This is called Modality mode. Modality mode can be useful if you 
want to monitor programs and other tasks running in Windows as you work in Mac OS X. 

To switch to Modality mode: 

• From Window mode, choose View > Modality. 

For more information on Modality mode, see the Modality mode settings topic (p. 155). 
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Set Windows to Take Up the Whole Screen 

You can set Windows to occupy your entire screen, so it looks just like it would if you were using a 
Windows PC. In Full Screen mode, Mac OS X and all of the Parallels Desktop controls are hidden. 

To switch to Full Screen mode, do one of the following: 

• From Coherence mode, click the Parallels icon  in the menu bar, then choose Exit 
Coherence. Then click the View menu and select Enter Full Screen. 

• From Window mode, choose View > Enter Full Screen. 

If you are using Mac OS X Lion and in Window mode, click the Full Screen icon (double-arrows) in 
the upper-right corner of the window. 

To exit Full Screen mode, do one of the following: 

• Press Command-Control-F. 

• If one of the screen corners is configured to exit Full Screen (see below), move the pointer to 
that corner until it peels back, and then click Exit Full Screen. 

 

If you are using Mac OS X Lion and one of the screen corners is set to show the menu bar (p. 60), 
move the pointer to that corner and then click the Full Screen button in the top-right corner of the 
menu. 
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Adjust Full Screen Settings 

You can customize how Windows appears and behaves when in Full Screen mode. 

To access Full Screen settings: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure, and then 
click Options. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure, and then click Options. 

2 Click Full Screen. 
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3 In this Full Screen pane, you can adjust any of the settings listed below. 

Choose the Full Screen Mode You Want to Use 

By default, Parallels Desktop is configured to use the Mac OS X Lion's native Full Screen. When 
you switch Windows to this mode, it becomes displayed on a separate Desktop (Space). If you 
have two displays connected to your Mac and switch Windows to the native Full Screen, Windows 
becomes available on the primary display. The other is grayed out. To make both displays show 
Windows, select Use all displays in full screen. 

You can also work with Windows in the Mac OS X Snow Leopard-style Full Screen. When you 
switch Windows to this mode, it occupies the screen but remains on the same Desktop (Space). If 
you have two displays connected to your Mac and switch Windows to the Snow Leopard-style Full 
Screen, you can either configure both displays to show Windows (select Use all displays in full 
screen) or work with Windows on one display and Mac OS X on the other. To use this type of Full 
Screen, clear Use Mac OS X Full Screen. 

Set Actions for Screen Corners 

Parallels active screen corners allow you to exit Full Screen, display the Mac OS X menu bar and 
Dock. 

If you're using Mac OS X Lion, Parallels active screen corners are disabled by default. If you want to 
use Parallels active screen corners instead of Mac OS X hot corners, select Active Screen 
Corners. 

To set which action is performed for a screen corner, select one of the following from the menu 
near that corner: 

• Exit Full Screen: Moving the pointer to the corner until it peels back and then clicking Exit Full 
Screen switches the view to Window mode (p. 55). 

• Show menu bar: Moving the pointer to the corner shows the Mac OS X menu bar. 

• Show Dock: Moving the pointer to the corner shows the Mac OS X Dock. 

Note: If you're using Mac OS X Snow Leopard or Mac OS X Leopard and active screen corners such as 
Expose or Screen Saver are set in Mac OS X preferences, those settings take precedence over Full 
Screen mode active screen corner settings. You must deactivate Mac OS X active screen corners to 
enable Full Screen mode active screen corners. See Mac Help for more information. 

Scale to fit screen 

Using the Scale to fit screen menu, you can configure how Windows is displayed when working in 
Full Screen: 
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• Off. If Parallels Tools (p. 143) are installed, Windows resolution matches that of the Mac. If 
Parallels Tools (p. 143) aren't installed, Windows resolution remains unchanged. If it is lower 
than that of the Mac, Windows is displayed on the black background. If higher, Windows has 
scroll bars. 

• Auto. If Parallels Tools (p. 143) are installed, Windows resolution matches that of the Mac. If 
Parallels Tools (p. 143) aren't installed, Windows resolution remains unchanged. If it is lower 
than that of the Mac, Windows is displayed on the black background. If higher, Windows is 
entirely displayed on the screen without any scroll bars. 

• Keep ratio: No matter whether Parallels Tools (p. 143) are installed or not, Windows resolution 
remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black 
background. If higher, Windows is entirely displayed on the screen without any scroll bars. 

• Stretch: No matter whether Parallels Tools (p. 143) are installed or not, Windows resolution 
remains unchanged but Windows is stretched to occupy the whole screen. 

Using All Displays in Full Screen 

If you have multiple displays connected to your Mac, you can set Windows to occupy all of the 
displays when set to Full Screen mode: 

• Select Use all displays in full screen. 

Note: To prevent unauthorized changes to Full Screen settings, click the Lock icon  at the bottom 
of the window. Once locked, an administrator's password is required to make further changes. 

 

Set Windows to Look Like Mac OS X 

If you aren't used to working with Windows, you can make your Windows 7, Windows Vista and 
Windows XP look like Mac OS X. Windows icons, fonts, colors, and other elements take on a Mac-
like appearance. 

To set Windows to look like Mac OS X: 

1 In Parallels Desktop, start Windows (p. 41). 

2 Once Windows starts, do one of the following: 

• Option-click the Parallels icon  in the menu bar and choose View > Use MacLook. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose View > Use 
MacLook. 

To revert to a Windows appearance, repeat step 2 above to deselect Use MacLook. 
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Copy and Paste Between Mac OS X and Windows 

Parallels Desktop allows you to copy and paste pictures, formatted text (italic, bold, or underlined, 
of various colors, fonts, and sizes) between Mac OS X applications and Windows programs. 

If you opted to use Windows "Like a Mac" when you first installed Windows, copying and pasting 
between Mac OS X and Windows is already enabled. 

To enable copying and pasting between Mac OS X and Windows: 

3 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

4 Click Options > Advanced. 

5 Select Share Mac clipboard. 

6 To preserve text formatting when copying and pasting text, select Preserve text formatting. 

Note: To enable copying and pasting between Mac OS X and Windows, Parallels Tools (p. 196) must be 
installed. In most cases, Parallels Tools are installed by default. Copying and pasting between Mac OS X 
and Windows is unavailable if you isolate Mac OS X from Windows. 

 

Set a Program to Open When You Insert a CD or DVD 

You can set the Windows program of your choice to open when you insert a music CD, picture CD, 
video DVD, or a blank CD or DVD. 

1 From the Mac OS X Finder, choose Apple menu > System Preferences. 

2 Click CDs & DVDs. 

3 From the disc type menu of your choice, choose Open other application. 

4 Choose a Windows program from /username/Applications (Parallels)/Windows 
Applications. 

When you insert a disc of the type you selected, the Windows program you chose automatically 
opens. 

Note: 1.If you're unable to set a Windows program to open when you insert a CD or DVD, be sure that 
sharing Mac OS X applications (p. 69) is enabled and that Mac OS X CD/DVD-ROM is not selected in 
CD/DVD Preferences (p. 180). 

2. To enable a Windows program to open when you insert a CD or DVD, Parallels Tools must be installed 
(p. 196). In most cases, Parallels Tools are installed by default. 
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Share Items Between Mac OS X and Windows 

Parallels Desktop allows you to easily access your Mac OS X files using Windows programs, and 
also to access Windows files using Mac OS X applications. 

Read on to learn about all the ways you can share folders, files, and applications between Mac OS 
X and Windows. 
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Share Files and Folders 

Parallels Desktop allows you to share folders between the Mac OS X and Windows file systems, so 
you can easily open Mac OS X files from Windows programs and Windows files from Mac OS X 
applications. 

Set Mac OS X and Windows to Use the Same Folders 

You can set Mac OS X and Windows to use the same folders for things like music, documents, 
pictures, your desktop, and deleted files. So for example, if you save a file to the Documents folder, 
it will be in the Documents folder whether you're using a Mac OS X application or a Windows 
program. 

Note: If you selected "Like a Mac" when you installed and set up Windows, Mac OS X and Windows are 
already set to use the same folders. 

1 Start Windows. (p. 41) 

2 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

3 Click Options and select Sharing. 

4 Select the checkbox next to Share Mac user folders with Windows. 

Your Mac OS X Desktop, Documents, Pictures, Music, Movies, and Downloads 
folders are merged with the corresponding Windows folders, and the Mac OS X Trash is 
merged with the Windows Recycle Bin. 

5 If you only want to map some of the folders, click Configure and select the folders you want. 
To map the Mac OS Trash to the Windows Recycle Bin, select Merge with Mac's Trash. 

Access a Mac OS X Folder or File from a Windows Program 

With folder sharing enabled, you can navigate to any shared Mac OS X folder from within a 
Windows program. When you open a file (for example, by choosing File > Open in many 
programs), your shared Mac OS X folders appear as network shared directories labeled "psf." 

Note: If you selected "Like a Mac" when you installed and set up Windows, the folders in your Mac OS X 
Home folder are already shared and accessible from Windows programs. 

To enable Mac OS X folders for sharing with Windows programs: 

1 Start Windows. (p. 41) 

2 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 
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• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

3 Click Options and select Sharing. 

 

4 Do one of the following: 

• To share just the folders in your Home folder, choose  Home folder only from the Shared 
Folders menu. 

• To share all your Mac OS X folders, choose All disks from the Shared Folders menu. 

• To share any folder you want, click Custom Folders and click the add (+) button, then 
choose the folder you want to share. You can add more folders by clicking the add (+) 
button again. 
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Once you share a Mac OS X folder with Windows you can: 

• Disable the folder sharing by deselecting On. 

• Change the folder name that will be displayed in Windows by double-clicking the folder 
name in the Name column and typing another name. 

• Restrict writing to this folder by clicking Read & Write in the Permissions folder and 
choosing Read only. You will not be able to add items to the folder. 

5 Click OK. 

Note: 1. To enable folder sharing, the Isolate Mac from Windows option must be disabled in the 
Security pane of the Configuration dialog. 

2. If you're running Linux, shared folders are mounted to the /media/psf or /mnt/psf directory. 

Show an Item from Windows in the Finder 

If Windows is set to appear in a separate window or in full screen mode (p. 55), you can show an 
item from Windows in the Mac OS X Finder. 

• In Windows, right-click (or Control-click) a file or folder and choose Show in Finder from the 
shortcut menu. 

From the Finder you could, for example, apply a color label to an item, or easily drag it to another 
location in the Finder. 

Note: You can only perform these actions with files stored in shared folders (p. 65). 

Access a Windows Folder or File from a Mac OS X Application 

By default, you can navigate to all your Windows folders and files from Mac OS X. Windows disks 
are mounted to /Volumes. At the same time, Windows appears as a hard disk mounted on the 
Mac OS X desktop. 

• Double-click the icon to access Windows folders and files. You can also navigate to this disk 
from within Mac OS X applications. 
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Note: If the Windows disk icon doesn't appear on the Mac OS X desktop, from the Finder choose 
Finder > Preferences > General and make sure that Connected servers is selected. 

To unmount Windows from the desktop: 

1 Start Windows. (p. 41) 

2 Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. Then click 
Options and select Sharing. 

Note: If Windows is running in Window mode (p. 55), choose Configure from the Virtual Machine 
menu. 

3 Deselect Mount virtual disks to Mac desktop. 

Note: The Windows disk disappears from the desktop and the Finder, but you can still access all of the 
Windows files and folders via the Windows PVM file and Terminal (/Volumes). By default, the PVM file 
is either in /Users/<Username>/Documents/Parallels/ or /Users/Shared. You can also find 
the PVM file by right-clicking Windows in the Parallels Virtual Machines list and selecting Show in 
Finder. To access Windows files and folders, right-click the PVM file, select Show Package Contents 
from the context menu, and open the Windows Disks folder. To disable the ability to navigate to 
Windows files and folders, deselect Access Windows folders from Mac in step 3 above. 
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Share Applications and Programs 

You can access Mac OS X applications from within Windows and you can access Windows 
programs from Mac OS X. For example, if you locate a file using the Open menu in a Windows 
program and decide you would rather open the file using a Mac OS X application, you can. 

If you opted to use Windows "Like a Mac" when you first installed Windows, sharing applications is 
already enabled. 

Enable Sharing Mac OS X Applications 

When sharing Mac OS X applications is enabled, you can open Mac OS X Applications from within 
Windows or Windows programs.  

 If not, you can enable it at any time by doing the following: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 Click Options and click Applications. 

3 Select Share Mac applications with Windows. 

Once sharing Mac OS X applications is enabled, you can do the tasks below. 

Open a File from Windows in a Mac OS X Application  

You can open a file in a Mac OS X application from Windows Explorer, from the Open dialog in 
most Windows programs, or from Windows Desktop if Windows is set to appear in a separate 
Window or at full screen (p. 55). You may want to do this if you don't have a Windows program that 
can open the file. 

• In Windows, right-click (or Control-click) a file and do one of the following: 

• Choose Open on Mac from the shortcut menu. The file opens in the default Mac OS X 
application for that file type. 

• Choose Open With from the shortcut menu, and then choose an application. 

Note: You can only perform these actions with files stored in shared folders (p. 65). 

Open a Mac Application from the Windows Start Menu 

From the Windows Start menu, do one of the following: 

• Choose All Programs > Parallels Shared Applications, and then choose an application. 
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• Type the name of the application you're looking for in the search field, then choose the 
application from the list. 

Enable Sharing Windows Programs 

When sharing Windows programs is enabled, you can open Windows programs from the Mac OS 
X Finder. You can also choose to add a folder to the Dock containing all your Windows programs 
for easy access. 

4 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

5 Click Options and click Applications. 

6 Select Share Windows applications with Mac. 

Add a Windows Applications Folder to the Dock 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 Click Options and then click Applications. 

3 Be sure Share Windows applications with Mac is selected, and then select Show Windows 
applications folder in Dock. 

Force Quit Windows Programs 

If your running Windows guest OS program doesn't respond and freezes, you can easily force quit 
it as you can do with any Mac OS X application. To force quit a Windows program, do one of the 
following: 

• Right-click the icon of the Windows program available in the Dock, press Option (Alt), and 
choose Force Quit. 

• Press Option + Command + Esc (Alt + Command + Esc), select the name of the Windows 
program you want to quit, and click Force Quit. 

Note: To be able to force quit Windows guest OS programs, Parallels Tools installed (p. 196). If you 
selected Like a Mac when you first installed Windows, Parallels Tools should already be installed. 
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Set Files to Open in the Application or Program of Your Choice 

You can set files of a particular type that you open from the Mac OS X Finder to open in the 
Windows program of your choice. For example, you could set files ending in .txt to always open 
in Windows Notepad. 

You can also set files opened from Windows to always open in the Mac OS X application of your 
choice. 

Set Mac OS X Files of a Particular Type to Open in a Windows Program 

To open a Mac OS X file once with a Windows program: 

1 Right-click (or Control-click) the file in the Finder and choose Open With from the shortcut 
menu. 

2 Select a Windows program.  

If you don't see the program you want, click Other and choose a Windows program from 
/username/Applications (Parallels)/Windows Applications. 

You can also open a Mac OS X file in a Windows program by dragging it to the program's icon in 
the Dock. 

To set files of a particular type to always open in a Windows program: 

1 Right-click (or Control-click) a file and choose Get Info from the shortcut menu. 

2 Click the triangle next to "Open with" to expand the section. 

3 Choose a Windows program from the pop-up menu. 

If you don't see the program you want, choose Other and choose a Windows program from 
/username/Applications (Parallels)/Windows Applications. 

4 Click Change All. 

From this point on, double-clicking a file of this type (.txt in the example above) in the Mac OS X 
Finder opens the file in the Windows program. If Windows is shut down, suspended, or paused, 
double-clicking the file starts or resumes Windows in Coherence mode. When Windows starts up, 
the file opens in the Windows program. 

Set Windows Files of a Particular Type to Open in a Mac OS X Application 

To open a Windows file with a Mac OS X application only this time: 

• Right-click (or Control-click) the file in Windows, choose Open With from the shortcut menu, 
and choose an application. 

To set all files of a particular file type to open in a Mac OS X application: 
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1. Right-click (or Control-click) a file in Windows, choose Open With from the shortcut menu, 
and click Choose default program. 

2. Select an application, choose Always use the selected program to open this kind of file, 
and click OK. 

Note: To set files to open in the application or program of your choice, Parallels Tools must be installed 
(p. 196). In most cases, Parallels Tools are installed by default. Also, the Isolate Mac from Windows (p. 
96) option must be disabled, and Windows application sharing (p. 69) must be enabled. 
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Setting Internet Links to Always Open in Mac OS X or Windows 

By default, clicking a link (such as a web page URL) in Windows opens the default Windows 
program for that link type, and clicking a link in Mac OS X opens the default Mac OS X application.  

You can set links of a particular type to always open in Mac OS X or in Windows. For example, you 
could set web pages to always open in Windows Internet Explorer, even if the link is clicked in a 
Mac OS X application. 

Note: To set Internet links to open in Mac OS X or Windows, Parallels Tools must be installed (p. 196). In 
most cases, Parallels Tools are installed by default. 

To set Internet links to open in Mac OS X or Windows: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 Click Options and select Applications. 

3 Click the menu for the type of link you want to set. If you don't see the link type you want, click 
More Applications. The following types of links can be set: 

• Web pages: Web pages accessible through the HTTP and HTTPS protocols. 

• E-mail: Links in the mailto format that open a pre-addressed email. 

• Newsgroups: Links in the news. format that typically open a newsreader program. 

• FTP: File upload and download locations accessible through the FTP protocol. 

• RSS: Episodic content, such as blogs and podcasts. 

• Remote access: Locations accessible through the Telnet and Secure Shell (SSH) 
protocols. 

4 Choose one of the following: 

• Default: The link opens in the application or program set as default in the operating system 
(Mac OS X or Windows) where you click the link. 

• Open in Windows: Links clicked in Mac OS X or Windows open in the default Windows 
program for that link type. 

• Open in Mac: Links clicked in Mac OS X or Windows open in the default Mac OS X 
application for that link type. 
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Share External Storage Devices and Volumes 

When you connect an external storage device, such as a USB drive, to your Mac, you can access 
the contents from Mac OS X applications. 

Using SmartMount, you can set Parallels Desktop to automatically mount storage devices and 
volumes to Windows. That way, you can access the contents from both Mac OS X and Windows. 

With SmartMount enabled, these items are automatically mounted to Windows: 

• Removable drives: External storage devices, such as USB hard disks and USB flash drives. 

• CD/DVD drives: CD and DVD drives or CD/DVD images (files most commonly ending in .dmg, 
.iso, and .img.). 

• Network folders: Folders shared over the network. 

To enable SmartMount: 

5 Start Windows. (p. 41) 

6 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

7 Click Options and select Sharing. 

8 Selec Map Mac volumes to Windows. 

When you connect a storage device or volume, it is mounted as a network drive. For example, a 
USB flash drive plugged in to your Mac will be accessible from both the /Volumes folder in Mac 
OS X and My Computer in Windows. 

Note: Permissions for accessing the mounted device from Windows are the same as permission settings 
for the device in Mac OS X. For example, if you can read from and write to a USB flash drive in Mac OS 
X, you can also read from and write to it in Windows. One exception: Mac OS X can't write to NTFS 
volumes, regardless of permissions. 
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Apply Mac OS X Parental Controls to Windows 

If you have administrator rights in Mac OS X, you can use parental controls to prevent others with 
accounts on your Mac from using certain Windows programs or accessing certain web sites. 

To apply parental control settings: 

1 In Mac OS X, choose Apple menu > System Preferences and click Parental Controls. 

2 Click the lock if it's not unlocked, and then enter an administrator name and password. 

3 Select the account that you want to restrict, click Enable Parental Controls, and set up the 
controls. If you want the user to be able to use some Windows programs, be sure to select 
Parallels Desktop in the list of allowed applications. 

For more information on using parental controls, see Mac Help. 

Note: To enable copying and pasting between Mac OS X and Windows, Parallels Tools must be installed 
(p. 196). In most cases, Parallels Tools are installed by default. 

 

Mouse, Trackpad, and Keyboard 
Parallels Desktop lets you configure your mouse or trackpad and your keyboard to work just the 
way you want them to. 

You can also use trackpad gestures or the optional Apple Remote to control Windows programs 
just as you can with Mac OS X applications. 

Read on to learn how to customize how your mouse, trackpad, and keyboard work with Windows 
programs. 
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Set Your Mouse or Trackpad to Right-Click 

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking. 

By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click 
the mouse. You can change which key combination triggers a right-click.  

You can also set your trackpad to allow right-clicking, and if you have an Apple Mighty Mouse 
(included with Apple desktop computers from 2005-2009) or Magic Mouse (included with current 
Apple desktop computers), you can set the mouse to allow right-clicking.  

Most other mice are pre-configured for right-clicking. 

Set the Trackpad for Right-Clicking. 

1 Choose Apple menu > System Preferences and click Trackpad. 

2 Select Secondary Tap. 

Now you can tap the trackpad with two fingers to simulate a right-click. 

Set an Apple Mighty Mouse for Right-Clicking 

1 Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse. 

2 Choose Secondary Button from the menu to the right of the mouse. 

Set an Apple Magic Mouse for Right-Clicking 

1 Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse. 

2 Select Secondary click. 

Set Which Key Combination Triggers a Right-Click 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Preferences. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences. 

2 Click Keyboard. 

3 If necessary, click the lock icon and enter an administrator password. 

4 Select Use [blank] + to right-click. 

5 Click in the text field and press the key or combination of keys that you want to use with a 
mouse click to trigger a right-click. You can use any combination of the Control, Option (Alt), 
Shift, and Command keys. 
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Control Programs with Trackpad Gestures or the Apple Remote 

You can use the Apple Remote to control some Windows programs. If you have an Apple portable 
computer, such as a Macbook, or if you have an Apple Magic Trackpad, you can use gestures, 
such as swiping left or right across the trackpad, to control some Windows programs. 

To use the Apple Remote, you must first enable it by doing the following: 

1 Start Windows (p. 41). 

2 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

3 Click Options, and then click Advanced. 

4 Select Enable next to Apple Remote. 

The following table provides commands to control some of the more popular Windows 
applications. 

Action Keyboard and Mouse 
Combination 

Apple 
Remote 

Touchpad Gesture 

General 

Scroll Swipe up, down, left, or 
right with two fingers 

Up, down, left, or right arrow n/a 

Microsoft Power Point 

Start slide show F5  n/a 

End slide show Esc  n/a 

Perform the next animation 
or advance to the next 
slide 

N, Enter, Page Down, Right 
Arrow, Down Arrow, Space (or 
click the mouse) 

 
Swipe right with three 
fingers 

Perform the previous 
animation or return to the 
previous slide 

P, Page Up, Left Arrow, Up 
Arrow, Backspace  Swipe left with three fingers 

Zoom in/zoom out Ctrl+wheel up /Ctrl+wheel down n/a Pinch open/pinch close 

Microsoft Word/Excel 

Zoom in/zoom out Ctrl+wheel up /Ctrl+wheel down n/a Pinch open/pinch close 

Windows Media Player 

Start/pause playback Space  n/a 

Skip to the next song Ctrl+F   
Swipe right with three 
fingers 



78 
 

Use Windows on Your Mac 
 

  Play the previous song Ctrl+B Swipe left with three fingers 

Volume up F8, Up Arrow, wheel up  n/a 

Volume down F9, Down Arrow, wheel down   n/a 

Media Player Classic (k-lite) 

Start playback/pause Space  n/a 

Volume up F8, Up Arrow, wheel up  n/a 

Volume down F9, Down Arrow, wheel down   n/a 

Winamp 

Start playback/pause X to start, C to pause  n/a 

Volume up Up Arrow, wheel up  n/a 

Volume down Down Arrow, wheel down   n/a 

Microsoft Internet Explorer 

Backspace, Option+Left Arrow 
(Alt+Left Arrow) 

n/a or 

 

Swipe right with three 
fingers 

Page back 

Page forward Right Arrow (Alt+Right Option+
Arrow) 

n/a or 

  
Swipe left with three fingers 

Zoom in/zoom out Ctrl+wheel up/Ctrl+wheel down n/a Pinch open/pinch close 

Mozilla Firefox 

n/a or Backspace, Option+Left Arrow 
(Alt+Left Arow) 

Swipe riPage back 
 

ght with three 
fingers 

Page forward Option+Right Arrow (Alt+Right 
Arrow) 

n/a or 

  
Swipe left with three fingers 

Zoom in/zoom out Ctrl-wh
Ctrl-"+"/C

eel up/Ctrl-wheel down or 
trl-"-" 

n/a Pinch open/pinch close 

iewer Windows Picture and Fax V

Next image Right Arrow   
Swipe right with three 
fingers 

Previous image Left Arrow   Swipe left with three fingers 

 or 

  

Pinch open/pinch close Zoom in/zoom out "+"/"-" 

Rotate clockwise Ctrl+K n/a Rotate right with two fingers 

Rotate counterclockwise Ctrl+L n/a Rotate left with two fingers 
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eyboard shortcuts. For example, in Mac OS X 
you

By default, Parallels Desktop maps common Mac OS X keyboard shortcut key combinations to the 
equivalent Windows key combinations. That way if you're used to, for example, pressing 
Command-C to copy text in Mac OS X, you don't have to switch to the Windows equivalent, 
Control-C. 

You can also use and customize keyboard shortcuts for switching between Coherence, Full 
Screen, and Window view modes, and for showing and hiding Parallels Desktop. 

Cu

1 

Customize the Keyboard 

Both Mac OS X and Windows provide extensive k
 can hold down the Command key and press Q (Command-Q) to quit the current application. 

stomize Keyboard Shortcuts 

Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Preferences

If the Parallels Desktop menu bar is vi

. 

• sible at the top of the screen, choose Parallels 

3 rator password. 

Desktop > Preferences. 

2 Click Keyboard. 

 If necessary, click the lock icon and enter an administ
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Pressing a key combination in the From column while working in a Windows program triggers 

 
ange the character in the text field. 

the key combination in the To column. 

4 Do one of the following: 

• To edit an existing key combination, double-click the key combination. Click modifier keys to
select or deselect them. If you wish, ch

 

• To delete a key combination, select it and click the Remove button . 

• To add a new key combination, click the Add button . 

• To disable a key combination without deleting it, click the checkbox next to the key 
combination to deselect it. 

If you're using multiple operating systems with Parallels Desktop, you can create keyboard profiles 
for each OS (p. 142). 

Note: 1. Some key combinations can't be edited or deleted. 

2. There are Mac shortcuts that do not have similar shortcuts in Windows, for example, you can use the 
F11 key or Fn+F11 combination to see your Mac OS desktop with Expose, but in Windows there are no 
keys or key combinations that enable you to perform the same action, because there is no Expose in 
Windows. 

Enable or Disable Mac OS X System Shortcuts 

By default, when a Windows program is active the customizable function keys (F1, F2, F3, and so 
on) continue to activate Mac OS X functions, such as adjusting the brightness or displaying the 
Dashboard. 

To disable or re-enable these functions: 

• Select or deselect Enable Mac OS X system shortcuts checkbox. 
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ws and Mac 
OS X when you connect them to your Mac.  

ct such a device, you can 
choose whether you want to use it with Mac OS X or Windows. 

To connect a USB device: 

1 Connect the device to a USB port on your Mac. 

used with both Windows and Mac OS X at the 

 Windows programs, click the 
Windows screen. 

Connect USB Devices 
Many USB devices, such as mice and printers, are available by default to both Windo

Some USB devices, such as an Apple iPhone, can only be used with either Mac OS X applications 
or Windows programs, but not both at the same time. When you conne

2 If Windows is running and the device can't be 
same time, you're prompted to choose which one you want to use it with. To use the device 
with Mac OS X applications, click the Mac icon. To use it with
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 USB 2.0 and 32 USB 1.1 devices to your Mac and use them with 
Windows. You can connect and use up to 30 USB printers. 
You can connect up to 15

Impor s tant: To be able to use a USB device with Windows programs, you may need to install Window
drivers for the device. Typically you can download drivers from the manufacturer's website. 

You ca hen any new USB device is connected and set particular USB 
s be used with either Mac OS X or Windows (p. 83). 

) reader can work simultaneously in Mac OS X and Windows. 

2 to choose Windows or the Mac, click the Windows screen. The CAC 

Adjust USB Settings 

In the USB pane of Parallels Desktop Preferences, you can: 

 used with either Mac OS X or Windows. 

n also set what happens w
devices to alway

Connect a Common Access Card reader 

A Common Access Card (CAC

1 Connect the CAC reader to your Mac. 

When you're prompted 
reader becomes available to both Windows and Mac OS X. 

 
 

• Set what happens when you connect any new USB device to your Mac. 

• Set a particular USB device to always be
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To access USB Settings: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Preferences. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences. 

USB Device to Your Mac 

devices are automatically available for use with Mac OS X 

• Connect it to the active virtual machine. New USB devices are automatically available for use 
with Windows programs. If Windows isn't running, the USB device is connected to Mac OS X. 

• Ask me what to do. Each time you connect a USB device, you're prompted to choose 
whether you want to connect the device to Windows or the Mac. 

Set a Particular USB Device to Always Be Used With Mac OS X or Windows 

If you know you always want a particular USB device to be available to either Mac OS X or 
Windows, you can set it to do so by following the instructions below. The device must already have 
been connected to your Mac at least once. 

1 Click the Add (+) button towards the bottom of the window. 

2 Select the device from the list. 

3 Double-click the word (either Computer or some form of Windows) in the Connect To 
column. The word becomes a pop-up menu. 

4 Do one of the following: 

• To set the device to always be available to Mac OS X applications, choose Computer from 
the menu. 

• To set the device to always be available to Windows programs, choose Windows from the 
menu. 

To remove an existing assignment, so that the device no longer automatically connects to Mac OS 
X or Windows, select the device in the USB Device column and click the Remove (-) button. 

2 Click USB. 

Set What Happens When You Connect a New 

Choose one of the following: 

• Connect it to my Mac. New USB 
applications. 

Important: To be able to use a USB device with Windows programs, you may need to install Windows 
drivers for the device. Typically you can download drivers from the manufacturer's website. 
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from a 

ter. There are a few ways to set up printing in 

ny of the printers connected to your Mac. 

• Connect to a network printer. 

ctly to Windows. 
 

Print from Windows 
By default, Windows is set to use the same printer that you use with Mac OS X. Simply print 
Windows program the way you normally would. 

You can also set Windows to use a different prin
Windows: 

• Share a

• Connect to a local printer using Apple Bonjour. 

• Connect a USB printer dire
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 when you installed and set up Windows, you can use any printer 
connected to your Mac with Windows programs. (If you selected "Like a PC", see below for 

To p

• O int it the way you normally would (for example, choose File > 

onnected to your Mac. 

t printer as your Mac. To use a different default 

5 

Share a Printer Connected to Your Mac 

If you selected "Like a Mac"

instructions on sharing printers connected to your Mac.) 

rint a document from a Windows program: 

pen the document and simply pr
Print). 

In the print window, you can choose any printer that's c

Set a New Default Printer 

By default, Windows is set to use the same defaul
printer for Windows. 

Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine
> Configure. 

 

6 Click Hardware and select Print. 

Note: The Print pane is available for Windows 2000 and newer versions of Windows. 

7 Deselect Synchronize default printer. 

Now you can set a new default printer in Windows the way you normally would. 

Share Printers Connected to Your Mac 

If you didn't select "Like a Mac" when you installed and set up Windows, you can set printers 
connected to your Mac to be available to Windows programs by doing the following: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 Click Hardware and select Print. 

3 Select Add all Mac printers. 

Add a printer in Linux 
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uest operating system depends on the Linux 
 to add a printer to a virtual machine running RHEL 

5.4 Server. However, you can use these guidelines as general instructions on how to add a printer 

1 Start the Linux virtual machine and log in when the guest operating system boots up. 

The procedure of adding a printer in a Linux g
distribution. In this example, we describe how

to a Linux virtual machine: 

Note: You must log in as root or acquire root privileges after successful login. If you don't do that, you 
will be required to enter the root password when starting the system-config-printer 
administration tool in the next step. 

2 ter administration tool by doing one of the following: 

tration > Printing; or 

 Start the system-config-prin

• Click System > Adminis

• Start the Terminal and enter the following command: 
system-config-printer 

3 In the displayed window, click New Printer. 

4 In the next window, you must type a printer n
in your Linux guest operating system. You can al

ame. Under this name the printer will be displayed 
so enter the printer description and location. 

ill be shared with the virtual machine. As the 
 

ard. 

t printer you have, choose 

achine. 

When ready, click Forward. 

5 Now you have to specify how your Mac printer w
printer is connected to the virtual machine printer port, select LPT #1 (or another port to which
the printer is connected) and click Forw

6 Then specify the printer manufacturer and model. No matter wha
either HP Color LaserJet 8500 PS or Apple Color LW 12/660 PS. When ready, click Forward. 

7 Click Apply to finish setting up the printer. 

Now the printer is properly configured and you can use it to print documents from your Linux 
virtual m
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Set Up a Printer Using Bonjour 

If you have more than one Mac connected to your home network, you can use Apple Bonjour for 
Windows to share any printer connected to any of them. 

To see the list of all Windows operating systems supported by Bonjour, please refer to 
http://support.apple.com/kb/dl999. 

Important: To share a Mac printer with Windows via Apple Bonjour, Windows must be configured to 
work in the Bridged networking mode. 

To set up a printer via Bonjour: 

1 Be sure the printer you want to use is set to be shared on your Mac. To share a printer, in Mac 
OS X choose Apple menu >  System Preferences and click Print & Fax. Then select the 
printer and select Share this printer. 

2 Open Parallels Desktop and start Windows. 

3 When Windows starts, go to  http://support.apple.com/kb/dl99  and download the Bonjour for 
Windows installation package. 

 file from 

6 lecting 

7 nters window, select the printer that you want to use and click 

een successfully 
configured. Click Finish and you can start using the newly added printer to print documents 
from Windows programs. 

However, if the next window you see is Install Bonjour Printer, you must choose the printer 
manufacturer and model. 

9

4 In Windows, start the Bonjour installation by launching the BonjourPSSetup.exe
the folder in which it was downloaded. 

5 Follow the onscreen instructions to install Bonjour for Windows. 

Start the Bonjour Printer wizard either by double-clicking its icon on the desktop or by se
Start -> All Programs -> Bonjour Print Services -> Bonjour Printer Wizard. 

In the Browse for Bonjour Pri
Next. 

8 If the next window you see is Completing the Bonjour Printer Wizard, then the driver required 
by this printer is available in the Windows driver library and the printer has b
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If the required printer model is not listed, you can do one of the following: 

 button in the Install Bonjour 
ated in the folder where you 

he 
ndows programs. 

 

• Install the printer drivers in Windows. Then click Have Disk
Printer window and specify the path to the .inf file loc
installed the printer drivers. 

• In the Install Bonjour Printer window, select Generic in the Manufacturer list and 
Generic/Postscript in the Model list. 

Click Next. 

9 In the Completing the Bonjour Printer Wizard window, click Finish. You can start using t
newly added printer to print documents from Wi
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ac can access the Internet. 

 work in either the Shared networking mode or Bridged networking 

• ccess the network printer. 

er. 

appropriate printer driver. For 

 or Windows Vista: 

 and Sound and click Add a printer in the 

CP/IP address window, select Add a printer using a 

t TCP/IP Device from the Device type menu. 

lect the driver to use option if it is 

Set Up a Network Printer 

You can install a network printer directly into Windows. 

Before installing a network printer in Windows, make sure that: 

• Your M

• Windows is configured to
mode and can access the Internet too. 

 The user account in Windows has permission to a

• You know the printer IP address. 

After that, you can log in to Windows and install a network print

In Windows 

Before adding a network printer in Windows, download and install an 
detailed information on installing the printer driver, refer to the printer manufacturer documentation. 

To add a network printer in Windows 7

1 Open the Windows Start menu and select Control Panel. 

2 In the Control Panel window, select Hardware
Devices and Printers section (Printers in Windows Vista). The Add Printer wizard opens. 

3 In the first window, click Add a network, wireless or Bluetooth printer. 

4 In the next window, click The printer that I want isn't listed. 

5 In the Find a printer by name or T
TCP/IP address or hostname and click Next. 

6 In the Type a printer hostname or IP address window, do the following: 

1. Selec

2. Specify the printer IP address in the Hostname or IP address field. 

3. Clear the Query the printer and automatically se
selected. 

4. When ready, click Next. 
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ork 

If the required printer model is not listed, click Have Disk button and specify the path to the 
er. 

When ready, click Next. 

configuration procedure. When the printer is added to Windows, you 
nts from Windows XP. 

4 I

inter option if it is also 

Port window, select Create a new port and specify Standard TCP/IP 

tandard TCP/IP Printer Port Wizard window, click Next. 

ify the network printer IP address and click Next. 

k 

10 rinter Port Wizard window, click Finish. 

 

 located in the folder where you installed the printer driver. 

 n procedure. When the printer is added to Windows, you 

In Linux 

7 If prompted to specify additional port information, choose Standard, select Generic Netw
Card from the list, and click Next. 

8 In the Install Printer Software window, specify the manufacturer and model of the network 
printer. 

.inf file located in the folder where you installed the printer driv

9 Continue with the printer 
can use it to print docume

To add a network printer in Windows XP: 

1 Open the Windows Start menu and select Control Panel. 

2 In the Control Panel window, double-click the Printers and Faxes item. 

3 Click the Add a printer link to open the Add Printer wizard. 

n the Welcome to the Add Printer Wizard window, click Next. 

5 In the Local or Network Printer window, select Local printer attached to this computer and 
clear the Automatically detect and install my Plug and Play pr
selected. When ready, click Next. 

6 In the Select a Printer 
Port as the port type. When ready, click Next. 

7 In the Welcome to the Add S

8 In the Add Port window, spec

9 If prompted to specify additional port information, choose Standard, select Generic Networ
Card from the list, and click Next. 

In the Completing the Add Standard TCP/IP P

11 In the Install Printer Software window, specify the manufacturer and model of the network 
printer. 

If the required printer model is not listed, click Have Disk button and specify the path to the 
 file.inf

When ready, click Next. 

12 Continue with the printer configuratio
can use it to print documents from Windows XP. 
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ne running RHEL 5.4 Server. However, you can use these 
uctions on how to set up a network printer in a Linux or FreeBSD virtual 

The procedure of setting up a network printer in a Linux or FreeBSD guest operating system 
depends on the Linux or FreeBSD distribution and printer. In this example, we describe how to set 
up a network printer in a virtual machi
guidelines as general instr
machine. 

Note: For more detailed information, refer to the CUPS documentation. 

To set up a network printer: 

1 Start the virtual machine. 

talled in the guest operating system: 

UPS). Installation instructions can be found at CUPS site; 

2 Make sure the following components are ins

• Common UNIX Printing System (C

• Samba service. Installation instructions can be found at Samba site; and 

• A Web browser, since we consider controlling CUPS via web interface. 

Note: To set up a network printer, you should have root privileges. 

3 Download and install an appropriate printer driver. For detailed information on installing the 

Terminal, type the command: 

printer driver, refer to the printer manufacturer's documentation. 

4 Start Common UNIX Printing System. In the 
/etc/init.d/cups start 

5 Start a web browser and type either the IP address of your virtual machine or 
http://127.0.0.1:631. 

6 Click the Add Printer button. 

7 In the Add New Printer window, specify a printer name. Under th
displayed in the guest operating system. You can also enter the p

is name the printer will be 
rinter description and location. 

When ready, click Forward. 

8 In the Device for <Printer Name> window, select AppSocket/HP JetDirect and click 
Continue. 

9 In the Device URI for <Printer Name> window, specify the printer IP address in the following 
format: 

socket://<printer IP address> 

When ready, click Continue. 

10 In the Make/Manufacturer for <Printer Name> window, select the manufacturer of your 
printer and click Continue. 

11 In the Model/Driver for <Printer Name> window, select the model of your printer and click 
Add Printer. 

12 Enter the root password when prompted. 
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CUPS performs the installation. If the installation is successful, the "Printer <name> has been 
r to print 

Set Up a USB Printer 

 Windows. In this case, the printer isn't available to Mac 
OS X. If you want to use the printer to print both from Mac OS X and from Windows, see Share a 

1 In Parallels Desktop, start Windows. 

on on how to do that, refer 
to the printer manufacturer's documentation. Typically you can find drivers on the 
manufacture's website. 

• If Windows is in Coherence, click the Parallels icon

configured successfully" message is displayed. Now you can use this printe
documents from the virtual machine. 
 

You can connect a USB printer directly to

Mac Printer (p. 86). 

To connect a USB printer directly to Windows: 

 

2 When Windows starts, install the printer driver. For detailed informati

3 Do one of the following: 

• If the USB printer is already connected to your Mac: 

  in the menu bar, choose Devices > 
inter from the list. USB and select this pr

• If Windows is working in a separate window, click the USB controller icon  in the 

• If th is not connected to your Mac, connect it. In the New USB device detected 

re wizard instructions. 

Windows status bar and select this printer from the list. 

e USB printer 
window, connect the printer to Windows. 

4 In Windows, follow the Add New Hardwa
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amera or Another 

bcam, 

To use a built-in iSight or external camera with Windows: 

ble to select the iSight or 

Use the Built-in iSight C
Webcam 
If your Mac or display has a built-in iSight camera, or if you connect a compatible external we
by default you can use it with Windows.  

• Simply open a Windows program that uses a camera, you should be a
external camera for use with the program. 

Note: If you are running a guest OS other than Windows XP Service Pack 2 or later, Windows Vista, or 
Wi B video device class (UVC) drivers installed. ndows 7, be sure you have US

Disable Camera Sharing 

ms or the built-in iSight 
camera, you can disable camera sharing by doing the following: 

1  Do one of the following: 

If you don't want Windows programs to be able use connected webca

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 

2 Click Hardware and click USB Controller. 

 

Protect Your Data 
You probabl uments, photos, and more on your Mac. When running Windows 

 your data from viruses and unauthorized use. Read 

 

> Configure. 

3 Deselect Share camera with Windows. 

y have important doc
on your Mac, it's especially important to protect
this section to learn how. 
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n for 

ac. When the trial periods expire, you can purchase 
permanent activation keys. 

spersky Internet Security for Windows 

1 

2 

Protect Your Data from Viruses 

Parallels Desktop offers complementary 90-day subscriptions to Kaspersky antivirus protectio
both Mac OS X and Windows.  

To take advantage of these offers, you download and install Kaspersky Internet Security for 
Windows and Kaspersky Anti-Virus for M

Download and Install Ka

Open Parallels Desktop and start Windows. 

If Parallels Desktop is set to Coherence mode, click the Parallels icon  in the menu bar and 
ch ose Exit Coheo rence.  

arallels Internet Security.  

5 After the installation is complete, click Reboot. Windows restarts. 

3 Choose Virtual Machine > Install P

4 Click Install. 

Your free 90-day trial of Kaspersky Internet Security begins. 

Note: Kaspersky Internet Security for Windows is supported by Windows 7, Vista and XP only. Parallels 
Tools must be installed (p. 196). In most cases, Parallels Tools are installed by default. 

Remove Kaspersky Antivirus from Windows 

To e it like any other Windows application. 

or Mac 

lick the Parallels icon 

remove Kaspersky Internet Security, remov

Download and Install Kaspersky Anti-Virus f

1 If Parallels Desktop is set to Coherence mode, c  in the menu bar and 

3 istrator user name and password. 

. 

aspersky Anti-Virus for Mac 

Choose Uninstall Kaspersky for Mac from the File menu, enter your administrator credentials, 
and wait until uninstall is complete. 
 

choose Exit Coherence.  

2 Choose File > Install Kaspersky for Mac. 

When prompted, enter your admin

4 Once the installation is complete, activate the trial version of the software

Your free 90-day trial of Kaspersky Anti-Virus for Mac begins. 

Remove K
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ws 

ected external devices are no longer automatically accessible by Windows, and 
een Windows and Mac OS X. Isolating Mac OS X 

 higher level of security by not allowing compromised items from one 

Isolate Mac OS X from Windo

You can isolate Mac OS X from Windows, so that they no longer share folders, profiles, and 
applications, conn
you can no longer copy or move objects betw
from Windows may provide a
OS to come into contact with the other. 

To isolate Mac OS X from Windows 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 

2 

3 e ws. 
 

Work in Windows Without Saving Changes 

If you don't want Windows to store the changes you make to it during the working session (for 
example, when testing some Windows programs that may damage Windows), you can start 
Windows in Safe Mode: 

1 Open Parallels Desktop. 

2 From the Parallels Virtual Machines list select Windows that you want to start in Safe Mode 
and click Virtual Machine > Safe Mode. 

Set Windows to Always Start in Safe Mode 

If you want Windows to always start in Safe Mode: 

1 Open Parallels Desktop. 

2 From the Parallels Virtual Machines list select Windows and click Virtual Machine > 
Configure > Options > Security. 

3 Choose Ask me what to do from the Undo Disks menu and click OK. 

> Configure. 

Click Options and select Security. 

S lect Isolate Mac from Windo

Note: If you have the automatic compression of virtual disks (p. 106) enabled, it will become disabled 
after you enable Undo Disks. 
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rform 

• Option-click (Alt-click) the Parallels icon

Set Password Requirements 

For added security, you can set Parallels Desktop to require an administrator password to pe
certain functions. 

1 Do one of the following: 

  in the menu bar and choose Configure. 

creen, choose Virtual Machine 

3 Select one or more of the following to require a Mac OS X administrator password to perform 

• Exit full screen mode: A password is required to exit full screen mode (p. 55). 

ine state: A password is required to start, stop, suspend, pause, or 
ws. 

pshot (p. 126), or 

• If the Parallels Desktop menu bar is visible at the top of the s
> Configure. 

2  Click Options and select Security. 

the selected action: 

• Change virtual mach
shut down (p. 47) Windo

• Manage snapshots: A password is required to create or delete a sna
revert to a snapshot. 
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If you store any important data using Windows programs, it is highly recommended that you 

ions > Security. 

 In the Security pane, click Turn On, specify a password, and click OK. 

Encrypt Windows to Protect It from Unauthorized Use

encrypt Windows to protect your data from any unauthorized use. 

Encrypt Windows 

To encrypt Windows (it must be shut down): 

1 Select Windows and click Virtual Machine > Configure > Opt

2

Warning: The specified password is very important. You must record it. Without this password, 
you can't start Windows. 

Change Your Password 

To change the password for an encrypted Windows (it must be shut down): 

2 In the Security pane, click Change Password, specify a new password, and click OK. 

To remove encryption from Windows (it must be shut down): 

2 In the Security pane, click Turn Off. 
 

1 Select Windows and click Virtual Machine > Configure > Options > Security. 

Remove Encryption from Windows 

1 Select  Windows and click Virtual Machine > Configure > Options > Security. 
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r

 Shared Networking: Windows programs share a network connection with Mac OS X. This is 

ows can use one of your Mac's network adapters. This makes 

n't need to adjust network settings. If your Mac is set to connect to a 
 have access to the same network and the Internet. 

istrator to set it up properly. 

Rea
 

Sh

 of your 
Mac. Windows does not have its own IP address on the network.  

t to connect to a 

Connect to the Internet or a Network 
Pa allels Desktop allows you to use three types of networking with Windows: 

•
the default setting. 

• Bridged Ethernet: Wind
Windows appear as a separate computer on the network. 

H• ost-only networking: Windows can access only your Mac. 

In most cases, you do
network or to the Internet, Windows programs

The Bridged Ethernet networking mode is more complex and you may need to contact your 
system admin

d on for detailed information on these types of networking and how to configure them. 

are Network Settings Between Mac OS X and Windows 

By default, Windows is set to share network settings with Mac OS X. Windows programs can 
access other computers on your local network and the Internet by using the IP address

In most cases, you don't need to adjust network settings. If your Mac is se
network or to the Internet, Windows programs have access to the same network and the Internet. 
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ses: 

nternet via a modem or another non-Ethernet device. 

 

s to use Shared Networking: 

1 Do one of the following: 

You may wish to use Shared Network mode in the following ca

• Your Mac accesses the I

• You need to access the Internet from inside Windows but are concerned about security.

• You have problems with working in the Bridged Ethernet mode. 

To configure Window

 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 C

3 I
s

lick Hardware and then click Network. 

n the Network pane, make sure that the Connected and Shared Network options are 
elected. 

Note: In the MAC address field, you can change the MAC address currently assigned to Windows. 
MAC addresses are automatically generated when you first set up Windows on your Mac. However, you 
can modify the default MAC address by typing another value in the MAC address field or clicking the 
Generate button. When entering a new MAC address, make sure that it is unique within your network. 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
llels website. 

one 
 

base http://kb.parallels.com/ available at the Para
 

Apply Separate Network Settings to Windows 

When operating in the Bridged Ethernet mode, Windows appears on the network as a stand-al
computer with its own IP address and network name.

Note: The Bridged Ethernet networking mode is more complex than the Shared Networking mode and 
you may need to contact your system administrator to configure it properly. 
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 mode: To configure Windows to work in the Bridged Ethernet

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

2 Click Hardware and then click Network. 

3 In the Network pane, make sure that the Connected option is selected. 

Select the4  appropriate network adapter from the list. To connect the virtual machine's adapter 
to the active network adapter of your Mac, choose Default Adapter. 

Note: In the MAC address field, you can change the MAC address currently assigned to Windows. 
MAC addresses are automatically generated when you first set up Windows. However, you can modify 
the default MAC address by typing another value in the MAC address field or clicking the Generate 
button. When entering a new MAC address, make sure that it is unique within your network. 

If you can't configure Windows to function in the Bridged Ethernet mode, consider using Shared 
Networking or Host-Only Networking. 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
base http://kb.parallels.com/ available at the Parallels website. 
 

Use Host-Only Network Settings 

Parallels Desktop provides a closed network that is accessible only to Mac OS X and Windows. 
Mac OS X is connected to this network via the Parallels Host-Only Networking adapter 
automatically created on your Mac during the Parallels Desktop installation. The addresses for 
Windows are provided by the Parallels DHCP server. 
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nly Networking: 

1 Do one of the following: 

To configure Windows to use Host-O

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 

3 In the Network pane, make sure that the Connected and Host-Only Network options are 

> Configure. 

2 Click Hardware and then click Network. 

selected. 

Note: In the MAC address field, you can change the MAC address currently assigned to Windows. 
MAC addresses are automatically generated when you first set up Windows. However, you can modify 
the default MAC address by typing another value in the MAC address field or clicking the Generate 
button. When entering a new MAC address, make sure that it is unique within your network. 

For the information hooting networking problems, refer to the Parallels knowledge 
llels website. 

about troubles
base http://kb.parallels.com/ available at the Para
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If your Mac is already connected to the Internet wirelessly, by default Windows is also set to access 

If you change your network setup, you can reconfigure a Wi-Fi connection using the Bridged 
he network as a stand-alone 

Use Wi-Fi with Windows 

the Internet wirelessly, with no setup required. 

Ethernet mode, When operating in this mode, Windows appears on t
computer with its own IP address and network name. 

To configure Windows to access the Internet through Wi-Fi: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine
> Configure. 

 

ion is selected. 

ws is able to connect to the Internet through the AirPort 

If you can't configure your virtual machine to function in the Bridged Ethernet mode, consider using 
Shared Networking or Host-Only Networking. 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
base http://kb.parallels.com/ available at the Parallels website. 
 

Connect Windows to a VLAN 

If your Mac is a VLAN (virtual local area network) member, Parallels Desktop allows you to bridge 
Windows to this VLAN. 

To bridge Windows to the VLAN, do one of the following: 

• Option-click (Alt-click) the Parallels icon

2 Click Hardware and then click Network. 

3 In the Network pane, make sure that the Connected opt

4 Choose AirPort from the list. 

After you perform these steps, Windo
adapter of your Mac. 

  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 
> Configure. 

5 Click Hardware and then click Network. 

6 Select Bridged Network > VLAN from the Type list and make sure the Connected option is 
enabled. 

Windows is bridged to the selected VLAN. 
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Optimize Performance 
If W
its performa  helpful instructions for doing just that. 

s section to find out how you can tune Windows for speed. 
 

OS X may 
low down, which in turn can cause Windows programs to slow down because they're running on 
p of Mac OS X. If, on the other hand, too much memory is allocated to Mac OS X, then Mac OS 

X applications may run well but Windows programs might slow down.  

To optimize the performance of both Windows and Mac OS X, set the memory allocated to 
Windows to be somewhere within the recommended range. 

To set how much memory is allocated to Windows: 

1 Shut down Windows (p. 47). 

2 Choose Virtual Machine > Configure, and then click General. 

indows isn't working as speedily as you'd like, there are several simple ways you can optimize 
nce. This section contains many

Read thi

Set How Much Memory is Allocated to Windows 

Parallels Desktop is set to allocate a certain amount of your Mac's available RAM memory to 
Windows and the rest to Mac OS X. If too much memory is allocated to Windows, Mac 
s
to
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3 Move the memory slider to somewhere within the recommended range, indicated by the 
 above). 

uire lots of memory, like 3D or video production 
the right side of the range. If not, set it somewhere in the 

ing, then try a different 

 
graphic under the slider (see

4 If you use Windows programs that req
programs, move the slider towards 
middle or to the right. 

If you change this setting and then you don't like how Windows is perform
setting. 

Note: If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in any 
pane of Virtual Machine Configuration, an administrator's password will be required. 

 
 



106 
 

Use Windows on Your Mac 
 

• r speedier performance or more graphical features 

lick) the Parallels icon

Optimization Settings 

Using Optimization settings, you can: 

• Optimize performance for either Mac OS X applications or Windows programs  

Tune Windows fo

• If you're using a MacBook or other portable computer, optimize your computer for better 
battery life or higher performance 

• Conserve disk space 

To access Optimization  settings: 

1 Do one of the following: 

• Option-click (Alt-c   in the menu bar and choose Configure. 

 If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 

ion. 

•
> Configure. 

2 Click Options and select Optimizat
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 the Performance menu: 

's resources are given to Windows. The 

: More of your computer's resources are given to Mac OS X. The performance of 
, but Windows programs may slow down. 

T
d  on which application or program you're working with at the moment: 

• Select Enable Adaptive Hypervisor. When you're using a Windows program, more resources 
 resources are 

dier Performance 

are disabled. 

her Performance 

d options: 

• Longer battery life: If you have a portable Mac that you often use unplugged, you can choose 

Optimize Performance for Mac OS X Applications or Windows Programs 

Choose one of the following from

• Faster virtual machine: More of your computer
performance of Windows programs may be increased significantly, but Mac OS X applications 
may slow down. 

• Faster Mac
Mac OS X applications may be increased significantly

o set Parallels Desktop to automatically optimize performance for Mac OS X or Windows 
epending

are given to Windows, and when you're using a Mac OS X application, more
given to Mac OS X. 

Tune Windows for Spee

• Select Tune Windows for speed. 

Some Windows features that tend to slow down performance, such as animations during startup, 

Optimize your MacBook for Longer Battery Life or Hig

The Power menu contains the power and performance relate

this option to lower power consumption for longer battery life. This may slightly reduce 
Windows performance. 

• Better performance: This option (selected by default) maximizes Windows performance, but 
uses more power. 

Note: If you change options in the Power menu when Windows is running, you must shut down 
Windows and start it again for the changes to take effect. 

To show battery status in Windows: 

• Select Show battery in Windows. 

When your MacBook or other portable computer is running on battery power, the battery status is 

Automatically Conserve Disk Space 

displayed in the menu bar. 
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expands as you add files and 
Desktop to automatically 

reduce disk space periodically: 

sktop reviews disk space. If unused space takes up more than 50 percent 
eed up for your use. 

k space manually (p. 185). 

In most cases, the space that Windows takes up on your hard disk 
other data, but isn't reduced when you delete data. To set Parallels 

• Select Automatically compress virtual disks. 

Twice a day, Parallels De
of the Windows hard disk image size, the disk space is fr

You can also free up hard dis

Note: Compressing can be done only if you haven't saved a snapshot and if the Undo disks option is 
disabled. 

 

nce on a MacBook Pro 

Som ave two video adapters. By default, the slower video adapter 
hat saves energy is used.  

To use the faster video adapter for better 3D graphics performance: 

1 In the Mac OS X Finder, select Apple menu > System Preferences and click Energy Saver. 

2 Click Higher performance. 

Setting graphics to higher performance uses battery life faster. 
 

Speed Up Games and Graphics Programs 

With Parallels Desktop, you can run games and programs that require video cards with DirectX or 
OpenGL support. To do so, you must enable 3D acceleration. 

For information on whether a program requires DirectX or OpenGL support, see the materials that 
came with the game or program. 

To enable 3D acceleration: 

1 Shut down the virtual machine. (p. 47) 

2 Open the Virtual Machine menu and choose Configure. 

3 In the Video pane, select Enable 3D acceleration. 

Optimize 3D Graphics Performa

e new MacBook Pro computers h
t

Note: Parallels Tools must be installed (p. 196) before you can enable 3D acceleration. Parallels Tools 
are installed by default when you set up Windows. 
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erve your computer's resources by setting Windows to pause automatically when no 
grams are open. That way, more resources such as RAM and CPU can be used for 

Mac OS X applications. 

e when no programs are open: 

g: 

Pause Windows When No Programs Are Open 

You can cons
Windows pro

To set Windows to paus

1 Do one of the followin

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

ible at the top of the screen, choose Virtual Machine 

s. 

s selected, and then select Pause Windows 
pplications are open. 

• If the Parallels Desktop menu bar is vis
> Configure. 

2 Click Options and select Application

3 Be sure Share Windows applications with Mac i
when no a

 



110 
 

Use Windows on Your Mac 
 

Use Windows on Your iPad, iPhone, or iPod 

ol Windows remotely from your iPad, 

Par

Use any of your Windows programs on your iPad, iPhone, or iPod touch 

• s 

Internet 

fo

hone, or iPod touch, download and install Parallels Mobile from the App Store. 

 the following: 

• Option-click (Alt-click) the Parallels icon

touch 
You can use the free Parallels Mobile app to access and contr
iPhone, or iPod touch. 

allels Mobile lets you: 

• 

 Remotely start, stop, and reset Window

• Connect over Wi-Fi or 3G 

• Access Windows from anywhere over the 

Get Started 

Be re you can use Parallels Mobile, you must do the following: 

1 Be sure you have registered to use Parallels Desktop (p. 13). 

2 On your iPad, iP

3 Be sure you have installed Windows on your Mac (p. 21). 

4 In Parallels Desktop, do one of

  in the menu bar and choose Preferences. 

se Parallels Desktop > Preferences. 

il and password you used to register Parallels 

Your Mac must be on for Parallels Mobile to access and use Windows. 

2 Open Parallels Mobile on your iPad, iPhone, or iPod touch and log in to your account using the 
same email and password you used to register Parallels Desktop. 

3 Tap your Mac in the list of available Macs. 

When you access Windows for the first time, you see tips about gestures you can use to control 
Windows. Tap Close to go to the Windows desktop. 

• If Windows is running in Window mode (p. 55), choo

5 Click Mobile. 

6 Log in to your Parallels account using the ema
Desktop. 

You only have to do these steps once. 

Access Windows from your iPad, iPhone, or iPod touch 

1 Turn on your Mac. 
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et and 
irectly to your Mac for a faster experience. 

1 In Parallels Desktop on your Mac, do one of the following: 

 Option-click (Alt-click) the Parallels icon

Connect Directly to Your Mac for a Faster Experience 

If your Mac and your iOS device are on the same Wi-Fi network, you can bypass the Intern
connect your device d

 

 •  in the menu bar and choose Preferences. 

• Window mode (p. 55), choose Parallels Desktop > Preferences. 

2 

3 n the 

roll down and tap Parallels. 

5 

6 

8  from the Mobile preferences pane. 

9 E

10 T

r more information about using Parallels Mobile, see the Parallels Mobile Quick Start guide, 
available on the Parallels website. 
 

Save a Picture of the Screen 
To save a picture of Windows in Window Mode: 

• Choose View > Make Screenshot. 

A file named Parallels Picture.png is saved on the Mac OS X desktop. 

You can also take a picture of the entire screen at any time by pressing Command-Shift-3. By 
default, pictures are saved to the Mac OS X desktop. 
 

 If Windows is running in 

Click Mobile. 

Make sure Connect Parallels Mobile directly to my Mac is selected, and then write dow
IP Address listed under the checkbox. 

4 On your iOS device, open the Settings app, and then sc

Be sure Direct Connection is turned on. 

Press the Home button and then open Parallels Mobile on your iOS device. 

7 Tap Direct and tap the plus (+) icon. 

Enter a name for your Mac and enter the IP address

nter the user name and password you use for your Mac (your login password). 

ap Connect. 

Fo
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Set the Appearance of the Parallels Desktop 

You can choose which type of icon appears in the Mac OS X Dock when Parallels Desktop is open. 

t-click) the Parallels icon

Dock Icon 

1 Do one of the following: 

• Option-click (Al   in the menu bar and choose Preferences, and 
l. 

• menu bar is visible at the top of the screen, choose Parallels 

dows.  

, select 

then click Genera

 If the Parallels Desktop 
Desktop > Preferences, and then click General. 

2 From the Dock Icon menu, choose one of the following: 

• Live Screenshot: The Dock icon shows a miniature image of what you see in Win

• Parallels Desktop: The Dock icon appears as a static Parallels Desktop symbol. 

3 To set whether the icon appears as a Windows Start button when in Coherence mode
or deselect Use Start button icon in Coherence. 

Note: No matter which type of Dock icon you choose, clicking the icon when in Coherence mode 
displays the Windows Start menu. 
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with Virtual Machines 
ction for basic information about working with virtual machi es. 

C H A P T E R  5  

and virtual

In This Chapter 

Use Other Operating Systems on Yo
Install or Update Parallels Tools ..... ..
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Remove Parallels Desktop
Advanced Preferences .............................................................................................
Adding and Removing Devic
Hardware Settings....................................................................................................
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Supported Guest Operating Systems 

 guest operating systems can be installed in Parallels Desktop virtual machines. 

32-bit 64-bit 
xpress 

Installatio
 

Any of the following

 E

n

Windows 

Windows 7    

Windows Server® 2008 SP0, SP1, SP2, R2    

Windows Vista® Home, Business, Ultimate, Enterprise SP0, SP1, SP2    

Windows Server® 2003 SP0, SP1, SP2, R2    

Windows XP Home SP0, SP1, SP2, SP3    

Windows XP Professional SP0, SP1, SP2, SP3    

Windows XP Professional SP2    

Windows 2000 Professional SP4    

P4    Windows 2000 Server S

Windows NT 4.0 Server SP6, Workstation SP6    

Windows ME    

Windows 98 SE    

Windows 95    

Windows 3.11    

MS-DOS 6.22    

Linux 

Ubuntu® Linux 8.10, 9.04, 9.10, 10.04, 10.10    

Red Hat® Enterprise Linux 5.x, 6    

Red Hat Enterprise Linux 4.x    

CentOS Linux 5.x    

CentOS Linux 4.x    

Fedora™ Linux 12, 13, 14    

SUSE® Linux Enterprise Server 11, 10 SP2, Desktop 11    

OpenSUSE Linux 11.x    

Mandriva™ Linux 2009, 2010    
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Debian® Linux 5.0    

Mac OS 

Mac OS X Lion 10.7.x    

Mac OS X Lion Server 10.7.x    

Mac OS X Snow Leopard Server 10.6.x    

Mac OS X Leopard Server 10.5.x    

Chrome 

Chrome OS    

Solaris 

Open Solaris 2009.06    

Solaris® 10    

BSD 

FreeBSD® 7.x, 8.x    

OS/2 

OS/2® Warp 4.5, 4    

eComStation™ 1.2    

Please note that Paralle ktop s not system insta or their 
hould pur  the eparat

 

ows or ano  opera  syste top creates a "virtual 
r a virtual copy of a computer, insid your Mac. You can then install Windows in the 
ne, just as you would install an operating system on a egular mputer. 

Many use Parallels Desktop to create one virtual machine and install Windows in it. But you can 
y virtual m ines as u like, stall a different o erating ystem  each of them. 

an use m e op g sys gether at the same time on your Mac. And just 
like with a regular computer, you can turn virtual machines on and ff, con ure the , and install 

ls Des  doe  include operating llation discs 
images. You s chase m s ely. 

About Virtual Machines 

To add Wind ther ting m to your Mac, Parallels Desk
machine," o
virtual machi

e 
 r co

install as man ach  yo and in p  s  in
That way you c ultipl eratin tems to

 o fig m
and use programs. 
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figura s 

A typical virtual machine has the following basic virtual hardware: CPU, memory, hard disk drive, 
nd e, C VD dr ork a apter, U B controller, serial port, printer 
e p  set a e defa ac OS  

Default Con tion

floppy disk drive, sou  devic D/D ive, netw d S
port connected to th rinter s th ult in M .

Note: Apart from the ba ar ou can ces to your virtual m chine using the Virtual sic hardw e, y add new devi a
Machine Configuration di g (p. 169alo ). 

The amount of memory  the s f hard ent guest O s. Refer to the table 
the memory and hard disk values ne depending 

on the guest operating sy that will be insta  in it. V ual har  disks f r typical virtual 
always cr  in th pandi at (p. 2). 

 and ize o  disks vary for differ S
below to learn that are allocated to a virtual machi

lledstem irt d o
machines are eated e ex ng form 17

Guest Operating systems Memory, 
MB 

Video 
Memory, 
MB 

Hard 
Disk, M

NetworFloppy  CD/DV Sound 
k B Drive Device D Drive  
Adapter 

Mac OS X 1024   32 64,000    

Windows 7 1024 256  64,000     

Windows Server 2008 1024 128 64,000     

Windows Vista 1024 256 64,000     

Windows XP   1024 256 64,000     

Windows 2003 1024 64 64,000     

Windows 2000   256 256 64,000     

Windows ME 256 32 8,000     

Windows NT 256 32 4,000     

Windows 98 256 32 8,000     

Windows 95 128 32 2,000     

Windows 3.11 64 32 2,000     

Other Windows 1024 128 64,000     

Red 64,000  Hat Enterprise Linux 1024 32     

SUSE Linux Enterprise 1024 32 64,000     

Debian GNU/Linux 1024 32 64,000     

Ubuntu Linux 1024 32 64,000     

Fedora Linux 1024 32 64,000     

CentOS Linux 1024 32 64,000     
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OpenSUSE Linux 1024 32 64,000     

Mandriva Linux 1024 32 64,000     

Other Linux kernel 2.6 1024 32 64,000     

Other Linux kernel 2.4 1024 32 64,000     

Other Linux 1024 32 64,000     

FreeBSD 8.x 256 32 64,000     

Free 0BSD 7.x 256 32 64,0 0     

Other FreeBSD 256 32 64,000     

OS/2 Warp 4.5 256 32 2,000     

OS/2 Warp 4 128 32 2,000     

eComStation 1.2 256 32 2,000     

Other OS/2 128 32 2,000     

MS-DOS 6.22 64 32 2,000     

Other DOS 32 32 2,000     

Solaris 10 1024 32 64,000     

OpenSolaris 256 32 64,000     

Other Solaris 1024 32 64,000     

Other 256 32 8,000     

 
 

Set Where New Virtual Machines Are Stored 

By default, Parallels Desktop stores virtual machines in ~/Documents/Parallels. 

To change the default location for new virtual machine installations: 

1 Do one of the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Preferences, and 
then click General. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences, and then click General. 

2 Choose a location from the Virtual Machines Folder menu. 

All newly created virtual machines are stored in the new location. Any existing virtual machines 
remain in their original locations. 
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 of 

To change the virtual 

1 Do one of the following: 

• n

Change the Virtual Machine Name 

The name of a virtual machine is displayed in the Parallels Virtual Machines list and, at the top
the guest OS window when you are running in Window mode. 

machine name: 

  Option-click (Alt-click) the Parallels ico  in the menu bar and choose Configure. 

oose Virtual Machine 

e in the Name field. 

ope  programs appear on the Mac 
desktop next to your Mac applications. 

• If the Parallels Desktop menu bar is visible at the top of the screen, ch
> Configure. 

2 Click General and type a new nam

The length of the name is limited to 50 characters. 
 

Merge Linux and Mac OS X 

You can set Linux and Mac OS X to work seamlessly together, as if they were part of a single 
rating system. In this mode, called Coherence mode, Linux
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• Parallels Tools must be installed (p. 148). 

. 
 operating system 

• 

ce mode, do one of the following: 

k the View menu and select Exit Full Screen. Then open the 
View menu and select Enter Coherence. 

To enable the Coherence view mode: 

• Disable Linux 3D effects. The way you can do this depends on your Linux distribution. For 
example, in Fedora 14 click System > Preferences > Desktop Effects and select Standard
To learn how to disable Linux 3D effects in other Linux OSs, refer to the
documentation. 

Switch to Coherence Mode 

To switch from Window mode to Coherence mode, do one of the following: 

• Choose View > Enter Coherence. 

Press Control-Command-Return. 

To switch from Full Screen mode to Coheren

• Press Control-Option (Alt), clic

• Move the pointer to the upper-left corner of the screen until the corner peels back and click 
Exit Full Screen. Then choose View > Enter Coherence. 

 
 

If o  you can clone it. A clone is a separate virtual 
 a clone: 

2  

3 ant to store the clone. 

By default, Parallels Desktop stores clones in your Documents > Parallels folder. 

machine. 

Clone a Virtual Machine 

 y u need an exact copy of a virtual machine,
machine fully identical to the original one. To make

1 Start Parallels Desktop. 

In the Parallels Virtual Machines list select the virtual machine you want to clone (it must be
shut down) and choose File > Clone. 

Choose where you w

4 Click Save to start cloning the virtual 
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Back Up a Virtual Machine 

sider regular backups as a necessity until they have experienced a 
significant data loss. You should create your own backup strategy to protect yourself from data 

You can back up your virtual machine using one or several of the following methods: 

s in the Backup pane of the Virtual Machine 
Configuration dialog. 

 third-party backup utilities like Acronis Online Backup (p. 137). 

Con

In th  pane of the Virtual Machine Configuration dialog, you can choose how to back up 
irtual machine snapshots will be created 
e. 

If you choose to back up your virtual machine with Time Machine, your virtual machine's PVM file 
will be automatically backed up together with other files stored in Mac OS. As a consequence, files 
stored on your virtual machine's hard disk will be also backed up, since the virtual hard disk file 
(HDD) is stored inside the virtual machine bundle file (PVM). 

Most people don't seriously con

loss. Virtual machines are as vulnerable to crashes as physical computers. 

• Configure the regular backup setting

• Use

• Clone the virtual machine with the help of Clone Virtual Machine Assistant. Give a descriptive 
name to the clone and save it in a location specially designated for backups. 

• Copy the virtual machine files manually. 

figure Regular Backups 

e Backup
your virtual machine regularly. You can configure how the v
or choose to back up the virtual machine with Time Machin

Warning: Time Machine backups can guarantee safety only when your Parallels virtual machines 
were stopped or suspended during the backup. 

To restore some of your Windows files: 

1 From within the Finder (and not within Time Machine), locate the backup copy of your virtual 
machine's file (PVM) on your backup disk. 

2 Right-click the file, and choose Show Package Contents. 

3 In the virtual machine contents window, right-click the virtual hard disk file (HDD) that is usually 
named <VirtualMachine'sName>.hdd. and choose Open With > Parallels Mounter. 

4 Using Parallels Mounter, browse the contents of your virtual machine's hard disk to find the files 
you need to restore. 

Use Third-Party Backup Utilities 

You can use any third-party backup utilities you like. Registered Parallels Desktop users can use 
Acronis Online Backup (p. 137) to back up their Windows virtual machines. 
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Note: Acronis doesn't support backing up virtual machines that use Boot Camp as their hard disks. 

Clone the Virtual Machine 

You can create a complete clone of the virtual machine using Clone Virtual Machine Assistant. For 

inder and create a backup copy of the virtual machine file 
(PVM). 

Show in 
Finder folder where your virtual machine is stored. 

details, see Clone a Virtual Machine (p. 119). 

Copying the Virtual Machine Files 

You can locate your virtual machine in F

1 In the Parallels Virtual Machines list, right-click the virtual machine name and select 
 from the context menu. In Finder, go to the 

2 Locate the required virtual machine PVM file. 

Note: PVM file is a bundle that contains the virtual machine configuration file (PVS), virtual hard disk file 
(HDD), and other files. For more information about the virtual machine files, see About Virtual Machines 
(p. 115). 

3 C
 

opy the virtual machine's PVM file to a safe location. 
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Br

For
inst

If yo  
des  Windows is running, open Finder, choose Finder > Preferences > General and 
select the 

For can mount their hard disks in Mac OS X Finder 

If yo
mac

 Open the Sharing pane of the Virtual Machine Configuration dialog and enable the Mount 
virtual disks to Mac desktop option. 

owse Virtual Hard Disks in Mac OS X 

 easy access to Windows files, you can mount the virtual hard disk (on which Windows is 
alled) in Mac OS X. 

Mount a Virtual Hard Disk to the Mac OS X Desktop 

u need the virtual hard disk (on which Windows is installed) to be mounted to the Mac OS X
ktop when

Connected servers option. 

easy access to your virtual machines files, you 
together with other disks and storage devices. 

u want your virtual hard disks to be mounted to the Mac OS X desktop when the virtual 
hine is running, perform the following actions: 

1

Note: To be able to edit the settings in the Sharing pane, you must have Parallels Tools (p. 143) 
installed in the virtual machine and the Isolate Mac from Windows option disabled in the Security 
pane. 

2 Open the Finder Preferences, click the General tab and select the Connected servers option 
in the list of items displayed on the desktop. 

If you want to manage the virtual machine content without starting the virtual machine, you can 
mount the virtual hard disks manually using Parallels Mounter: 

1 Browse the virtual machine files in Finder. For Parallels virtual machines, right-click the virtual 
machine name in the Parallels Virtual Machines list and select Show in Finder from the 
context menu. 

The default paths for storing Parallels virtual machines are 
/Users/<UserName>/Documents/Parallels/ and /Users/Shared. 

2 To mount the hard disk of a particular virtual machine, right-click this virtual machine's file and 
choose Open With > Parallels Mounter or Open With > Other > Library > Parallels > 
Parallels Mounter from the shortcut menu. You can mount the following virtual machines and 
hard disks: 

• Parallels bundle (.pvm) or configuration file (.pvs) or virtual hard disk file (.hdd). 

• VMware configuration file (.vmx, .vmwarevm) or virtual hard disk file (.vmdk). 

• Virtual PC configuration file (.vmc, .vpc7) or virtual hard disk file (.vhd). 

• VirtualBox configuration file (.xml) or virtual hard disk file (.vdi). 
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If you choose the PVM file of a Parallels virtual machine or the configuration file of a third-party 
lumes will appear as mounted in 

Finder. 

ar of the Finder 
s. 

lick its icon in the sidebar of the Finder window. 

virtual machine that has several virtual hard disks, all its vo

If you want to mount a single virtual hard disk, double-click the virtual hard disk file to mount it 
with Parallels Mounter. The icon for the selected hard disk appears in the sideb
window, together with other Mac OS X icon

3 To browse the contents of a volume, c

You can manage the virtual machine files just as you manage your Mac OS X files in Finder 
windows. 

Note: If you are browsing the contents of a suspended virtual machine in Finder, you cannot delete, 
move, or otherwise modify its files. 

4 To unmount the volume, use the Eject button  next to the disk icon. 

Note: If a hard disk that has several volumes was mounted and you want to open it or the virtual 
machine using it in Parallels Desktop, you should disconnect its volumes one by one by clicking the 
Eject button. 
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plates 

te templates. Later you can use them to create 
ines. To create a virtual machine template, you can: 

• mplate. 

ne to a template, 
you  a 

e virtual machine and you 

A template, in its turn, can be converted or deployed back to the virtual machine. When you 
convert a template, it turns back to the virtual machine. And when you deploy it, the resulting virtual 
machine appears separately from the template and you can work with both. 

Convert a Virtual Machine to a Template 

To convert a virtual machine to a template: 

1 Start Parallels Desktop. 

2 In the Parallels Virtual Machines list, select the virtual machine you want to convert (it must be 
shut down) and choose File > Convert to Template. 

Convert a Template to the Virtual Machine 

To convert a template back to the virtual machine: 

1 Start Parallels Desktop. 

2 In the Parallels Virtual Machines list, right-click the template you want to convert and choose 
Convert to Virtual Machine. 

Clone a Virtual machine to a Template 

To clone a virtual machine to a template: 

1 Start Parallels Desktop. 

2 In the Parallels Virtual Machines list, select the virtual machine you want to clone (it must be 
shut down) and choose File > Clone to Template. 

3 Choose where you want to store the resulting template. 

By default, Parallels Desktop stores templates in your Documents > Parallels folder. 

4 Click Save to start cloning the virtual machine to the template. 

Create and Use Virtual Machine Tem

On the basis of your virtual machines you can crea
multiple identical virtual mach

• convert a virtual machine to a template; or 

clone a virtual machine to a te

The difference between these two ways is that when you convert a virtual machi
 can't run it until you convert the template back to the virtual machine. And when you clone

virtual machine to a template, the template appears separately from th
can work with both. 
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choose 
Deploy to Virtual Machine. 

Choose where you want to store the resulting virtual machine. 

4
 

Deploy a Template to the Virtual Machine 

To deploy a template back to the virtual machine: 

1 Start Parallels Desktop. 

2 In the Parallels Virtual Machines list, right-click the template you want to deploy and 

3 
By default, Parallels Desktop stores virtual machines in your Documents > Parallels folder. 

 Click Save to start deploying the template to the virtual machine. 
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Save Snapshots of a Virtual Machine 

A snapshot is a saved state of the guest OS. It's useful to create snapshots, for example, before: 

• you're going to run some programs that may damage the guest OS; or 

• if you're going to configure some guest OS software that requires a lot of settings; or 

• if you want to mark milestones in the development process. 

Note: 1. Snapshots cannot be created for Windows virtual machines that use the Boot Camp partition. 

2. If your virtual machine has one or more snapshots, you can neither compress nor resize the virtual 
hard disk. 

If something goes wrong, you can revert the changes back to any of your snapshots and continue 
working with the guest OS. 

Create a Snapshot 

1 Start Parallels Desktop. 

2 In the Parallels Virtual Machines list, select the virtual machine for which you want to create a 
snapshot. 

3 Click Virtual Machine > Manage Snapshots. 

4 Click New, specify the snapshot name and click OK. 

Automate the Creation of Snapshots 

The SmartGuard functionality allows you to automate snapshots creation. 

Note: SmartGuard is available only when the Undo Disks feature is disabled and the virtual machine is 
not running in Safe Mode. 

To access settings for automating snapshots: 

1 Start Parallels Desktop. 

2 In the Parallels Virtual Machines list, select the virtual machine for which you want to create a 
snapshot. 

3 Click Virtual Machine > Configure. 

4 Click Options > Backup. 
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not back up the entire virtual machine, but only 
f data that Time Machine backs up, 

to reduce the time Time Machine spends backing up the virtual hard disk(s), and to minimize 
ime 

e backup. 

• Custom. If you select this option, you will be able to manually set the snapshots frequency and 
maximum number of snapshots to keep. 

If you want to know when it is time to make the next snapshot and to be able to reject the 
snapshot creation, enable the Notify me before snapshot creation option. 

To automate snapshots, click the SmartGuard menu and choose one of the following: 

• Optimize for Time Machine. If you select this option, a snapshot will be taken every 24 hours. 
Time Machine, when backing up your Mac, will 
its latest snapshot. This allows you to reduce the amount o

the risk of data loss or corruption when restoring the virtual machine hard disk(s) from the T
Machin

Note: If you use Time Machine to back up your Mac, you can configure the virtual machine so that Time 
Machine would back up not its whole hard disk but only the changes made since the latest snapshot. 
Choose Optimize for Time Machine and click OK. 

To set how often snapshots are made: 

• Use the Take a Snapshot Every field. You can set from one to 48 hours. 

If the time interval is less than 24 hours, SmartGuard will allow you to restore the latest hourly, daily 
and weekly snapshot. If the time interval is more than 24 hours, you will be able to restore the latest 
daily, weekly and monthly snapshot. 

To limit how many snapshots are stored: 

• Use the Snapshots to Keep field to set the maximum number of snapshots that can be stored 
on your Mac. 

The maximum available value is 100 snapshots. As soon as Snapshots Manager reaches the limit 
for snapshots and needs to make a new one over limit, it deletes the oldest snapshot. 

Revert to a Snapshot 

To revert to a snapshot: 

1 Start Parallels Desktop. 

2 In the Parallels Virtual Machines list, select the virtual machine that you want to revert. 

3 Click Virtual Machine > Manage Snapshots. 

4 Select the snapshot to which you want to revert and click Go To. 

Delete a Snapshot 

To delete a snapshot: 

1 Start Parallels Desktop. 
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2 In the Parallels Virtual Machines list, select the virtual machine which snapshot you want to 

want to delete and click Delete. 

xt 
snapshot. 

 
delete. 

3 Click Virtual Machine > Manage Snapshots. 

4 Select the snapshot you 

When you delete an intermediate snapshot, the information it contains is merged into the ne
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Parallels Desktop allows you to connect or disconnect certain devices at runtime or switch some of 

VD-ROM drives 

Shared folders 

resent in the virtual machine configuration, you can also manage 

•  the Devices menu in the menu bar. This menu is available 

atus bar and choose the command from a device shortcut menu. 

The status bar displays the devices information when the virtual machine is running. 

•  shared folder on the appropriate device icon in the status 

Connecting a CD/DVD-ROM or a Floppy Drive 

es connected to your virtual machine, in the Devices menu 
ey are listed in the same order as they were connected. The first CD/DVD-ROM drive will be 

onnecting a Network Adapter 

You can set up any of the three network modes: Shared Networking, Bridged Networking, or Host-
Only Networking. 

Connecting a Sound Device 

To connect or disconnect a sound device, choose the Activate or Mute options respectively. You 
can also choose the type of output and input devices. 

Connecting a USB Device 

Change Virtual Machine Configuration at Runtime 

them for using other media. 

Generally, the following virtual devices can be connected or disconnected at runtime: 

• Floppy disk drive 

• CD/D

• Network adapter 

• Sound device 

 • USB device 

• 

If printer and serial ports are p
them at runtime.  

You can configure any of these devices in one of the following ways: 

Use the necessary command from
only when the virtual machine is running. 

• Click a device icon on the st

 Drag an image file (*.iso or *.fdd) or a
bar. This option is available only for CD/DVD-ROM drives, floppy drives and shared folders. 

If you have several CD/DVD-ROM driv
th
CD/DVD-ROM 1, the second will be CD/DVD-ROM 2, and so on. 

C
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cts all USB devices plugged into your Mac computer. The 
 to the virtual machine appear in the list from the Device menu. 

You cannot use a USB device in Mac OS X while it is being used by the virtual machine. 

The Shared Folders options available at runtime are similar to the settings in the Virtual Machine 

ly with the virtual machine 

 add a new shared folder 

 

lick the serial port icon

Parallels Desktop automatically dete
devices that are currently connected

Connecting a Shared Folder 

Configuration dialog. 

You can 

• share all Mac disks or Home Folder on

• share Windows guest operating system disks with Mac OS X 

•

Connecting a Serial Port 

To connect or disconnect a serial port, do the following:

• Click the Devices menu, select the corresponding serial port, and choose the appropriate 
command in the displayed menu. 

• Right-c   in the status bar to display the shortcut menu and choose 
the appropriate command. 

Connecting a Printer Port 

To connect or disconnect a printer port or to connect a printer or an output file to a printer port, do 
the following: 

• Click the Devices menu, select the corresponding printer port, and choose the appropriate 
command in the displayed menu. 

• Right-click the printer port icon  in the status bar to display the shortcut menu and choose 
the appropriate command. 
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g virtual machine, do one of the following: 

 Press the key combination that you want to send to your virtual machine when the keyboard 

•

Use Keyboard Shortcuts 

If you want to send a key combination to a runnin

•
input is captured inside the virtual machine window; 

 Click the keyboard icon  in the virtual machine status bar and click the key combination th
you want to send to your virtual machine; or 

at 

• Click the Devices menu, point to the Keyboard item, and click the key combination that you 

uts in MacBook and MacBook Pro 

• To use the F1-F12 keys in your virtual machine, press the Fn+(F1-F12) key combination 

 

You
is available only if Parallels Tools (p. 196) are installed in the virtual 

want to send to your virtual machine. 

Using Keyboard shortc

instead. 

Use Mouse Wheel Horizontal Scrolling 

 can use the mouse wheel horizontal scrolling when working with windows of virtual machine 
applications. This feature 
machine. 
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If you don't need a virtual machine any more, you can permanently remove it from your Mac: 

Remove a Virtual Machine 

Remove a Virtual Machine from your Mac 

Warning: Before removing, check that none of the virtual machine files (e.g. virtual hard disk) are 
used by other virtual machines. If you remove a Boot Camp virtual machine, the Boot Camp 
partition with Windows installed remains available on your Mac. 

1 Shut down the virtual machine if it is running and click File > Remove. You can also right-click 
 Virtual Machines list and choose Remove. 

Re

To temporarily remove a virtual machine from the Parallels Virtual Machines list: 

 the virtual machine you want to remove from the list and click File > Remove. You can 
also right-click this virtual machine in the Parallels Virtual Machines list and choose Remove. 

ls Desktop (p. 37). 
 

 
this virtual machine in the Parallels

2 Click Move to Trash. 

move a Virtual Machine from the Parallels Virtual Machines List 

1 Select

2 Click Keep Files. 

When you need this virtual machine again, you can easily import it in Paralle



134 
 

Advanced Topics 
 

liances 

-use virtual machine with a predefined configuration. 

Parallels Virtual Appliances are pre-built Fedora and Ubuntu virtual machines. 

To 

 Ubuntu and click Continue. 

 for the virtual appliance you're 
nytime by 

llels 

d the Google Chrome virtual appliance from Parallels Desktop: 

1

2 inue. 

you can pause it anytime by 

tart working with the Google Chrome virtual appliance in 
et connection, as well as your 

Download Pre-configured Virtual App

If you don't have enough time to create a new virtual machine with the required configuration, you 
can download a ready-to

Downloading Parallels Virtual Appliances 

download such an appliance and use it with Parallels Desktop: 

1 Choose New from the File menu. 

2 Select Download Fedora or Download

3 In the next step, you can see the user name and password
going to download. Click Download. Once the download starts, you can pause it a
clicking Pause. To resume the download, click Resume.  

Once the download is complete, you can start working with the virtual appliance in Para
Desktop. 

Downloading Google Chrome Virtual Appliance 

To downloa

 Choose New from the File menu. 

 Select Download Chrome and click Cont

3 In the next step, click Download. Once the download starts, 
clicking Pause. To resume the download, click Resume. 

Once the download is complete, you can s
Parallels Desktop. To log in to Chrome OS, you need an Intern
Google account name and password. 
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ersion 

o change 
it in the following cases: 

you upgrade the em (for example, from Windows XP to Windows 7), you 
need to change the guest OS type and version correspondingly or Parallels Tools (p. 143) may 

orking inco

reate a virt ing an operating system, and then decide to use it 
h a different op e one you initially specified. 

t the guest OS t

1 Shut down the virtual machine. (p. 47) 

2 Open the Virtual Machin

and n OS from the menu just under the Name field. 

y d to a Virtual Machine 

You can change the number of virtual CPUs that will be used to handle the processes running in a 
aral lates the maximum allowable number of virtual 
tion available to your Mac OS X 

Set the Guest OS Type and V

You can change which guest OS a virtual machine is configured to work with. You need t

• If  guest operating syst

start w rrectly. 

• If you c ual machine without install
wit erating system than th

To se ype and version: 

e menu and choose Configure. 

 select a3 Click General 
 

Set How Man Processors are Allocate

virtual machine. P lels Desktop automatically calcu
CPU. The calcula is based on the number of physical CPUs 
computer. 

Note: It is reasonable PU in your guest OS if you are going to use applications to use more than one C
that perform better under multi-core processors. 

To set how many proc hine: 

1 Shut down the virtual machine. (p. 47) 

ick General 

essors are allocated to a virtual mac

2 Open the Virtual Machine menu and choose Configure. 

3 Cl
 

and select a number from the CPUs menu. 
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Enable Spoken Commands 

You can work with Windows or other guest OSs using the following spoken commands: 

Commands Description 

Start Starts a virtual machine. 

Suspend Suspends a virtual machine. 

Shut Down Shuts down a virtual machine. 

Pause Pauses a virtual machine. 

Stop Stops a virtual machine. 

Reset Resets a virtual machine. 

Snapshot Opens the Snapshot Manager window. 

Make Screenshot Makes a screenshot of the Guest OS
Desktop. 

 window and stores it on the Mac OS X 

Make Clip Makes a clip. 

Switch to Coherence Switches to the Coherence view mode. 

Switch to Full Screen Switches to the Full Screen view mode. 

Switch to Window Switches to the Window view mode. 

Edit Configuration Opens the Virtual Machine Configuration dialog. 

New Creates a new virtual machine. 

Open Opens a virtual machine. 

Download Allows you to download a virtual machine appliance available at 
http://www.parallels.com/en/ptn/dir. 

About Parallels 
Opens the ADesktop  bout Parallels Desktop menu. 

Install Parallels Tools Launches the installation of Parallels Tools in the running virtual machine. 

Report a Problem Opens the Parallels Problem Report window. 

Open Opens an existing virtual machine and registers it in Parallels Desktop. 

Open Directory Opens the Parallels Virtual Machines window. 

To enable the spoken commands, choose Parallels Desktop > Preferences > Advanced and 
select Enable spoken commands. If necessary, tune the speech settings on the corresponding 
tab of Mac OS X System Preferences. 
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ws you to back 
up your Windows data up to 250 GB with full security and protection. For Parallels Desktop users, 

oad Acronis Online Ba do the

• Option-click (Alt-click) the Parallels icon

Get Acronis Online Backup 

As an additional benefit, Parallels provides you with Acronis Online Backup. It is an online backup 
tool for Windows 7, Windows Vista, and Windows XP. Acronis Online Backup allo

Acronis Online Backup is free for 90 days. 

To downl ckup, one of  following: 

  in the menu bar, choose Exit Coherence, and 
l Machine > Get croni  

sible at the top of the screen, choose Virtual Machine > 
up. 

pleScript with the Guest OS 

se AppleScript to open various files and websites in the guest OS applications. You may 
need this when creating automated workflows. 

ivid, let's assume that you need to open some .txt file in Windows 

choose Virtua s O line Backup.  A n

• If the Parallels Desktop menu bar is vi
Get Acronis Online Back

 

Use Ap

You can u

To make the explanation more v
Notepad using AppleScript (in AppleScript Editor). The syntax of this command is as follows: 
tell application "Notepad" 
open "/Users/username/somefile.txt" 
end tell 

As an example of opening a website in the guest OS application, let's assume that you need to 
open "www.parallels.com" in Internet Explorer. The syntax of this command is as follows: 

tell application "Internet Explorer" 
open "//www.parallels.com" 
end tell 
 

Use Other Operating Systems on Your Mac 
an 

Win
This section has topics with information that's specific to certain operating systems other th

dows XP, Windows Vista, or Windows 7. 
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Import Linux and Your Data from a PC 

You can import Linux and your data from a PC over a network or using an external storage device. 

s:  

These procedures are identical to the same ways of importing Windows (p. 22). 

You can import the following Linux operating system

OS Name 32-bit 64-bit  Migration Method 

Red Hat® Enterprise Linux 5 Network, External Storage   

Ubuntu® Linux 8.04  Network, External Storage  

Supported File Systems 

• Ext2 

• 

 

Ins

OS. 
e 

using third-party tools. 

a CD with the installation files. The inst

Preparing a Virtual Machine for Windows 95/98 Installation 

ssistant. Select the 
tion in the Name and Location window. 

re the 

. In 

ption is selected. 

2. Specify the floppy disc image in the Source menu. 

Ext3 

• Ext4 

talling Windows 98 

All Windows 95 and some of Windows 98 installation packages include a bootable floppy (a startup 
floppy disk). The floppy is used to perform disk partitioning and formatting by means of MS-D
Since modern Macs have no floppy drives, you will need an external USB floppy drive or an imag
of a bootable floppy disk. Such an image can be created 

If you have a bootable CD with Windows 98 installation, you can use it as is or create an ISO image 
of it. 

Below we describe how to install Windows 98, the case when you have a startup floppy image and 
allation of Windows 95 is similar to that. 

1 Create a Windows 98 virtual machine using New Virtual Machine A
Customize settings before installation op

2 In the Virtual Machine Configuration dialog, click Hardware > Boot Order, and configu
floppy disk to be the first boot device. 

3 Below the Boot Order item, select Floppy Disk to open the virtual floppy disk drive settings
the Floppy Disk pane, do the following: 

1. Make sure the Connected o
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Init

f 

pted, enter the following command: 

4 Click OK to save the virtual machine configuration. 

ial Partitioning and Formatting 

1 Start the virtual machine. You will see the black screen and messages indicating the process o
booting to MS DOS. 

2 When prom
fdisk 

Fdisk (MS-DOS utility) is used to partition hard disks and floppy disks. 

urn (Enter) to continue. 

Fdisk OS Partition option if 
 enter: 

3 The Fdisk options will be listed. Choose the operation to perform (the default choice is 1) and 
press Ret

4  prompts you to create a partition. Select the Create Primary D
you are going to have only one partition or less than four, and

1 

Other choices are for the case when you want to create more than four partitions. 

Then Fdisk 5 prompts you to define the size of the primary partition. Press Return (Enter) if you 
maximum size available. 

the size. 

7 at is, press 
 Shut Down button to 

 When the booting is complete, you should format the system drive C:.  

Enter the following command: 

wish to create a partition of the 

To define other size type N and press Return (Enter). You will be prompted to specify 

6 Fdisk creates the partition and then prompts you to restart the computer (virtual machine). 

Reboot the virtual machine using the same image of the boot floppy disk. Th
Ctrl+Option (Ctrl+Alt) to release the keyboard input and then click the
stop the virtual machine. Then click the Start button. 

8

format c: 

Confirm that you want to format the disk C: when prompted. Type y and press Return(Enter). 

You may be prompted to choose how exactly to format your disk. Windows 95/98 supports 
FAT16 and FAT32 file systems. 

FAT16 partition cannot be greater than 2 GB. Larger disks can be formatted with FAT32. But 
do not use larger disks if you are going to run legacy applications. 

The program starts formatting the disk C:. 

Format other disks too (if you created more than one primary partition or if you created a 
custom virtual machine with more than one disk). Use E:, F: drive letters. 

9 Enter a label for each disk (11 character string). The label is optional, you can press Return 
(Enter) to skip this step.  

10 Shut down the virtual machine. 

Now you are ready to start the installation of the Windows 98 operating system. 

General steps of Windows 98 installation 
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1 Start the virtual machine using the same bootable floppy image. 

llation disc choosing  

:), by default, your CD/DVD drive will have the 
drive letter D:. Type the command: 

 

2 Insert the Windows 98 installation CD or connect an ISO image of the insta
CD/DVD > Connect Image from the Devices menu. 

3 If you created only one primary partition (disk C

D:\setup.exe 

and press Return(Enter). The installati
hard disk. 

on starts and the files are copied from the CD to the virtual 

ome options 

one. 

g choose the type of installation. Typical is recommended. 

9 

 

11  Configure from the Virtual Machine menu, go to Hardware > Boot Order, and select 

e hard disk. 

 

4 Follow the on-screen instructions of the Setup. Note that you can add or remove s
later. 

5 Read and accept the License Agreement. Enter the license key. 

6 Confirm the default system directory or specify another 

7 In the Setup options dialo

8 (only for Windows 98) If you are going to use networking, select the network card when 
prompted. 

Turn off the virtual machine. 

10 Eject the installation CD or disconnect the ISO image. 

Choose
the hard disk to be the first boot device. Click OK to save the configuration. 

12 Restart the virtual machine. This time, it will boot from th
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If you have , Windows 98, or Windows ME installed on your Mac, you can improve 

st OS boots up, choose Virtual Machine > Install Parallels Tools. 

3 In Windows, click Start > Settings > Control Panel > Display. 

pter tab, click Change. The wizard opens. 

Next. 

r than the one your device is using now and click Next. 

Browse. Locate the \Drivers\Video\Win9x folder 
 OK. 

Next 

12 When you are prompted to restart the guest OS in the System Settings Change dialog box, 
click Yes. 

The new settings are applied once the virtual machine is restarted. 

 

To install a video driver in Windows NT: 

1 Start Windows NT. 

2 When the guest OS boots up, choose Virtual Machine > Install Parallels Tools. 

3 In Windows, click Start > Settings > Control Panel > Display. 

4 In the Display Properties dialog, go to the Settings tab and click the Display Type button. 

5 In the Adapter Type section, click Change. The Change Display window opens. 

6 In this window, click Have Disk. 

7 Click Browse. Select the \Drivers\Video\Nt4 folder on the CD-ROM drive and click Open 
twice. 

8 In the Install From Disk window, click OK. 

9 In the Change Display window, click OK. 

Improve Graphics Performance in Windows NT/98/ME 

Windows NT
graphics performance by installing a video driver. 

To install a video driver in Windows 98 and Windows ME: 

1 Start Windows 98, or Windows ME. 

2 When the gue

4 In the Display Properties dialog, go to the Settings tab and click the Advanced button. 

5 On the Ada

6 In the wizard, click 

7 Select Search for a better drive

8 Select Specify a location option. Click 
on the CD-ROM drive and click

9 Click Next in the Update Device Driver Wizard and then, when the driver is found, click 
again. 

10 Click Finish and then Close to close the Update Device Driver Wizard. 

11 Click Close to exit the Display Properties dialog box. 
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ox, 

The new settings are applied once the virtual machine is restarted. 

Customize the Keyboard for the Guest OS 

nt sets of key combinations typical 

 Windows 

•

achine, one of these profiles, depending on the guest 
the machine by default. 

 assign it to your virtual machines. To create your custom 

10 Confirm that you want to install the video driver. 

11 When you are prompted to restart the guest OS in the System Settings Change dialog b
click Yes. 

 

Using profiles 

By default, Parallels Desktop contains four profiles that represe
for the following OSs: 

•

 Linux 

• Mac OS X 

• Generic (for other guest OSs) 

When you create or register a virtual m
operating system, will be assigned to 

You can create your own profile and
keyboard profile or edit the existing profiles, click the Edit profiles button. The dialog for editing 
profiles will appear. 
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utton To add a new profile, click the Add b . In the Choose base profile window, specify the 
e profile from the list. After the profile is created, you can new profile name and select the bas

submit the changes by clicking OK, then return to the Keyboard pane of Parallels Desktop 
Preferences, select this new profile in the Profile list, and configure its shortcuts. 

To remove one of the existing custom profiles, select this profile and click the Remove button . 

To duplicate or rename one of the existing profiles, select this profile, click the button , and 
select the corresponding action from the menu. 

Note: You can rename or remove your custom profiles only. 

In this window, you can also assign profiles to your virtual machines. 

To change a profile assigned to a virtual machine: 

 t r virtua

2 In the Profile column, c rre list of available profiles 
and choose the profile you want to assign to this virtual machine. 

3 Click OK to submit the changes. 

gh k 

To emulate a mouse right-c t the
be used to emulate a mouse right-click in
 

 X Lio  t

When you install or upgrade to Mac OS X  Desktop 
allows you to install Mac OS X Lion is partition into a virtual machine. To do so: 

1 Open Parallels Desktop and choose 

io he 
izard's instructions. 

 

Install or Update
Parallels Tools are a suite o  between Mac 

not

This section gives an overview of Parallels Tools, for 
various guest operating systems. 
 

1 In the Assign profiles o you l machines table, select the virtual machine. 

sponding profile field to open the lick the co

Emulating a mouse ri t-clic

lick, selec  Use check box and specify the key combination that will 
 the virtual machine. 

Install Mac OS n From he Recovery Partition 

 Lion, a recovery partition is created. Parallels
from th

File > New. 

he Recovery Partition, click Continue, and follow t2 Select Install OS X L
w

n Using t

 Parallels Tools 
f behind-the-scenes tools that allow seamless operating

est operating system.  

and has information about how to install them 

OS X and Windows or a her gu
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Parallels Tools are a suite of special utilities that  the most 
comfortable and efficient way. With Para lessly between 

ang  simply resizing 
al mac settings of the 

host computer, share your Mac's disks a xt and drag 
and drop objects from Mac OS to a virtual machine and vice versa. 

 available ating 
systems, and include the utilities  your guest OS are installed 
in your virtual machine as a single pa

Parallels Tools Overview

help you use your virtual machines in
llels Tools, you can move the mouse seam
e the virtual machine's screen resolution by
hine's time and date settings with the time 
nd folders with its virtual machines, copy te

the virtual machine a
its window, synchronize 

nd your Mac, ch
your virtu

Parallels Tools are  for the most popular Windows, Linux, and Mac OS X oper
 listed below. All utilities supported by

ckage when you install Parallels Tools. 

Utility Available for Description 

Mouse Synchronization Tool 

Windows 

Linux 

Mac OS X 

Mouse Synchronization Tool captures the mouse input 
in the virtual machine each time the pointer moves over 
its window and automatically releases the input when 
the pointer moves outside the window. 

Time Synchronization Tool 

Windows 

S X 

• Automatically synchronize the time settings of 

maintain the time difference 
between your Mac and your virtual machine. 

Linux  

Mac O

Time Synchronization Tool enables you to customize 
your virtual machine time settings. You can: 

your virtual machine with your Mac time 
settings. 

• Set up and 

Drag-and-Drop Tool  
and Mac OS.  

Windows Drag-and-Drop Tool allows dragging and dropping  files 
between your virtual machines 

Clipboard Synchronization 
Tool 

Windows 

Linux 

guest operating systems installed in them. 

Clipboard Synchronization Tool enables you to easily 
exchange texts between: 

• the virtual machine and your Mac. 

• different virtual machines irrespective of the 

To copy and paste text, you should use the standard  

 from the 

procedure for the current operating system. For 
example, to copy some text in the Windows guest OS, 
select the text, and press Ctrl+C. To paste this text in 
Mac OS X, press Cmd+V, or select Paste
shortcut menu. 

Dynamic Resolution Tool Linux 

Mac OS X 

Dynamic Resolution Tool enables you to work with 
dynamic resolution. When you resize the guest OS 
window by dragging its lower right corner, the guest OS 
window resolution changes automatically. 

Windows 
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Windows 

Mac OS X 

Shared Folders Tool enables you to share Mac folders 
with the virtual machine and vice versa. With this tool, 
you can access your Mac folders from the virtual 
machine and virtual machine folders from Mac OS X. 

Shared Folders Tool Linux 

Coherence Tool 
Windows 

The Coherence tool allows you to work with your 
Windows or Linux applications like if they were Mac 

Linux applications. It hides the virtual machine's window 
leaving only guest OS and Mac applications visible. 

Shared Profile Tool Windows 

Shared Profile Tool enables you to share your Mac 
desktop, pictures, documents, downloads, music and 
videos with your virtual machine, which allows you to 
access them right from Windows. 

Shared Applications Tool Windows 

Shared Applications Tool enables you to specify default 
applications for certain types of files, so that you can 
open some types of files in Windows applications by 
default, and others - in Mac OS. 

Shared Internet Applications 

Shared Internet Applications Tool enables you to specify 
default Internet browsers, including those installed in the 
virtual machine, for different types of Internet pages. For 

default Mac OS X Internet browser, and FTP pages to 
open in your virtual machine Internet browser. 

Tool Windows example, you may set the Internet pages to open in your 

SmartMount 

Windows 

Linux 
SmartMount automatically detects volumes connected 
to your Mac and makes them available to the virtual 

Mac OS X 
machine as well. 

Printing Tool Windows 
Printing Tool allows you to synchronize the host and 
guest OS printers. 

Tray Integration Tool Windows 
icons in the Mac menu bar. 
Tray Integration Tool allows you to use Windows tray 

Parallels Tools are located on disc images that are installed together with Parallels Desktop. There 
s. 

• prl-tools-win.iso - disc image with Parallels Tools for Windows guest operating systems. 

. 

The ocation on your Mac: 
/Li
 

is a separate Parallels Tools disc image for each type of the supported guest operating system

• prl-tools-lin.iso - disc image with Parallels Tools for Linux guest operating systems

• prl-tools-mac.iso - disc image with Parallels Tools for Mac OS X Server Leopard. 

se disc images can be found in the following l
brary/Parallels/Tools/. 
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indows Parallels Tools for W

Important: To t of much of the functionality Parallels Desktop offers, Parallels Tools must ake advantage 
be installed. 

Parallels Tools can be installed in the following Windows guest operating systems: 

• Windows Server 2003 

Installing P

If yo  installed Windows, Parallels Tools were installed 

If yo

1 Start Windows (p. 41). 

 from the Virtual Machine menu. 

• Windows 7 

• Windows Server 2008 

• Windows Vista 

• Windows XP 

• Windows 2000 

arallels Tools 

u chose Express Installation when you first
automatically after the installation. 

u didn't choose Express Installation, do the following to install Parallels Tools: 

2 When Windows boots up, choose Install Parallels Tools

Note: After you choose Install Parallels Tools in Windows 7 and Windows Vista, User Access Control 
(UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to 
allow the installation. 

3 In the Welcome window, click Install to start the Parallels Tools installation or wait for 8 
seconds and it will start automatically. 

4 When the installation is complete, click Reboot to restart the virtual machine or wait for 8 
seconds and it will be rebooted automatically. 

If the Parallels Tools installation does not start automatically after you choose Install Parallels 
Tools (for example, because the CD/DVD autorun is disabled), you can install them manually: 

1 Log in to the Windows guest operating system and mount the Parallels Tools ISO image by 
doing the following: 

• Right-click the CD/DVD drive icon in the virtual machine's status bar and choose Connect 
Image. 

• In the Finder window, go to the hard disk folder (normally named "Macintosh HD"), select 
the /Library/Parallels/Tools/ folder, select the prl-tools-win.iso file, and 
click Open. 
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2 In the Windows guest operating system, open My Computer, right-click the Parallels Tools  
disc and choose Open. 

3 Double-click Setup.exe to launch the installer. 

Note: After you double-click Setup.exe in Windows 7 and Windows Vista, User Access Control (UAC) 
may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to allow the 
installation. 

4 Follow the wizard's instructions to complete the installation. 

 e ngs of Parallels Tools installed in your virtual machine, use the Options tab in the 
 Configuration dialog. 

ate Parallels Tools 

 reinstall Parallels Tools: 

1

Once Windows starts, if Parallels Desktop is in Coherence mode, click the Parallels icon

To dit the setti
Virtual Machine

Reinstall or Upd

To

 Start Windows (p. 41). 

  in 
Exit Coherence. 

2 When Windows boots up, choose Install Parallels Tools from the Virtual Machine menu. 

e

You
the rs 
in t
Wh ey to release the mouse and 
keyboard - they are released automatically. 
 

the menu bar and choose 

This option is available only if Parallels Tools are up-to-date. If Parallels Tools are outdated, you 
will see the Update Parallels Tools option instead. 

Ch ck Whether Parallels Tools Have Been Installed 

 can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at 
 status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appea
he status bar of the virtual machine's window, this means that Parallels Tools were not installed. 
en Parallels Tools are installed, you do not need to press any k
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4.6 and later (libstdc++.so.6) 

Parallels Tools for Linux 

Parallels Tools can be installed in Linux guest operating systems that comply with the following 
requirements: 

• glibc 2.3.4 and later 

• libstdc++ 3.

• gcc 3.4.6 and later (including C++ support) 

• make 3.80 

• X Window System X11R6.7, X11R6.8, X11R6.8.99, X11R7.0, X11R7.1, X11R7.2 (1.3), 
X11R7.3 (1.4) 

• kernel sources or development package 

Note: Some of Parallels Tools, like Shared Folders Tool and Time Synchronization Tool, may also work in 
the Linux operating systems that do not comply with the requirements listed above. 

Preparing for installation 

r, disable it. 

he gcc package and kernel sources installed. If these packages are 

name depends on the type of Linux operating system you use: it can be , or 
fer to 

x. 

Before installing Parallels Tools in a Linux virtual machine, perform the following actions: 

• Close all applications running on the virtual machine. 

• If you use a 3D accelerated window manage

• Make sure that you have t
not installed, the Parallels Tools installer will inform you about this. The kernel sources package 

kernel-devel
kernel-headers, or something else. For more information about the kernel sources, re
Installing the GCC package and Kernel Sources in Linu

Note: root To install Parallels Tools in your virtual machine, you must have the  privileges.  

Installing Parallels Tools in the most recent versions of Linux systems 

Fedora) in your virtual machine, 
 image file will be mounted automatically after you connect it to the 

CD

achine Install Parallels 

If you have one of the m
the prl-tools-lin.i

ost recent versions of Linux OSs (Ubuntu, 
so

/DVD drive. To install Parallels Tools, do the following: 

1 

2  and choose 

Start the virtual machine. 

 When the operating system boots up, click Virtual M
Tools. 

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system 
complies with the requirements listed above. 

The prl-tools-lin.iso image file will be mounted to the virtual machine's CD/DVD drive. 
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and mount the Parallels Tools ISO image file manually. Right-click the 
e Connect Image. In 

lder (normally named "Macintosh HD"), select the 
/
O

3 S
p

You can connect 
CD/DVD drive icon in the virtual machine's window status bar and choos
the Finder window, go to the hard disk fo
Library/Parallels/Tools/ folder, select the prl-tools-lin.iso file, and click 
pen to connect it to the virtual machine. 

tart a terminal in your Linux guest OS. Type the following command to gain the root 
rivileges: 

su 

Change the dire4 ctory to the CD/DVD drive directory using 
cd /media/cdrom/ 

Note: In some of the Linux operating systems, the mount point for the virtual CD/DVD drive may appear 
as /media/Parallels\ Tools/. 

5 In the CD/DVD drive directory, enter the to launch Parallels Tools following command 
installation: 

./install 

6 Follow the Parallels Tools Installer instructions to complete the installation. 

7 W

To install Parallels Tools in the older versions of Linux OSs, you have to mount the prl-tools-

1 Start the virtual machine. 

hen the installation of Parallels Tools is complete, restart your virtual machine. 

Installing Parallels Tools in other versions of Linux guest OSs 

lin.iso image file manually. Do the following: 

2 When the guest OS boots up, choose Install Parallels Tools from the Virtual Machine menu. 

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system 
complies with the requirements for Parallels Tools installation. 

The prl-tools-lin.iso image file will be connected to the virtual machine's CD/DVD drive. 

 your Linux guest OS. Type the following command to gain the root 
privileges: 

3 Start a terminal in

su 

4 Check if the Parallels Tools CD image is mounted by entering 
mount | grep iso9660 

If this command does not return anything, proceed to the next step. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0), 

skip the next step and proceed to the following one. 

If this command returns anything like 
/dev/cdrom on /media/cdrom

with

 type iso9660 (ro,noexec,nosuid,nodev,uid=0) 

xt step: 
 the noexec option present in parentheses, you need to unmount the disc using the 

following command and then proceed to the ne
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umount /dev/cdrom 

5 To mount the Parallels Tools installation disc image, enter the following: 
mount -o exec /dev/cdrom /media/cdrom 

Note: /dev/cdrom is the virtual machine's CD/DVD drive and /media/cdrom is the mount point for 
this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb 
and the mount point . Some Linux OSs d/mnt/cdrom o not have the CD/DVD drive mount point. In this 
case, you should create the mount point directory manually. 

6 When the installation disc image is mounted, change the directory to the CD/DVD drive 
directory using 

cd /media/cdrom/ 

7 In the CD/DVD drive directory, enter the following to launch Parallels Tools installation: 
./install 

Note: You must have the root privileges to run this command. 

8 Follow the Parallels Tools Installer instructions to complete the installation. 

9 When the installation of Parallels Tools is complete, restart your virtual machine. 

Note: If X Server fails to start in your virtual machine, you can install Parallels Tools manually in text 
mode. 

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the 
Virtual Machine Configuration dialog. 

How to check if Parallels Tools have been installed 

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at 
the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and 
keyboard" appears in the status bar of the virtual machine's window, this means that Parallels 

n Parallels Tools are installed, you do not need to press any key to 
matically. 

Parallels Tools installer can be blocked by SELinux. To solve this problem: 

Tools were not installed. Whe
release the mouse and keyboard - they are released auto

Troubleshooting 

1 Start a terminal and determine your version of kernel by entering 
uname -r 
2.6.18-8.el5 

2.6.18-8.el5 is the version of your kernel. 

Open the /boot/gr2 ub/grub.conf file or /boot/grub/menu.lst (depends on the 
version of your Linux operating system) and find the entry that corresponds to your version of 
kernel. 

title Red Hat Enterprise Linux Server (2.6.18-8.el5) 
 root (hd0,0) 
 kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet 
 initrd /initrd-2.6.18-8.el5.img 
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3 Type the following text at the end of the entry: 
selinux=0 

and the whole entry will be: 
kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet selinux=0 

machine. 

Before updating Parallels Tools, you form the following actions: 

• C

• D

In L

ine. 

2  follow the instructions. 

3 your virtual machine. 

Re

 once again. 

achine, and log in to the guest OS. 

nnect and mount the prl-tools-mac.iso image 

5 ation window, you can see the process of Parallels Tools being removed from 
ne. 

quit the 
t. 

4 Save the file and restart the virtual 

After the restart, mount the Parallels Tools disc image and try to install Parallels Tools. 

Update Parallels Tools 

should per

lose all applications in the guest operating system. 

isable the 3D accelerated window manager if you have any. 

inux guest operating systems, you should check for Parallels Tools updates manually from time 
to time. 

To update Parallels Tools: 

1 Start the virtual mach

Choose Update Parallels Tools from the Virtual Machine menu and

When the update is complete, restart 

install Parallels Tools 

To reinstall Parallels Tools in Linux, first remove Parallels Tools and then install them

Remove Parallels Tools 

1 Start the virtual m

2 To remove Parallels Tools, you should co
and launch Parallels Tools Installer. For detailed instructions, see Installing Parallels Tools in 
Mac OS X. 

3 Open the mounted image of the disc and double-click the Uninstall Parallels Tools icon to 
start the deinstallation. 

4 In the Welcome window, click Uninstall. Enter the password when prompted. 

In the Uninstall 
the virtual machi

6 In the U
assistan

ninstallation Completed window, click Restart to finish the deinstallation and 
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Parallels Desktop, the X Server may fail to start in Linux virtual machines. To fix 
the problem, you need to install Parallels Tools in text mode. 

2 When you see a message that X Server failed to start, switch to another virtual console using 
lt+F1) and enter your login details. 

3 Choose Install Parallels Tools from the Virtual Machine menu to connect the Parallels Tools 

Installing and Upgrading Parallels Tools in Text Mode in Linux

After upgrading to 

1 Start the virtual machine. 

Ctrl+Option+F1 (Ctrl+A

ISO image to your virtual machine. 

Note: If the Install Parallels Tools option is grayed out, make sure that Parallels Tools can be installed 
in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the 
Parallels Tools Overview section in Parallels Desktop User's Guide. 

The prl-tools-lin.iso image file will be connected to the virtual machine's CD/DVD drive. 

4 In the virtual machine console, type the following command to gain the root privileges: 
su 

5 Check if the Parallels Tools CD image is mounted by entering 
mount | grep iso9660 

If this command does not return anything, proceed to the next step. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro

skip the next step and proceed to the followin
,exec,nosuid,nodev,uid=0), 

g one. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0) 

following command and then proceed to the next step: 
with the noexec option present in parentheses, you need to unmount the disc using the 

umount /dev/cdrom 

6 To mount the Parallels Tools installation disc image, enter the following: 
mount -o exec /dev/cdrom /media/cdrom 

Note: /dev/cdrom is the virtual machine's CD/DVD drive and /media/cdrom is the mount point for 
this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb 
and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this 
case, you should create the mount point directory manually. 

7 When the installation disc image is mounted, 
directory using 

change the directory to the CD/DVD drive 

cd /media/cdrom/ 

In the CD/DVD drive directory, enter the fo8 llowing to launch Parallels Tools installation: 
./install 

Note: You must have the root privileges to run this command. 

9 Follow the Parallels Tools Installer instructions to complete the installation. 
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10 When the installation of Parallels Tools is complete, restart your virtual machine. 

Installing Parallels Tools in a 

Install Parallels Tools 

ools in Mac OS X guest operating systems: 

uest operating system. 

 Parallels Tools. The Parallels Tools icon 

s instructions. 

Up

hould update Parallels Tools installed in your Mac OS X 
ms. If you revert a Mac OS X guest operating system to the snapshot made 

when an earlier version of Parallels Tools was installed, you should also update them. To update 
Parallels Tools: 

1 Start the Mac OS X guest operating system. 

2 When it boots up, choose Virtual Machine > Update Parallels Tools. The Parallels Tools icon 
appears on the Mac OS X desktop. 

3 Double-click the Parallels Tools icon, double-click Install and follow the assistant's instructions. 

Reinstall Parallels Tools 

If for some reason Parallels Tools stop functioning, reinstall them: remove Parallels Tools and then 
install them once again. 

Remove Parallels Tools 

To remove Parallels Tools from Mac OS X guest operating systems: 

1 Start the Mac OS X guest operating system. 

2 When it boots up, choose Virtual Machine > Reinstall Parallels Tools. The Parallels Tools 
icon appears on the Mac OS X desktop. 

3 Double-click the Parallels Tools icon, double-click Uninstall Parallels Tools and follow the 
assistant's instructions. 

 

 

For general information on installing Parallels Tools in Linux, refer to 
Linux Guest OS. 
 

Parallels Tools for Mac 

To install Parallels T

1 Start the Mac OS X g

2 When it boots up, choose Virtual Machine > Install
appears on the Mac OS X desktop. 

3 Double-click the Parallels Tools icon, double-click Install and follow the assistant'

date Parallels Tools 

After you update Parallels Desktop, you s
guest operating syste
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OS/2 and eComStation 

Sound driver for OS/2 and eComStation can be installed from the prl-tools-other.iso CD 

stall Parallels Tools from the Virtual Machine menu. 

pport installed in the guest 

und Driver: 

 

/DVD 
ec 

4 Restart the guest operating system. 

Install Sound Driver in 

image. Before starting the installation, connect the CD image with Parallels Tools to your virtual 
machine's CD/DVD drive. Choose In

 

Before installing Sound Driver, make sure you have the multimedia su
operating system. 

To install So

1 Click the System Setup icon on the system panel. 

2 Select Install/Remove line and then select Multimedia Application Install. 

3 In the IBM Multimedia Presentation Manager/2 - Installation window choose the CD
drive, then the <CD-ROM drive>\Drivers\Sound\OS2 directory. Select the ALC Cod
feature and click the Install button. 
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Modality Mode 
When you switch to Modality, you can resize the virtual machine windows and place them side by 
side with your Mac's applications.  

In the Modality mode, you can: 

• Resize the Windows window by dragging its lower-right corner. 

• Resize the Windows window while keeping its shape by pressing and holding the Option (Alt) 
key and dragging the lower-right corner of the window. 

• Resize the Windows window and dynamically adjust the screen resolution by pressing and 
holding the Shift and dragging the lower-right corner of the window. 

Using the Modality settings, you can configure the virtual machine appearance and behavior when 
it is running in the Modality mode. In the Modality mode, you can resize the virtual machine 
windows and place them side by side with your Mac applications. A Modality window can be 
scaled to any size, and its content will still be active. This allows you to monitor the tasks running 
inside the virtual machine while you are working on the Mac side

2 In the Virtual Machine Configuration window, click Options and select the settings name in 

nfigure the settings in this pane even when the virtual machine is running. 

. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu or Option-click (Alt-click) the Parallels icon in the Mac menu 
bar (in the Crystal view mode) and click Configure. 

the sidebar. 

You can co
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In the Modality mode, the virtual machine window becomes transparent by default. You can specify 
the level of visibility in the Opacity field by dragging the slider between Transparent and Opaque. 
You can change the level of transparency for your virtual machine that is running when it is in the 
Modality mode. 

To manage the behavior of the virtual machine window in the Modality mode, use the following 
options selected by default: 

• Keep on top of other windows. Clear this option if you do not want the virtual machine 
window to appear on top of all other open windows when the virtual machine is in Modality. 

• Capture keyboard and mouse on click. Clear this option if you do not want the virtual 
machine to capture the keyboard and mouse input when in Modality. 
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sktop 
rallels Desktop, you can hide and show it and all its windows by 

pressing the F6 shortcut. 

If Parallels Desktop is visible but running in the background, pressing F6 will bring Parallels Desktop 

Hide and Show Parallels De
When you are working with Pa

and all its windows to focus. 

Note 1: To be able to use the F6 shortcut, make sure the Enable Mac OS X system shortcuts option 
is enabled in the Keyboard pane of Parallels Desktop Preferences. 

Note 2: F6 is the default shortcut for hiding/showing Parallels Desktop. You can set another shortcut for 
these actions: in the Keyboard pane of Parallels Desktop Preferences, double-click the Show/Hide 
App ecify the shortcut you want and click OK. lication item, sp
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 Locate and open the DMG installation image file that you used to install Parallels Desktop and 
double-click Uninstall. 

ue. 

3 In the Select components to uninstall window, select the components you want to remove 
rallels Desktop 

d virtual machines from your computer. 

Remove Parallels Desktop 
To remove Parallels Desktop: 

1

2 In the Welcome dialog, click Contin

and click Uninstall. Selecting the Application Settings option removes the Pa
settings, network settings, and the list of registere

Note: The operation of removing Parallels Desktop doesn't remove the virtual machines and their files 
from your Mac. 
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Confirm your choice of the components to be removed by clicking Uninstall. 

lick OK. 

5 The uninstaller removes Parallels Desktop from your Mac. 

 

Remove Without Installation Disc 

Parallels Desktop can be removed without the installation disc using the Terminal. 

To remove Parallels Desktop using the Terminal: 

1 Open the Terminal (it is usually available in the /Applications/Utilities folder) and enter the 
following command: 

4 Enter your password when prompted and c

6 When the removal is complete, click Close to quit the uninstaller. 

sudo sh /Library/Parallels/Uninstaller/Parallels\ Hypervisor/Uninstaller.sh 
virtualization 

Note: If the Password: line appears, you will need to enter an administrator's password. 

2 When Parallels Desktop is removed the following message appears: 
[UN_PERCENT]:100[UN_OP]:Uninstall successfull[UN_MSG]:Removed successfully 

Note: The operation of removing Parallels Desktop doesn't remove virtual machines and their files from 
your Mac. 
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Advanced Preferences 
In the Advanced pane of Parallels Desktop Preferences, you can configure some additional 
settings. 
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In the Advanced pane of Parallels Desktop Preferences, you can configure a number of network-
gs for Parallels Desktop and your virtual machines. Click Change settings and the 

window with network settings will appear. You can configure the range of IP addresses to be 

For details on configuring the host-only networking settings, refer to Host-Only Networking 

working settings, refer to Shared Networking Settings (p. 

 

rd to section of the Advanced pane, you can set restrictions on the 
following operations for non-administrator users: 

• Create a new virtual machine. You will have to provide your administrator password to create 

 

 virtual machine. You will have to provide your administrator password to remove 
your virtual machines from the Parallels Virtual Machines list. 

chine or template. You will have to provide your administrator 
password to clone a virtual machine, to create a template, to convert a template into a virtual 

u to operate your virtual machine by using the speech commands. If you 
want to do that, select Enable spoken commands and make sure that: 

Preferences 

should turn on speakable items in System Preferences'
tune the speech settings, click System Preferences. 

Configuring Network Preferences 

related settin

assigned to your virtual machines when they are operating in the host-only and shared networking 
modes. 

Settings (p. 165). 

For details on configuring the shared net
163). 

Using Third-party Plugins 

To be able to encrypt Windows (p. 98) using third-party plugins, select Allow third-party plugins.

Requiring Password 

In the Require passwo

a new virtual machine. 

• Add an existing virtual machine. You will have to provide your administrator password to add
an existing virtual machine to the Parallels Virtual Machines list. 

• Remove a

• Clone or convert a virtual ma

machine, and to deploy a template into a new virtual machine. 

Speech 

Parallels Desktop allows yo

• the virtual machine window is active, and 

• the speech settings are properly tuned on the corresponding tab of Mac OS X System 

If the speech settings are not tuned, you will see the 'To enable this option, you 
 warning message. To 
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vailable to manage your virtual machines, please refer to 

 Customer Experience Program, select the corresponding option. If you join this 
program, Parallels will collect information about your Mac and virtual machines configuration. The 
collected information will help us to make the product better fit your needs. 

If you join, only the following types of data will be collected: 

• hardware configuration of your Mac 

• software configuration of your Mac and virtual machines (the names and versions of the 
operating systems and software installed in them) 

• configuration files of virtual machines 

Any types of private information like your name, e-mail, address, phone number, and keyboard 
input will not be collected. 

For more details, visit the Customer Experience Program page at the Parallels website (follow the 
link in the pane). 

Troubleshooting 

While functioning, Parallels Desktop automatically creates a log file that can be used by the Parallels 
support team for solving problems and improving the product. If you select the Use detailed log 
messages option, Parallels Desktop will start creating a more detailed log file. It can be helpful for 
the Parallels support team, but uses more hard disk space and may slightly lower the system 
performance. 

Resetting Hidden Messages 

Some Parallels Desktop dialogs and wizard windows are provided with the Do not show this 
message again option. If you select this option, the corresponding dialog will not appear next time 
you perform the same operation. Using the Reset button, you can reset all dialogs and wizard 
windows with this option selected so that they would be displayed again each time you initiate the 
corresponding operation. 

Locking Parallels Desktop Preferences 

If you want to prevent Parallels Desktop Preferences from further unauthorized changes, click the 

Lock icon 

To view the list of all spoken commands a
Enable Spoken Commands. 

Feedback 

To participate in the

 at the bottom of the window. The next time anybody wants to change the settings 
in any pane of Parallels Desktop Preferences, an administrator's password will be required. 
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d networking settings, click Network: Change settings in the 
Advanced pane of Parallels Desktop Preferences and select the Shared tab. You will see the 

Shared Networking Settings 

To make changes the share

following window: 
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 the necessary changes to the settings of the Parallels DHCP servers 

y, rtual machines set to operate in the shared networking mode cannot be accessed from 
 and 
 

t to a specific port on your Mac will be redirected to a specific port of your 
irtual machine according to the port-forwarding rule. 

To add a port forwarding rule: 

In this window, you can make
for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to your 
virtual machines operating in the shared networking mode. To disable any of these servers, clear 
the corresponding option. 

For more information about configuring shared networking, refer to Shared Networking. 

Port Forwarding 

Normall  vi
external computers. The port forwarding functionality allows computers on your local network
on the Internet to transfer data to any of your virtual machines that use the shared networking
mode. The data sen
v

1 Click the Add button  below the Port forwarding rules list. 

twork 
connections. You can choose between the TCP or UDP port types. 

• In the Incoming Port field, type the number of the incoming port on your Mac. 

• In the IP Address field, indicate the IP address of the virtual machine you want to connect. 

• In the Destination Port field, type the port on the virtual machine to which the data will be 
transferred. 

2 In the displayed window, do the following: 

• In the Port Type field, specify the port type you want to use for establishing ne
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3 Click OK to add the rule. 

When the rule is added, use the following IP address combination for external connections to your 
virtual machine: <you Mac's IP address>:<Incoming port>. 

To e dit a rule, select it in the Port forwarding rules list, click the Edit button , modify the
necessary settings, 

 
and click OK to apply them. 

move To remove a port forwarding rule, select it in the Port forwarding rules list and click the Re
button . 

Click OK to save the changes, other
Restore Defaults. 

wise, click Cancel. To restore the default settings, click 

 

Host-Only Networking Settings 

 Network: Change settings in the 

 

To make changes to the host-only networking settings, click
Advanced pane of Parallels Desktop Preferences. The following window will appear: 
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ou can make the necessary changes to the settings of the Parallels DHCP servers 
. These servers, enabled by default, automatically assign IP addresses to the 

ar 

tworking

Advanced Settings 

In the 

1 
ence view mode) and click Configure. 

2 in 

In this window, y
for IPv4 and IPv6
virtual machines operating in the host-only networking mode. To disable any of these servers, cle
the corresponding option. 

Click OK to save the changes, otherwise, click Cancel. To restore the default settings, click 
Restore Defaults. 

For more information on configuring the host-only networking settings, refer to Host-Only 
. Ne

 

Advanced pane, you can configure the Parallels Desktop additional settings. 

To edit these settings, do the following: 

Open the Virtual Machine menu or Option+click (Alt+click) the Parallels icon in the Mac menu 
bar (in the Coher

 In the Virtual Machine Configuration window, click Options and select the settings name 
the sidebar. 

 



167 
 

Advanced Topics 
 

•

• If you select Off, you will need to click inside the virtual machine window to capture the mouse 

SmartMouse 

The SmartMouse option allows the mouse to move smoothly between the virtual machine and 
your Mac. With this option enabled, Parallels Desktop automatically grabs the mouse input when 
you move the pointer to the virtual machine, and releases it when you move it back to Mac OS. 

 If you select On, the mouse input will be automatically captured in the virtual machine window 
when the mouse pointer hovers over it and then released when it moves back to Mac OS, 
which will make the mouse move seamlessly between your Mac and the virtual machine. 

input, and press Ctrl+Option (Ctrl+Alt) to release it back to your Mac. 

Note: Ctrl-+Option (Ctrl+Alt) is the default key combination. You can define another key combination for 
releasing the mouse in the Keyboard pane of Parallels Desktop Preferences. 

• If you select Auto, the option will automatically become disabled (Off) each time you use a 
game, graphic application, or any other program that uses its own mouse pointer instead of 
using the operating system pointer. The option will be automatically enabled (On) after you quit 
the application. 

Important: In Coherence mode, SmartMouse is automatically enabled. If you're using a program that 
uses its own pointer and requires SmartMouse to be disabled, you must switch to Window or Full Screen 
mode. 

Modifier Keys Optimization 

Enable Optimize modifier keys for games if you actively use modifier keys (Option (Alt), Ctrl, Shift) 
in action games. If you enable this option, signals from these keys will be processed faster. 

Apple Remote 

Enable the Apple Remote option to use the Apple Remote to control some Windows applications. 

For detailed information on using Apple Remote, see Control Programs with Trackpad Gestures 
or the Apple Remote. 

Time Synchronization 

Select Sync from Mac OS X to synchronize Windows time settings with those of your Mac. 

If you want Windows and Mac OS X time settings to always be the same, select Sync from either 
OS. With this option selected, if you manually change the time settings in Windows, they are 
changed accordingly in Mac OS X and vice versa. 

If the time zone set in your virtual machine differs from that of your Mac, you can maintain this time 
difference by selecting Do not sync. 
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systems, select Share 

Copy & Paste 

If you want to copy and paste data between the host and guest operating 
Mac clipboard. If the data you copy and paste between Mac OS X and your virtual machine is text 
and you want to preserve text formatting, select Preserve text formatting. 

Note: only for virtual machines with Parallels Tools installed (p. 196).  This functionality is available 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in 
chine Configuration, an administrator's password will be required. any pane of Virtual Ma
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Adding and Removing Devices 
r. 

e added to the 

• 

• p

• 

• ser

• prin

• sound device 

• USB controller 

Any of the aforementioned devices can be added to the corresponding virtual machine only when it 
is stopped. 

Adding new devices to a virtual machine is easier than connecting new devices to a real compute
Removing or disconnecting devices is also easy. The following virtual devices can b
configuration or removed from it: 

• virtual hard disk drive 

CD/DVD drive 

flo py disk drive 

network adapter 

ial port 

ter port 

Note: To be able to connect any virtual device to a real one, you should have system privileges to access 
the real device. Otherwise, the real device will not appear in the list of available devices even though it is 
installed on your computer. 

Adding a New Device to a Virtual Machine 

1 Choose Configure from the Virtual Machine menu to open Virtual Machine Configuration. 

2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the 
pane for editing hardware devices. 

3 Click the Add button  in the bottom part of the Virtual Machine Configuration dialog and 
select the device to be added to your virtual machine. 

Note: The Add button is disabled when the virtual machine is running. You need to stop the virtual 
machine before you can use this button. 
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4 

 The hard disk type: a new image file or an existing one. Select Boot Camp if you want to 

The hard disk location. Provide the path on your Mac to the existing image file or the path 
e the new image 

 you can choose one of the following formats: Expanding or 

lit 
 more information on hard disk formats, refer to 

Support for Virtual and Real Disks (p. 172). 

If you selected any device except for a hard disk, the corresponding device with a typical 
configuration is added at once and ready for use. 

If you selected a hard disk, you should specify some parameters: 

•
add an existing Boot Camp partition as a hard disk to your virtual machine. 

• 
and name for the new image file. By default, Parallels Desktop offers to sav
file in the virtual machine PVM bundle. 

• The hard disk size for the new hard disk image file. 

• For the new hard disk image file,
Plain. By default, the hard disk will have the Expanding format. To create a Plain hard disk, 
clear the Expanding disk option. If you want the virtual hard disk to be split, select the Sp
the disk image to 2 GB files option. For
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Click OK, to add the hard disk. After you added a new virtual hard disk to the virtual machine 
g system installed inside the virtual machine until 

the moment you initialize it. For detailed information on how to initialize the newly added hard 

and start using it. 

2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the 
rdware devices. 

3 Select the device you want to remove and click the Remove button 

configuration, it will be invisible to the operatin

disk, see Initializing the Newly Added Disk. 

After the new device is added, you can manage its properties as usual 

Removing Devices From the Virtual Machine Configuration 

1 Choose Configure from the Virtual Machine menu to open Virtual Machine Configuration. 

pane for editing ha

 in the bottom part of 
the Virtual Machine Configuration dialog. 

Note: If you accidentally click the Remove button , click Cancel in Virtual Machine Configuration. 
Once you click OK, the device will be removed. 
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 machines and provides the 
information about basic operations you can perform on these disks. 

es of Hard Disks 

heir hard 

m 100 MB to 2 TB. 

Virtual hard disks can be of either plain or expanding format. 

A plain virtual hard disk image file has a fixed size.  The size is determined when the 

Support for Virtual and Real Disks 

This section lists the types of disks that can be used by Parallels virtual

Supported Typ

Parallels virtual machines can use either virtual hard disks or Boot Camp partitions as t
disks. 

Virtual Hard Disks 

The capacity of a virtual hard disk can be set fro

plain disk is created. Plain disks can be created with the help of New Virtual Machine 
wizard (the Custom mode.)  

expanding 
applications and data to the virtual hard disk in the guest OS. 
An expanding virtual hard age file is small initially. Its size grows as you add  disk im

When you create a virtual machine, the disk is created in the expanding format. You can change 
e disk format in the Hard Disk pane of the Virtual Machine Configuration dialog. To add a plain 

your virtual machine, clear the Expanding disk option when adding a hard disk to the 
virtual machine. 

 single .hdd file. 

ur Boot Camp Windows XP, Windows Vista, 
system: to boot in it natively (via Boot Camp) or in a virtual machine (via 

Parallels Desktop). A Boot Camp Windows partition can be used as a bootable disk or as a data 
disk in Parallels virtual machines. For detailed information, see Using the Boot Camp Partition in 
a Virtual Machine. 

th
hard disk to 

Split disks 

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB 
pieces and is stored as a

Boot Camp Partitions 

With Parallels Desktop, you can choose how to use yo
or Windows 7 operating 

Note: You cannot create snapshots or use the Undo Disks option for a virtual machine that uses the 
Boot Camp partition. 

CD/DVD Discs and Their Images 
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 can access real CD/DVD discs and images of CD/DVD discs. 

Parallels Desktop has no limitations on using multi-session CD/DVD discs. A virtual machine can 

If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a 

 the ISO, CUE, and CCD formats. 

Parallels Desktop

play back audio CDs without any limitations on copy-protected discs. 

virtual machine. 

Parallels Desktop supports CD/DVD disc images in

Note: DMG disk images made with Mac OS X Disk Utility are also supported by Parallels Desktop. When 
cre  image without any ating such an image, make sure you create a read-only and uncompressed
en n. cryptio

Floppy Disks and Floppy Disk Images 

Parallels Desktop can use two types of floppy disks: 

• Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine. 

• Floppy disk image files having the .fdd extension and connected to the virtual machine. 

Parallels Desktop treats floppy disk images like real diskettes. Parallels Desktop supports floppy 
disk image files that have the .fdd extension and 1.44 MB size. 

 
 

Hardware Settings 
Using the Virtual Machine Configuration dialog, you can configure the virtual hardware available 
in your virtual machine: 

• Configure the devices currently available inside the virtual machine. 

• Add or remove devices. 

• Configure the boot order of your virtual machine. 
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Usi  Order settings, you can configure the virtual machine boot sequence, that is, the 
. 

Boot Order 

ng the Boot
order in which the virtual machine will try to load the operating system from different boot devices

Note: These settings cannot be changed when the virtual machine is running. 

To edit the Boot Order settings, do the following: 

igure. 
1 Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac menu 

bar (in the Crystal view mode) and choose Conf

2 In the Virtual Machine Configuration dialog, click Hardware and select Boot Order in the 
sidebar. 
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• CD/DVD-ROM. Select this device if you want the virtual machine to boot up from the media 
cted to its virtual CD/DVD-ROM drive. 

The currently supported boot devices are listed below: 

• Hard Disk. Select this device if you want the virtual machine to boot up from its virtual hard 
disk drive. 

conne

Note: The virtual machine will use the CD/DVD-ROM drive specified as CD/DVD-ROM 1 in its 
configuration. 

• Floppy Disk. Select this device if you want the virtual machine to boot up from a floppy disk 
disk drive. 

Network Adapter. Select this device if you want your virtual machine to boot from a network 

image connected to its virtual floppy 

• 
adapter using PXE (Pre-Execution Environment). 

Note: The virtual machine will use the network adapter specified as Network Adapter 1 in its 
configuration. 

E ecified as the first one in 
the Boot Order list. If the virtual machine cannot boot from the first device (for example, no media 
is connected to it), the virtual machine proceeds to the second device in the list and tries to boot 
from this device, and so on. 

In this pane, you can perform the following operations: 

• Change the currently set boot sequence by selecting the name of the corresponding boot 
device in the Boot Order list and moving it up or down using the arrows to the right of the list. 

• Remove a boot device from the sequence by clearing the check box next to its name. 

If you choose the Select boot device on startup option, you will see the following message at the 
virtual machine startup: "Press ESC to select boot device". If you press ESC pending 5 
seconds, you will be able to select a boot device. If you do not press ESC, the virtual machine will 
try to boot from the devices specified in the Boot Order list. 

very time you start the virtual machine, it tries to boot from the device sp

Note: Make sure that the device you wish to use for your virtual machine booting (hard disk drive, CD-
ROM drive, floppy disk drive, or network adapter) is available to the virtual machine and configured 
properly. If you do not have any boot devices configured in your virtual machine, you will see the following 
error message after you start the virtual machine: “No boot device is available”. In this case, 
you should stop the virtual machine and configure at least one boot device for it. 

The Boot flags field is intended for specifying the flags that can change the virtual machine system 
behavior. The system flags can be used by the Parallels customer support team in cases when 
something goes wrong in your virtual machine. It is not recommended to type anything into this 
field without being instructed to do so by the customer support staff. 
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icon 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

 at the bottom of the window. The next time someone wants to change the settings in 
password will be required. 

ilable to the virtual machine video card, use 
the Video settings. 

To edit these settings, do the following: 

nu 
in the Crystal view mode) and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Video in the sidebar. 

any pane of Virtual Machine Configuration, an administrator's 
 

Video 

To view and configure the amount of video memory ava

1 Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac me
bar (

Note: en the virtual machine is running. These settings cannot be changed wh
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ory field, you can set the amount of video memory that will be available to the 

• 

Enabling 3D Acceleration 

I  
t lect the Enable 3D acceleration 
option. 

Enabling Vertical Synchronization 

Sometimes in games and 3D applications, a newly rendered frame may overlap a previously 
rendered one and then screen tearing happens. This occurs when the video card or the software 
using it begins updating the actively-displayed memory in a manner that is out of sync with the 
monitor's refresh rate. To prevent screen tearing, select the Enable vertical synchronization 
option. 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon 

In the Video mem
virtual machine. 

To configure the video memory limit, do one of the following: 

• drag the slider 

• use the spin box arrows 

type the value directly into the Video memory field 

f you want to use Windows Aero in your Windows virtual machines or use games and applications
hat require video cards that support DirectX or OpenGL, se

 at the bottom of the window. The next time someone wants to change the settings in 
f Virtual Machine Configuration, an administrator's password will be required. 

 

any pane o
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s. 

To edit the device settings, do the following: 

ual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac menu 

rdware and select this device name in 
the sidebar. 

Floppy Disk 

To view and configure the virtual machine floppy disk drive settings, use the Floppy Disk setting

1 Open the Virt
bar (in the Crystal view mode) and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Ha

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on 
how to add a device, refer to Adding and Removing Devices. 
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 option if you want the floppy disk drive or floppy disk image to be 
d to the virtual machine on its startup. 

e name 

loppy disk image, click the Source field, click Choose an image file, and 
specify the path to the desired floppy disk image file. 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon

Select the Connected
automatically connecte

In the Source field, specify the source device or image file that will emulate the virtual machine 
floppy disk drive: 

• If you want to use a real floppy disk drive, click the Source field and select the real devic
from the list. 

• If you want to use a f

 at the bottom of the window. The next time som eone wants to change the settings in 

 

any pane of Virtual Machine Configuration, an administrator's password will be required. 
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VD 
/DVD images. 

CD/DVD-ROM 

To configure the virtual machine CD/DVD drive settings, use the CD/DVD settings. Virtual CD/D
drives can be connected either to physical CD/DVD drives or to CD

Note: You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI 
devices to a virtual machine. Each device is listed separately in the Virtual Machine Configuration dialog 
and has its own number. 

To edit the device settings, do the following: 

1 Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac menu
bar (in the Crystal view mode) and choose Co

 
nfigure. 

 in 2 In the Virtual Machine Configuration dialog, click Hardware and select this device name
the sidebar. 

Note: l Machine Configuration. For detailed information on  If this device is absent, you can add it to Virtua
how to add a device, refer to Adding and Removing Devices. 
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ected option if you want the CD/DVD drive to be automatically connected to the 
on its startup. 

Select the Conn
virtual machine 

To emulate the virtual CD/DVD drive, you can connect one of the real CD/DVD drives on your 
physical computer or a CD/DVD image file to the virtual machine. 

Note: Parallels virtual machines support ISO and DMG image files and may support CUE and CCD 
image files. 

In the Connect to field, the source device or image file that emulates the virtual machine CD/DVD 
drive is specified. You can change the source device: 

• To use a real CD/DVD drive as the virtual machine CD/DVD drive, click the Connect to field 
e list. 

click the Connect to field and 

In the 

• virtual devices (hard disks or CD/DVD 
drives). 

• SATA. Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD 
drives). 

• SCSI. Using this interface type, you can connect up to 15 virtual devices (hard disks or 
CD/DVD drives). 

and select the real device name from th

• To use an image file as the virtual machine CD/DVD drive, 
choose the image file from the list, or click Choose an image file and specify the path to the 
desired image file on your Mac. 

Location field, you can specify the type of interface for connecting the device: 

 IDE. Using this interface type, you can connect up to 4 

Note 1: The Mac OS X guest OS does not support the SCSI controller. In the latest Linux distributions 
(e.g. RHEL 5.3), the SCSI driver may be not installed. In this case, you should install this driver in your 
Linux guest OS to be able to use the SCSI controller. 

Note 2: The SCSI 7:0 location is not available for selecting, since it is occupied by the SCSI controller 
itself. 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in 
f Virtual Machine Configuration, an administrator's password will be required. 

 

any pane o
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o  to use hard disk images in the .hdd 

Hard Disk 

To view and configure the virtual hard disk settings, use the Hard Disk pane of Virtual Machine 
C nfiguration. Parallels Desktop allows virtual machines
format and Windows Boot Camp partitions. 

Note: You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI 
devices to a virtual machine. Each device is listed separately in the Virtual Machine Configuration dialog 
and has its own number. 

To edit the device settings, do the following: 

1 Shut down the virtual machine. (p. 47) 

2 Open th e Virtual Machine menu and choose Configure. 

e in 3 In the Virtual Machine Configuration dialog, click Hardware and select this device nam
the sidebar. 

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on 
how to add a device, refer to Adding and Removing Devices. 
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I
s  disk source: 

• To use the Boot Camp partition as the virtual machine hard disk, click the Source field and 
select the Boot Camp partition name from the list. 

• To use a virtual hard disk file as the virtual machine hard disk, click the Source field and choose 
the virtual hard disk file from the list, or click Choose an image file and specify the path to the 
desired image file (.hdd) on your Mac. 

In the Location field, you can specify the type of interface for connecting the device: 

• IDE. Using this interface type, you can connect up to 4 virtual devices (hard disks or CD/DVD 
drives). 

• SATA. Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD 
drives). 

n the Source field, the virtual hard disk file (.hdd) that emulates the virtual machine hard disk is 
pecified. You can change the hard

• SCSI. Using this interface type, you can connect up to 15 virtual devices (hard disks or 
CD/DVD drives). 

Note 1: The Mac OS X guest OS does not support the SCSI controller. In the latest Linux distributions 
(e.g. RHEL 5.3), the SCSI driver may be not installed. In this case, you should install this driver in your 
Linux guest OS to be able to use the SCSI controller. 

Note 2: The SCSI 7:0 location is not available for selecting, since it is occupied by the SCSI controller 
itself. 

Co

some 
 disk, free unused space appears on the disk, but the amount of space 

k image file size will be decreased. As a result, there will be more free space on your Mac 
hard disk. 

mpressing the Disk 

If you use an expanding (p. 172) virtual hard disk in your virtual machine, its image file size on the 
physical hard disk increases as you add new data to the virtual hard disk. When you delete 
data from this virtual hard
your virtual machine occupies on the hard disk of your Mac does not reduce. To free the unused 
space back to Mac, click the Compress button. The virtual hard disk will be compressed and the 
hard dis

Note: Compressing can be performed for virtual machines without snapshots and with the Undo disks 
option disabled. 

In the Optimization pane of Virtual Machine Configuration, you can enable regular automatic disk 
compression. 

Editing the Disk 

If you find that the capacity of your virtual machine hard disk does not fit your needs anymore, you 
can change its size. Click the Edit button and the dialog for changing the disk size will appear. 
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Note: If your virtual machine is running, has snapshots, or uses a Boot Camp partition as a hard disk, its 
virtual hard disks cannot be resized. 

 

change the disk size, drag the slider or type the new size in the Size field. Select the Res
tem option if you want to change the file system size: 

If you select the Resize file system option whe

To ize file 
sys

• n increasing the disk size, the additional disk 
space will be added to the last volume. If you clear the Resize file system option, the added 

o 
r create a new partition or expand an existing partition. 

For instructions on allocating the added space, please refer to the guest OS documentation. 

• If you select the Resize file system option when decreasing the disk size, the disk will be 
decreased via removing the unallocated space and decreasing the size of the disk partitions. If 
you clear the Resize file system option when decreasing the disk size, you will be able to 
remove the unallocated space of the disk only and the disk partitions will remain untouched. 

If the format of the virtual hard disk is expanding, you can convert it to plain by clearing the 
Expanding disk option. 

If you want the virtual hard disk to be split, select the Split the disk image into 2 GB files option 
option. 

space will appear as unallocated space and will be invisible to the guest operating system. T
allocate this space, you will have to eithe

Note: For more information about virtual hard disk types, please refer to Support for Virtual and Real 
Disks (p. 172). 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in 
f Virtual Machine Configuration, an administrator's password will be required. 

 

any pane o
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Hard Disk 

me 
pace appears on the disk, but the amount of space 
k of your Mac does not reduce. To free the unused 

d c n your Mac's hard disk. 

• To compress the virtual hard disk manually at any time, select Configure from the Virtual 

• Automatically compress virtual 
disks option. The virtual hard disk in an expanding format will be reviewed twice a day, and, if 
the unused space occupies more than 50 percent of the hard disk image size, it will be 
compressed and the hard disk image file size will be decreased. The Automatically compress 
virtual disks option can be enabled for all hard disks of a virtual machine in the Optimization 
pane of Virtual Machine Configuration. 

Compact a Virtual 

If you use an expanding (p. 172) virtual hard disk in your virtual machine, its image file size on the 
physical hard disk increases as you add new data to the virtual hard disk. When you delete so
data from this virtual hard disk, free unused s
your virtual machine occupies on the hard dis
space back to Mac, you can compress the virtual hard disk. The hard disk image file size will be 

e reased and, as a result, there will be more free space o

You can compress virtual hard disks either manually or automatically: 

Machine menu, click Hardware, open the hard disk setting, and click the Compress button. 

 To regularly free the unused space back to Mac, use the 

Note: Compressing of virtual hard disks can be performed for virtual machines without snapshots and 
with the Enable Undo disks option disabled. 
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1 lick (Option-click) the Parallels icon in the Mac menu 

Network Adapter 

Using the Network settings, you can change the network type used in your virtual machine. 

To edit the device settings, do the following: 

Open the Virtual Machine menu or Alt-c
bar (in the Crystal view mode) and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in 
the sidebar. 

No n on te: If this device is absent, you can add it to Virtual Machine Configuration. For detailed informatio
how to add a device, refer to Adding and Removing Devices. 
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pter 

 
ion 

etwork to learn how to configure this network type. 

• Bridged Network. Select this option to allow the virtual machine to access the local network 

lone computer on the network and should be 
configured in the same way as a real one. You can choose the physical adapter where the 

the list below the Bridged Network option. 

• ual machine to connect to the host 

See Host-Only Network to learn how to configure this network type. 

s currently assigned to the virtual 
machine. MAC addresses are automatically generated during the virtual machine creation. 
However, you can modify the default MAC address by typing another value in the MAC address 
field or clicking the Generate button. When entering a new MAC address, make sure that it is 
unique within your network. 

Wi-Fi Bridging Support 

To be able to connect to wireless networks from your virtual machine: 

1 Click the Type field. 

2 Choose the AirPort adapter from the Bridged Network list, and click OK to apply the 
changes. 

After you perform these steps, your virtual machine will be able to connect to the Internet through 
the AirPort adapter of your Mac. 

When you try to connect to the Internet via Wi-Fi, and the Wi-Fi Access Point has the Validate 
DHCP packets option enabled, you may experience problems connecting to the Internet. In this 
case, enable the Send the host's MAC address to DHCP server o  to ensure that your virtual 
machine gets an IP address for accessing the Internet. 

Select the Connected option if you want the virtual machine to start up with this network ada
connected. 

You can choose one of the following network types for the virtual machine network adapter: 

• Shared Network. Select this option to enable the Network Address Translation (NAT) feature
for the virtual machine. In this case, your virtual machine will share whatever network connect
is currently used by the host computer. 

See Shared N

and Internet through one of the network adapters installed on the host computer. In this case, 
the virtual machine is treated as a stand-a

virtual machine adapter will be bridged in 

See Bridged Ethernet Network to learn how to configure this network type. 

Host-Only Network. Select this option to allow the virt
computer and the virtual machines residing on it and to make it invisible outside the host 
computer. 

In the MAC address field, you can change the MAC addres

 ption

Note: Enabling the Send the host's MAC address to DHCP server option will not work with some 
DHCP servers - your virtual machine may get the same IP address as the physical computer. 
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g another network mode: Shared Network mode or Host-Only Network mode. 
If you cannot configure your virtual machine to work in the Bridged Ethernet mode, you can 
consider usin

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in 
any pane of Virtual Machine Configuration, an administrator's password will be required. 

rtual 
three printer ports. 

1 Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac menu 

2 d select this device name in 

 

Printer Port 

Using the Printer Port settings, you can configure the virtual machine printer port settings. A vi
machine can have up to 

To edit the device settings, do the following: 

bar (in the Crystal view mode) and choose Configure. 

In the Virtual Machine Configuration dialog, click Hardware an
the sidebar. 

N te: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information oo n 
how to add a device, refer to Adding and Removing Devices. 
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ected option if you want the virtual machine to start up with the printer port 

 USB port type. 
Connecting a printer to a virtual machine via USB ensures faster data transfer rate than connecting 

Select the Conn
connected. 

In the Port field, choose the port type. If available, you're recommended to use the

it via LPT. 

Notes: 

1. You can connect up to 6 USB and up to 3 LPT printers to a single virtual machine. 

2. You can connect a USB printer only if your virtual machine has a USB controller (p. 194). If not, you 
can easily add it (p. 169). 

In the Source field, the source device that emulates this printer port is specified. A printer port can 

irtual machine. Click 

For the detailed information on how to set up a printer in your virtual machine, please refer to 

y using an output file. Click the 
Source field and choose an output file from the list, or click Choose an output file and specify 

 

be emulated by one of the following devices: 

• Printers. You can use any of the printers connected to your Mac in your v
the Source field and select the appropriate printer from the list. 

Print from Windows (p. 85). 

• Real printer port. If your Mac has a physical printer port, you can connect it to your virtual 
machine. Click the Source field and select the physical port name from the list. 

• Output File. You can emulate the virtual machine printer port b

the path to the desired output file on your Mac. 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

icon  at the bottom of the window. The next time someone wants to change the settings in 
f Virtual Machine Configuration, an administrator's password will be required. any pane o
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Serial Port 

In the Serial Port pane, you can configure the virtual machine serial port settings. 

To edit the device settings, do the following: 

1 Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac menu 
bar (in the Crystal view mode) and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in 
the sidebar. 

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on 
how to add a device, refer to Adding and Removing Devices. 

Using serial ports, you can establish a connection between: 

• The virtual machine and the host computer devices (using a real port); or 

• Between two virtual machines located on the same host computer (using a socket). 

d by a real port. The Source list comprises the devices on the host computer that are 
 

machine status bar. 

ort 

wo
pan

If yo
use
the computer. You will be able to view and analyze the activity history of the virtual 
machine any time you need by exploring this file. 

You al machine using Add Hardware Assistant. For the 

If you want to connect your virtual machine to the host computer device, you should create a serial 
port emulate
available for connection. The connected device, being used in any virtual machine, cannot be used
by the host computer. To be able to use it in the host computer, you should first disconnect it from 
the virtual machine. To do that, use the virtual 

If you want to connect two virtual machines with each other, you need to create a serial p
emulated by a socket in each virtual machine. The names of the serial ports should be identical. 
The connection between the virtual machines via serial ports is bidirectional. It means that the 

rking modes of the sockets set during the port creation can be changed later in the Serial Port 
e. 

u need to log the performance activity of your virtual machine or to record the data from it and 
 this information later on, you can connect your virtual machine serial port to an output file on 
 physical 

 can add a new serial port to your virtu
instruction on how to add serial ports, refer to Adding and Removing Devices. 

Note: You can connect up to four serial ports to a virtual machine. 
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Select the Connected option if you want the virtual machine to start up with the serial port 
connected. 

In the Source field, the source device that emulates this serial port is specified.Serial ports can be 
emulated by the following devices: 

• Real Port. To connect the virtual machine serial port to one of the existing serial ports on the 
host computer, choose the appropriate port on the host computer in the Source list. 

• Socket. To connect two virtual machines through the sockets, click the Source list and choose 
the appropriate socket. If there are no sockets available, click New socket and specify its name 
in the Enter a socket name field. 

You should also configure the role the virtual machine will play in the connection by selecting 
the necessary role in the Mode list. Selecting Server enables you to use this virtual machine to 
direct the other one. Selecting Client enables you to direct this virtual machine from the other 
one. 

Note: If you change the socket mode of the first virtual machine, make sure the socket mode of the 
second virtual machine is also modified. 

• Output File. To connect the virtual machine serial port to an output file, click the Source list 
and choose the appropriate output file. You can also click Choose an output file to locate the 
necessary file. 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in 
f Virtual Machine Configuration, an administrator's password will be required. 

 

any pane o
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d 
device parameters. 

 

 In the Virtual Machine Configuration dialog, click Hardware and select this device name in 

Sound 

The Sound pane of Virtual Machine Configuration allows you to configure the virtual machine soun

To edit the device settings, do the following: 

1 Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac menu
bar (in the Crystal view mode) and choose Configure. 

2
the sidebar. 

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on 
how to add a device, refer to Adding and Removing Devices. 
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e Connected option to have the sound device automatically connected on the virtual 
tup. 

• Default. Select this option if you want to use the input device set as default in Mac OS. 

 you want to use the built-in microphone. 

• evice. 

Use ist to choose the necessary device. You can choose one of the following devices: 

e of the output devices from your Mac. 

• Null device. Select this option if you want to mute the output device. 

Select th
machine star

Use the Input list to choose the necessary device. You can choose one of the following devices: 

• Built-in Microphone. Select this option if

• Built-in Input. Select this option if you want to use one of the input devices from your Mac. 

Null device. Select this option if you want to mute the input d

 the Output l

• Default. Select this option if you want to use the output device set as default in Mac OS. 

• Built-in Output. Select this option if you want to use on

Note: If you have a 5.1 or 7.1 surround-capable sound card connected to your Mac, you can use it in 
Windows (p. 199). 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in 
f Virtual Machine Configuration, an administrator's password will be required. 

 

any pane o
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USB 

hich provides you with the possibility to 
the virtual machine. 

To edit the device settings, do the following: 

 menu 
bar (in the Crystal view mode) and choose Configure. 

evice name in 

A virtual machine can emulate only one USB controller, w
connect up to eight USB 2.0 and five USB 1.1 devices to 

1 Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac

2 In the Virtual Machine Configuration dialog, click Hardware and select this d
the sidebar. 

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on 
how to add a device, refer to Adding and Removing Devices. 

 

In the USB Controller pane, you can: 

• see the USB devices currently connected to your virtual machine, and 

• disable camera sharing 

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock 

icon  at the bottom of the window. The next time someone wants to change the settings in 
f Virtual Machine Configuration, an administrator's password will be required. 

 

any pane o



 

If you're having trouble using Parallels Desktop, check this section for possible solutions. 

If you don't find the solution to your problem here, see More Resources (p. 206). 
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 Seamless Operation 
 OS X 

Par
Par

• n Windows and Mac OS X 

• 

• 

Install Parallels Tools for
Between Windows and Mac
Many issues with using Parallels Desktop can be solved by installing Parallels Tools. 

allels Tools help you work with Windows in the most comfortable and efficient way. With 
allels Tools, you can: 

Move the mouse seamlessly betwee

• Synchronize the Windows time and date settings with those of Mac OS X 

Share your Mac OS X disks and folders with Windows 

Copy text and drag and drop objects from Mac OS X to Windows and vice versa 

Important: Once you install Parallels Tools and restart Windows, you don't have to do anything else. 
Parallels Tool on or configuration on your part. s automatically just work, without any acti

To install Parallels Tools: 

1 Start Windows (p. 41). 

2 Choose Virtual Machine > Install Parallels Tools and follow the onscreen instructions. 

For more information on installing and updating Parallels Tools, see Parallels Tools for Windows (p. 
146). 
 

I Can't Activate Parallels Desktop 
You must activate Parallels Desktop to be able to use all of its features. 

If you are having trouble activating Parallels Desktop, try the following: 

• Make sure the activation key you're using is for the version of the software being installed.  

• Make sure you're entering the key correctly.  

If you purchased and downloaded Parallels Desktop from the Internet, you received an 
activation key via email. For best results, copy and paste the key from the email. 

If you have a boxed copy of Parallels Desktop, the key is printed on the DVD sleeve. Make sure 
you enter the entire key (30 characters). Dashes are added automatically. 

• If still can't activate Parallels Desktop, check this Knowledge Base Article for an extended list of 
solutions. 
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Windows Se

• 

in Applications > Utilities) to see how much of your Mac's memory each 

 

 allocated to Mac OS X, then Mac OS X applications may run well 
but Windows programs might slow down.  

To optimize the performance of both Windows and Mac OS X, set the memory allocated to 
Windows (p. 104) to be somewhere within the recommended range, indicated by the graphic 
under the memory slider in the General configuration panel (see below). 

ems Slow 
If Windows performance seems slow, try the following: 

Quit applications and programs you aren't using: If you run a number of memory-
consuming applications and programs simultaneously, Windows performance may become 
slow. Quit any applications that you aren't using. You can also use Activity Monitor (located in 
the Mac OS X Finder 
application is using. That way, you'll have a better idea of which applications cause 
performance to degrade the most. 

• Change how much memory is allocated to Windows: Parallels Desktop is set to allocate a
certain amount of your Mac's available RAM memory to Windows and the rest to Mac OS X. If 
too much memory is allocated to Windows, Mac OS X may slow down, which in turn can cause 
Windows programs to slow down because they're running on top of Mac OS X. If, on the other 
hand, too much memory is

 



198 
 

Tips and Troubleshooting 
 

•  Antivirus software may slow down your virtual machine: Windows may become slower 
after you install antivirus software. To be protected, you have to sacrifice performance. 

Note: Do not install more than one Windows antivirus program. 

• Run fewer virtual machines at once: If you are running multiple operating systems at once 
using Parallels Desktop, stop one or more of them to improve performance of the others. 

mance will be lower than if it were 

To speed up Windows, select  in the 

ges in the Advanced pane of 
Parallels Desktop Preferences, Parallels Desktop will start creating a more detailed log file. It can 

t uses more hard disk space and may slightly lower 

 

• Run Windows locally: If you start Windows stored on an external storage device connected to 
your Mac (for example, an external USB disk drive), its perfor
stored on your Mac. 

• Tune Windows for speed: Tune Windows for speed
Optimization pane (p. 106). 

• Disable log messages: If you select Use detailed log messa

be helpful for the Parallels support team, bu
the system performance. 
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onfigure 5.1 or 7.1 Surround Sound in a Virtual 

your Mac (via USB or FireWire), 

Con

 X: 

 Start the Audio MIDI Setup application (you can find it in /Applications/Utilities). 

.1 or 7.1 surround-capable sound card and choose the necessary sample rate 
and bit depth from the Format pop-up menus. 

C
Machine 
If you have a 5.1 or 7.1 surround-capable sound card connected to 
you can use it in your virtual machine. Follow these steps: 

Step 1. Configure the sound card in Mac OS X. 

Step 2. Select the sound card as the sound output device in the virtual machine configuration. 

Step 3. Configure the sound card in the guest operating system. 

figure the sound card in Mac OS X 

To configure a sound card in Mac OS

1

2 Select your 5

Note: Make sure these settings match the appropriate settings for the sound card. 

3 Click Configure Speakers, select Multichannel and choose
the pop-up menu. 

 the necessary type of output from 

 Set this sound card as the default output device in Mac OS X: select it in System Preferences 
nd > Output. 

uration 

Mac OS X, select it as the sound output device in the 

1 Do one of the following: 

4
> Sou

Select the sound card as the sound output device in the virtual machine 
config

After you have configured the sound card in 
virtual machine configuration: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Configure. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine 

3 Make sure the Connected option is selected. 

 Choose Default from the Output menu. 

Configure the sound card in the guest operating system 

> Configure. 

2 Click Hardware and select Sound. 

4
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Configure the sound card in the guest operating system. 

 

k Finish. 

4 On the Playback tab, select Parallels Audio Controller again and click Properties. 

5 

 

In Windows 7/Vista: 

1 Click Start > Control Panel > Hardware and Sound >Sound. 

2 On the Playback tab, select Parallels Audio Controller and click Configure. 

3 Select 5.1 Surround or 7.1 Surround (depends on your sound card), click Next several times, 
and then clic

Click the Advanced tab and choose the sample rate and bit depth. 

Note: The specified settings shouldn't be higher than the same settings specified in the Audio MIDI 
Setup application in Mac OS X (described above). 

6 When ready, click OK twice.  

 On the Speakers tab, select the necessary speaker setup. 

use the 5.1 or 7.1 surround-capable sound card in 

'm Having Problems Connecting to the Internet 
When you install Windows, it is automatically configured to share your Mac's Internet connection. 
For details on configuring Windows' network and Internet connection, see the section on 
connecting to the Internet or a network (p. 99). 

 
 

 

In Windows XP: 

1 Click Start > Control Panel and double-click Sound and Audio Devices. 

2 On the Volume tab, click Advanced in the Speaker settings section. 

3

 

In Linux: 

You can try to follow these general guidelines to 
Linux: 

1 Click System > Preferences > Sound. 

2 On the Hardware tab, choose the necessary speaker setup from the Profile menu. 
 

I
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rus Software 
p 

To prevent the antivirus software from blocking Parallels Desktop processes, perform a full system 
p 

processes to the list of ses. For information on how to do this, refer to your antivirus 

I'm Having Problems with Antivi
Because of the close integration between Parallels Desktop and Mac OS X, some Parallels Deskto
processes may be detected as malicious by antivirus software installed on your Mac. 

scan using the antivirus software, and then  if no viruses are detected, add the Parallels Deskto
trusted proces

software Help. 

Impor tart with prl or parallels. tant: The names of Parallels Desktop processes usually s
 

The F8 Key Isn't Working Correctly 
In Ma
featu

c OS X, the F8 key and Ctrl+arrow key combination are reserved for triggering Spaces (a 
re that lets you organize your windows on multiple desktops). Because of this, the F8 key and 

s settings. See Mac Help for more 
mation. From the Finder, choose Help > Mac Help or Help > Help Center and search for 

A Password is Required to Open the Virtual 
Machine Configuration 
In Parallels Desktop 7 activated with the volume license product key, virtual machine configuration 
can be password protected from being viewed and edited. 

So if you're requested to enter the password to open the virtual machine configuration and you 
don't know it, contact the person who gave you this virtual machine (in most cases, it's your 
system administrator). 
 

Ctrl+arrow key may not function correctly with Windows programs. 

If you are experiencing this problem, change the Spaces hotkey
infor
"Spaces." 
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network in Linux, you may need to configure the DHCP client to send the virtual 
machine's ID in DHCP requests. For information on how to configure your DHCP client, refer to the 

 the DHCP client configuration file. 

Configuring a Network in Linux 
When setting up 

DHCP client documentation. 

For example, in Red Hat Linux guest OSs, you need to edit

1 Open the dhclient.conf file and make sure that the following lines are present. 
interface "eth0" { 
 send dhcp-client-identifier 1:<MAC address>; 
}  

2 If there are no such lines, add them manually to the file and save it.  

ntains these lines, DHCP client sends the virtual machine's ID to 
 response. 

When the dhclient.conf file co
the DHCP server. The DHCP server sends an IP address in

Tip 

To locate the dhclient.conf file, in a terminal, enter: 

strings /sbin/dhclient | grep etc | grep dhclient.conf 

or: 
rpm -ql dhclient 
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ources 

 
 

distribution disks. 

d kernel sources in the RHEL/Fedora/CentOS Linux distribution, enter 
the following command in a terminal: 

Installing the GCC Package and Kernel S
in Linux 
When installing or upgrading Parallels Tools in a Linux virtual machine, you may need to install the
gcc package and kernel sources in your Linux guest OS. Kernel sources can be either downloaded
from the Internet or installed from Linux 

To install the gcc package an

yum install gcc kernel-devel 
mak

rces in the Debian/Ubuntu Linux distribution, enter the 
follo

e 

To install the gcc package and kernel sou
wing command in a terminal: 

apt-get install gcc make linux-headers-$(uname -r) 

For information on how to install the gcc package and kernel sources in other Linux distributions, 
refer to the documentation for these distributions. 

If you still experience any problems, try to find a solution in Parallels Knowledge Base 
(http://kb.parallels.com/) or refer to the Parallels support team 
http://www.parallels.com/en/support/desktop/. 
 

Checking the Build Number 
To check the version and build number of the Parallels Desktop software you are using, do one of 
the following: 

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose About Parallels 
Desktop.  

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop 
> About Parallels Desktop. 

A window appears showing the build number. 

Note: The window that appears also provides you with other useful information about your copy of 
Parallels Desktop, including the licensing information and a link to the Parallels support web page. 
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Report a Problem and Request Support 
To h

hut down because of an error, Parallels Desktop automatically opens a 
Problem Report for Parallels Desktop form. If you notice unusual behavior in Parallels Desktop, 
you can also create a report manually. 

To create a problem report: 

1 If Parallels Desktop is in Coherence mode, click the Parallels icon 

elp improve the quality of Parallels Desktop , you can send problem reports to Parallels.  

If Windows is forced to s

 in the menu bar and 
choose Exit Coherence. 

2 Choose Help > Report a Problem.  

Parallels Desktop creates a status report and a screenshot of the software. 
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roblem you're having from the Specify the problem type menu, and fill out 
the form. 

3 Select the type of p

Note: You can review the problem report components that will be sent to the Parallels support team 
and deselect some of them in the Parallels Problem Report Details window, if desired. To open this 
window, click See Details. 

4 Click Send Report. 

 

Parallels team uses error reports to improve the product quality but doesn't respond to them unless
you request support (see below). 

 

To contact the Parallels 

e steps above to create and send a problem report. 

3  contacted by 

4 

 

 

Request Support 

support team to request help with your problem: 

1 Follow th

2 Click Request Support. 

Your support code is displayed. Write it down for reference in case you are
Parallels Support. 

Click Get Support. 



 

For more information and help using Parallels Desktop, see the following resources:  

) 

 Parallels Knowledge Base: This online resource (http://kb.parallels.com/) has valuable articles 
about using Parallels Desktop and other Parallels products. 

• Online documentation: You can find PDF user guides for Parallels Desktop and Parallels 
Transporter online by choosing Help > Online Documentation. 

• Parallels Command Line Reference Guide: This document, available on the Parallels Online 
documentation page, has information on using the prlctl command line utility to manage 
Parallels Desktop and its virtual machines from a terminal. 

• Parallels API references and the SDK programmer's guide: These guides for IT-
professionals can be found on the Parallels Online documentation page. 

Feedback 

• Parallels welcomes your feedback on how to make our documentation more helpful. You can 
submit feedback using the Documentation Feedback form on our website 
(http://www.parallels.com/en/support/usersdoc/). 

In This Chapter 

Visit the Parallels Desktop Twitter and Facebook Pages............................................206 
Visit the Parallels Convenience Store.........................................................................207 

 
 

Visit the Parallels Desktop Twitter and Facebook 
Pages 
To keep up with the latest news and updates, you can visit the Parallels Desktop Twitter and 
Facebook pages. Choose Parallels Desktop > About Parallels Desktop and click Our Twitter or 
Facebook page. 
 

C H A P T E R  7  

More Resources 

• Parallels support website: The Parallels support website (http://www.parallels.com/support/
includes product help files and a FAQ section. 

 

•
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Visit the Parallels Convenience Store 
nience store, you can purchase and download various commercial and free 

applications. 

To access this store, do one of the following: 

In the Parallels Conve

• Option-click (Alt-click) the Parallels icon  in the menu bar and choose Convenience Store. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose File > 
Convenience Store. 
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 and spells out abbreviations used in Parallels Desktop documentation. 
References to terms defined elsewhere in the glossary appear in italics. 

Glossary 

This glossary defines terms
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Activation key. A unique set of symbols that activates the Parallels Desktop application on your 

 operating system where Parallels Transporter Agent is launched. 

Boot Camp partition. A partition on the hard disk of your Mac that can be used for installing a 

ables the virtual machine to 
appear as any other computer on the network, with its own IP address and network name. 

 hardware configuration, the devices it uses, 
and other settings. It is created automatically when you create a new virtual machine. See also PVS 

r. 

Disks in the old format. Disks of virtual machines that were created in Parallels Desktop 2.5 and 

Disks in the new format. Disks of virtual machines that were created or used in Parallels hardware 

Expanding format. A virtual hard disk format. An expanding virtual hard disk image file resides on 

FireWire connection. A wired connection that enables a high-speed data transmission between 

Guest operating system (guest OS). An operating system installed inside your virtual machine. 

 machines. In case of Parallels Desktop for 
Mac, it is your Mac. In case of Parallels Desktop for Windows or Parallels Desktop for Linux, it is the 

ls 
. 

Hot key. A user-defined key or combination of keys that provides quick access to applications and 
commands. See also Shortcut. 

Administrator. A user with administrative privileges. 

Mac and lets you use the Parallels Desktop functionality to its full extent. 

Active operating system. The

Active volume: The volume of the physical source computer that is used as a boot volume for the 
active operating system.  

Bootable hard disk. A disk used by the operating system to boot from, usually a disk that has an 
operating system installed. 

Boot Volume. A hard disk partition from which the operating system boots. 

Windows operating system on it (for Mac host computers only). 

Bridged networking. Virtual machine network connection mode that en

Configuration file. A file specifies the virtual machine's

file.  

CPU. Stands for central processing unit. It is an internal part of the computer. See also Processo

earlier or Parallels Workstation 2.2. 

virtualization products starting from version 3.0. 

your host computer and is small initially. Its size grows as you add applications and data to the 
virtual machine. 

computers. 

Host computer: The computer that is used to run virtual

Windows- or Linux-based physical computer where Parallels Desktop is installed. In the Paralle
Transporter documentation, this term may define the computer that hosts the result of migration
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Host-only networking. Virtual machine network connection mode that creates a private network 
 available 

from the host computer only. 

he entire contents of a CD or DVD disc commonly used to 
install an operating system. 

. 

Merged disk. A split disk whose parts were merged into a single disk. 

e process of transferring data from a physical computer or a third-party virtual 
machine into a Parallels virtual machine or virtual disk. 

Parallels Desktop for Mac. An application that enables you to create, manage, and use virtual 

Parallels Mounter. An application that enables you to to browse the contents of your virtual 

Parallels Tools. A set of Parallels utilities that ensures a high level of integration between the 

 a 
d 

Parallels Transporter Agent. An application that collects data on a physical computer and 

 virtual hard disk image file resides on the host 
computer and has a fixed size that cannot be changed. 

vironment to boot computers using a network 
interface independently of available data storage devices (like hard disks) or installed operating 

HDD file. During the creation, the virtual machine acquires a virtual hard disk file with the .hdd 
extension. See also virtual hard disk file. 

between the host computer and its virtual machines, which makes the virtual machines

ISO image. A special file that contains t

Image file. A single file containing the complete contents and structure of a data storage medium 
or device, such as a hard disk drive, CD, or DVD. 

IP address. A unique address that is assigned to a physical computer or a virtual machine that 
participates in computer networking

Linux computer. A physical computer that has a Linux operating system installed. 

Migration. Th

OS. An operating system. 

machines on your Mac. 

machines and virtual hard disks directly in Mac OS X Finder. 

primary and the guest operating systems. 

Parallels Transporter. An application that uses data of a physical or virtual computer for creating
Parallels virtual clone of this physical or virtual computer. The resulting virtual machines can be use
with Parallels Desktop. 

transfers it to Parallels Transporter installed on your Mac. 

Plain format. A virtual hard disk format. A plain

Preboot Execution Environment (PXE). An en

systems. 
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erating system of 
the physical computer where the Parallels Desktop application is installed. 

Processor. The central processing unit, or CPU. It is an internal part of the computer. 

S file. A virtual machine configuration file that contains information about the virtual machine 
sources, devices and other settings. 

Shared networking. Virtual machine network connection mode that allows the virtual machine to 
use the host computer network connections. In this mode, the virtual machine is invisible to other 
computers on the network the host computer belongs to. 

Shortcut. A user-defined key or combination of keys that provides quick access to applications 
and commands. See also Hot key. 

Snapshot. A copy of the virtual machine state at a particular point of time. The files related to 
snapshots are stored in a special subfolder in the virtual machine's folder. 

Source computer. The computer from which you are going to migrate data using Parallels 
Transporter. 

Split disk. A split disk is cut into 2 GB pieces, but is stored as a single HDD file. Split disks allow 
you to transfer the data stored on a split disk piece by piece using a USB drive or other media that 
have limited space and cannot store a large virtual hard disk image file. 

Terminal. In Mac OS and GNU/Linux operating systems, a utility that enables you to access the 
command line. 

Third-party virtual machine. A virtual machine created in a third-party virtualization product, that 
can be converted to a Parallels virtual machine with the help of Parallels Transporter. 

Virtual hard disk (virtual disk). A file that emulates the virtual machine's hard disk. 

Virtual Machine. The computer emulated using Parallels Desktop. A virtual machine has its own 
virtual hardware and requires an operating system to control its hardware. The installed operating 
system and its applications are isolated inside the virtual machine and share physical hardware 
resources of the host computer. 

Virtual Machine Configuration. Like any physical computer, a virtual machine has its own 
configuration which is set during the creation and can be later modified. The virtual machine 
configuration settings are stored in a PVS file. 

Virtual machine files. Files stored in a virtual machine folder. A virtual machine has at least two 
files: configuration file and virtual hard disk file. 

Virtual hard disk file. During the creation, the virtual machine acquires a virtual hard disk file with 
the .hdd extension. This file performs the functions of a real hard disk. See also HDD file. 

Primary operating system (primary OS). Operating system that controls the I/O devices of the 
computer and that is loaded when the physical computer is turned on. It is the op

PV
re
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Virtual machine template. A virtual machine that can be cloned to multiple virtual machines that 
will have the same configuration and data that the virtual machine template had. 

al Machine. 

Windows computer. A physical computer that has a Windows operating system installed. 

 

VM. See Virtu
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