
ProVision - Job Aid
Getting Started with ProVision Tool Suite - ADA



Overview 
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User Registration
• Using Internet Explorer, go to www.provision.avaya.com.  Click the New User?

Register Now link.

• Email ProVision team (provisionteam@avaya.com) to inform about your recent
registration.

• You will receive an email with the login credentials once your application to register
has been successfully verified.

• Return to www.provision.avaya.com and log in using the user ID and password you
have received from the ProVision administration.

• Navigate to About ProVision -> Download.

• Follow the instructions to register as an Avaya Associate, Business Partner, or
Customer.

This job aid describes the work instructions tasks you can perform while migrating 
CS1000 data to Avaya Aura CM and SMGR, using Nortel Migration Tool (NMT). The 
document also covers steps on how to get started with ProVision Tool Suite via ProVision 
portal.

www.provision.avaya.com
mailto:provisionteam@avaya.com
www.provision.avaya.com


2 

Copyright © 2018 Avaya Inc. All Rights Reserved.

• Read and accept the ProVision usage terms and conditions.
• Click the link associated with latest version of ProVision.

• A new tab will open with the Avaya ShareFile location of the ProVision installer (.EXE).
• Click the Download button.

• Click the Download link on the next page.

• Choose either Run (fully automated install process), or Save (to install sometime after
download completes).

• Locate the ProVision installer in your Downloads folder, right-click and select Run
as administrator.
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• ProVision installation will proceed with little user interaction. Always, choose default
settings, when prompted.

• ProVision requires Administrator privileges to run properly. To ensure ProVision is
always started with administrator privileges, use Windows Explorer and navigate to
C:\Program Files (x86)\Avaya\ProVision\bin directory.

• Right-click on the ProVision.exe file and select Properties.

• Click the Compatibility tab and tick the Run this program as an administrator checkbox.

• Click OK to save this change.
• Start ProVision by double-clicking the desktop icon, or using Windows Explorer.

• On initial start-up, ProVision will display the License Warning window.



• Click the License Now button to begin the licensing process
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• ProVision will now display the Subscription Activation window.
• In the Copy your Locking Code section, click the Copy button to select the

Locking Code listed in the text box.

• Return to www.provision.avaya.com and log in using the user ID and password you
recently created.

• Navigate to Licensing -> Manage.

• Read and accept the ProVision usage terms and conditions.
• On the Unlock a New Subscription page, paste the Locking Code in the textbox and

click the UNLOCK button.

• On the Manage – ProVision License Key page, highlight and copy the License Key.

www.provision.avaya.com
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• From ProVision, on the ProVision Subscription Activation window, locate
the Paste Your License Key section.

• Paste your License Key in the provided text box.

• Click the Submit button and then click the OK button.

• Save the following ProVision project archive (PVA) to any known Device Adapter
project folder on your machine.

o Avaya Device Adapter PVA
• Enter the access information, click the Continue button, and then click the

Download button.

• Start ProVision and select Tools -> Restore.

https://provision.avaya.com/iProVision/secured/downloads/default.aspx?docID=644
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• Navigate to and select the previously saved PVA.

• Restore the saved PVA to the root of ProVision Explorer tree (your computer name,
example highlighted below).

• The PVA will unzip and the restored Device Adapter project will be visible in
your ProVision Explorer window.



ProVision Online Training
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• Return to www.provision.avaya.com and log in using the User ID and password you
recently created.

• Navigate to Training & Support -> Online Training.

• Complete the following training modules located on that training page:
o What is ProVision
o Introduction to ProVision
o Connecting to a Switch Using ProVision
o Using Grids and Forms in ProVision
o Setting Up and Managing Projects in ProVision
o Using Models

www.provision.avaya.com
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ProVision - Retrieve from CS1K
• System properties for the source CS1K need to be applied. Use the following as

an example, to ensure successful connection:

• To capture MGC information, be sure to enter proper PDT shell credentials. If PDT
shell access is unavailable or not required, simply uncheck the checkbox. Use the
following as an example, to ensure successful connection:

• Retrieve CS1K Data to Provision using predefined transactions available in the
Source CS1K folder:
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• Carefully review both ‘cs mgc’ and ‘cs mgc ports’ tables, to verify MGC data retrieved
from PDC shell and make any data changes deemed necessary. Both tables are
located in the config folder of the source CS1K project. During the NMT run, these
tables will be referenced in order to create an MGC XML file that can be imported into
the target Aura SMGR.



• NMT can be launched, after starting ProVision, from the Tools menu.

Nortel Migration Tool 

• NMT main interface requires information in order
to begin the migration.

o Customer Name and Description fields,
mainly for post-migration reports.

o Source Nortel CS1K CUST number to be
migrated.

o Additional Extension Pool  (ex:
9000-9999):
 A range used to create stations with

unique primary extension.
o Optional Feature Key Label (FKL)

migration:
 Requires database.rec file retrieved

from source CS1K
o ProVision project configuration (Config)

folders:
 Source Nortel CS1K
 Target Avaya Aura CM & Target

Avaya Aura System Manager (ASM)

o Completely read the NMT Help Documentation.
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• Once NMT starts, an intermediate progress window will appear, providing the following;
o Grid with overview of modifications made to facilitate CS1K set to Aura (CM)

stations.
o Ability to view all logs and a report, in Excel format (Log and Report buttons).
o Next button to continue migration after review.
o Close button to return to main UI window.
o Help button which launches help window.

• The next window provides a grid where the converted CS1K sets are assigned an
Aura (CM) station type and SIP domain.

• The station type is taken from the target project’s CM model form and the SIP domain
is provide by the customer.
Note: Only assign model and domain to CS1K sets that will be migrated. This is
especially important for “phased” migrations, where sets are migrated together in
groups and the others are left for later phases.



• The model form is located in the config folder of the target CM, within the ProVision
migration project.

• Models are templates that define global attributes for groups stations related to the target
ProVision project.

• Models should be created during target Aura solution configuration, before NMT is used.

• Points to consider before CS1K collapse and TN replacement:
• CM dial plan must include extension range for each CS1K collapse

o All Endpoint primary extensions – NMT renumbering feature (prefixing) may be
useful

o “Free Extension Pool” range for non-MARP and orphaned extension (not primary on
any endpoint)

• CM 'coverage answer path' starting point has to be known and entered in NMT, before
each migration

• Initial CS1K-to-ADA migration drives available Loop+Shelf availability
• Table 'cs issp' must be retrieved from each CS1K, as NMT verifies version to properly

convert TNs
o Checking for CS1KM or CS1KE.
o Can be manually edited, if necessary

• TN replacement format required in mapping file:
o CS1KM - Original TN Loop + Shelf => Replacement TN Loop Ex. (008 0, 016)
o CS1KE - Original TN Loop + Shelf => Replacement TN Loop + Shelf (008 0, 016 0)

• (CS1KM) Replace TNs dialog:  Use this feature to migrate CS1KM (Meridian) type
systems.

• Use the Browse… button to load the replacement TN file (with either .txt or .csv extension)
that contains the comma separated TN replacement pairs.

Replacing TNs:
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• Note: The Original Node Id and Replacement Node Id textboxes are disabled, as no
Breeze CSV file is created for CS1KM TN replacements.

• (CS1KM) Replacement TN File is created by the administrator and contains the original
TN (Loop and Shelf) and replacement TN (Loop only) separated by a comma.

• (CS1KE) Replace TNs dialog:  Use this feature to avoid TN conflicts, when collapsing
multiple CS1Ks.

• Supply the original Signaling Server Node Id number and a replacement Node Id. If
desired, the Replacement Node Id can be the same as the Original Node Id, if the
replacement is not already assigned on the Aura Breeze cluster.

• Use the Browse… button to load the replacement TN file (with either .txt or .csv
extension) that contains the comma separated TN replacement pairs.

Replacing TNs (CS1KE):

• (CS1KE) Replacement TN File:  This file is created by the administrator and contains the
original TN (Loop and Shelf) and replacement TN (Loop and Shelf) separated by a comma.



• Call Center (CC) endpoints are identified during the migration as “CC-Agent” or “CC-
Supervisor” in the Mapping dialog.

• The default CS1K-IPCC models (provided with the Avaya Device Adapter Project
archive) or a custom-made model should be applied.

Call Center Stations:

• When creating and using custom models for CC agent endpoints, the model settings for
individual buttons will take precedence (override) the logic built into the migration tool.
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• As NMT finishes, the final progress window will appear with following details;
o Grid with overview of steps taken to add CS1K set as Aura (CM) stations into

Provision target project’s config.
o Ability to view all logs and a final report in Excel format (Log and Report

buttons).
o Ability to view all stations-related  data processed during migration in Excel

format (Subscribers button).
o Re-run button to restart migration steps.
o Close button to return to main UI window.
o Help button which launches help window.

• For Call Center migrations, logs will provide additional details for each CC station
created.  Data for each (taken from the original CS1K) is provided, including
ACDN, ACID, SPID, AST, PRI settings.
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• The new stations added by NMT can be reviewed in ProVision.
• These stations can now be scheduled for upload to the target CM.

• The new stations added to ProVision can be viewed in two formats. A right-click on
station icon provides the option.

o Form view – Identical to CM OSSI GUI
o Grid view – Similar to an MS Excel sheet for most of the fields (columns)

Review of New Stations



• The new Call Center stations can be reviewed for proper buttons assignments,
based on the model applied during migration.

Review of MGCs Import XML File
1. After a successful NMT run, a file named MGC_Import will be shown in the target

SMGR config folder. This XML file can be imported into the Aura SMGR, via the web UI.
The file can be accessed ( to be saved elsewhere or opened for review) by:

a. Right-clicking on the name or icon and selecting either the Copy or Open option.
or,

b. Use Windows Explorer to navigate to the file’s directory location.
(Example: C:\Users\<userid>\AppData\Roaming\Avaya\ProVision
\default.px\Avaya Device Adapter.prj\Target SMGR.smi\Config.cfg)

• After a successful NMT run for a collapsed CS1K, the target CM config folder will have a new
CVS file (uniquely named using the System ID).  There will be a CSV file for each collapsed
CS1K, named with that CS1K’s System ID.

Review of Breeze Import CSV File

• The file can be accessed ( to be saved elsewhere or opened for review) by:
o Right-clicking on the name or icon and selecting either the Copy or Open option…

or,
o Use Windows Explorer to navigate to the file’s directory location… Example: C:

\Users\<userid>\AppData\Roaming\Avaya\ProVision\default.px\Avaya Device
Adapter.prj\Target SMGR.smi\Config.cfg
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• Breeze Replacement TN file content:
o Each row contains Original Node Id + Original TN + Replacement Node Id +

Replacement TN separated by a colon.
o Also, the TNs contain a period (.) where a space would normally exist.

• Extension, Call Party Name Display (CPND), and the provided domain are used to 
create SIP User tables with basic data. Aura SM related fields can then be manually 
populated before Send operation during the migration.  Each record in the SIP User 
tables matches an entry in the CM station table.

• SIP User tables can be opened in form and grid view, as shown below.

Review of New SIP Users
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• As with the source CS1K, System Properties for CM and SMGR need to be applied.

Send to CM and SMGR

• Some necessary data cannot be collected from the CS1K, therefore some Aura 
SMGR-related fields need to be manually populated before send operation.  The 
following fields need to be manually populated, at a minimum:

o Primary Session Manager
o Secondary Session Manager
o Origination Application Sequence
o Termination Application Sequence
o Home Location
o Endpoint Profile-System



• In the Target CM and Target SMGR folders, predefined Send transactions are
available.

o The CM-related Send transactions are sent first.

o The SMGR-related Send transaction follows.
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o This will happen when a non-Avaya services account (login name) is used.
o Click the ‘No’ button to preserve the project device type.

• Connectivity to the target SMGR can be established using one of following methods:
1. Web Service connections – Retrieve and send transactions are performed

through an established IP network connection (Real time method).
2. File connections – Retrieve and send transactions are saved to a designated

(XML) file, located on the machine running ProVision (Offline method).
• Please refer to this job aid to learn more: SMGR Connection Methods.
• As previously mentioned in this document, using the File connection option is

recommended over Web Service connection.

• Connectivity to target CM 8.0.1 may trigger a “device type mismatch” warning.
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• Run the CM transactions in the order shown below;
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• Run the SMGR transactions in the order shown below;

Note: SIP user communication profile is sent twice.
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• The Communications Monitor and Event Log Viewer will display Send transaction
interactions and results.

• The CM station and SMGR user tables can also be sent without using the predefined
transactions. Examples of two alternate ways are.

o Click the Send icon, on ProVision’s toolbar, to launch the Send window, or;
o Right-click on the station form, within the target project config folder.
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(MERA) Preparing Communication Manager Setup AND Feature 
Migration Remarks:

• Make sure that there are no conflicts between existing CM extensions and migrated
Extensions.

• Administrator should configure Dialplan /Routing that satisfies all porting extensions.
• Take attention on Communication Manager: dialplan-analysis, uniform dialplan,

private-numbering, aar analysis.
• In case of number of migrated sets is less than number of DNs on these sets:

Administrator defined Extension pool is used to assign Extension for Sets that
doesn’t win any DN as Extension.

Station Migration

Multiple Appearance DN
• In case of number of DNs is more than number of Sets and in some other cases,

such DN is translated as Virtual/XPORT Station type: 9408
• Limitation for Communication Manager 8.0.1.0 for CS1k-ana stations:

o Behavior for Analog Sets will always - Multiple Call Arrangement.
o All brdg-appr buttons are considered as “B: a” buttons instead concrete

index “B: <number>”.

Short Hunt
• Short Hunting generally translated as multiple call-appr buttons on station.
• For some special cases short hunt virtual station (XPORT 9408) is created

for purposes of this feature.

Call Waiting
• Call Waiting key is translated to call-appr button on station.

Privacy Release
• Administrator should configure Communication Manager / System / System

Parameters – Features / AUTOMATIC  EXCLUSION  PARAMETERS: Automatic
Exclusion  by  COS?:  Y

• Provision/NMT tool sets COS #1 for all migrated Stations
• Administrator should configure Communication Manager / System / Class Of

Service:
Number: 1,2
Automatic Callback: Y

Privacy Override
• Provision/NMT tool sets COS #1,2 for all migrated Stations.
• Administrator should configure Communication Manager / System / Class Of

Service:
With the exact correspondence of Numbers and parameters:
COS  Number:  1
Bridging Exclusion Override: N
COS  Number:  2
Bridging Exclusion Override: Y

Ring Again
• Administrator should configure Communication Manager / System / Class Of

Service:
Number: 1,2
Automatic Callback: Y
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Call Forward Busy/ No Answer/ Make Set Busy
• Call Forward Busy/ No Answer/ MSB features are translated to CM Coverage

feature.
• It is represented by coverage path, coverage remote tables.
• Redirect numbers that don’t represent Directory Numbers migrated Extensions is

treated as Coverage Remote entries:
• TNB:

FDN
HUNT
ATT_DATA:
ATDN (in case of Customer redirection(RDR_DATA: FNAL/D) configuration is ATT)

• For Redirect numbers that represent Coverage Remote entries – dialplan/routing
should be properly configured. (take in account uniform dialplan)

• Administrator should configure System parameters call coverage/ call forwarding
Maintain SBA At Principal: N

• Short Hunting feature also may use Coverage Path in some special cases.

Call Pickup
• Call Pickup is translated to pickup groups
• CM Pickup group supports only 100 extensions
• Administrator should allow Extended; Direct pickup in System Parameters Features
• Provision/NMT tool sets COR #1/2/3/4 for all migrated Stations
• Administrator should configure Communication Manager / System / Class Of

Restriction with the exact correspondence of Numbers and parameters:
• COR  Number:  1

Can  Be  Picked  Up  By  Directed  Call  Pickup? N
Can  Use  Directed  Call  Pickup? N

• COR  Number:  2
Can  Be  Picked  Up  By  Directed  Call  Pickup? Y
Can  Use  Directed  Call  Pickup? N

• COR  Number:  3
Can  Be  Picked  Up  By  Directed  Call  Pickup? N
Can  Use  Directed  Call  Pickup? Y

• COR  Number:  4
Can  Be  Picked  Up  By  Directed  Call  Pickup? Y
Can  Use  Directed  Call  Pickup? Y

Autodial
• CS1K ADL key destination number is not translated to autodial button during

migration. (Phone User should configure it after migration. These autodial buttons
has no administratively configured number)

o E.g. KEY 01 ADL 16  1100005  --->  button 1: autodial.
Call Forward All Calls

• CS1K CFW key destination number is translated. Number is translated to Enhanced
Call Forwarding Destination intermediately
E.g. KEY 19 CFW 12  1100005  --->

button 19: call-fwd Ext: <blank> 
Uncond For Internal Calls To: 1100005 Active: n

• It will be removed and transformed to call-fwd destination number during the first
registration of the Set.

Ambarish.Kanhere
Cross-Out
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• Extended pickup group supports only 25 group within itself.

Message Waiting Indicator; Message / Inbox Key; Call Park

• Voicemail and Call Park deployment should be preconfigured and integrated with
Aura.

• Call Park  make use of pre-installed(dependent) Avaya Breeze Call Park & Page
snap-in.

• Call Park doesn’t requires any conversion from CS1000 logic and doesn’t use
Provision for migration.

Message / Inbox Key
• Voice Main Number of User should be filled in Provision.
• Fill user communication profile Provision table column: Endpoint Profile – Voice

Mail Number by voice-mail system number using GRID editor after NMT tool
conversion.

Speed Dial, Hotline

• Speed Dial and Hotline translates to abbreviated-dialing group lists.
• Need to configure Abbreviated Dialing List1/2/3 Access Code on CM.
• Special hotline virtual station(XPORT 9408) is created for purposes of this feature.

Group Call Pickup
• Group Call Pickup use CM Extended Pickup groups
• User experience is changed for group call pickup .
• To access another group user should enter Pickup Number from Extended Pickup

Group associated with Pickup Group Number.
• Pickup Group Index may not match with Pickup Group Number on CS1K. After

migration need to take in account conversion like here:
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(MERA) Preparing Communication Manager Setup AND Feature Migration 
Remarks:

Wrong button transfer of CS1K Analog Sets (Limitation for Communication 
Manager 8.0.1)

• During Transfer of CS1k-ana sets:
If CS1k-ana station has single brdg-appr button
Error occurs (Event Log Viewer, 2 times): “station <Extension>: Buttons 0 and 1
must be the same button type and data”
In this case Station is translated with 2 call-appr buttons instead.

Wrong button transfer of CS1K Analog Sets (Limitation for Communication 
Manager 8.0.1.0)
Solution:
Open View->Event Log Viewer:

1. Double click on such errors: Station with wrong configuration is opened.
2. Copy brdg-appr button to the both positions.
3. Change “B:” attribute of the button to “a” for both buttons.


	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page

