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Copyright Notice 

Copyright © 2019 by BrightBox Software Pty. Ltd. All rights reserved. 

No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any 

language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical, manual or otherwise, without prior 

permission of BrightBox Software. 

 

Disclaimer 
Except for the limited warranty described in the software license agreement, Brighbox Software Pty. Ltd. makes no representation 

or warranties with respect to the contents hereof and specifically disclaims any implied warranties of merchantability or fitness for 

any particular purpose. No dealer, company or person is authorised to expand or alter our warranties or this disclaimer. Any such 

representation will not bind Brightbox Software Pty. Ltd. 

Brightbox Software Pty. Ltd. reserves the right to revise this publication and to make changes from time to time in the content 

hereof without obligation of Brightbox Software Pty. Ltd. to notify any person of such changes. 

Trademarks 

Microsoft Excel is a trademark of the Microsoft Corporation. AutoCAD is a trademark of the AutoDesk Corporation. Any 

references made or implied to other products have been made to help describe functions used in the software. Every effort has 

been made to supply complete and accurate information. However, Brightbox Software Pty. Ltd. assumes no responsibility for its 

use, nor any infringements of patent or other rights of third parties which would result. 
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Introduction 
 

MudShark is the next generation earthworks estimating software, that is simple enough for anyone to 

start using while including many powerful and purpose-driven features.  

Using this Guide 
The content of this guide has been designed so it can be read from cover to cover or skip to individual 

sections of interest.  

After reading this guide, you should be able to: 

• Understand the recommended workflow of using MudShark 

• Confidently interact with the MudShark user interface 

• Manage your MudShark projects and plans 

• Takeoff contours, spot elevations, and structures quickly and accurately 

• Manipulate and reuse materials 

• Calculate and understand the results of a project 

• Produce and interact with 3D and 4D models of your site 

• Produce detailed reports of stripping, cut, fill, respread and structure volumes 

 

Other ways to learn 
Although the User Guide is a great source of information to use MudShark, we know everyone learns 

differently, and we have many methods to empowering our users.  

Some of our other channels of learning and information include: 

• Our YouTube channel 

• Our Knowledge Centre 

• Direct training 
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Sample Project 
We provide a sample project for you to interact with, to help you get familiar with MudShark.  

To open the sample project: 

1. Click Project, at the top right of the ribbon.  

2. Click Import Project 

3. From the Import Project window, navigate to: Program Files\BrightBox\MudShark 

x64\Samples 

4. Select HillTopHouse.bbx  

5. Click Open 

 

 

Figure 1. Example project in MudShark  
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Workflow 
MudShark can be used in multiple ways, and can fit your existing workflow. However, for maximum 

efficiency we recommend using the following as a guide for completing a project in MudShark. 

 

Recommended MudShark workflow: 

 

Prepare Plans  

Recommended steps for preparing your plans: 

1. Insert and align your plans  

2. Scale your plans 

3. Define your working area 

 

Perform Takeoff  

Recommended steps for site takeoff: 

1. Enter the surface elevations using contours and/or spot elevations for your Existing and 

Proposed Sites 

2. Set the boundaries and materials of structures as required 

 

Calculate Results  

Recommended steps for calculating your results: 

1. Configure ground settings 

2. Generate Results 

3. Validate your calculation by inspecting your 3D site and Results 

4. Export your results data 

 

Prepare 
Plans

Perform 
Takeoff

Calculate 
Results
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Options 
There are some options you can set for MudShark, including viewport style, ground settings, and where 

your data is saved and the default measurement units. 

To access MudShark options: 

1. Click Project, at the top right of the ribbon. 

2. Click Options… at the bottom of the application menu.  

3. The MudShark Options window will open, and you can navigate between the three option 

tabs: Viewport Styles, Ground Settings, and Data 

 

 

Figure 2. Options are accessed from the program menu 
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Viewport Style 

From the Viewport tab you can affect how the Viewport displays some elements.  

 

Figure 3. Viewport Style tab in Options 

 

Active input line 

You can change the colour for the current active input line and its line thickness. By default the Line 

colour is orange, and the Line thickness is thin. 

 

Viewport colours 

You can also change the colours that denote current Selection, the Viewport Background and the 

Viewport Foreground, By default, these are blue, grey and black, respectively.  
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Ground Settings 

From the Ground Settings tab you can affect how MudShark manages your ground settings. 

 

Figure 4. Ground Settings in Options 

 

Thickness 

You can set the default depth for Stripping and Respread, which will determine the defaults for ground 

stripped for an Existing Site and respread for a Proposed Site. 

 

Material Reuse 

You can set defaults for how material is reused through your project.  

You enter a percentage for Unusable stripping which will set the default wastage percentage of stripped 

earth. Setting this percentage will limit how much material can be reused on the site. You can also enter a 

percentage for Unusable cut which will limit how much material can be reused on the site.  

 You can check Respread only from stripping , which when checked will only reuse the material that is 

stripped from the existing site in the respread.  
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TIP: If there is not enough stripped material to respread the required volume, the remaining volume will 

be considered as Imported Material. 

You can check Fill only from cut, which when checked will only reuse material that is taken from cut for 

fills. 

TIP: If there is not enough cut material to fill the required volume, the remaining volume will be 

considered as Imported Material. 

 

Imported Respread Material 

This is for setting up the default material to use if there is any imported respread required. 

 

Imported Fill Material 

This is for setting up the default material to use if there is any imported fill required. 
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Data 

From the Data tab you can affect how MudShark manages your project data, licence and software.  

 

Figure 5. Data tab in Options 

 

Data Folder 

The data folder will be the location set during installation where your project data is saved. You can 

interact with your data folder in two ways: you can click Data folder: to open the location where your 

data folder is or you can click the … button to change your data folder. 

 

Max visible image Plans 

There is a default to the amount of image plans displayed in a project, this limit ensures computers 

processing power isn’t dragged down. By default, this limit is set to two. You can adjust this by changing 

the number directly or using the arrow up, and arrow down buttons. 
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Deactivate on exit 

By default, if you’re using a floating licence, Deactivate on exit is checked. As long as this is checked, and 

you have an active internet connection when you close MudShark, your licence will be deactivated so 

you can open MudShark on another computer. 

TIP: This option is only visible if your have a floating licence.   

 

 

Default Units 

Your default units are set when installing MudShark for the first time. You can only use MudShark with 

one default at a time. 
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User Interface 
MudShark’s intuitive interface is designed to help you easily navigate the software. We’ve designed 

MudShark with a minimal learning curve and utilise modern design so you have flexibility in how you 

interact with the software. 

 

 

Figure 6. Understanding the user interface for MudShark 

 

Application Button 
You can access the application menu by clicking Project. From here you can open, save, copy or create a 

project. From this menu you can also import or export your project as a Brightbox file. 

 

Quick Access Toolbar 
By default, from the quick access toolbar, you can save your project and undo or redo actions you’ve 

taken.  
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Ribbon 
You work through your project by using the ribbon, which is divided up into four distinctive tabs.  

Home Tab 

 

Figure 7. The Home tab in the ribbon 
 

The Home tab will be shown when you first open MudShark, it is where your takeoff tools live and the 

tab you will likely use most. Notable features of the Home tab include changing between Takeoff and 3D 

modes, choosing between Existing or Proposed for your Site, your Drawing tools and the Calculate 

button. 

Plans Tab 

 

Figure 8. The Plans tab in the ribbon 
 

The Plans tab is where you can insert plans for a project; and rotate, move, and scale your plans.  

View Tab 

 

Figure 9. The View tab in the ribbon 
 

You can control what’s being displayed from the View tab, including labels in the Viewport and the 

different panes.  
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Data Tab 

 

Figure 10. The Data tab in the ribbon 
 

When you have completed your takeoff, you can use the Data tab to export your results into a Microsoft 

Excel file or for estimating software. From the Data tab you can also access your Global Materials, 

Project Materials and Trench Definitions.  
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Panes 
MudShark is comprised of multiple panes which display your plans, takeoff, results and other details and 

data.  

Although you can move and adjust the panes to suit your workflow, they are primarily divided up into 

two groups: 

• The embedded panes – Project Details, Boring Log, Viewport, Cross-Sections, Results 

• The list panes – Plans, Takeoff, 3d Site List, Section List, Properties 

Embedded Panes 

Project Details Pane 

You can view and edit the details for a project, this information is further divided into groups for Project, 

Client and Ground Settings. Read Understanding Project Metadata for more information.  

Boring Log Pane 

You can define the default materials that make up the ground on your site either as single list thicknesses 

or a complex array of multiple soil borings.  

Viewport Pane 

The Viewport is one of the most important parts of MudShark, it’s where you view your plans, takeoff, 

and results. All your takeoff is done from the Viewport. Read Viewport for more information. 

Cross-Sections Pane 

View and inspect your site with any cross-sections you have entered for your project. 

Results Pane 

You can explore any calculated data for your project. This information is further divided into groups for 

Cut and Fill, Trench Measurements, Existing Site Measurements, and Final Site Measurements.  
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List Panes 

Plans Pane 

You can manage your plans, and plan layers, for any file you’ve inserted into your project. You can 

rename plans and their layers, delete plans and control their visibility here.   

Takeoff Pane 

You can view and edit details for your takeoff from the Takeoff pane. You can delete takeoff, and select 

one or more items. The Takeoff pane works best with the Properties pane, where you can edit various 

takeoff details. 

3D Site List Pane 

From the 3D Site List pane you can control the visibility of your 3D project in the viewport.  

Section List 

If you have input cross-sections they will be displayed in this list, you can select a cross-section to display 

it. The cross-section which will be displayed is for the currently active site stage, switch between site 

stages to display the different cross-sections. 

Properties Pane 

If you have one item selected, the Properties pane, you will display information about the item. If you 

have multiple items selected, it will show you the total selected items. If you select takeoff, from the 

Viewport or the Takeoff pane, you will be able to edit some parts of that takeoff, including elevation, 

overlay options, line widths, colours and more. 
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Utilising List Panes  

Item Visibility 

You can affect the visibility of plans, takeoff and 3D layers from the corresponding pane, although some 

of this is handled automatically (like changing between Existing and Proposed sites.)  

There is a checkbox next to each item if there is a check in that box it denotes that that particular item is 

visible if the box is empty that item is currently hidden. Simply, click this box to change the items 

visibility.  

TIP: Changing the visibility of a group or container, will also change the visibility of its sub-items.   

Selection 

Items in the list panes can be selected by clicking on their names. When an item is selected in a list it is 

also shown as selected in the Viewport. If the item has sub-items, they too will be selected and 

highlighted. 

Deleting 

You can press Delete on your keyboard to delete a selected item. Some items in the list panes cannot be 

deleted, and instead its sub-items will be deleted.  

TIP: If you delete something by mistake, click Undo to reverse it. 

Expansion 

You can expand and collapse items in the list pane by clicking the arrow next to the item.  

Adjusting Panes 

The position and size of your panes can be adjusted.  

Your panes can be in one of three states:   

• Docked panes appear against an edge of MudShark, by default docked panes are on the right. 

• Embedded panes appear in the centre workspace, where the Viewport is docked. 

• Floating panes can appear anywhere on your screen. 

If a pane has been closed, from the View tab you can click the pane from the Show Panes group, and that 

pane will appear where it was last visible.  

TIP: If you close and reopen MudShark, all panes will appear in their default locations.  
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Viewport 
Although just a pane, the Viewport is one of the most important parts of MudShark, it’s where you view 

your plans, takeoff, and results. All your takeoff is done from the Viewport. 

From the viewport you can utilise the Viewport toolbar, the Viewcube and the Task panel. 

 

Figure 11. Understanding the Viewport 
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Navigating the Viewport 
The most efficient way to navigate around the Viewport is with your mouse.  

TIP: To navigate the Viewport, you need to click into it to activate it. We recommend right-

mouse button, or the mouse scroll button clicking to select the Viewport without initiating any 

takeoff.  

Zoom Fit 

 

Clicking Zoom Fit from the Viewport Toolbar will be reset your view so that all currently visible 

contents fit in the Viewport. This is often a great view of your site, and an easy way to reset the Viewport.  

Zoom to Selected Items 

 

Clicking Zoom to Selected Items in the Viewport Toolbar will fill the Viewport with the currently 

selected entities.  

Zoom Window 

 

Clicking Zoom Window will let you draw a rectangle that will zoom and fill your Viewport as best as it 

can.  

Zoom 

 

The best way to zoom in and out in the Viewport is just by scrolling your mouse wheel up or down, to 

zoom in or out, respectively. Alternatively, you can click Zoom from the Viewport Toolbar and click your 

mouse and move the cursor up or down to accomplish the same affect.  
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Pan 

 

You can move the contents of your Viewport left, right, up, and down with Pan. Click and hold the mouse 

wheel button in the Viewport, and move your cursor in the direction you want to pan. You can also use 

the arrows on your keyboard to pan.  

TIP: Pan will move visible and non-visible contents, and won’t effect your takeoff or results.  

Rotate 

 

You can change the perspective you’re viewing by holding Ctrl and clicking and moving your mouse 

wheel button, like you would when panning. You can also click Rotate from the Viewport Toolbar.  

Top Down 

 

To move the camera to get a bird’s eye view of your site from Takeoff or 3D, click Top Down in the 

Viewport Toolbar. 

TIP: Use Top Down to reset your view if you move or rotate your Viewport out of position. 

Viewcube 

 

You can rotate around the Viewport with the Viewcube. You can click on a side or edge of the cube to 

change to that perspective, or click and hold down the mouse button, then the Viewcube will move in the 

direction you scroll, affecting your plan, takeoff or 3D in real-time.  
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Projects 
 

A Project contains all of your plans, takeoff, and results relating to a site.  

There are no limitations for the number of Projects you can save on your computer, but you can only 

open one at any given time.  

TIP: It is important to regularly save your Project in MudShark so that you don't lose any data. We also 

recommend regularly backing up your Data Folder. 

 

Understanding Project Metadata 
You can save metadata for a Project, this is broken into three categories: Project, Client, and Ground 

Settings.  

TIP: While no fields are mandatory, we do recommend entering a Project Name. 

 

Figure 12. Details for a Project 
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Project Details 

All fields will start empty, however by default the Project will be named New Project [Creation Date] 

[Creation Time].  

We advise changing the Name to better reflect the Project so you can identify it easier later. You can also 

add a Note for your Project.  

You can enter a Site Address for a project, this is broken down into Street, Suburb, State, Postcode and 

Country. There is also a Note field for additional details about the Site Address.  

Client Details 

Client Details is broken down into three sections, Contact, Company and Company Address.  

You can enter First name, Last name, Email, Mobile and Phone for a Contact. 

TIP: You can only set one Contact per project, but you can use the Note field for additional contacts.  

You can enter Name, Phone, and Fax for Company, and also enter the Company Address broken down 

into parts.  

Ground Settings 

Entering Ground Settings will have impact on the calculations for a Project.  

By default, Strip by thickness will be 0, unless you have set a default in Options. You can change this 

value or select Strip Away and select any Layers you want to strip from your Proposed Site. 

By default, Respread thickness is also set to 0, unless you have set a default in Options. This value is 

editable.  

There are three other options available for you to check. By default Calculate Open Ground Fill is 

checked, which will calculate any fill without a structure on top. 

You can check Only Use Proposed Contours For Structures and Spots, which will ignore contours and 

spots except for calculating structure surfaces if you’re using Overlay Options. By default, this is 

unchecked.  

You can check Calculate Heat Map, this will generate a Heat Map for your Site that will show you the cut 

and fill depths. By default, this option is unchecked; checking it may increase the time it takes for your 

calculation to complete 
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Create a New Project 
By default, when you launch MudShark, a new project will be created for you.  

If you want to create new project: 

1. Click the application button, labelled Project, at the top right of the ribbon. 

2. Click New. 

TIP: You can also use the keyboard shortcut Ctrl + N to create a new project. 

While there are no mandatory fields for your Project Details, we recommend at least entering a Name.  

 

 

Figure 13. New Project 
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Open an Existing Project 
By default, when you launch MudShark, a new project will be created for you.  

To open an existing Project: 

1. Click the application button, labelled Project, at the top right of the ribbon.  

2. Click Open. 

3. The Open Project window that will appear, where you can soft and filter your projects by 

various fields. 

4. Find the project you want to open, then select it. 

5. Click Open. 

TIP: You can also use the keyboard shortcut Ctrl + O to open a Project. 

 

 

Figure 14. The Open Project window  
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Filtering Projects 

From the Open Project window, you can filter your projects to better find the project you need. You can 

filter based on one, or more columns and any projects not matching your criteria will be hidden. Different 

filters can be combined and you can easily clear your filter to show all projects, again. 

 

Simple Filtering  

The default filtering option is Contains, so whatever you enter in the line underneath it will filter the 

projects that contain the entered characters. If you click Contains, you can change how that column is 

being filtered.  

 

Clearing Filters  

On the far left of the filter row you can click the Clear Filter icon to clear all filters and see all projects. 

You can also click this icon in any entered filter column. 

 

Custom Filtering for a Column 

Instead using just a single filter, if you click the empty field you can select Custom to create a custom 

filter. The Custom Filter window which will appear, and you can build up multiple criteria for a single 

column. 

 

Filtering Project Displays 

There are three ways your projects can be saved: Synchronised, Data Folder, and Missing. 

The format you’ll primarily use is Synchronised, which is also the default. Most of the time you won’t 

need to change from this format because it will display all projects in your database.  

If, at any point, you create a new database your Synchronised projects might be empty, and you might 

need to select Data Folder to see projects you have saved on your computer. Once you have opened and 

saved a project from the Data Folder, it will appear under Synchronised.  

Projects would only appear in Missing if there are project files within the database, but not the project 

file directory, you shouldn’t need to use this option.  
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Copy a Project 
You can easily copy a Project at any time, as a means of saving a version or just as a means of 

experimenting with site balancing.  

To copy an open Project: 

1. Click the application button, labelled Project, at the top right of the ribbon. 

2. Click Create a Copy. 

3. Enter a Name for the new project from the Create a Copy window that appears.  

4. Click Create a Copy. 

After your project has been successfully copied, an alert will appear at the bottom right of your screen.  

TIP: Click this alert to open the copied Project. 

Your copied Project will appear in your Project list, where you can open it like any other Project.  

 

 

Figure 15. Create a Copy from the application menu 

 

 

Figure 16. Create a Copy of the currently opened project 
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Export a Project 
If you need to share a MudShark project with someone else or with another computer, you have to 

export the project as a BBX file.  

To export a Project: 

1. Click the application button, labelled Project, at the top right of the ribbon.  

2. Click Export Project. 

3. Enter a name for your BBX file, by default it will be the project name. 

4. Browse your computer to the location you want the BBX file saved.  

5. Click Save. 

After your project has been successfully exported, an alert will appear at the bottom right of your screen.  

TIP: Click this alert to be taken to the folder where you saved your BBX file.. 

 

 

Figure 17. Export Project 

 

 

Figure 18. Export a project 
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Import a Project 
If you need to accept a MudShark project from someone else or from another computer, the project must 

be exported as a BBX file. Once you have this BBX file, you can import it into MudShark.  

To import a Project: 

1. Click the application button, labelled Project, at the top right of the ribbon.  

2. Click Import Project. 

3. Browse your computer to the location the BBX file is saved, then select it.  

4. Click Open. 

TIP: Only folders and BBX files will be visible from the Import Project window. 

 

 

Figure 19. Import Project 

 

 

Figure 20. Import a project 
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Plans 
 

MudShark has been designed so you can takeoff from plans as accurately and quickly as possible, and 

you can insert a wide variety of digital plans.  

MudShark works best with vectorised plans, specifically DWGs, DXFs, and some PDFs. A vectorised 

format will include layer information, so you can use some of the automatic tools to speed up your 

takeoff. MudShark will still allow you to import BMPs, PNGs, JPGs, as well as non-vectorised PDFs and 

most common image formats.  

To get your plans takeoff ready: 

 

Plan List  
You can inspect plans and, where applicable, their layers from the Plan List pane. From this pane you can 

select plans, or their layers, for the various features and use the checkboxes to show, or hide, plans or 

their layers. 

 

Figure 21. An example Plan displayed in the Plan List pane 

TIP: For PDF files with multiple pages, a Plan will be inserted for each page.  

  

Insert & Align Scale & Check
Set 

Working Area
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Insert a Plan 
The easiest way to insert a plan into MudShark is to drag and drop a plan from your computer, into the 

MudShark viewport. Doing this will automatically insert that plan into current Project.  

Alternatively, you can find a plan from within MudShark. 

To insert a plan: 

1. From the Plans tab in the ribbon, click Insert Plan. 

2. From the Open window, select one or more files you want to insert as Plans into your 

Project 

3. Click Open. 

TIP: By default only supported file formats will be displayed in the Open window. 

 

 

Figure 22 Insert Plan 
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Scale a Plan 
You can scale a plan one at a time, or you can save time and scale multiple plans at once.  

To scale a plan: 

1. From the Plan List pane, select the plan or plans you want to scale. To select multiple plans, 

hold Ctrl as you select plans from the list.  

2. From the Plans tab in the ribbon, click Scale. 

3. Find a reference line that you want to use to scale your plan, the longer the line the better.  

4. Use your mouse to click each end of the reference point.  

TIP: If you’re using a vector plan, hold Shift on your keyboard as you move your mouse to each 

reference point to enable snapping for a more accurate point 

5. Enter the Line length that you just clicked on inside the Scale Plans window. 

6. Click Scale. 

 

 

Figure 23 Scale a plan 
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Check the Scale of a Plan 

Getting your scale right is critical for accurate results, always check your scale for each plan.  

To check a scale: 

1. From the Plans tab in the ribbon, click Scale. 

2. Find any straight line on your plan with a clearly defined length, then click the beginning of 

this line. 

3. Move your mouse to the end point, but do no click, a length will appear to the right of your 

mouse, this should be the same or very close to the length of the line.  

 

Clear the Scaling from a Plan 

You can rescale a plan at any point, and you can also clear the scale.  

To clear the scale of a plan:. 

1. From the Plans List pane, select the plan or plans you want to clear the scale from. 

2. From the Plans tab in the ribbon, click Clear Scale. 

3. Any selected plans will appear, to confirm clearing the scale for the selected plans click 

Clear Anyway. 

 
 

 

Figure 24 Clear a plan 
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Rescale a Plan  

You can rescale a plan at any point; however rescaling incorrectly can invalidate existing takeoff.  

The process of rescaling is the same as scaling a plan; however you will be presented with four options to 

how your rescaling is applied to the project.  

 

Rescale all takeoff and altitudes 

Not only will any selected plans be rescaled, but selecting this options will rescale all takeoff (contours, 

boring. Structures, etc) and all altitudes. If you use this option, ensure you inspect your site in 3d and 

check your results to ensure your project is correct. 

 

Rescale all takeoff, ignoring altitudes 

Not only will any selected plans be rescaled, but selecting this options will rescale all takeoff (contours, 

boring. Structures, etc). Any entered altitudes will remain the same, unchanged by rescaling. If you use 

this option, ensure you inspect your site in 3d and check your results to ensure your project is correct. 

 

Rescale plan only, ignoring takeoff 

Only selected plans will be rescaled, all takeoff and altitudes will remained unchanged.  

 

Rescale plan and delete takeoff 

Only selected plans will be rescaled, but all takeoff and altitudes will be deleted.   
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Align a Plan 
You may need to align a plan before you begin your takeoff. You can rotate and move your plan to place it 

where you need it.  

TIP: If you have inserted multiple plans, and they’re different sizes, we recommend scaling your plans 

first. 

Rotate a Plan  

If you plan has been inserted upside down, or turned on a strange angle, you can rotate your plan so it 

displays correctly.  

To rotate a plan by 90 degrees: 

1. From the Plan List pane, select the plan you want to rotate. 

2. From the Plans tab in the ribbon, click Rotate Left or Rotate Right.  

 

Figure 25 Rotate Left button 

To rotate a plan by a custom degrees: 

1. From the Plan List, select the plan you want to rotate. 

2. From the Plans tab in the ribbon, click Rotate Custom. 

3. The Custom Rotate window will open, enter the Rotation angle. 

4. Click the direction button to determine the direction the angle rotation will be applied. 

5. Click OK to rotate your plan.   

TIP: This is incremental, so you can move your plan in smaller angles to get it right. 
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Figure 26 Custom Rotate window 

Move a Plan 

If you have plans that don’t align, you can move your plans to align them.  

To move a plan: 

1. From the Plan List pane, select the plan you want to move. 

2. From the Plans tab in the ribbon, click Move. 

3. Click a point on the plan. This will be your first reference point, that will be moved. 

4. Click a second point, you previous point will be moved to align to this point.  

TIP: You can select and move more than one plan at a time. 

 

 

Figure 27 Move a plan  
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Takeoff 
Understanding Working Areas 
Before you begin your takeoff, you need to define the area where your results will be calculated for, this 

is your Working Area.  Your Working Area can include multiple areas and exclusions.  

 

Figure 28. Example Working Areas 

 

You only need a single Working Area for a project, although you can define multiple Working Areas for 

these sites.  

Tip: Your Existing and Proposed sites will share the Working Area. 

You can redefine your Working Area at any point, either editing boundaries, adding additional areas or 

creating a new exclusion.  
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Define Your Working Area 
Ensure you plans are scaled and aligned before you define you Working Area.  

Define your Working Area: 

1. From the Home tab in the ribbon, click Working Area.  

2. From the Drawing group click Polyline.   

TIP: You can also use Transmute, Transmute Area, Offset, and Extrude to takeoff your Working 
Area. 

3. Using your mouse, drawn the boundary of your Working Area, by clicking each corner.  

4. After you have clicked on each corner, you can join the current line to the starting point 

with a right-mouse click. 

 

Figure 29. Ribbon configured to Add Working Area Boundaries to the Project. 

With Working Area selected, if you takeoff another area within an existing working area, you will 

automatically create an exclusion. If you takeoff another area outside the existing one, you will create an 

additional working area. 

  



  

42 

 

Interactive View 
You can view and interact with your Viewport in two ways: 

• Select Takeoff to complete any takeoff for your project. 

• Select 3D to inspect a 3D model of your site. 

By default, your project will be set to Takeoff.  

 

 

Figure 30.The View group in the Home tab 

 

Active Site  
Your takeoff will be performed for either the Existing Site or the Proposed Site. 

The currently active site will be highlighted to make it clear which site you’re contributing towards.  

 

 

Figure 31. The Site group in the Home tab 
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Drawing Tools 
There are a number of tools that are designed specifically to make your takeoff efficient and accurate. 

Not every tool is useful in every situation, but the right tool can make even the most difficult takeoff 

easy.  

Depending on what you’re attempting to takeoff, we will recommend different tools, but you can try 

different tools for different takeoff to find the fastest way for you.  

Tip: If you takeoff incorrectly, you can use Undo to reverse your last action.  

 

Figure 32. Drawing group in the Home tab 

Polyline 

    

A polyline is a sequence of one or more straight lines or curves. You can use the Polyline tool by clicking 

the corners or points of the shape you’re tracing or drawing.  

Tip: If you are using a vectorised plan, hold SHIFT to enable point snapping for better accuracy. 

To draw a curved line, click the start of the curve then click and hold the mouse button at the end of the 

curve, then drag your cursor towards to curve the line.  

Tip: Sometimes to accurately trace a curve you might need a few smaller curves.  

Polyline is an intelligent tool, so depending on what your taking off, will determine how your Polyline 

finishes. If you’re drawing a contour and right-mouse click, your line will complete on your previous 

mouse click. If you’re drawing an area that requires to be closed, like a structure, the right-mouse-click 

will close the shape between the previous point and the starting point.  
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Transmute 

    

Transmute is the most powerful tool in MudShark. Transmute has two main uses; with a 3D vector plan 

you can automatically takeoff an entire layer for contours or spots and you can automatically takeoff 

lines, curves, and various shapes from a plan in the Viewport. 

To Transmute an entire contour layer or spot layer from a plan with 3D details, you click Transmute then 

select the layer from the Plan pane. 

To Transmute from a plan in the Viewport, you can click the entity from the plan. 

Transmute Dashed 

    

When you need to takeoff dashed lines from a plan, whether its contours or structures using dashed 

lines, you’ll want to use the Transmute Dashed. Much like polyline, mouse click on the line, and then keep 

clicking along the line to continue. Right-mouse click to complete to your previous mouse click. 

Transmute Area 

    

To takeoff an enclosed area, you can use Transmute Area to automatically find an area and create 

boundaries for it. When using Transmute Area, you can hover over the area you want to takeoff, and you 

will see a preview of the boundary area, when the preview shows the area you want the boundaries for, 

right-mouse click to complete it.  

 

Point 

    

Points are a useful takeoff tool, used for entering spots, boring points and counts.  
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Offset 

                

The Offset tool lets you select Offset Input or Offset Selected.  

Offset Input will let you draw a line then enter an offset distance and angle to create a new line. 

Offset Selected will let you select a line from your plan or takeoff then enter an offset distance and angle 

to create a new line 

 

Extrude 

                

The Extrude tool lets you select Extrude Input or Extrude Selected.  

Extrude Input will let you draw a line then enter an offset distance and angle to create a new area using 

the boundary of the drawn line and offset. 

Extrude Selected will let you select a line then enter an offset distance and angle to create a new area 

using the boundary of the selected line and offset 
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Takeoff Boring 
A boring represents a soil sample at a given location on a site. Multiple borings help with modelling the 

initial ground strata for more accurate results. Boring will produce ordered layers of material, detailing 

the thickness of each material. 

There are two ways you can takeoff boring: 

• Create and assign boring points as you go 

• Create a Boring Log, then assign the boring points 

You can only input boring for the Existing Site.  

Create a Boring Point 

You can create and assign boring points directly in the Viewport, this is useful if you have simple 

materials and only a few points to enter.  

 

Figure 33. Selecting Boring from the ribbon 
 

To enter a boring point: 

1. From the Home tab in the ribbon, select Existing from the Site group.  

2. From the Ground group in the ribbon, click Boring.   

3. From the Drawing group in the ribbon, click Point.   

4. From the Viewport, click the point you want to enter your boring point. 

5. The Boring Point window will open.  

6. Enter a Name for the boring point.  

Tip: By default Altitude will be set to Undefined, if you leave this the altitude will be determined 

by entered contours and spot elevations. 

7. Enter Materials and their Thickness.  

8. Click OK. 

 



  

47 

 

 
Figure 34. Enter materials in the Boring Point window 

 

Create Boring Log 

Especially if you have multiple borings you want to input, you can create a Boring Log with all the borings 

for a project. Creating a Boring Log will let you create and define as many borings as you need, and then 

you can input them quickly.  

The Materials in Ground list is the master list of materials for the boring points, deleting a material from 

here will remove it from all existing borings points. 

To create a boring log: 

1. Click the Boring Log embedded pane. 

2. From the Materials in Ground pane on the left side of the Boring Log, click Enter Material 

in the Material column and select or create a material to be used in the project.  

Tip: Before you can assign a material for a boring point, it need to be entered in the Materials in 

Ground. If there is a consistent thickness for any material you can enter a Thickness, or you can 

leave it as default and define it for each boring point.  

3. From the Insert new Boring window in the Boring Log pane, enter a Name for the first 

boring point.  

Tip: By default Altitude will be set to Undefined, if you leave this the altitude will be determined 

by entered contours and spot elevations when you enter the point in the Viewport. 

4. All the available materials entered in Materials in Ground will be shown for the boring 

point, define the thickness of each.  

Tip: If a material is not present in a point, set the Material Thickness to 0.  
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5. Continue creating as many boring points as you need for your project, after you name a 

boring point, a new empty point will be created.  

 

 

Figure 35 Create a Boring Log 

 

Assign a Boring Point 

If you have defined boring points in the Boring Log, you can assign them in the Viewport.  

 

Figure 36. Selecting Boring from the ribbon 
 

To assign a boring point: 

1. From the Home tab in the ribbon, select Existing from the Site group.  

2. From the Ground group in the ribbon, click Boring.   

3. From the Drawing group in the ribbon, click Point.   

4. From the Viewport, click the point you want to enter your boring point. 

5. The Boring Point window will open.  

6. From the Name field, select the boring point you want to plot.  

Tip: By default Altitude will be set to Undefined, if you leave this the altitude will be 

determined by entered contours and spot elevations. 

7. Click OK. 
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Figure 37. Assign Boring Points 
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Takeoff Contours 
Contours are lines that represent the geographic topography of the site. MudShark gives you multiple 

ways to takeoff contours, and the more you experience these tools, the easier you will be able to 

determine when to use each drawing tool. 

Tip: Always ensure the right Site is selected before you takeoff contours.  

Takeoff Contours From a Layer 

If the plan you want to takeoff contours from is DWG or DXF file, you might be able to use Transmute for 

a layer to automatically takeoff all contours. This will require the DWG or DXF plan to have a layer with 

only contours and 3D information about those contours, specifically altitudes. If your plan fulfils the 

criteria, using Transmute on a layer is the fastest way to takeoff contours. 

 

Figure 38. Selecting Transmute for contours 
 

To Transmute a contour layer: 

1. From the Home tab in the ribbon, select Existing or Proposed to determine the site your 

contours will be added to.  

2. From the Ground group in the ribbon, click Contours.   

3. From the Drawing group in the ribbon, click Transmute.   

4. From the Plans pane, expand the DWG or DXF plan which has the contours you want to 

takeoff. 

5. Click the layer that contains the contours. 

Tip: Use the visibility options to ensure you have the right layer for your contours.  

6. The Transmute window will open, telling you how many layers MudShark will transmute.  

7. Click Transmute. 
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Takeoff Contours from the Viewport 

If you want to takeoff contours from a plan that contains vector details (like a DWG file, DXF file, or 

vectorised PDF file) you can use Transmute. If your plan does not fulfil the criterial, you might need to 

takeoff the contour with Polyline.  

 

Figure 39. Selecting Transmute for contours 
 

To Transmute contours from the Viewport: 

1. From the Home tab in the ribbon, select Existing or Proposed to determine the site your 

contours will be added to.  

2. From the Ground group in the ribbon, click Contours.   

3. From the Drawing group in the ribbon, click Transmute.   

4. From the Task panel, select Custom from the Altitude source drop down menu.  

Tip: You can select Plan for the Altitude source if you have a DWG or DFX file with 3D data, but 

want to takeoff the contours one at a time instead of the whole layer.  

5. From the Task panel, enter your Next altitude, which will be the altitude you will draw first.  

6. From the Task panel, enter the Increment the altitudes on the plan adjust by, then select 

the Direction that the altitude is changing.  

Tip: You can, and likely will change the Direction as you go, between increasing, remaining the 

same and decreasing.  

7. Mouse click on the contour in the Viewport that you wish to takeoff first.  

Tip: Regardless of length, complexity and curvature, as long as there are no breaks in the contour, 

Transmute will takeoff the entire contour with one click.  

8. Your Next altitude will be displayed in the Task panel, which will be the previous altitude 

modified by the Increment and Direction set. If these are correct, continue your takeoff, or 

change them to proceed.  

Tip: You can also just type the altitude value using your keyboard, this number will be entered as 

your Next altitude regardless of what was there before.  
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Takeoff Dashed-Line Contours  

If you want to takeoff contours that are created with dashed-lines and the plan contains vector details 

(like a DWG file, DXF file, or vectorised PDF file) you can use Transmute Dashed. If your plan does not 

fulfil the criterial, you might need to takeoff the contour with Polyline.  

 

Figure 40. Selecting Transmute Dashed for contours 
 

To Transmute dashed-line contours from the Viewport: 

1. From the Home tab in the ribbon, select Existing or Proposed to determine the site your 

contours will be added to.  

2. From the Ground group in the ribbon, click Contours.   

3. From the Drawing group in the ribbon, click the arrow under Transmute, then click 

Transmute Dashed.   

4. From the Task panel, select Custom from the Altitude source drop down menu.  

Tip: You can select Plan for the Altitude source if you have a DWG or DFX file with 3D data, but 

want to takeoff the contours one at a time instead of the whole layer.  

5. From the Task panel, enter your Next altitude, which will be the altitude you will draw first.  

6. From the Task panel, enter the Increment the altitudes on the plan adjust by, then select 

the Direction that the altitude is changing.  

Tip: You can, and likely will change the Direction as you go, between increasing, remaining the 

same and decreasing.  

7. Mouse click on the contour from the Viewport that you wish to takeoff first.  

Tip: Transmute Dashed will try and takeoff as much of the contour as possible.  

8. If the entire contour is found and added to your takeoff, click the right-mouse button to 

complete the contour. If not, keep clicking along the dashed line until the contour is 

complete.  

Tip: You may need multiple clicks to complete the contour.  

9. Your Next altitude will be displayed in the Task panel, which will be the previous altitude 

modified by the Increment and Direction set. If these are correct, continue your takeoff, or 

change them to proceed.  

Tip: You can also just type the altitude value using your keyboard, this number will be entered as 

your Next altitude regardless of what was there before.  
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Takeoff Contours by Tracing  

No matter what type of plan you’re using, you can always takeoff contours with Polyline. However, if you 

plan will allow you to use another method, you should try it first.   

 

Figure 41. Selecting Polyline for contours 
 

To trace a contour: 

1. From the Home tab in the ribbon, select Existing or Proposed to determine the site your 

contours will be added to.  

2. From the Ground group in the ribbon, click Contours.   

3. From the Drawing group in the ribbon, click Polyline.   

4. From the Task panel, enter your Next altitude, which will be the altitude you will draw first.  

5. From the Task panel, enter the Increment the altitudes on the plan adjust by, then select 

the Direction that the altitude is changing.  

Tip: You can, and likely will change the Direction as you go, between increasing, remaining the 

same and decreasing.  

6. Mouse click at the end of the contour from the Viewport that you wish to takeoff first.  

Tip: If you are tracing a DWG, DFX or vectorised PDF, you can hold Shift to snap to the endpoint 

for greater accuracy. 

7. If the contour isn’t a straight line, click at each corner or point where the line changes 

direction. If the contour curves, click at the start of the curve and hold the left-mouse 

button at the end of the curve, then drag your cursor towards to curve the line.  

Tip: If you’re having trouble with a curve, try breaking it into smaller arcs.  

8. Mouse click the end of the line, then right-mouse click to complete the contour to your last 

left-mouse click.  

Tip: To close the boundaries, you can use the shortcut Ctrl + J to join the last drawn point to the 

first.  

9. Your Next altitude will be displayed in the Task panel, which will be the previous altitude 

modified by the Increment and Direction set. If these are correct, continue your takeoff, or 

change them to proceed.  

Tip: You can also just type the altitude value using your keyboard, this number will be entered as 

your Next altitude regardless of what was there before.  
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Takeoff Spot Elevations 
Spot elevations are points that represent the geographic topography of the site. MudShark gives you two 

ways to takeoff spot elevations.  

Tip: Always ensure the right Site is selected before you takeoff spots.  

Takeoff Spot Elevations From a Layer 

If the plan you want to takeoff spot elevations from is a DWG or DXF file, you might be able to use 

Transmute for a layer to automatically takeoff all spots. This will require the DWG or DXF plan to have a 

layer with only points or symbols representing spot points and 3D information about those spots, 

specifically altitudes. If your plan fulfils the criteria, using Transmute on a layer is the fastest way to 

takeoff spot elevations. 

 

Figure 42.Transmute for Spot Elevations. 
 

To Transmute a spot elevation layer: 

1. From the Home tab in the ribbon, select Existing or Proposed to determine the site your 

spots will be added to.  

2. From the Ground group in the ribbon, click Spot Elevations.   

3. From the Drawing group in the ribbon, click Transmute.   

4. From the Plans pane, expand the DWG or DXF plan which has the spots you want to 

takeoff. 

5. Click the layer that contains the spot elevations. 

Tip: Use the visibility options to ensure you have the right layer for your spot elevations.  

6. The Transmute window will open, telling you how many layers or points MudShark will 

transmute.  

7. Click Transmute. 
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Takeoff Spot Elevations Individually  

No matter what type of plan you’re using, you can always takeoff spot elevations one-at-a-time with 

Point.  

 

Figure 43. Using Point to takeoff Spot Elevations. 
 

To enter spot elevations: 

1. From the Home tab in the ribbon, select Existing or Proposed to determine the site your 

contours will be added to.  

2. From the Ground group in the ribbon, click Contours.   

3. From the Drawing group in the ribbon, click Point.   

4. From the Task panel, enter your Next altitude, which will be the altitude of the spot you 

enter next.  

5. From the Viewport, click the spot locations are at the altitude you entered.  

6. Using your keyboard, type the altitude for the next spot elevation you intend to takeoff, this 

value will be displayed in the Task panel in the Next altitude field.  

7. Continue entering the spot elevations you wish to use for calculation.  
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Takeoff Structures 
You can create structures in MudShark to be demolished or built. Structures are created with enclosed 

boundaries, and have their own volumes.  

Understanding Structures  

Structures are designed to be flexible, and can be used in a number of ways to simplify your takeoff and 

provide greater accuracy.  

Structures can be used to takeoff:  

• Building slabs 

• Footpaths and driveways 

• Landscaping  

• Roads 

• Carparks 

• Sports fields 

• Banking and batter 

• Retaining Walls 

 

Any structure created for the Existing Site is categorised as a Demolished Structure, and any materials 

detailed in these structures will require to be removed from site.  

Any structure created for the Proposed Site is categorised as a Built Structure, and any materials 

detailed in these structures will require to be reused from cut materials or imported onto site.  

Tip: If a structure in your project won’t change or affect your earthworks, instead of creating a 

structure, you can excluded that area from the Working Area. Read more here: Understanding Working 

Areas.  



  

57 

 

 

Create a New Structure 

You can create as many structures as you need for a project.  

To create a new structure: 

1. From the Home tab in the ribbon, select Existing or Proposed to determine the site your 

structure will be added to.  

Tip: Structures in the Existing Site are Demolished Structures,  in the Proposed Site are Built 

Structures. 

2. From the Earthworks group in the ribbon, click the dropdown arrow under Structure.  

Tip: Use the keyboard shortcut Ctrl + Shift + N to create a new structure. 

3. The New Structure window will open.  

4. Enter a Name for your structure.   

5. You can select Overlay options, and the direction of your Surface Definition.  

6. Click Advanced for additional structure options.  

Tip: Learn more here: Understanding Overlay Options and Advanced Structure Options 

7. You can set the Area type, Colour, and Line width to affect the structure’s appearance. 

8. Enter a Starting Altitude for your structure . 

Tip: Structure boundaries can have different altitudes, which can be defined when performing 

takeoff.  

9. Enter any materials for your structure, you can select or create a new material in the 

Material column and set a thickness in the Thickness column.  

10. Click Create. 

 

Figure 44. The New Structure window. 

Understanding Overlay Options 

The Overlay options define how the surface within a structure boundary is created.  
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When no Overlay options are set, a structure will be calculated from inputted altitudes, so contours and 

spot elevations are ignored.  

When an Overlay option is selected, the surface of a given structure is produced from contours or spot 

elevations, and inputted altitudes for that structure is ignored.  

 

Surface Option Checked 

With only the surface option ticked the boundary points as input are used in conjunction with any 

contours or spots which cross or are within the structure boundary to define the structure surface. The 

user can use precise control for the boundary points specifying their altitude and use contours and spots 

to create a complex surface within the boundary. A good example of this use is; you have a car park or 

road with well-defined edges with known points defining the perimeter in addition to contours or spots 

defining an internal shape for drainage. 

 

Points Option Checked 

With only the boundary points option ticked the input boundary point altitudes are ignored and the 

altitude of the points projected onto the surface defined by the spots and contours is used instead. A 

linear surface is created within the boundary. This option is the least commonly used but has some uses 

when the boundary point altitudes are not know and it is felt the overlaying to obtain the altitudes using 

the contour and spot information would be accurate enough without seeking further detail. 

 

Surface and Points Options Checked 

With both surface and boundary points ticked the structure surface is created using the spots and 

contours. This is a bit like laying a cloth over the surface so it matches exactly. The most common use of 

this option is where there is landscaping and there are different areas of materials e.g. One area may be 

turfed and another may be flower beds. 

 
Tip: Using overlay options will add complexity to your project and increase calculation time.  
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Advanced Structure Options 

Trim 

Trimming options allow the structure to be trimmed against the surface generated by the contours and 

spots in either the Existing or Proposed sites.  By default, your structures are set to None, and the 

structure boundary remains as it was created. 

If you check Top To Proposed of Top to Existing, the top surface of the structure will be trimmed against 

the Proposed Site or the Existing Site.  

Tip: Top to Proposed can be the best option for calculating banking and batter. 

If you check Bottom to Proposed or Bottom to Existing the bottom surface of the structure will be 

trimmed against the Proposed Site or Existing Site. site.  

Tip: If there are materials in the structure you are trimming from the bottom of, the structure will protrude 

above the surface by the material depth.  

If setting a Trim option, you will need to indicate whether you are trimming to Inside or Outside from the 

Trim To options.  Selecting Inside this will trim the structure and keep the part under the surface. 

Selecting Outside will trim the structure and keep the part above the surface. 

Tip: In most cases select Inside for calculating batter and Outside for calculating banking. 

Cut and Fill Options 

You can specify what cut and fill calculations are performed for the structure. The default options for a 

Demolished structure are Fill Underneath and Back Fill, and for a Built Structure are Calculate Cut and 

Fill Underneath. 

Calculate Cut and Fill Underneath will calculate the cut or fill respectively for the structure.  

Trim Fill To Proposed is useful where a structure slab extends above the surface of the Proposed Site 

and you want to have fill underneath, but only to the point where the structure intersects the Proposed 

surface.  

Back Fill indicates whether fill should be applied above the structure.  

Respread Under is used in conjunction with Trim Fill to proposed and re-spreading, and if a structure 

extends beyond the surface of the Proposed Site, the respread will be extended under that structure 

extension.   
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Trace Structure Boundary  

There are multiple ways to takeoff boundaries for a structure, including tracing the boundary from a 

plan.  

To trace a boundary for a structure: 

1. From the Home tab in the ribbon, select Existing or Proposed, depending on where the 

Structure was created.  

2. From the Earthworks group in the ribbon, click the arrow in Structure.   

3. Select the structure you want to takeoff the boundary for.  

4. From the Drawing group in the ribbon, click Polyline.   

5. From the Task panel, enter your Next altitude, which will be the altitude you will draw first. 

You can change the altitudes at each point, or leave it the same depending on the structure 

you’re drawing.   

6. From the Viewport, click at the corner of the a structure you’re tracing.  

Tip: If you are tracing a DWG, DFX or vectorised PDF, you can hold Shift to snap to the corner for 

greater accuracy. 

7. If a part of the structure is curved, click at where the line begins to arc, then click and hold 

the left-mouse button at the end of the curve, then drag your cursor towards to curve the 

line.  

Tip: If you’re having trouble with a curve, try breaking it into smaller arcs.  

8. Mouse click the end of the line, then right-mouse click to complete the contour to your last 

left-mouse click.  

Tip: To close the boundaries, you can also use the keyboard shortcut Ctrl + J to join the last drawn 

point to the first.  

 

  



  

61 

 

Takeoff Structure Area 

There are multiple ways to takeoff boundaries for a structure, including finding the area for a structure.  

To takeoff a structure from an area: 

1. From the Home tab in the ribbon, select Existing or Proposed, depending on where the 

Structure was created.  

2. From the Earthworks group in the ribbon, click the arrow in Structure.   

3. Select the structure you want to takeoff the boundary for.  

4. From the Drawing group in the ribbon, click the arrow in Transmute. 

5. Select Transmute Area.    

6. From the Task panel, enter your Next altitude, which will be the altitude your structure 

uses  

7. From the Viewport, move your mouse into the are of the structure you’re trying to takeoff.  

Tip: You can move your mouse around until the area preview displays the area you want to use. 

8. Use your mouse to click, and the boundary of the area will be used to create a takeoff for 

the structure.  

Tip: Transmute Area is the fastest way to takeoff a boundary, but if the boundary uses changing 

altitude points it has to be edited after you have created your structure. Alternatively, you can use 

Polyline to takeoff the structure for more control as you takeoff.  
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Editing Structure Boundary Altitudes 

You can edit the altitudes for each point of a structure boundary, whether you’re input the boundary 

wrong or just want to change it.  

To edit the altitudes of a structure boundary: 

1. From the list panes, click Takeoff. 

2. Navigate to expand either the items from the Demolished Structures in Existing or Built 

Structures in Proposed. 

3. Click the arrow to expand the structure you want to edit.  

4. Click to select the Boundary you want to edit. 

5. Click Point Altitudes from the Properties pane. 

6. The altitudes for each point will be shown, you can enter a new altitude for any of these 

points.  

 

 

Figure 45. Edit Point Altitudes for a takeoff item boundary 

 

  



  

63 

 

Stripping and Respread 
To save you time, MudShark automatically calculates the volumes for stripping and respread based on 

the takeoff you have entered. All you need to calculate your stripping and respread, is to enter a 

thickness for each.  

By default, Strip by thickness and  Respread thickness will be set to 0, unless you have set a default in 

Options before you created the project. Instead of stripping by thickness, you can select layers to be 

removed using the Strip Away drop-down menu.  

You can enter a thickness for stripping and respread, or the layers to strip from the Ground Settings 

options in the Project Details embedded tab or from the Calculate Checklist window which appears 

when you click Calculate. 

 

 

Figure 46. Striping and Respread options in Ground Settings. 
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Set Stripping Thickness 

Your stripping can be calculated by setting a thickness, and your Existing Site will strip the thickness 

regardless of material layer.  

To set a stripping thicknesses: 

1. From the Project Details embedded tab, click Ground Settings option. 

2. Click the radio button for Strip by thickness.  

3. You can enter the thickness you wish to strip for your Existing Site in the Strip by 

Thickness field. 

Tip: You don’t need to enter whole numbers, you can use decimals for accuracy, like 0.1 or 0.75. 

Select Layers to be Stripped Away 

Your stripping can be calculated by selecting one or more material layers, which will be stripped from 

your Proposed Site regardless of thickness.  

To strip by layers: 

1. From the Project Details embedded tab, click Ground Settings option. 

2. Click the radio button for Strip away.  

3. Click the field under Strip away, and select the material layer or material category you wish 

to strip away to.  

Tip: You can read more about materials, including material categories, here: Understanding 

Materials 

 

Set Respread Thickness 

Your respread can only be respread by setting a thickness.  

To set a respread thicknesses: 

1. From the Project Details embedded tab, click Ground Settings option. 

2. You can enter the thickness you wish to respread for your Proposed Site in the Respread 

Thickness field. 

Tip: You don’t need to enter whole numbers, you can use decimals for accuracy, like 0.1 or 0.75. 
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Materials 
Understanding Materials 
In MudShark, you can use a materials library to control how it looks and affects how the Material 

behaves when subjected to cut and fill operations. 

Materials can also be divided into Global Materials which are accessible for all projects, and Project 

Materials which are accessible only for a specific project. 

There are multiple editable fields for materials, including Description, Category, Colour, Unsuitable 

percentage and Note. Within a project you can set whether that material is used for Respread, Structure 

Fill, and Ground Fill. You can also set a Bulking and Compression factor.  

Access Global Materials 

Materials created in the Global Materials list can be used in any project.  

To access Global Materials: 

1) From the Data tab in the ribbon, click Global Materials. 

2) The Global Material window will open.  

 

Figure 47. Global Materials window 
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Access Project Materials 

Once you use a material in a project, it will be added to the Project Materials list.  

Project Materials are unique to a project, any property of that material that is changed will change 

everywhere in that project, but will not affect other projects or the Global Material list. 

For Project Materials, you can set whether certain materials are used for Respread, Structure Fill, and 

Ground Fill. 

Tip: Selecting a Material in the Project Materials window will highlight that Material in the Viewport, if 

its use is currently visible. 

To access Project Materials: 

1) From the Data tab in the ribbon, click Project Materials. 

2) The Project Materials window will open.  

 

 

Figure 48. Project Materials window 
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Understanding Factors 

You can set two factors for each material, a Bulking Factor and a Compression Factor. These materials 

affect the volumes added or removed to the ground or a structure. By default, factors are set to 1.0, but 

they can be changed. If you have set these factors for the Global Materials list, those factors will be used 

for each project, but can be changed. 

 

Bulking Factor 

Sometimes, when material is moved from the ground it can swell up to occupy a larger volume. You can 

use the Bulking Factor to indicate the extent of this bulking. 

For Example: If a material has its Bulking Factor set to 2.00, when that material is Cut from the soil the 

volume will be double. 

  

Compression Factor 

Sometimes, when Material is added to the ground it can settle, shrink, or be compacted to be a smaller 

volume. You can use the Compression Factor to indicate how material behaves in this circumstance. 

For Example: If you are importing material from offsite, you can set the Compression to 0.5, so that the 

imported material will halve in volume when it is put into the ground. 

 

Factor Order 

If you are reusing material, the Bulking Factor will be calculated first and then the Compression Factor 

applied next 

For Example: If the materials Bulking Factor is 2,  the Compression Factor is 0.5, the reused 

material will be half of the banked volume and a quarter of the bulked volume. 
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Using Materials 
Two Materials are added into a project by default; Respread Material and Fill Material. These both 

denote the properties of material that may need to be imported into the site. Changes made to the 

Respread Material can affect the Imported Respread results, likewise, changes to the Fill Material can 

affect the Imported Fill results. 

Tip: The default values for Respread Material and Fill Material can be changed in Options, but these 

will take effect on the next new project. 

 
 

Add a New Material 

You can add materials to the Global Materials list.  

To add a new material: 

1) From the Data tab in the ribbon, click Global Materials. 

2) The Global Material window will open.  

3) From the Categories pane, select a category. 

Tip: To create a new category, enter a Name then select a Default Colour for that category. 

4) Select the bottom most row from the Materials pane. 

5)  Enter a Description for the material. A default Colour will automatically be set, as will 

Bulking and Compression factors; you can edit these.  

6) Click Save. 

 

Figure 49. Add material to Global Materials 
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Results 

Understanding Results 
So your takeoff is efficient and seamless, MudShark won’t calculate your results until you’re ready.  

MudShark can calculate Results for:  

• Stripping area and volumes 

• Cut and fill volumes in open ground and beneath structures 

• Respread area and volumes 

• Structure material volumes 

• Material reuse 

• Site balance volumes 

• Trench and pipe networks 

• Areas, Lengths, and counts 

 

To calculate results MudShark requires at least: 

• A  defined Working Area  

• An elevation (Contour or Spot Elevation) in the Existing Site 
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Calculate Your Results 
You can calculate results at anytime, however we recommend waiting until most of your takeoff is done 

or complete.  

 

Figure 50. Calculate button 

To calculate your Results: 

1. From the Home tab in the ribbon, click Calculate. 

2. The Calculate Check List window will appear. 
 

TIP: Any defaults entered in the Ground Settings under Project Details will show here. You can 

change these settings, and your defaults for the project will remain unchanged. 
 

3. You can set the depth you want to strip the site by in Strip by thickness or select layers to 

strip from the Strip layers menu.  

4. Select a volume that will be used for Respread thickness.  

5. You can check, or uncheck Calculate Open Ground Fill, if checked, any area without a 

structure on top will be calculated when you click Calculate.  

6. You can check Only Use Proposed Contours For Structures, which will otherwise ignore 

contours except for structures. By default, this is unchecked.  

7. You can check Calculate Heat Map, which will generate a Heat Map for your project. 

Checking this option will increase the time it takes for your calculation to complete. 

8. Click Ok. 

TIP: Your project may take a few minutes to calculate, calculation time depends on multiple 

factors, including scale and amount of takeoff. 

 

 

Figure 51. Calculate Check List window 
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Inspect 3D Site 
Calculating your project, will generate your site in 3D, which you can use to validate your results. 

Inspecting your 3D site in the Viewport is one of the best ways to validate your results, because you can 

zoom in close and any incorrect altitudes will be immediately noticeable by spikes.  

Tip: You can export an image of the current Viewport or your site as a 3D vector file by clicking 

Viewport Snapshot and Visible Site respectively from the Data tab in the ribbon. 

To inspect your site in 3D: 

1) From the Home tab in the ribbon, click 3D.  

2) Use the Viewcube to change the angle of your site, and scroll into your site with your mouse 

wheel, and pan around the site by clicking your scroll wheel button.  

3) From the 3D Site List pane, you can change the visibility of different layers.  

TIP: Click Existing or Proposed from the Home tab in the ribbon, to change your 3D site between 

these states. 
 

 

Figure 52. 3D Site  of a Proposed Site.  
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Understanding Edge Styles 

You can change how the 3D is displayed in your Viewport.  

There are three display options: 

• Sharp highlights the edges of your 3D with a black line. 

• Opaque highlights the edges with a lighter version of the material colour. 

• Smooth doesn’t highlight edges at all.  

 

Change Edge Styles 

To rotate a plan by a custom degrees: 

1. From the View tab in the ribbon, click Edge Style. 

2. Select between Sharp, Opaque, and Smooth for the edge style you which to view your 3D 

site. 

TIP: By default, Sharp edge style will be displayed.   

 

 

Figure 53 Select Edge Style 
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Check Contours 
If your results couldn’t be calculated, or on inspecting your site in 3D something looked wrong, you might 

have crossing contours. MudShark can check if you have any contours that match this.  

To check your Contours: 

1. Click the arrow under Check from the Home tab in the ribbon. 

2. Click Check Contours. 

3. Any crossing contours will be highlighted, or you will be greeted with a notification reading: 

No incorrect contours found. 

 

Figure 54. Check contours 
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Results Grid 
All volume results are collated, filtered and grouped in the Results pane as a grid. From the Results 

embedded tab, you can drill down into details about your volumes.  

The Results pane will show you total Cut (Bulked) volume for a single Strata Operation, a single Material 

or the Entire Site. It will also show you how much Exported (Bulked) volume needs to be taken off site 

and how much is Reused (Bulked) in the site. 

You can see the total volume for the Fill (Compressed) and a breakdown of how much of that was reused 

From Site (Compressed) versus what will need to be Imported (Banked) from off site. 

These volumes are then summarised as Site Balance (Bulked), which displays which items have a net 

effect of requiring materials to be removed from the site or brought in from elsewhere. A negative 

number indicates a net effect of material being removed from the site. You can then use the Site Balance 

(Bulked) values to adjust your earthwork plans to try and achieve the optimal material reuse. 

 

 

Figure 55. Results pane 
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Result Filters 

There are filters you can apply to your results.  

There are two groupings: 

• The Strata Operations group includes results organised by the Strata Operation that affects 

them so you can easily see volumes as they relate to each operation, regardless of material.  

For example: All Stripping is under a single group. 

• The Materials group includes results organised by the type of material used, so you can see how 

much of each material is being used, and where it is being used on the site.  

For example: All Sand (dry) is under a single group. 

For each grouping you are able to drill down into finer detail that shows where the result has come from. 

You can filter these groups so that you are only able to see volume results from Structures, Ground or 

All. 

Tip: Selecting items in the Results pane will highlight them in the Viewport.  
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Export Results 
You can export your results in a number of formats, including for Microsoft Excel and a snapshot of the 

Viewport. 

Export to Cubit 

You can export your results for Cubit – Natural Estimating. You will save your results as a XML result file, 

which can then be imported into Cubit. 

 

Figure 56. Click Cubit to export your results for the estimating software 

 

To Export your results for Cubit: 

1. From the Data tab in the ribbon, click Cubit. 

2. Navigate your computer and select the location where you want to save the file. 

3. Enter a name in the File name box, by default the project name will be used. 

TIP: Your results will be saved as a XML result file. 

4. Click Save. 
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Export to CostX 

You can export your results for CostX. You will save your results as a RIB file, which can then be 

imported into CostX. 

 

Figure 57. Click Cubit to export your results for the estimating software 

 

To Export your results for Cubit: 

1. From the Data tab in the ribbon, click CostX. 

2. Navigate your computer and select the location where you want to save the file. 

3. Enter a name in the File name box, by default the project name will be used. 

TIP: Your results will be saved as a RIB file. 

4. Click Save. 
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Export to Microsoft Excel 

You can export your results, or measurements to a Microsoft Excel file.  

 

Figure 58. Excel export options 

To export a Microsoft Excel file:  

1. From the Data tab in the ribbon, click the arrow under Excel. 

2. Select Results to Excel or Measurements to Excel, to export your results or measurements. 

TIP: If there are changes to your project that haven’t been calculated, you will be offered a chance to 

Calculate Site. 

3. Navigate your computer and select the location where you want to save the file. 

4. Enter a name in the File name box, by default the project name will be used. 

5. Click Save. 

The Excel file will have the different results filters as separate tabs. Also, the data is formatted so you can 

interact with the data groups like you do in MudShark , with expandable and collapsible groups. 

 

Figure 59. A MudShark project in Microsoft Excel  
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Export a Viewport Snapshot 

You can save an image file of the Viewport and its contents. You can take snapshots of your project 

Takeoff or 3D, Existing or Proposed sites, and with any visibility you’ve set.   

 

Figure 60. Click Viewport Snapshot to export an image of your Viewport 

 

To Export a Viewport Snapshot: 

1. From the Data tab in the ribbon, click  Viewport Snapshot. 

2. Navigate your computer and select the location where you want to save the file. 

3. Enter a name in the File name box, by default the project name will be used. 

4. From the Save as Type box select the file type you want to create, by default this is set to 

PNG.  

TIP: You can also save your site as a BMP file or EMF file. 

5. Click Save. 

 

Figure 61. A Viewport snapshot 
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Export 3D Vector Data 

You can export all visible entities in the Viewport as a 3D vector file, which can be used in other 

applications. You can control the visibilities from the 3D Site List pane. 

Saving your project as a 3D vector file is useful if you utilise a BIM workflow or 3D printing. 

 

 

Figure 62. Click Visible Site to export your 3D vector site 

 

To Export the Visible Site: 

1. From the Data tab in the ribbon, click Visible Site.. 

2. Navigate your computer and select the location where you want to save the file. 

3. Enter a name in the File name box, by default the project name will be used. 

4. From the Save as Type box select the file type you want to create, by default this is set to 

DWG.  

TIP: You can also save your site as a DXF file, OBJ file, 3D Print STL file, or a 3d Webgl HTML file. 

(Use 3D Print STL file for 3D printing.) 

5. Click Save. 
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Keyboard and Mouse Shortcuts 
General 
 

Delete Delete current selection. 

Ctrl + S Save the current Project. 

Ctrl + O Open a Project. 

Ctrl + N Create a New Project. 

Ctrl + Shift + N  Create a New Structure. 

Ctrl + Z Undo. 

Ctrl + Y Redo. 

Ctrl + C Copy text from a control. 

Ctrl + V Paste text into an editable control. 

Ctrl + right arrow Move the insertion point to the beginning of the next word. 

Ctrl + left arrow Move the insertion point to the beginning of the previous word. 

Ctrl + Tab Cycle through pane windows. 

Ctrl + F4 Close the active pane if that pane can be closed. 

Ctrl + 1 Show Plan List pane. 

Ctrl + 2 Show Take Off List pane. 

Ctrl + 3 Show 3D Site List pane. 

Ctrl + 4 Show Properties pane. 

Ctrl + 5 Show Project Details pane. 

Ctrl + 6 Show Viewport pane. 

Ctrl + 7 Show Results pane. 
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Viewport 
 

Ctrl + A Selects all the entities in the Viewport. 

Left arrow Pan the Viewport left. 

Right arrow Pan the Viewport right. 

Up arrow Pan the Viewport up. 

Down arrow Pan the Viewport down. 

Ctrl + 0 Perform zoom fit of Viewport entities. 

Ctrl + J Joins the last takeoff point to the start point. 

Scroll mouse wheel Zooms into the Viewport. 

 Click mouse wheel Enables panning of the Viewport contents. 

 

List Panes 
 

Asterix* Display all sub-items under selected item. 

Plus* Display all sub-items directly under selected item. 

Minus* Collapse items directly under the selected item group. 

Left arrow Collapse current selection. 

Right arrow Display all sub-items directly under the selected item. 

Ctrl + up arrow Scroll the list without affecting the selection. 

Ctrl + down arrow Scroll the list without affecting the selection. 

 
 
 
 
 
 
 

* Shortcut only applies to numeric keypad 


