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Before You Begin
Before You Begin
This section provides you with safety information, technical support 
information, and sources for additional product information.

Safety Information
Your safety is extremely important. Read and follow all warnings and 
cautions in this document before handling and operating Intermec 
equipment. You can be seriously injured, and equipment and data can be 
damaged if you do not follow the safety warnings and cautions.

This section explains how to identify and understand dangers, warnings, 
cautions, and notes that are in this document. You may also see icons that 
tell you when to follow ESD procedures and when to take special 
precautions for handling optical parts.

Global Services and Support

Warranty Information
To understand the warranty for your Intermec product, visit the Intermec 
web site at www.intermec.com and click Service & Support. The Intermec 
Global Sales & Service page appears. From the Service & Support menu, 
move your pointer over Support, and then click Warranty.

Visit www.intermec.com/activate to activate your warranty.

Disclaimer of warranties: The sample code included in this document is 
presented for reference only. The code does not necessarily represent 
complete, tested programs. The code is provided “as is with all faults.” All 
warranties are expressly disclaimed, including the implied warranties of 
merchantability and fitness for a particular purpose.

Web Support
Visit the Intermec web site at www.intermec.com to download our current 
manuals in PDF format. To order printed versions of the Intermec 
manuals, contact your local Intermec representative or distributor.

A warning alerts you of an operating procedure, practice, condition, or 
statement that must be strictly observed to avoid death or serious injury 
to the persons working on the equipment.

A caution alerts you to an operating procedure, practice, condition, or 
statement that must be strictly observed to prevent equipment damage 
or destruction, or corruption or loss of data.

Note: Notes either provide extra information about a topic or contain 
special instructions for handling a particular condition or set of 
circumstances.
EasyADC® for SAP Business One System Manual vii
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Before You Begin
Visit the Intermec technical knowledge base (Knowledge Central) at 
intermec.custhelp.com to review technical information or to request 
technical support for your Intermec product.

Telephone Support
These services are available from Intermec Technologies Corporation.

Outside the U.S.A. and Canada, contact your local Intermec representative. 
To search for your local representative, from the Intermec web site, click 
Contact.

Who Should Read this Manual
The EasyADC® for SAP Business One System Manual provides you with 
information about the software components of SmartSystems Console and 
EasyADC Data Collection Management.

Before you configure the SmartSystems and EasyADC applications, you 
should be familiar with your network and general networking terms, such 
as IP addresses.

Use this manual to install the software and hardware and test the installa-
tion, learn about EasyADC, use the EasyADC Inventory Transactions on 
CK30s, and train users and operators.

Service Description

In the U.S.A. and Canada 
call 1-800-755-5505 and 
choose this option

Order Intermec 
products

• Place an order.
• Ask about an existing order.

1 and then choose 2

Order Intermec media Order printer labels and ribbons. 1 and then choose 1
Order spare parts Order spare parts. 1 or 2 and then choose 4
Technical Support Talk to technical support about 

your Intermec product.
2 and then choose 2

Service • Get a return authorization 
number for authorized service 
center repair.

• Request an on-site repair tech-
nician.

2 and then choose 1

Service contracts • Ask about an existing con-
tract.

• Renew a contract.
• Inquire about repair billing or 

other service invoicing ques-
tions.

1 or 2 and then choose 3
viii EasyADC® for SAP Business One System Manual
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Before You Begin
Related Documents

The EasyADC and SmartSystems CDs contain PDF copies of these 
manuals. To access these manuals, insert the CDs in your CD drive, cancel 
the Installation Wizard that launches automatically, and browse to the 
“\Manuals” folder.

The Intermec web site at www.intermec.com contains our documents that 
you can download in PDF format.

To order printed versions of the Intermec manuals, contact your local 
Intermec representative or distributor.

Document Title Part Number

EasyADC for SAP Business One Installation CD 235-113-001

SmartSystems Foundation - ADC Console Installation CD 235-113-002

CK30 Handheld Computer User’s Manual 073528

CK30 Command Reference Manual 073529

MobileLAN access WA2X System Manual 073915

EasyCoder PM4i Bar Code Label Printer User’s Guide (Fingerprint 
Version)

1-960583

LabelShop ULTRA/PRO User’s Manual N/A

LabelShop START Quick Start Guide N/A
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 Quick Start
Quick Start
This section provides an outline of what needs to be installed and config-
ured to set up your EasyADC® network. Each step includes a page reference 
where detailed information begins in this system manual.

Using the CK30 Handheld Computers
This chapter introduces the CK30 Handheld Computer keypad, explains 
how to log on and off the CK30, and how to move through the EasyADC 
Terminal menus on the CK30. Go to Chapter 3, starting on page 35, to 
learn how to use the CK30.

Using the EasyADC Data Collection Manager
This chapter explains how to use the modules of the EasyADC Data Col-
lection Manager application. The following topics are addressed:

• Using the Remote Terminal Emulator (page 55)

• Using the System Manager (page 56)

• Viewing Log and Error Log Information (page 61)

• Running the Benchmark Reports (page 63)

• Doing the Warehouse Inventory (page 67)

Using the SmartSystems™ Console
This chapter explains how to use the SmartSystems Console to monitor 
and manage the hardware components of the system. The following infor-
mation is covered:

• Starting the SmartSystems Console (page 72)

• Monitoring Devices (page 72)

• Viewing the Troubleshooting Tips (page 73)

• Enabling Email Notification (page 73)

• Configuring the Network Security Level (page 74)

• Adding New Devices (page 74)

• Resetting an Access Point to its Factory Defaults (page 74)

• Updating System Software (page 75)

• Updating the Discovered Devices Folder (page 75)

Troubleshooting
This chapter addresses how to troubleshoot your system. Information 
begins on page 77.
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1Introducing EasyADC® for SAP 
Business One

The following information is available in this chapter:

• What is EasyADC? (page 2)

• What are the EasyADC Requirements? (page 4)
EasyADC® for SAP Business One System Manual 1
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What is EasyADC?
EasyADC is an easy and efficient bar code data collection system that seam-
lessly integrates with SAP Business One. 

This system enables access into SAP Business One through select transac-
tions supported on the CK30. This allows the user to collect information 
on the warehouse floor using the CK30 by scanning and entering informa-
tion which is updated in the SAP Business One system in real time.

EasyADC is a self-contained system for adding bar code data collection to 
the warehouse distribution environment and has these advantages: 

• Reduced errors

• Increased speed

• Improved order-to-cash cycle

• Rapid ROI (Return on Investment)

• Visibility

• Productivity

• Profitability

• Security

EasyADC Hardware Components
The standard EasyADC includes these products:

• Two CK30 Handheld Computers
wireless handheld computers with integrated bar code scanners

• One MobileLAN™ access WA22 Access Point
high-speed and high-security wireless access point

• One EasyCoder® PM4i Fingerprint Printer
industrial-strength thermal label printer

• CK30 Charging Docks
that keep your CK30s fully charged when not enroute
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EasyADC Software Components
EasyADC consists of the following applications from Intermec in addition 
to partner applications, such as Wavelink Avalanche:

• SmartSystems™ Console

• EasyADC Data Collection Manager

• EasyADC Inventory Transactions on the CK30s

• LabelShop PRO 6

What is the SmartSystems Console?
The SmartSystems Console is a software platform that provides a single, 
integrated environment for hands-free deployment and management of 
devices located anywhere in the enterprise – on-site or remote. The console 
works with the Intermec components of your system to make the most of 
limited IT resources, and lower your total cost of ownership for data collec-
tion equipment.

To Your Network

CK30
Scans bar code data 
and transmits it 
wirelessly to the WA22. 

MobileLAN™access WA22 and 
MobileLAN power bridge
Collects data from the CK30s and 
sends it to the EasyADC PC through 
your Ethernet network. Powered 
over Ethernet by the MobileLAN 
power bridge.

EasyCoder® PM4i
Prints customizable bar code 
labels from LabelShop PRO 6 
software (included).EasyADC PC

Manages the data interface 
to your SAP Business One 
application software.
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The SmartSystems Console provides a simple, comprehensive, management 
tool for monitoring and managing your Intermec automatic identification 
and data collection network. The console also allows you to add CK30, 
WA22, and PM4i devices to EasyADC. The console includes a built-in 
diagnostics intelligence and the ability to update system software.

What is the EasyADC Data Collection Manager?
The EasyADC Data Collection Manager is the software interface between 
EasyADC and your ERP software. The EasyADC Data Collection Man-
ager consists of screens to view and change current settings and a Remote 
Terminal Emulator to emulate the menu system of a connected CK30 for 
testing and training.

What are the EasyADC Inventory Transactions on the CK30s?
The CK30 EasyADC Inventory Transactions perform sales order fulfill-
ment, goods receipt, goods issue, item transfer, inquiries, inventory, cross-
reference, goods receipt purchase orders, and label printing.

What are the EasyADC Requirements?
Before you begin installing EasyADC, you need these items:

• Version number of your software as shown on your installation CDs

• Name of and path to your SAP Business One server

• Name of your company database

• SQL System Administrator password

• User ID and password

Dedicated EasyADC PC Requirements
You also need to provide a PC connected to your local area network with a 
static IP address running an unmodified SAP Business One client to act as 
your EasyADC PC. Hardware requirements for the PC are as follows:

• Windows® XP Professional (Service Pack 2)

• 2 GHz Pentium 4 or better

• 512 MB RAM

• 500 MB available hard disk space

• CD-ROM drive

• An available USB port and mouse

• An available 100baseTx Ethernet port
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Tools and Additional Materials
Use a Phillips screwdriver to install the handstraps on the CK30s. Other 
suggested materials include: a ladder to reach the permanent mounting 
location for the WA22, six mounting screws for the WA22 mounting 
bracket (type and size of screws depend on materials at the installation loca-
tion), a drill and bit, a screwdriver for the bracket mounting screws, and 
three Ethernet cables (CAT5). Note: EasyADC comes with three 3.05 m (10 
ft) Ethernet cables. If you need longer cable runs, you have to supply your own.
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2Installing and Configuring 
EasyADC®

Use this chapter to install and configure EasyADC. If anything is missing, 
contact your Intermec representative. See the “Before You Begin” section 
for contact information.
Note: You should have the SAP Business One application installed on your 
designated EasyADC PC. If not, please contact your SAP Business One 
partner of choice for more information.
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PreInstallation Worksheet
Gather as much of the following information as you can before you begin 
the installation:

• EasyADC Host PC location: _________________________________

• PM4i printer location: ______________________________________

• WA22 access point location:
1) Outside - 300 ft radius (283,000 sq ft)
2) Inside - 100 ft radius (31,000 sq ft) _________________________

• Warehouse square footage: ___________________________________

• AC2 4 Bay charging dock location: ____________________________

Test Database
• Client version: ____________________________________________

• Server version: ____________________________________________

• Test Company Name: ______________________________________

• Production Company Name:_________________________________

• Admin login name and password:______________________________

• New User profiles for each CK30 user:__________________________

• Host IP Address: __________________________________________

• Static IP Range (5 to 50 addresses): ____________________________

Active Database
See “Starting the EasyADC Data Collection Manager” on page 30 for 
instructions on switching to the active database.

• Test Company Name: ______________________________________

• Production Company Name:_________________________________

• Admin login name and password:______________________________

• New User profiles for each CK30 user:__________________________

• Host IP Address: __________________________________________

• Static IP Range (5 to 50 addresses): ____________________________
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Unpacking EasyADC
Use this checklist to verify that you receive all the components of 
EasyADC. If any is missing, contact your Intermec representative.

EasyCoder PM4i Printer

Media for PM4i

AC2 4-Bay Charging Dock

• PM4i printer

• Printer accessories box

For a complete list of the 
Printer accessories box 
contents, see the EasyCoder 
PM4i Bar Code Label 
Printer User’s Guide in the 
box.

• 2 rolls 4x6-inch label media

• 1 roll thermal transfer ribbon

• 1 cardboard takeup roll (or tube)

• AC2 charging dock

• Quick start guide
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EasyADC Installation CDs

Two CK30 Handheld Computers

MobileLAN access WA22

• All required software to install the EasyADC Data 
Collection Manager and SmartSystems Foundation 
applications

• LabelShop PRO 6

• Manuals and quick start guides for products and 
EasyADC system

• CK30 computer

• Rechargeable AB1 battery

• Packet including documentation and 
labels

For a complete list of the packet contents, 
see the CK30 Handheld Computer Quick 
Start Guide in the packet.

Note: Two CK30 Product Authorization Keys (PAKs) are automatically 
configured with your EasyADC for SAP Business One package. To include 
more CK30s in this network, you must purchase additional PAKs. Contact 
your Intermec representative for information.

• WA22 access point

• Mounting bracket and hardware

• Documentation packet

For a complete list of the packet 
contents, see the MobileLAN access 
WA22 Quick Start Guide in the 
packet.
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Accessories Box

Installing the WA22
Choose a location for the MobileLAN™ access WA22 access point based on 
these guidelines, then follow these instructions to install the WA22:

• Place the WA22 horizontally on a desk or counter, or mount it vertically 
on a wall with the included mounting bracket.

• Mount the WA22 as high as possible (at about two-thirds of the floor-to-
ceiling distance), close to the area where the CK30s are used.

• Keep the WA22 clear of metal surfaces like beams or girders, which may 
decrease the radio range.

• Keep large quantities of paper products from blocking the line-of-sight 
between the WA22 and the CK30s, as these products do absorb the 
radio signals and make communications unreliable.

1 Get the MobileLAN power bridge and AC power cord, two Ethernet 
cables (or other cables longer than 3.05 m [10 ft]), and two antennae 
from the Accessories box.

2 On the WA22, remove the antennae port caps and the plastic plug in the 
Ethernet port.

3 Attach both antennae to the WA22. Tighten the nut to finger tightness. 
If you are not using the mounting bracket, “Installing without a 
Mounting Bracket” on page 13, else go to the next paragraph.

Includes the accessories specific 
to your EasyADC components. 
For a complete list, see the 
EasyADC Accessories checklist in 
the box.
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Installing with a Mounting Bracket
1 Insert one shoulder screw into each of the four brass inserts and tighten 

them securely.

2 Using the bracket as a template, mark the mounting hole locations on 
the mounting surface.

3 Route the Ethernet cables through the cable routing channels in the 
bracket.

4 Mount the WA22 in the bracket by inserting the shoulder screws into 
the keyhole slots in the bracket. Slide the WA22 down until it is firmly 
seated.

Shoulder
screws
(4 places)

Brass
inserts

Mounting 
screws
(2-6 places)

Cable routing
channels

Mounting 
bracket
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Installing without a Mounting Bracket
1 Connect one Ethernet cable to the WA22 Ethernet port.

2 Connect the Ethernet cable from the WA22 to the Power & Data Out 
port on the power bridge.

3 Connect an Ethernet cable from the Data In port on the power bridge to 
a port on an Ethernet hub or switch connected to your LAN.

4 Connect the AC power cord to the power bridge and an AC outlet.

On the WA22, the green Power light turns on and stays solid and the 
other lights start blinking as the WA22 boots. The blue light turns on 
and remains on after the WA22 has finished booting.

Ethernet port

To Ethernet

Data InPower & 
Data Out
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Setting Up the AC2 and CK30s

Do the following to set up the AC2:

1 Get the AC2 power supply and AC power cord from the Accessories box.

2 Place the charging dock on a flat, stable, and clean surface that is within 
1.5 m (5 ft) of an AC power outlet.

3 Connect the power supply to the power connector on the back of the 
AC2.

4 Connect the power supply to an AC power outlet. The yellow Power 
light turns on showing that the charging dock is ready to charge.

5 Get a CK30 and an AB1 battery from one of the CK30 shipping boxes.

6 Insert the tabs on the bottom of the battery into the CK30 and snap the 
battery into place.

If you want to use the included AL2 handstraps, continue with the next 
step. If you do not want to install the handstraps, continue with Step 8.

Note: If you have already unpacked and installed the AC2, then skip to 
“Installing the Software” on page 16.

Power
light

AB1 battery
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7 Get an AL2 handstrap from the Accessories box and follow the 
instructions in the shipping bag to install the handstrap on the CK30.

Unhook the bottom of the handstrap to remove and install the AB1 
battery.

8 Slide the CK30 into any of the four bays on top of the charging dock. 
The Charge light for that bay turns on to indicate the battery charge 
status. For more information, see the AC2 Charging Dock Quick Start 
Guide that shipped with the dock.

Repeat Steps 5 though 8 for the other CK30.

Handstrap
hook 

Adjustment
tab

Top of 
handstrap

Charge 
lights
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Installing the Software

If the installation does not start automatically, select Start > Run, enter the 
setup command, such as “D:\setup.exe,” then click OK to start the 
InstallShield Wizard.

Installing the SmartSystems Foundation - ADC Console
Get the installation CDs from the shipping box. Insert the “SmartSystems 
Foundation - ADC Console” CD into the CD drive in the designated 
EasyADC PC also running the SAP Business One application.

If you do not have Microsoft .NET Framework 1.1 on your designated PC, 
then the process begins with the Microsoft .NET Framework 1.1 installa-
tion. Follow the onscreen instructions to install and configure the .NET 
Framework files.

After the installation wizard is set up for the SmartSystems Server Setup, 
click Restart to reboot your PC.

After your PC reboots and you return to your desktop, wait for the Smart-
Systems Server InstallShield Wizard to appear.

Note: You should have the SAP Business One application installed on your 
designated EasyADC PC. If not, please contact your SAP Business One 
partner of choice for more information.
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1 Click Next to begin the installation.

2 Click Yes to accept the license agreement.
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3 Click Browse to change the location if necessary. Click Next to install 
the SmartSystems Server in the location defined.

4 Wait approximately fifteen minutes while the InstallShield Wizard 
installs a number of features needed for the SmartSystems Server.

Select Yes, I want to restart my computer now, remove the installation 
CD, then click Finish to shut down the computer and reboot.

5 Once you are back on the desktop, wait several minutes before you see 
this message. Click OK to close.
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Installing the EasyADC for SAP Business One

Before you do the next installation, close all SmartSystems explorer win-
dows, right-click the SmartSystems Console icon in the Windows system 
tray for a pop-up menu, then select Exit to close the application.

Installing EasyADC
Insert the CD with “EasyADC for SAP Business One” on the label into the 
CD drive in the designated EasyADC PC, then wait for the EasyADC 
InstallShield Wizard to appear.

1 Click Next to begin the installation.

2 Follow the onscreen instructions for the LabelShop® PRO 6 application 
with all its default settings.

Note: You should have the SmartSystems Foundation application installed 
on your designated EasyADC PC. If not, please go to “Installing the Smart-
Systems Foundation - ADC Console” on page 16 to install this application.
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3 Select Yes, I want to restart my computer now, then click Finish to 
install the EasyADC Data Collection Manager.

Including the WA22 Access Point
1 Wait as the system looks for the WA22. When the WA22 is located, its 

EasyADC PC IP address appears in the Host IP Address field. Enter a 
range of IP addresses for your system, then click Next to continue.
20 EasyADC® for SAP Business One System Manual



Chapter 2 —  Installing and Configuring EasyADC®
2 The progress of the Configuration Wizard is monitored. As each task is 
complete, that box is checked in the list. This may take up to five minutes.

3 Once the Intermec Ready-To-Work™ indicator (blue light) for the 
WA22 returns to steady on, reboot all of your other EasyADC devices to 
their defaults, then click Finish to complete the configuration. See 
“Resetting Defaults” on page 33 to perform these reboots.
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Finishing the Software Installation
1 Select Yes, I want to restart my computer now, remove the installation 

CD from the CD drive, then click Finish to shut down the computer 
and reboot. Note that this may take several minutes.

2 Once you are back on the desktop, get the LabelShop PRO 6 envelope 
from the Accessories box and take the LabelShop dongle from the enve-
lope. Plug the LabelShop dongle into an available USB port on the Easy-
ADC PC.

Installing the PM4i
Do the following to install the EasyCoder® PM4i Printer:

Unpacking the PM4i
1 Unpack the PM4i and its box of printer accessories.

2 Get the teal high edge guide and AC power cord from the Printer Acces-
sories box. Set aside the other items described in the user guide for later.

3 Get the 3.05 m (10 ft) Ethernet cable from the EasyADC Accessories 
box or another Ethernet cable if you need a longer cable run.

4 Connect the AC power cord to an AC outlet and the back of the PM4i.

5 Connect the Ethernet cable from your network hub or switch to the 
Ethernet port on the back of the printer.

Note: The sample media and ribbon in the printer box are not intended 
for use with the EasyADC. Do not use them in this installation.
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Installing the Ribbon
1 Open the printer front and side doors.

2 Turn the printhead lift lever clockwise to raise the printhead.

3 Get the roll of thermal transfer ribbon from the EasyADC shipping box.

4 Remove the wrapper from the 2-part ribbon and cardboard core pack-
age.

5 Slide the ribbon onto the supply hub so the shiny side faces up when the 
ribbon is routed through the print mechanism.
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6 Route the ribbon through the print mechanism under the transparent 
upper LSS guide. Pull out about 20 cm (8 in) of ribbon leader.

7 Without releasing the ribbon, turn the printhead lift lever clockwise to 
engage the printhead and lock the ribbon.

8 Slide the cardboard core onto the ribbon rewind hub.

20 cm
(8 in)
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9 Bring the end of the ribbon back over the printhead and around the 
cardboard core. Press the adhesive end of the ribbon onto the core, make 
sure to line up the sides of the ribbon with the edges of the core.

Turn the printhead lever clockwise to release the ribbon. Manually advance 
the ribbon until all of the metallic leader has passed the printhead and the 
ribbon becomes tight.
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Removing the Low Edge Guide
Do the following to remove the installed low edge guide:

1 Tilt the low edge guide so it is parallel to the mounting arm.

2 Pull the edge guide toward the front of the printer and unhook the guide 
by rotating it counterclockwise as seen below.

3 Install the high edge guide by reversing steps 1 and 2. For help, see 
“Media Supply Roll Post” in Chapter 2 of the EasyCoder PM4i Bar Code 
Label Printer User’s Guide.

Installing the Media
1 Get a roll of 4x6-inch media from the EasyADC shipping box.

2 Place the roll on the supply post and push it all the way to the bottom of 
the post.

Low edge guide
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3 Fold up the edge guide and slide it next to the edge of the media roll to 
hold the roll in place on the supply post.

4 Route the media through the print mechanism, keeping the media as 
close to the middle wall of the printer as possible. The label path here is 
also illustrated inside the printer lid.

5 Turn the printhead lever counterclockwise to engage the printhead.

6 Adjust the position of the green edge guide so the media is guided with a 
minimum of play and lock the nut.
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7 Adjust the position of the edge guide on the label slack absorber 
according to the width of the media.

8 Close the front and side doors, making sure that the media runs through 
the front door slot.

Activating the PM4i Printer
Turn on the PM4i. The display on the front of the printer shows 
initialization messages. When initialization is complete, the SmartSystems 
Console looks for the printer and connects it to the network. When the 
printer is connected, it pulls the excess ribbon back in and prints a test 
label. The red error light turns off, and the Intermec Ready-To-Work blue 
light stays on, indicating that the PM4i is configured correctly.

If the test label does not print and the red error light stays on, there is a 
problem connecting the printer. See “Resetting the WA22 to Factory 
Defaults” on page 87 to correct this connection.
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Configuring the CK30s
These instructions assume your CK30s are set up for your network. If not, 
then go to “Setting Up the AC2 and CK30s” on page 14.

If the CK30s did not turn on when you installed batteries, press I to turn 
them on. When the CK30s turn on, the Setup Assistant screen appears.

Follow the next procedure to configure the CK30s. You will use the follow-
ing keys, illustrated below, in working with the CK30.

To configure the CK30s:

1 Press Enter for the ION Client screen.

2 Press U to choose Yes, then press Enter for progress messages to appear.

3 Press Enter when the Setup - Complete screen appears.

4 After the CK30 reboots, the blue light on the CK30 blinks as the CK30 
tries to establish contact with the WA22. This contact may take a few 
minutes. When contact is established, the EasyADC login screen appears 
on the CK30 display and the blue light stops blinking and switches to a 
solid blue.

5 Press B, C, [1], [3], then [1] to set the date:

a Press Enter.

b Use Tab to switch fields and U and D to set the date.

c Press Enter, then Esc to return to the Device Settings screen.

Up arrow
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I/O key
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Tab

Esc
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6 Press [2] to set the time:

a Press Enter.

b Use Tab to switch fields and U and D to set the time.

c Press Enter, then Esc to return to the Device Settings screen.

7 Press Esc until you exit the Configuration Utility. When prompted to 
have your settings persist through a cold-boot, press Enter. Press Esc 
when the System Main Menu appears. When the EasyADC login screen 
appears, you are ready to login.

Starting the EasyADC Data Collection Manager

After you have thoroughly tested your EasyADC installation and trained 
your staff, you are ready to go live with the EasyADC. To go live, you sim-
ply switch from your test database to your active database.

To switch to your active database

1 From the EasyADC Data Collection Manager, select File > Configura-
tion Options > SAP Database Options.

2 Enter your Database Server Name (either the machine name or the IP 
address) of the machine where your database is located.

3 Enter the Database User Name and Database Password (and verify the 
password) of your database administrator.

If the Data Collection Manager is started on your system, close the 
application, then start it again. From the desktop, select Start > Programs > 
Intermec > EasyADC Data Collection Manager > EasyADC Data 
Collection Manager, or double-click the EasyADC Data Collection 
Manager icon on the desktop.
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4 Enter the Company Name of your company’s database to use, then click 
Save for the EasyADC to use the active database.

Go to Chapter 4, “Using the EasyADC® Data Collection Manager” on 
page 49 to learn more about using this application.

Setting Security

2 Click Max to set the security level to maximum, then click OK.

Your installation of the EasyADC is complete! For more information on 
operating your Intermec hardware products, see the user’s manual or quick 
start guide for that product. Complete manuals for your Intermec products 
are available as PDF files on the CDs. Browse for the “\Manuals” folder.

Using the SmartSystems Console
Now that the SmartSystems Console and EasyADC Data Collection Man-
ager are installed and running, you can use the SmartSystems Console to 
monitor the status of each component in the system.

1 Right-click the SmartSystems Console icon in the Windows system tray, 
then select Explore to initiate the SmartSystems Console.

1 To set the security for your system, right-click the WA22 access point 
icon in the “\SmartSystems Console\Discovered Devices” folder, then 
select Security to access its Security Level.
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2 In the SmartSystems Console, click Discover to add devices to the 
“\SmartSystems Console\Discovered Devices” folder.

Or, click SmartSystems > Add Devices to initiate the EasyADC Con-
figuration Wizard which scans your network for additional devices to 
add to the “\SmartSystems Console\Discovered Devices” folder.

For more information, see the SmartSystems Console Online Manual. In any 
SmartSystems Console screen, select SmartSystems > Help.
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Uninstalling the Software
To uninstall SmartSystems and EasyADC, you need to restore the default 
hardware settings for all components and then uninstall the SmartSystems 
Console and EasyADC Data Collection Manager software. 

Follow this procedure carefully. Restore the CK30s, WA22, and PM4i 
devices to their default conditions before you uninstall the SmartSystems 
and EasyADC software. Uninstalling the software before restoring the 
hardware defaults requires you to return components to Intermec 
Technologies for repair.

Closing Applications
Close these applications on the EasyADC PC: 

• SmartSystems Console

• EasyADC Data Collection Manager

• LabelShop PRO 6

• your SAP Business One client

Resetting Defaults

Note: Although your server and client software are not affected by 
uninstalling SmartSystems and EasyADC, be sure to know the name of 
your server. You need the server name to install the software.

1 Restore the CK30 defaults by pressing C, B, [1], [6], [ENT] to select 
Yes, then the CK30 performs a cold boot. Press I to turn off the CK30.

2 Restore the defaults on the WA22 as follows:

a In the SmartSystems Console, select SmartSystems > Restore 
Defaults from the toolbar.

b Click Next, click Yes, then click Finish.
3 Restore the defaults on the PM4i as follows:

a Press Setup, then press the right arrow key until Test/Service appears.

b Press the down arrow key, then the right arrow key until Memory 
Reset appears.

c Press the down arrow key for “All” to appear, then press Enter to 
select the option to reset All memory.

d Press Setup to exit the setup menu. The PM4i initializes and resets.
4 Right-click the SmartSystems Console icon in the system tray, then 

select Exit.
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Removing Programs

a Microsoft .NET Framework

b SmartSystems Console

c EasyADC Data Collection Manager

d LabelShop PRO

3 Close the Add or Remove Programs window.

For More Information
Browse for the “Manuals” folder on your CD, or visit the Intermec website 
at www.intermec.com to download current PDF manuals. To order 
printed versions of the Intermec manuals, contact your Intermec represen-
tative. 

See the EasyADC Service and Support Card for specific information about 
maintaining your EasyADC. If you need assistance, call 1-800-755-5505, 
select the option for technical support, then the option for SMB™ products.

1 From the desktop, select Start > Settings > Control Panel, then click the 
Add or Remove Programs icon.

2 For each of the following (in this order), select the program name, click 
Remove, then follow the prompts to remove each:

4 From the desktop, click the My Computer icon, then delete the 
“C:\Program Files\Intermec” folder.
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3Using the CK30 Handheld 
Computers

The following information is in this chapter:

• The CK30 Keypad (page 36)

• Tips for Working with EasyADC Inventory Transactions (page 38)

• Logging On and Off (page 39)

• Overview of EasyADC Inventory Transactions (page 39)
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The CK30 Keypad
Your EasyADC® CK30 Handheld Computer has a 52-key full numeric 
keypad as shown in the next illustration.

CK30 52-key Full Numeric Keypad

This chapter describes how to use this keypad to navigate through the 
EasyADC Inventory Transactions.

To learn how to use the keypad, including how to use the color-coded keys 
and how to capitalize characters, see the CK30 Handheld Computer User’s 
Manual (P/N 073528).
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A Diagram of CK30 Functions
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Tips for Working with EasyADC Inventory Transactions
The next tables contain helpful information on using capitalization, enter-
ing data, and using special keys in the CK30 Inventory Transactions.

General Guidelines for Working in the CK30 Inventory Transactions

Topic Description

Case sensitivity All CK30 inventory transaction options are case-sensitive. When you key a field in uppercase, 
the database is updated in uppercase. If you key an inventory name in lowercase and the data-
base has it stored in uppercase, the item cannot be found.

Selecting an option To select an option from any CK30 inventory transaction, you press the number associated 
with the option.

Entering data There are several ways to “enter data” with the CK30:
• Scan a bar code.
• Type the data on the keypad, then press Enter.
• Scroll through a scroll list to the item, then press Enter.

Scrollable Lists in CK30 Inventory Transactions

Characters Description

<U D> These characters appear when there is a scrollable list from which to select. To move through the list, 
press the left arrow (press the orange B key and U) or the right arrow (press the orange B key and 
D). When you find the desired selection (or when the correct value is displayed), Press Enter to select 
the currently displayed value. You may also key or scan the value on these screens.

Using Special Keys in CK30 Inventory Transactions

Special 
Key Description Note that these are also available on an Options line or near the bottom of the screen.

Esc Press Esc to return to the last logical screen. If you are on the first screen of an option (such as deliver sales 
order), pressing Esc returns you to the Main Menu. Data may or may not be discarded, depending on the 
situation.

F1 Press this key to post your transaction when you are done with your current data entry routine. For exam-
ple, the [F1] option appears after receiving items in Good Receipts PO. Pressing [F1] means that you are 
done receiving a PO and are ready to update your server.

F2 Press this key to see a list of entries from which a selection may be made.

F3 Press this key to view your selections which have already been made.

F4 Press this key to save the current serial number selections.
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Logging On and Off
When you turn on an EasyADC CK30, a login screen appears.

To log on the CK30

The user name and password may be case-sensitive, depending on your sys-
tem. Intermec recommends using all uppercase user names and passwords, 
since toggling capitalization on the CK30 requires extra keystrokes. Be sure 
to enter the user name and password from your ERP system.

1 Type a valid user name in the Enter User Name field, then press Enter.

2 Type a password in the Enter Password field, then press Enter.

To log off the CK30
From the Main Menu, press [0] for the login screen.

Overview of EasyADC Inventory Transactions
This describes how to use the CK30 keypad to move through the EasyADC 
Inventory Transactions.

Main Menu
The Main Menu appears after you log in successfully and when you exit an 
option, such as Good Receipt PO. To select an option from any CK30 
inventory transaction, press the number associated with the option. The 
options on the Main Menu are described in the next few pages.
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Goods Receipt PO
You use the Good Receipt PO option to receive items against a valid 
Purchase Order.

Here is an overview of a typical receiving process with the CK30:

1 The product arrives on pallets in the receiving area and is verified against 
the Vendor Packing Slip.

2 Log into the CK30, press [1] to select Good Receipt PO from the Main 
Menu.

3 Enter the PO Number to receive against by scanning a bar code or 
typing the number and pressing Enter.

4 Scan the first item you want to receive, then enter the quantity to receive 
for the item. The labels then print from the PM4i.

5 When finished, press [F1] to post the Receiving Transaction Entry.

6 The items are staged in the receiving area for the put-away process.

Receiving for Purchase Order Processing: This diagram illustrates the general information flow on the CK30. 
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Delivery Sales Order
You use the Delivery SO (Sales Order) option to indicate whether a 
shipment or delivery of goods occurred. Creating a Delivery SO reduces 
actual stock levels. The Delivery SO is linked to a Sales Order.

Here is an overview of a typical sales order fulfillment with the CK30 when 
the picking tickets are given to warehouse personnel:

1 Log into the CK30, then press [2] to select Delivery SO from the Main 
Menu.

2 Scan the Sales Order Document Number Barcode on the pick ticket, 
then scroll through the list of items until you find the item to pick. 

3 In the warehouse, find the item to pick, scan its item bar code, type the 
quantity picked, then press Enter.

4 Continue the scanning process until there are no more items to pick on 
the sales order.

5 When finished, press [F1] to post the transaction.

6 When prompted, enter the number of boxes for which the label is 
printed, then press Enter. The labels then print from the PM4i.
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Goods Receipt and Goods Issue
It is possible to post a goods movement without referring to a customer or 
supplier. These movements are not the result of a procurement or sales 
process. Within the system, these movements are known as Goods Receipt 
and Goods Issues. 

Goods Receipt
You use the Goods Receipt option when the company receives product that 
does not have a cost associated with it being added to the inventory. Thus, 
the stock level of that product is increased and the inventory account is 
debited while the inventory variance gain or loss account is credited. Here 
is an overview of a typical goods receipt with the CK30:

1 Log into the CK30, then press [3] to select Goods Receipt.

2 Enter item numbers and their quantities. The labels then print from the 
PM4i.

3 When finished, press [F1] to post the transaction. No additional steps 
are needed.
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Goods Issue
You use the Goods Issue option when your company supplies product that 
does not have direct cost associated with the product leaving inventory. 
Thus, the stock level of that product is decreased and the inventory account 
is credited while the inventory variance gain or loss account is debited. 
Here is an overview of a typical goods issue with the CK30:

1 Log into the CK30, then press [4] to select Goods Issue.

2 Enter item numbers and their quantities.

3 When finished, press [F1] to post the transaction. No additional steps 
are needed.
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Stock Transfer
You use the Stock Transfer option to move inventory from one location or 
site to another, for example from the main warehouse to the remote 
warehouse. When you make a stock transfer, the account where the stock 
comes from is debited and the account where the stock goes to is credited. 
Here is an overview of a typical stock transfer with the CK30:

1 Log in to the CK30, then press [5] to select Stock Transfer from the 
Main Menu.

2 Enter the originating (or “from”) site, and the destination (or “to”) site 
for the transfer.

3 Scan the item number bar code from the item, then type in the quantity 
to transfer.

4 When finished, press [F1] to post the transfer.
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Queries
You use Queries to check the database, such as inventory status, purchase 
orders, or sales orders.

When you select Queries from the Main Menu by pressing [6] on the 
CK30, a menu appears which offers the options described in this table.

Options on the Queries Menu

Option Description

Inventory Status This shows inventory quantities for any selected item.

Purchase Orders This option lets you select a purchase order from a list of all open 
purchase orders to view.

Sales Orders This lets you select a sales order from a list of all open sales orders.
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Count Inventory
The Count Inventory feature only appears in the CK30 Main Menu after 
you start the inventory count from the EasyADC Data Collection Man-
ager. See “Doing the Warehouse Inventory” on page 67 for information.

Use this feature to collect inventory counts by item and warehouse.

1 From the EasyADC Data Collection Manager, select Inventory > Ware-
house Maintenance. Verify the correct warehouse is selected in the 
drop-down list, then click Count Inventory to start the count.

2 Log into the CK30, press [7] Count Inventory from the Main Menu, 
scroll to the warehouse zone to which to send the inventory count, press 
Enter, then enter the quantity for that warehouse zone.

3 When finished, press [F1] to post the inventory.
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Build Item Cross-Reference
The Cross-Reference information resides in the EasyADC Data Collection 
Manager and does not update the SAP database. This feature only appears 
in the CK30 Main Menu after you enable cross-reference building from the 
EasyADC Data Collection Manager. See “Build Item Cross-Reference” on 
page 47 for more information.

Use this to pair alternate item numbers with item numbers found in SAP. 
You can use the item numbers instead of SAP item numbers in any transac-
tion.

1 From the EasyADC Data Collection Manager, select File > Configura-
tion Options > ClientUI Options. Check Allow Building Cross-Ref-
erence Information, then click Save.

2 Log into the CK30, press [A] Item Cross-Ref from the Main Menu.

3 Scan or enter an SAP item number, then key in or scan the alternate item 
numbers (these must be unique), press Enter, then press [F4] to save 
your entries. 
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4 When finished, press [F1] to post the cross-reference.
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4Using the EasyADC® Data 
Collection Manager

You will find these sections in this chapter:

• Starting the EasyADC Data Collection Manager (page 50)

• Designing Labels (page 50)

• Using the Remote Terminal Emulator (page 55)

• Using the System Manager (page 56)

• Viewing Log and Error Log Information (page 61)

• Running the Benchmark Reports (page 63)

• Doing the Warehouse Inventory (page 67)
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Starting the EasyADC Data Collection Manager

The Telnet server is needed for the EasyADC Data Collection Manager to 
operate properly. Should your service be disabled, go to “Starting the Telnet 
Server Automatically” on page 90 to ensure your service is set to start auto-
matically before running the EasyADC Data Collection Manager.

Designing Labels
EasyADC comes with a default label format (or template) for each 
applicable module, which is specified on the corresponding tab. The 
associated file names are listed in the following table:

The files are stored in the “C:\Program Files\Intermec\EasyADC-SBO 
Data Collection Manager\Labels” folder. In the EasyADC Data Collection 
Manager, select File > Configuration Options > Label Templates to view 
these labels. For help, see the table on the next page.

There are two ways to start the EasyADC Data Collection Manager on the 
EasyADC PC. From the desktop, select Start > Programs > Intermec > 
EasyADC Data Collection Manager > EasyADC Data Collection 
Manager, or double-click the EasyADC Data Collection Manager icon on 
the desktop.

Label Manager Default Label Formats

Default Label Format Associated File Name

Purchase Orders POP.lab

Delivery SOP.lab

Goods, Vendor information MSC.lab
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You can modify default label files if you are using label sizes other than the 
current default (4” wide x 6” high) label size. Before you do, Intermec 
recommends that you save a copy of the original files first.

You can also use LabelShop® PRO 6 to create your own labels. Various data 
elements (fields) are available for printing when designing labels from both 
tables and values from the windows within the program. The type of data 
accessible do vary by module (tab) selected.

When designing labels, you must reference particular fields properly to 
have them print on a label format. The required structure for field names 
differs between table data and values on the Label Manager screens, but 
both types are presented here.

Goods Receipts Purchase Order Label
This transaction allows the printing of labels, one for each transacted item. 
That is, for each quantity based item, one label is printed per item number. 
For each serialized item, one label prints per serial number. You can print 
duplicates for any of these items.

Note: Changes to the label format are not in use until the next time the 
EasyADC Data Collection Manager is restarted.

Goods Receipt PO Provides the path to the default POP.lab file. Click Browse to go to a different location.

Goods Receipt Provides the path to the default MSC.lab file. Click Browse to go to a different location.

Delivery Sales Order Provides the path to the default SPO.lab file. Click Browse to go to a different location.

Company Name Enter the company name that is to appear on the label.

Address Line 1 Enter the company’s address that is to appear on line 1 for the address on the label.

Address Line 2 Enter the company’s address that is to appear on line 2 for the address on the label.

Address Line 3 Enter the company’s city, state and zip code to appear on the bottom line of the label.

Restore Installation Default Click this to return all Label Templates information to their defaults.

Undo These Changes Click this to clear any changes you made since you last clicked Save.

Cancel Click this to clear any changes you made since you last clicked Save, then exit to close.

Save Click this to save all changes, then exit to close.

LabelShop PRO 6 Bar 
Code Items Description

ITEMNBR Prints the item number and bar code.

ITEMDESC Prints the first 50 characters of the item description.

QUANTITY Prints the received quantity for quantity based items. Prints a quantity of one for serial-
ized items.

SERIAL_BATCH_NBR Prints the serial number and bar code for serialized items (managed by serial number).
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Delivery Sales Order Label
This prints a label for complete transactions, which include item numbers 
for quantity-based items, and serial numbers for serialized items. You can 
print duplicates for any of these items.

SERIAL_BATCH_LBL Prints the serial number and bar code for serial items on the label.

COMPANY NAME
ADDRESS 1
ADDRESS 2
ADDRESS 3

Prints the company name and its address.

PONUMBER SAP Business One purchase order and associated bar codes.

VENDORNBR Prints the vendor ID and bar code.

WHSCODE Prints the warehouse code.

WHSNAME Prints the name of the warehouse.

VENDORNAME Prints the name of the vendor.

LabelShop PRO 6 
Bar Code Items Description

SONUMBER Prints the sales order number and bar code.

XX A counter from 1 to YY, such as “label 2 of 4.”

YY Total boxes of labels requested.

DELIVERYNBR Prints the deliver number.

COMPANY NAME
ADDRESS 1
ADDRESS 2
ADDRESS 3

Prints the company name and address.

CUSTOMERNBR Prints the customer bar code.

CUSTOMERNAME
CUSTOMERADDR1
CUSTOMERADDR2
CUSTOMERADDR3

Prints the customer name and address.

LabelShop PRO 6 Bar 
Code Items Description
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Goods Receipts Label Contents
This transaction allows the printing of labels, one for each transacted item. 
That is, for each quantity based item, one label is printed per item number. 
For each serialized item, one label prints per serial number. You can print 
duplicates for any of these items.

Using LabelShop PRO
In this example, the Purchase Orders label format file (POP.Lab) is opened 
and is modified to include a new Vendor Name field.

1 From the desktop, select Start > Programs > Intermec LabelShop PRO 
6 > LabelShop Pro 6 to access the application.

2 Right-click Form in the left column, then select Add.

LabelShop PRO 6 Bar 
Code Items Description

ITEMNBR Prints the item number and bar code.

ITEMDESC Prints the first 50 characters of the item description.

QUANTITY Prints received quantity for quantity-based items and quantities of one for serialized 
items.

SERIAL_BATCH_NBR Prints the serial number and bar code for serialized items (managed by serial number).

SERIAL_BATCH_LBL Prints the serial number and bar code for serial items on the label.

COMPANY NAME
ADDRESS 1
ADDRESS 2
ADDRESS 3

Prints the company name and address.

WHSCODE Prints the warehouse code.

WHSNAME Prints the name of the warehouse.
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A field is automatically added with an assigned name.

4 To specify that the bar code should print the assigned value, click the 
Data source tab, click Variable data for the type, click (+) to expand 
Form, then select the correct field name.

When information is specified, the new field is placed on the label format, 
which you can then modify as desired. See the LabelShop PRO online help.

3 To place the field on the label, select to highlight the new field, click the 
Barcode icon in the center (shown to the left), click anywhere on the label 
format screen on the right, then enter the required information.
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Using the Remote Terminal Emulator
The Remote Terminal Emulator is a PC-based terminal emulation pro-
gram that simulates the TE 2000 terminal emulation application running 
on CK30s. 

To access the Remote Terminal Emulator, select Remote Terminal from 
the EasyADC Data Collection Manager menu bar. Note that the keyboard 
controls are the same as on the CK30. Use your arrow keys to navigate and 
the Enter key to enter data.
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Using the System Manager 
This manages CK30 processes, licenses, and item cross-references.

Client Processes
The System Manager menu bar option in the EasyADC Data Collection 
Manager lets you view CK30 information in a Client Processes window, 
which starts up immediately when the EasyADC Data Collection Manager 
is launched.

Should the Microsoft Telnet application not release its attachment to your 
CK30s (showing all sessions already in use), and another person is not able 
to access the Telnet application, click End Selected Process(es) to access 
the End Process window.

Select to highlight the processes, then click End Selected Process(es) to 
break their Telnet sessions and free up sessions for others to use. Click 
Refresh View to see what processes remain, and click Close to return to the 
Client Processes window.
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To set preferences for the Systems Manager, from the EasyADC Data Col-
lection Manager main screen, select File > Configuration Options > Sys-
tem Manager Options, then set preferences, as needed. For help, see below.

User State Color: None Click Change to the right to adjust the appearance of a user when disconnected.

User State Color: Active Click Change to the right to adjust the appearance of a user when active.

User State Color: Logging On Click Change to the right to adjust the appearance of a user when logging on.

User State Color: Logging Off Click Change to the right to adjust the appearance of a user when logging off.

Log Color - Main Click Change to the right to adjust the appearance of the main log entries.

Log Color - UIM Click Change to the right to adjust the appearance of the UIM log entries.

Log Color - SIM Click Change to the right to adjust the appearance of the SIM log entries.

Log Color - PIM Click Change to the right to adjust the appearance of the PIM log entries.

Log Color - Config Click Change to the right to adjust the appearance of configuration log entries.

Log Color - Comm Click Change to the right to adjust the appearance of communication log entries.

Log Color - Client Click Change to the right to adjust the appearance of client log entries.

Log Color Click Change to the right to adjust the appearance of miscellaneous log entries.

Restore Installation Defaults Click this to return user state and log entry colors back to their original colors.

Undo These Changes Click this to erase what changes were made before the last save.

Cancel Click this to exit the System Manager Options without saving any changes made.

Save Click this to update the System Manager settings with the changes made. and exit 
the System Manager Options.
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License Information
Licensing determines the number of CK30s running the client applications 
allowed to connect to the SAP Business One application through the Easy-
ADC Data Collection Manager. Two Product Authorization Keys (PAKs) 
are automatically configured with the product.

You can call the Intermec Customer Service at 1-800-755-5505 to pur-
chase additional licenses, which are delivered on printed certificates. The 
system makes use of Intermec’s PAKs to provide you with 25-character keys 
for your application.

To view current license information load additional licenses from PAK 
data, select System Manager > License Information. The total licenses 
owned including the two supplied with the system, and the current number 
of available logons (the number of additional CK30s that could connect at 
that point in time are shown. This screen is updated if additional licenses 
are entered.

Click Close to exit this information.

Enter License Information
To enter your 25-key character PAK license, click Enter License Informa-
tion, key in the characters, then click Submit License Number.
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Load License from disk
To load your license from a disk, insert the disk in your EasyADC PC, then 
click Load License from disk. If your additional licenses are not installed 
automatically, browse to the location of your license file (licpak.txt), then 
double-click the file to install its information.

Item Cross-Reference
Use this to pair alternate item numbers with item numbers found in SAP. 
Note that the information here does not update the SAP database. Each row in 
the table contains an SAP item number which must be a valid, inventoried 
SAP item, an alternate item number that is unique in the database, and an 
“unusable” flag that indicates a validation problem with the entry.

Unusable entries are retained and ignored when validating item numbers 
for remote terminal transactions. This table is validated each time the Data 
Collection Manager is started and when you click Validate Items.
EasyADC® for SAP Business One System Manual 59



Chapter 4 — Using the EasyADC® Data Collection Manager
You can do new entries - first identify one or more SAP numbers in the 
Item Code column, then assign respective alternate item numbers in the 
Alternate Items column. You can enter a specific Item Code, query for a 
range of SAP item numbers using Find Item, or query an item group from 
within SAP using Find Item Group - then enter their respective alternate 
item numbers. When data is saved, entries without alternate item numbers 
are automatically purged.

Alternate Item Enter an alternate item number for the SAP item in this row.

Item Code The SAP item number assigned to the item in this row.

Item Description Description of the SAP item.

Usable This is checked by the system after a validation to indicate that neither alternate item number nor 
the SAP item number is duplicated and the SAP item number is valid.

Find Item Enter the range of SAP item numbers to locate within the SAP database. If you do not know what 
to enter, you can use an asterisk as a wildcard.

Find Item Group Select a group from the drop-down list to locate within the SAP database.

Validate Items Click this to verify whether assigned alternate item numbers are unique. If there are any dupli-
cates, or if an SAP item number is invalid, the Usable check box is cleared.

Refresh Items Click this to renew the list after you make manual changes, or to include any new data received 
while the Item Cross-Reference window is open. Note that this removes any items not assigned alter-
nate item numbers.

Cancel Changes Click this, then Yes to undo any alternate item entries you had entered, but not saved to the list.

Save Changes Click this to save any changes made to the list.

Close Click this to exit the Item Cross-Reference window.
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Viewing Log and Error Log Information
Two logs are provided to assist in diagnosing problems. A technical support 
person may request information from these logs. Both logs are cleared after 
reaching specified sizes to conserve space.

The Log is also used primarily for troubleshooting. Its text file is called 
EasyADC-SBO.log and is located in the “C:\Program Files\Intermec\Easy-
ADC-SBO Data Collection Manager\Log” folder. To view this log, start 
the EasyADC Data Collection Manager, then select Log > Log View.

The error log text file is called EasyADC-SBOError.log and is located in 
the “C:\Program Files\Intermec\EasyADC-SBO Data Collection Manage-
ment\Log” folder. To view this log, select Log > Error Log View.
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To configure your log files, such as set default sizes, select File > Configura-
tion Options > Log Options, then set preferences as needed. For help, see 
the following table.

Log File Name Provides the default file name for the log file. You can change this file name, but be 
sure to keep the .log extension.

Error Log File Name Provides the default file name for the error log file. You can change this file name, 
but be sure to keep the .log extension.

Max Length Provides the size of the log files at which the system clears the log files. The default 
size is 102400. You can enter the size that best works for your network.

Path for Log File Provides the default location where the log files are stored. Click Browse to change 
the location of this storage.

Log Level check boxes Check the types of messages to store in the log file.

Client Log Level check boxes Check whether to store errors, warnings, metrics, or debug messages in the log file.

Restore Installation Defaults Click this to return all of the Lot Options information to their defaults. You will be 
prompted to verify this restoration.

Undo These Changes Click this to clear any changes you made since you last clicked the Save button.

Cancel Click this to clear any changes you made since you last clicked the Save button, 
then exit to return to the EasyADC Data Collection Manager.

Save Click this to save all of your changes, then exit to return to the EasyADC Data 
Collection Manager.
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Running the Benchmark Reports
Eight reports are installed with the EasyADC Data Collection Manager and 
summarize timely business transactions. By default, daily reports start at 6 
a.m. and include 12 60-minute reporting periods, weekly reports also start 
at 6 a.m. and include 7 24-hour calendar days. Information from these 
reports are saved and retained for 30 days. You can customize and add addi-
tional reports as needed for your network.

Configure
Select Report > Configure to review, change, delete, and add to the reports 
shown. Click Close to exit.

Preview Report
To get a sneak peek of what how a report is to appear, select the report in 
question from the Report Name drop-down list, then click Preview 
Report, which opens to today’s date.
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If you want to switch to another date, click the drop-down arrow for a cal-
endar, make your selection, then click Close.

Click Run Report to see the preview, click Close to exit. For more details 
on the report, check Expanded Report. Go to page 66 for a sample screen.

Add New
You can customize your own reports to add to the list of benchmark 
reports. Select the features for this report, then click Save to add this report 
to the benchmark. Note the information provided here also applies to the Copy 
Report and Edit Report options. Minutes are in 15-minute increments.

Report Name Enter a unique name that accurately describes this report.

Report Start Time Use the three drop-down arrows to set the start time when data is collected for the report.

Length of Period Use the Hours and Minutes drop-down arrows to set the length of time per period.

Number of Periods . . . Enter the number of periods to show on this report.

Report Type Select either Number of Transactions or Number of Items, then enter the target amount.

Transactions On Report Check the items to appear on the report.
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Copy Report
You can take an existing benchmark report with its features intact and 
assign a new name. Select the report to copy from the Report Name drop-
down list, then click Copy Report. Assign the new unique name, make any 
adjustments needed for the new report, then click Save to add the new 
report to the benchmark. See the table under Add New for information.

Edit Report
Click this to edit the report you select from the Report Name drop-down 
list. Note the report name is grayed-out, you cannot change the name for this 
report. See the table under Add New for information.
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Delete
To delete a report from the benchmark, select the report from the Report 
Name drop-down list, then click Delete. Click Yes at the prompt to verify 
the deletion.

Run Benchmark
To view an existing report, select Report > Run Benchmark, select an 
option, select a date, then click Run Report.

Note the report’s target value is shown as the first bar in the chart. The 
height of the chart is cumulative, with the bar to the right including all data 
to its left, plus data for its time period.
66 EasyADC® for SAP Business One System Manual



Chapter 4 —  Using the EasyADC® Data Collection Manager
You can check Expanded Data to show additional details for this report.

Export Data
Use this to send data saved from these benchmark reports to a location you 
designate on your EasyADC PC. Select Report > Export Data, select the 
path, enter the file name, then click Save to assign the export text file.

Doing the Warehouse Inventory
The EasyADC Data Collection Manager collects inventory counts by item, 
warehouse, and counting zone (as set on your CK30s). You can establish 
one or more “counting zones” for known warehouses to manage the count-
ing process. At least one zone must exist at all times. You may not remove 
these zones while counting is enabled, but you can add and rename these 
zones at any time. The SAP database is queried for recognized warehouses 
each time the function is entered.
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Warehouse Maintenance
To access and add to the list of warehouse zones, select Inventory > Ware-
house Maintenance.

Data stays in the database until counting is closed and posted to the SAP 
database. This information remains until you click Clear Inventory Count 
or Count Inventory. Zones not counted are posted automatically and 
duplicates are reserved for manual resolution.

Warehouse Select from the drop-down list the zone to which to perform an inventory count.

Description Includes zones selected from the warehouse drop-down and any zones you enter manually.

Clear Inventory Count Click this, then click Yes to erase its inventory count from the database.

Count Inventory Click this, then click Yes to perform an inventory count.

Cancel Changes Click this, then click Yes to undo any manual entries you made to the zone list.

Save Changes Click this, then click Yes to save any manual changes you made to the list.
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Inventory Count
The information presented here is time-sensitive. For each item posted to 
SAP, it is placed in the Stock Posting under Inventory Transactions. Go 
into SAP to accept the transaction or reconcile any differences for the 
inventory amounts to take affect.

Go to “Count Inventory” on page 46 to validate this information from 
your CK30s.

Counted This is checked when one or more values are returned from the CK30 transaction, includ-
ing a counted zero.

Display SAP On-Hand 
Quantities

Check this to include the quantities available onhand in the SAP database, which are 
shown in the On-Hand Qty column.

Clear Inventory Count Click this, then click Yes to erase its inventory count from the database.

Post Inventory to SAP Sends information checked in the Counted column to the SAP database, then click 
whether to clear that counted value from the inventory count. If changes were made, but 
not saved, then click Yes at the prompt to save the changes before posting the information.

Close Inventory Count When enabled, you can click this, then click Yes to end an inventory count.

Refresh On-hand quan-
tities from SAP

Click this to update the On-Hand Qty column.

Refresh Inventory 
Counts

Click this to display current counted values after receiving new counts or making manual 
changes without saving them.

Cancel Changes Click this, then click Yes to undo any manual entries you made to the inventory count.

Save Changes Click this to save any manual changes you made to the inventory count.
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5Using the SmartSystems™ 
Console

You will find these sections in this chapter:

• Starting the SmartSystems Console (page 72)

• Monitoring Devices (page 72)

• Viewing the Troubleshooting Tips (page 73)

• Enabling Email Notification (page 73)

• Configuring the Network Security Level (page 74)

• Adding New Devices (page 74)

• Resetting an Access Point to its Factory Defaults (page 74)

• Updating System Software (page 75)

• Updating the Discovered Devices Folder (page 75)
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Starting the SmartSystems Console
The SmartSystems Console allows you to monitor and manage all the hard-
ware devices in the EasyADC. The Console runs on your dedicated Easy-
ADC PC and lets you perform management tasks. From the Windows 
desktop, select Start > Programs > Intermec > SmartSystem > Console. 

The Console icon appears in the Windows system tray (lower-right corner 
of the desktop). When the devices in EasyADC are operating normally, the 
Console icon appears as shown.

If there is a problem or status change with any device in the system, the 
Console icon assumes another symbol. See “Images Appear With Console 
Icon” on page 78 for help.

Monitoring Devices
To monitor hardware devices in EasyADC, you must display the SmartSys-
tems Console screen. There are two ways to display this screen, either dou-
ble-click the Console icon, or right-click the Console icon, then select 
Explore from the menu, which opens the Console to the “SmartSystems/
Discovered Devices” folder. Click each device to display information. If you 
see a troubleshooting message, see the online tips to handle each issue.
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Viewing the Troubleshooting Tips
Comprehensive troubleshooting tips are available online via the SmartSys-
tems Console. To view the tips, right-click an icon for its pop-up menu, 
then select Diagnostics.

Enabling Email Notification
With the Console, you can configure EasyADC to send email when any 
device status changes. You can receive email every time a CK30 roams out 
of range, or every time the PM4i runs out of media. To further customize 
email notification, see the online help. To enable email notification:

2 Select Configure > SmartSystems Console for the SmartSystems 
Console Configuration screen. Enter the SMTP Server and Return 
Address information, then check Enable Email Notification at the 
bottom of the screen.

3 Click Add for the Add an Email Address dialog box, type an email 
address, then click OK. The email address appears in the list and is 
checked Enabled.

4 Continue adding email addresses, as needed. When finished, click OK to 
close the SmartSystems Console Configuration screen.

1 Right-click the SmartSystems Console icon in the Windows system 
tray.
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Configuring the Network Security Level
The Console lets you configures network security for EasyADC.

To configure the network security level

1 Right-click the WA22 access point icon for a pop-up menu, then select 
Security to access the Security Level.

2 Move the indicator to Min or Max, pending on your network security 
needs, then click OK:

• Min indicates the network is secure, but that devices may be added.

• Max indicates that the network is so secure that no new devices may 
be added. Do not choose Max until you have finished installing 
devices in your system.

Adding New Devices
You can add CK30s or WA22s from a dedicated EasyADC PC.

To add a new device

1 Select SmartSystems > Add Device(s) from the SmartSystems Console.

2 Follow the prompts as the Intermec EasyADC Configuration Wizard 
walks you through the process.

3 If you are adding a CK30, the Console automatically sets the Network 
Security Level to Min to allow the device to add to the system. See the 
previous page for instructions on resetting the Network Security Level to 
Max.

Resetting an Access Point to its Factory Defaults
The Console lets you reset an access point to its factory defaults from your 
dedicated EasyADC PC. To reset the access point to factory defaults, select 
SmartSystems > Restore Defaults from the toolbar, then follow the 
prompts as the Intermec EasyADC Configuration Wizard walks you 
through the process.
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Updating System Software
You can use the WA22 to synchronize the dispersal of new system software 
and configuration files for the CK30, WA22, and PM4i devices in 
EasyADC.

When you copy new system software and configuration files to the 
EasyADC software library, “C:\Program Files\Intermec\EasyADC 
Configuration Wizard\IONLibrary,” any update files are synchronized with 
the WA22. The next time the target device talks to the server in the WA22, 
it receives the updates:

• The CK30 can receive TE 2000 configuration updates (via an updated 
CONFIG.DAT file) or general CK30 configuration updates.

• The WA22 can receive firmware updates.

• The PM4i can receive firmware and configuration updates.

To update the system software in a CK30, WA22, or PM4i, download the 
latest system software from the Intermec web site (see your Intermec repre-
sentative for information), then use the drag-and-drop method as described 
in the SmartSystems Online Manual.

Updating the Discovered Devices Folder
By default, the SmartSystems Console queries the status of every device 
shown in the Discovered Devices folder every fifteen minutes. You can 
select SmartSystems > Add Devices to scan for additional devices, or right-
click any where in the folder for a pop-up menu, then select Refresh to get 
the latest status.
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6Troubleshooting

You will find these sections in this chapter:

• Images Appear With Console Icon (page 78)

• Logging In (page 79)

• Resetting the WA22 to Factory Defaults (page 87)

• Posting Transactions (page 81)

• Printing Labels (page 82)

• Ready-To-Work™ Indicator on EasyADC Devices (page 86)

• Resetting the WA22 to Factory Defaults (page 87)

• Starting the CK30 Application (page 88)

• Starting the Telnet Server Automatically (page 90)

• Other Issues (page 92)
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Images Appear With Console Icon
If any device in EasyADC develops a problem that requires attention, a red 
stop sign or a yellow triangle with an exclamation point appears on the 
Console icon displayed in the Windows system tray.

EasyADC Console Status

Icon Description

The Console icon indicates that all devices in SmartSystems are configured and operating normally.

(Warning) The red stop sign indicates that at least one device that was communicating with the Console 
is no longer communicating. Go to the Discovered Devices folder to determine which device needs 
attention. For help, see “Monitoring Devices” on page 72.

(Caution) The yellow triangle with the exclamation point indicates that at least one device is not 
operating and requires attention. Go to the Discovered Devices folder to determine which device needs 
attention. For help, see “Monitoring Devices” on page 72.
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Logging In
If you cannot login to the Data Collection Manager or the SAP Business 
One application, perform each of the following procedures until you dis-
cover the cause:

1 Make sure your username and password are valid in the SAP Business 
One application and that you are set up correctly as a “Superuser.” Also, 
verify that you have a valid SDK Tools license from SAP Business One.

2 Verify your database configuration. From the Data Collection Manager, 
select File > Configuration Options >SAP Database Options, then ver-
ify the database server name, user name, password, and company name.

3 Verify whether the SAP Business One SDK is installed on the designated 
EasyADC computer. If not, contact your SAP Business One partner of 
choice for information on loading this SDK.

4 If the “No licenses available for logon” message appears, then you have 
gone over the number of licenses permitted for your Data Collection 
Manager. Select System Manager > License Information to see the 
total number of licenses and the number available to use. If you need 
additional Product Authorization Keys (PAKs) or licenses, contact your 
Intermec representative for more information.
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PM4i Printer Connection Error
If the test label does not print on the PM4i Printer and the red error light 
stays on, there is a problem connecting the printer. Do the following to cor-
rect the connection:

2 Right-click the printer icon and select Delete.

4 The Console looks for the printer and connects it to the network. The 
PM4i pulls the excess ribbon back in and prints a test label. The red 
error light turns off and the blue light stays on, indicating the PM4i is 
configured and added to the network.

5 Right-click the Discovered Devices screen and select Refresh for the 
printer icon to appear.

1 Double-click the SmartSystems Console icon in the system tray.

3 Right-click the SmartSystems Console icon in the system tray, then 
select Explore.
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Posting Transactions
When an error occurs posting a transaction, it may be because the Foreign 
Currency Exchange Rate within SAP Business One was not defined.

Errors occur when you attempt to post a Delivery Sales Order (SO) trans-
action where the SO was created for a customer that is of the BP “Lead” 
type instead of the “Customer” type.

Errors occur when you attempt to post a Goods Receipt Purchase Order 
(PO) when the price was not provided in the PO. This could happen for a 
item that was not purchased before and the price list to use was set to “Last 
Purchase Price.”

Errors occur when you post transactions that contain serialized items or 
when items added to the Delivery and Goods Receipt PO were not on the 
base document (SO or PO).

Try entering the same information and post the transaction within the SAP 
Business One application to determine whether any errors are reported. If 
these errors still occur, then contact your Intermec representative or your 
SAP Business One partner for more information.
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Printing Labels
If your PM4i is not printing any labels, check the following until you deter-
mine the cause:

1 Verify whether the PM4i is discovered and is available on the network. 
Its Ready-To-Work™ indicator (blue light) should be steady.

2 Within the Data Collection Manager log file, if the log level is set to 
“Log Debug,” you should see an entry indicating the Printer Interface 
Manager (PIM) was started successfully. If not, verify the paths to the 
label files. From the Data Collection Manager, select File > Configura-
tion Options > Label Templates. Verify the pathnames of each of the 
three label files. Make sure these files exist at these locations, otherwise 
update the path settings to the appropriate location.
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3 From the Data Collection Manager, select File > Configuration Options 
> Label Printer Options. Verify at least one printer is selected. If not, 
then add a label printer.

4 Verify whether the printer is added to the LabelShop PRO application. 
From your PC desktop, select Start > Programs > Intermec LabelShop 
PRO 6 > LabelShop PRO 6. From the application, select File > Select 
printer. 

You should see an entry similar to the following. Verify its IP address 
and port.
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5 If you have multiple printers and the label is not printing or is printing 
from the wrong printer, select File > Configuration Options > ClientUI 
Options, then verify that a valid and desired label printer is selected for 
each label type.

6 If Prompt for printer is checked, and you changed any printer name 
(alias) while logged in the system through a CK30 or the Remote Termi-
nal Emulator, exit the transaction and try the transaction again to refresh 
the list of printers.

7 Attempt loading one the default label files and printing a test label from 
within LabelShop PRO.

8 Make sure the PM4i is discovered, configured and added to the 
LabelShop Pro application as “EasyCoder PM4i DP mode (203 dpi).” 
Shut down, then restart the EasyADC Data Collection Manager.

9 If some characters are getting replaced on the label, make sure the 
hardware key or dongle is plugged into your designated EasyADC PC in 
a USB port.
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10 If the company name and address information printed on the label is not 
correct, then you need to enter the correct information in the EasyADC 
Data Collection Manager. From the application, select File > Configura-
tion Options > Label Templates, then enter the correct “Company 
Information for Label” information.
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Ready-To-Work™ Indicator on EasyADC Devices
CK30, WA22, and PM4i devices all have a blue light called Intermec 
Ready-To-Work indicators that may blink or shut off. Should this occur, 
go to your “SmartSystems\Discovered Devices” folder and view the icons 
shown there. The following table shows what may be the significance of 
each icon.

Device and Status EasyADC Console Icons Description

CK30 Offline The CK30 is offline, it is not in communication, and its status is 
unknown. The CK30 may need your attention.

CK30 Off TE 2000 application was not loaded successfully.

CK30 Blinking The CK30 is not connected to the host. For example, the CK30 
may have roamed out of range of the EasyADC WA22 access 
point.

CK30 On A connection in your application is established and all network 
connections are active. You can use TE 2000.

WA22 Off The WA22 is not operational or it was not booted.

WA22 Blinking The WA22 is searching for the root access point in EasyADC.

WA22 On The WA22 found a root access point or it became the root 
access point. The WA22 is ready for use in EasyADC.

PM4i Off The printer is not ready.

PM4i Blinking The printer is not ready. For example, the printer may need 
media. See the display window on the printer for information.

PM4i On The printer is ready for use in EasyADC.
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Resetting the WA22 to Factory Defaults
If your previous attempts to reset the WA22 to its factory defaults have 
failed, then Intermec recommends that you use the MobileLAN Access 
Utility.

These instructions are to give you a general idea of how to use the 
MobileLAN Access Utility. For specific instructions, see the MobileLAN 
Access Utility online help.

You can download the MobileLAN Access Utility from the Intermec web 
site. Contact your Intermec representative about this URL.

To use the utility if you know the IP address of the WA22

1 Start the MobileLAN Access Utility, then click Restore to factory 
defaults.

2 Enter the IP address.

3 Power cycle the WA22.

4 Click Restore. This could take up to a minute as the WA22 is restored to 
its defaults.

To use the utility if you do NOT know the IP address of the WA22

1 Look at the WA22 configuration label to learn the Ethernet MAC 
address of the WA22, then specify the new IP address and the MAC 
address of the WA22.

2 Power cycle the WA22, then click Set.

3 Perform the steps in the previous procedure to restore the WA22 to its 
factory defaults.
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Starting the CK30 Application
The Microsoft Telnet Server with Windows XP only supports ten connec-
tions. If the Telnet Sever is reporting ten connections, then when the elev-
enth connection is attempted, the server fails and the following text flashes 
on the CK30 screen. When you see this message, try steps 1 and 2 for pos-
sible solutions.

Parsing autolog script
1 If a device cannot connect and the connection limit is not reached, verify 

whether telnet server connections are set to “tlntadmn -s all.” 

Also verify whether the telnet server's maximum connection configura-
tion is set to “tlntadmn” and the maxconn setting value is set to “10.”

To change the maximum connections, issue the “tlntadmn config max-
conn=10” command. On Windows XP, 10 is the highest setting sup-
ported.

2 If the telnet server reports more connections than what is actually sup-
ported, there may be some “orphaned” sessions. This could occur when 
the device reboots, goes out a range for too long a period, loses its con-
nection, and establishes a new connection. Identify these orphaned pro-
cesses, then terminate them through the “End Process(es)” procedure in 
the EasyADC Data Collection Manager (see “Using the System Man-
ager” on page 56 for more information). 

You can also use the telnet server “tlntadmn -s all” utility to remove these 
orphaned processes. Look for any telnet sessions with duplicate IP 
addresses, then end the entries with the longest “tlntadmn -k <id>” 
IdleTime, where <id> is the telnet session ID.

3 If you have problems connecting from the CK30, see “Using the Remote 
Terminal Emulator” on page 55 to simulate the CK30. If successful, 
check for firewalls and whether they are stopped or configured correctly.

4 If the emulator is unsuccessful, verify whether the telnet server is enabled 
and running. If the service is disabled, set the services startup type to 
“manual” (see “Starting the Telnet Server Automatically” on page 90), 
then either start the service or start the EasyADC Data Collection Man-
ager, which attempts to start the telnet server. Run the “tlntadmn” com-
mand. If the state is not set to “Running,” then run the “tlntadmn start” 
command.

5 If the telnet server is running, verify whether the “TelnetClients” user 
group was created along with the “SBOClient” local user, and whether 
the “SBOClient” is a member of the “TelnetClients” group. If not, 
either run the installation again or add the “TelnetClients” user group 
manually. The “SBOClient” user password is “SBO_Client_1234” and 
it is case sensitive.

6 If the device does not automatically attempt to connect (a message simi-
lar to “Parsing autolog script” appears), verify whether the 
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AUTOLOG.SCR file exists on the device in the “\CK_FFS” folder. If 
not, reset the device back to factory defaults.

7 If it appears that the device establishes a telnet session but does not auto-
matically start the application, verify whether the LOGIN.CMD file 
exists in the “\Windows\System32” directory. Also check the contents of 
this file, it should attempt to change the current directory to the installa-
tion directory (where the EasyADC Data Collection Manager was 
installed), then execute the UI.EXE application. If not, either create, 
modify, or reinstall the UI.EXE file.
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Starting the Telnet Server Automatically
The Telnet server is needed for the EasyADC Data Collection Manager to 
operate properly. Should your service be disabled, you need to do the fol-
lowing to ensure your service is set to start automatically before running the 
EasyADC Data Collection Manager.

Shut down your EasyADC Data Collection Manager before doing the fol-
lowing:
1 From your desktop, right-click the My Computer icon, then select Man-

age to access the Computer Management dialog.

2 On the left, click (+) to expand Services and Applications, then double-
click Services. Tap the Standard tab on the bottom.
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3 Scroll through the list of services for the “Telnet” entry, select to high-
light, do a right-click, then select Properties.

4 If the Startup type drop-down list is set to “Disabled,” change the value 
to “Manual,” click Apply, then click OK.
EasyADC® for SAP Business One System Manual 91



Chapter 6 — Troubleshooting
Other Issues
Below are more troubleshooting tips to assist any issues you may encounter:

DLLs
Two DLLs are installed (SSLEAY32.DLL and LIBEAY32.DLL) for use in 
SmartSystems and EasyADC. Other programs do install DLLs with similar 
file names. Intermec compiles additional functions into its DLLs, when 
other applications use a subset of the functionality Intermec uses. The issue 
is that some applications install these two DLLs in the 
“\Windows\System32” directory or other directories that appear in the 
search path before the Intermec DLLs.

Search for, then rename all but Intermec instances of these two DLLs to 
something such as SSLEAY32.SAV and LIBEAY32.SAV. Copy the Inter-
mec DLLs to each location with these renamed files, then reboot the desig-
nated EasyADC PC.

IQueue Service
If you see “Error: EasyADC/SmartSystems is not properly running! Correct 
the problem and restart the system,” the IQueue service is not running. 
Restart the Intermec Core Messaging Server service.
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SAP Database Options
If errors are logged or reported within the Inventory Count or Item Cross 
Reference, and a log entry indicates an error opening the SIM Interface; the 
Inventory Count option is not available on the CK30 though its warehouse 
count is enabled; or the InventoryCountOpen broadcast message is empty, 
then the SAP Business One name and password fields are invalid. From the 
Data Collection Manager, select File > Configuration Options > SAP 
Database Options to verify these values.
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