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c1Working with gCADPlus
Here we show how to work with gCADPlus software. Our main focus is on the gCADPlus user interface.

This movie provides a short introduction to the various components that make up the gCADPlus drawing environment. We cover how to use drop down menus, 
using commands to draw lines, circles and other entities, add dimensions and examine landscape productivity tools on the special gCADPlus drop down menu. We 
show how to handle floating toolbars, edit entities using the properties box, the importance of the mouse and the value of right clicking the mouse while drafting. We 
survey the command and status areas, the mini layer tool, show how to get online help, work with multiple drawings and the multiplicity of layout spaces available 
to gCADPlus users. The figure below shows the usual interface. Tip: The drawing editor background is black but can be set to white if desired.

FILENAME
MENU BARSTANDARD TOOLBAR

DRAWING EDITOR

FORMAT TOOLBAR

OSNAP TOOLS

MODIFY TOOLS

LAYOUT TABS  COMMAND AREA  STATUS LINEMINI LAYER TOOLS

PROPERTIES

DIMENSION TOOLBAR

DRAW

Landscape drawings 
are constructed in the 
drawing editor area 
(dark background) 
using tools in various 
drop down menus 
and toolbar items.

The landscape model 
is constructed full 
size in drawing units 
(mm for the metric 
environment) and 
decimal feet in the 
USA.
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Key areas in the drawing environment are labeled in the figure above. All the tools necessary to create landscape drawings are in easy reach via drop down menus, 
toolbar icons or right click pop up menus. The black area in the figure above is termed the drawing editor (aka model space) and it is here that designs are created using 
various tools selected from toolbars, menus or typed in the command area. We think that it is important to maintain consistency in the interface and not to change the 
location of menu items or screen layout when new versions of gCADPlus are released - consistency in the use of gCADPlus is our aim.

Viewing a typical design - units and printing from a layout space

The figure below shows a full size landscape model created using decimal feet as the base unit - metric units (mm) can also be used. When complete, the design can 
be displayed on any number of layout spaces, each complete with site details and designer’s logo, ready for printing. These views in layout space are most important, 
because they provide a quick impression of what the design will look like before printing. The figure below shows an example printed from an architectural C size  
layout sheet. Note the inclusion of a plant schedule that is automatically generated using one of the tools in the specialist gCADPlus drop down menu.

A typical landscape plan for a large site in 
Massachusetts, USA. The plant schedule 
shown on the right is generated automatically.
As each new symbolis added to it is 
assigned to a particular species name in an 
accompanying plant data file.
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Creating new designs

New designs can be created in a number of ways - it is possible to start with a blank canvas and use various draw tools to create a base plan and place entities into a 
drawing. Alternatively, it is possible to start with a template and simply drag designs, part designs and landscape symbols from a library to complete the drawing.

This movie illustrates some of the various ways in which landscape drawings can be developed.

One of the templates available in gCADPlus. In this case, the site boundaries might be placed at left and the 
design ‘dressed up’ by dragging symbols in from the right. That’s an easy way to quickly create a design. 
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Site measurements - creating base plans
Once an understanding of the CAD coordinate system has been gained, it is a relatively simple matter to prepare an accurate base plan taking measurements from a 
‘mud map‘ containing actual site measurements made on site.

This movie shows how to make an accurate base plan for a design for the rear of a small cottage. 

Tip: We recommend placing the footprint of any building before drawing site boundaries.

Using triangulation to create an accurate base plan ready for a landscape design.
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More on the drawing interface - the Properties Box

The Properties Box at the left of screen is a particularly powerful tool. Once an entity in a drawing is selected (using the left mouse button), most characteristics of the 
entity - its color, layer, linetype, line thickness, text style and so on can be changed in the box simply by typing new values or selecting from a drop down menu inside 
the Properties Box itself. If more than one entity is selected, properties for the whole group can be altered in one fell swoop. 

The role of the Properties dialog box when drafting is discussed in this movie.

The Properties box shows all characteristics of  a 
selected entity. In this case a polyline - a flexible line.
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Selecting a rectangle. The properties box displays a great deal of information 
about this entity

The appearance of the Properties box, when several entities are selected. Scroll 
the list (see figure at left) to get information on a particular entity

The Properties box shows all characteristics of  a selected entity. Select several 
entities and cycle to each.
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The use of color

Color in gCADPlus drawings is handled in much the same way as it is in AutoCAD.. Color can be assigned to an individual entity or to a layer. The figure below 
shows the color dialog box. This box can be reached from the Format drop down menu or fromat drop down menu or by clicking in the color field of the Properties 
box when an entity is selected.

When specifying a color, you can enter the neame of a color or its number. gCADPlus uses 256 indexed colors or the color of an entity can be chosen from millions of 
true colors defined by a mixture of red, green and blue values.

Using true color for subtle shading in landscape designs is achieved using True Colors rather than applying transparency to one of the 
statndard 256 color numbers.

Setting index colors, true colors, controlling color by layer, color inside plant symbol blocks.

The select color dialog box can 
be used to assign a color to the 
selected entity. If no entity is 
selected, the box can also be used 
to set the current drawing color. 
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Status line switches

It is common when drafting to use drafting aids. These are built in to gCADPlus. Aids such as as ORTHO forces lines to be drawn in the horizontal or vertical plane. 
The POLAR option allows entities to be placed at defined angles (such as 45 degrees) as well as horizontally or vertically. The OSNAP option causes gCADPlus to 
jump to geometric points on entities already in the drawing. We will discuss the function of the tools shortly. 

The status line at the extreme bottom of the drawing space is most important and controls the behaviour of many editing tools. Drafting can become tricky if you are 
not aware what these switches are doing in the background.

This movie explains the use of switches in the status line.

Tip: Especially when learning to use gCADPlus, we recommend selecting these switches one at a time and not making them permanent. It is very easy to turn any one 
of these switches on and forget that it is operational. That slows drafting and often forces users to erase entities because they have been wrongly drawn. To aid users, 
we have programmed gCADPlus to make the color of a switch red when it is active. 

Status line switches - colored red when on. The 
current plant data file associated with the drawing is 
also shown in the status line

Controls for the POLAR switch
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SNAP

In common with most CAD software like AutoCAD, gCADPlus allows for the activation of an ‘electronic’ grid covering the drawing area. Provided that the 
appropriate grid values are set appropriately, this option causes the cursor to jump to grid points when placing entities. The cursor jumps to a grid point when this 
switch is on (red). Function key #9 also toggles the snap setting on or off.

GRID

This switch turns the visibility of the electronic grid on or off. As an aid to layout, the grid is automatically turned on when a layout view is activated.

The grid is a pattern of equidistant dots that extends over the drawing. Using the grid is similar to placing a sheet of grid paper under a transparent drawing. The 
grid serves two purposes; first, it helps you align objects and visualize the distances between them; and, second, the grid can be used as a snap device, or frame 
that entities may drape themselves on. The grid makes coordinate points “visible”. gCADPlus allows you to set cursor snap to the grid nodes. The cursor will then 
move exactly from node to node as you move the mouse.

The grid an snap values are set with the Drafting Settings option which is available by right clicking on the drawing editor. X and Y values for a grid are set along 
with a value to determine the grid bold step interval. F7 toggles the grid on or off.

Tip: The grid can be a useful aid when applying dimensioning.

ORTHO

This switch constrains lines to the vertical or horizontal plane. The tracking option can be turned on and off with the F8 key allowing for quick access to the 
ORTHO mode. Alternatively, select the ORTHO option in the status line at the bottom of the screen.

POLAR

There are often occasions where designers require lines to be at 90 degrees (orthogonal) to one another or some other angle. gCADPlus has a ‘drawing aid’ called 
Polar Tracking, to assist in constructing such lines. Tip: Via the Options dialog box, it is also possible to track at different angles and adjust the step value that 
shows as the cross hair cursor is moved.

OSNAP

Object snaps (entity snaps) can be used at any time that gCADPlus asks for a point. Use an entity snap to locate the new entity accurately at a point on a properly 
defined geometric point on an existing entity. For example you might start a new line at the precise center of a circle and use an entity (object) snap to do that.

LWT

It is possible to assign a line weight to any entity. This status line switch controls the visibility of lineweight. 

ENT

Controls the display of pop up screen view of extended data added to an entity. See image below.

This movie shows how extra data can be stored with various entities in drawings.

REGEN

This option is used to refresh the screen. There are occasions (for example, after pasting information from the clipboard) when the gCADPlus display screen needs 
to be refreshed.
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 Additional information stored behind an entity is displayed when the ENT switch 
is on and the mouse comes near an entity with extended data.
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The POLAR status line switch

Beginners sometimes find it difficult to distinguish between ORTHO and POLAR. Both enable lines to be drawn orthogonal to one another, but the polar switch is 
much more versatile.

This movie illustrates how an understanding of the operation of the POLAR switch and step size switch can greatly speed drafting.

Using polar step size to speed 
placement of pavers.

Copying a composting bin at a tricky angle is simplified by creating a new angle in the polar settings dialog box.
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Plant List

Not a toggle, but the path of any plant data file attached to the drawing is also shown in the status line.

This movie shows how a plant list can be attached to a drawing and how it can be used to generate a plant schedule.

 Plant lists can be associated with drawings. The 
name of the current list is shown in the extreme 
right of the status line.

http://youtu.be/RiPQ8B3fQjM
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Mini layer tool

Selecting View > Layer puts a box that we have called Mini under the properties box enabling manipulation of layers - this tool replicates what is shown when the 
LAYER command is used, but is sown in more compact form. If required, it is possible to float the mini layer windows.

This movie illustrates the use of the mini layer tool.

We discuss the display and operation of the gCADPlus mini layer tool, control display of points and show printing high quality PDF On a Mac.

The Mini Layer tool provides a convenient 
mechanism for turning layers on and off.
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The symbol library

This drop down menu provides quick access to a wide range of symbols for species planting and other details. 

The ‘plants ‘group contains three types of symbols - standard, sized and named. The standard group consists of > 100 stock symbols each 1 meter (3 feet) in diameter, 
the sized group contains links to symbols for climbers, grasses, ground covers, hedge, large, medium, small and mini shrubs, small and large trees adjust according 
to expected size. The named group contains symbols designed illustrate specific 
species. The ‘details’ group leads to symbols for details such as north points, 
drawing sheets etc. The ‘designs’ group is provided so you can store completed 
design work ready for incorporation into new jobs.

The ‘broadscale’ group is designed for use in large scale projects.

Tip: Selecting a symbol enables it to be dropped directly into a design. Library drop down menus used to access 
the many plant and detail symbols 
available in the gCADPlus environment.
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Typical symbols.Navigating to the library of ‘modern’ 
planting symbols

Navigating to the library of standard 
planting symbols.

Here we discuss the various ways to use the gCADPlus symbol library.

Once selected, insert symbol into design.

https://youtu.be/tjjbGB8McLo
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Exploring the interface - getting your hands dirty!

We suggest that the simplest way to start learning to use gCADPlus is to work with a practice drawing containing some landscape 
elements. 
Start gCADPlus, select File>New and choose the built-in template called “Funky“. A new drawing 
based on that template choice will appear containing planting and other symbols on the right. These 
symbols can simply be dragged into position to make the design. 

Before starting, select the distance option found on the standard toolbar (circled in the figure at 
right). Use it to measure the size of the table. The value reported should be full size in either mm 
or feet depending on the version of gCADPlus in use.

Tip: Later you will create your own templates containing all your favorite symbols, 
details, dimension and text styles, so new design work can be created efficiently.

Experiment magnifying and reducing the view using the mouse wheel. Roll the wheel 
away from you to magnify the view; roll toward you to shrink the view [zoom out]. Distance tool.

Create designs quickly 
using templates - here 
the ‘‘Funky” template 
in gCADPlus has been 
used.
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To pan (move the view of a drawing), hold the mouse wheel down (and keep it down) while moving to a 
new position.

Tip: gCADPlus is designed so that you can construct drawings primarily using the mouse. Instructions for gCADPlus to place entities like 
circles and lines are selected with the left button of the mouse from drop down or from toolbar icons.

As a further exercise, open the drawing ConstructedWetlandAssemblyPartFinished from the Drawings 
folder (In User>My Documents>gCADPlus) and repeat the zooming and panning exercises described above.

The distance tool shows 
the table to be just over a 
meter (3 feet) in diameter.

Constructed wetland 
drawing.
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A quick check print

It is a good idea to gain some appreciation of the appearance of the final printed result at quite an early stage of your design work. gCADPlus provides a flexible 
method of producing a PDF file and the file can be created at a number of different resolution settings. Switch to the layout tab labeled Layout1 and select File >Save 
As PDF.

Tip: Select Window, Medium resolution, put a box around the area to be printed and ok. The drawing may appear in a PDF viewer such as Acrobat Reader.

This Save As PDF tool provides a quick way to visualize how the design might look in the hands of a client.

The Save As PDF dialog box.
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The importance of the right click menu
After zooming in and out using the wheel of the mouse, try clicking the right mouse button. A pop up menu appears. This 
menu provides options for controlling the view of the design and offers access to some additional tools.

Tip: Try selecting an entity with the left mouse button, then using the right button (click option) choose erase. Whenever you are  using gCADPlus to create designs; 
different options will appear on the menu based on the entity selected.

How to use the right click pop up menus in gCADPlus.

The right click menu - no entity selected. Commands 
recently used by you are listed above Zoom Extents.
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Drop down menus

Drop down menus are available at the top of the gCADPlus screen. Clicking on the title of a drop menu uncovers a series of options (and sub-options). 

The majority of drop menus in gCADPlus, provide the standard features found in most CAD software - tools for File manipulation, Edit, Format, Draw, Dimension, 
Modify etc. and are discussed elsewhere. However, the View, Help, Tools and gCADPlus drop down menus contain specialist landscape tools and are briefly 
introduced here. More on the gCADPlus menu can be found in Chapter 10 and on the Tools drop down menu in Chapter 11.

Some of the drop down menus in gCADPlus.
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The View drop down menu

For example, selecting the title “View” shows options seen previously in the right click pop up menu, together with quite a number of other tools along with some fly-
out sub menus. 
Perhaps the most useful thing to try at this stage in the View drop menu is to select one of Properties, Layers or 
Command Line options. One (left) click on any of those, changes the appearance of the screen dramatically by making that 
window disappear. A further click causes the zone to re-appear. We have added this capability because users asked for 
it. The reason being that experienced users want to be able to use maximum screen real estate when working on designs. 

The View drop down menu. Zoom Extents, Window and previous are also on the right click menu, Zoom selected enables a quick zoom to an entity, Regen is used if 
the screen is unresponsive, Pan to shift the drawing, Transparent Render shows transparency if set to entities, Pro-perties, Mini Layer and Command boxes can be 
toggled on or off, toolbars customized, workspaces saved and background changed from black to white.  
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View menu - Workspaces

Worspaces are collections of arrangements of menus and toolbars suited to different drafting styles. For example, the gCADPlus default workspace shows all toolbars, 
window zones and menus, while the minimal workspace (shown below) strips everything away except the design itself.

It is possible via the View drop down menu, to switch to, customize and store workspaces. Experienced gCADPlus users like this facility and learn to use numerous 
shortcuts to produce landscape drawings. They minimize zooming in and out on a design. They mostly want a minimal, uncluttered drawing interface. 

Tip: In order to return to the default view of a drawing when the minimal workspace view is showing, move the mouse to the top title bar, right click and select “Show 
menu bar“ then select View>Workspace>gCADPlus default.

This movie shows the workspace tool in operation.

Here we have switched gCADPlus to a ‘‘Minimal workspace. This option reclaims maximal screen real estate. Since gCADPlus can be 
driven by the left and right clicks of the mouse, this can be an efficient way to work, especially on a large site.
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Saving custom workspaces
It is possible to customize toolbars and arrangement of menus and save that arrangement under a name of choice. That choice can be recalled in a later drawing session 
(check that changes to toolbars are saved).

Tip: We suggest that you do not experiment with the use of the workspace tool until you have developed your gCADPlus skills to a reasonable level.

Restore the default workspace from 
the minimal workspace.

Switching workspaces

Lightly drawn upper canopy
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Increment and save

One of the unique features of Computer Aided Design is the length of time you often work on a single design (drawing) file. It’s possible to start on a drawing for a 
particular job (let’s call it JohnDoeHouse) and work on it many times over a period of weeks. Even if you save often, there are only two copies of the file in existence 
- the native gCADPlus file with its .lcd extension and the .bak version of that same file. With the best intention in the world, no computer, operating system or 
application is immune to file corruption so you need to protect that valuable work.

Dialog box used to control backup time. It 
is possible to turn off the warning or change 
the default time for thois operation.

gCADPlus offers various levels of protection - an automatic save every 15 minutes to a file with the extension lc$, error checking etc. However, we believe that the 
incremental save tool (found behind the green cross on the standard toolbar) offers landscape designers the best level of protection. Click once on this icon and a copy 
of the file is saved under its existing name, and the name of the current JohnDoeHouse drawing file increments and becomes JohnDoeHouse_01. Each time the green 
plus sign is clicked, the drawing file increments by one. This means you can have multiple copies of the drawing file and an audit trail. At any time, you can go back 
to an earlier version of the design. Our users report that this is a really valuable feature from a  design viewpoint - it is not uncommon to head in one design direction 
and want to retreat when things do not work out. In that case, all you need do is open an earlier version of your design. The figure below shows the location of the 
incremental backup tool (increment and save) on the standard toolbar.

This movie shows how the incremental save feature works.

Incremental backup tool is located on the 
standrad toolbar.
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Help while working with gCADPlus

There are a number of alternative ways to get help while working with gCADPlus.

The ‘Help’ drop down menu

This menu provides a link to the search tool on the gCADPlus Facebook site. To get help, simply Posts and type your search query in much the same way as you do 
with a Google search. A list links to movies will show after the query.

The help options are discussed in this movie.

Press the F1 key or click on the book icon on the standard toolbar next to the right of the AREA tool and the gCADPlus help file will appear. Note that it is possible to 
search for an individual command or search for more general help.

Searching the Help file.
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The gCADPlus drop down menu

This menu provides access to most of the ‘smarts‘ in gCADPlus - the tools used to automate many tedious landscape design steps - attaching plant database files, 
setting symbols to a plant name, generating plant list, extracting information, interacting with SketchUp for 3D modelling, a shadow tool, inserting Google Maps and 
GIS/GPS tools etc. These are discussed in depth in the file “Automating draftings tasks“.

Some of the automated design tools 
available in gCADPlus
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The ‘Tools’ drop down menu

This menu contains a range of different tools targeted at the basics of constructing landscape drawings - marking areas, alter drafting settings, change draw order of 
entities, isolate just those elements on a single layer, create a blank database file, draw hold cloud, link to the DeepRoot online database, check an AutoCAD dwg file 
for compatibility, purge a drawing of unwanted blocks, set backup time, create a section, set point markers, insert grid lines, use a section tool, run a sustainability 
calculator, gain access to SppDb, the personal plant database designed for use with gCADPlus, merge PDF output files and switch languages. 

Tools drop down menu (above), sustainability calculator (below)

Use construction lines to create sight lines.

Isola Madre 
- Palazzo 
Borromeo 
(Italy)
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Tools menu - language switching
The figure below shows gCADPlus operating in the French language. Several 
different languages are available - French, Czech, German, Russian and Spanish. 
Note that not all gCADPlus commands have been translated. We would appreciate 
assistance in translating commands to the languages listed above.

Switch gCADPlus commands to French and other 
languages.
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The ‘Window’ drop down menu

This menu allows activity in gCADPlus’s multiple document interface - switching between different drawings, tiling windows etc.

This movie discusses switching from one drawing to another and shows how to copy entities between drawings. 

Tip: Use ‘right click’ and select the copy to clipboard option to paste entities from one drawing to another.

Using gCADPlus multiple user interface - switching 
drawings via the Window drop down menu.
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Selecting CAD entities

When using gCADPlus, it is important to understand how to use the various 
methods of selecting entities and to manipulate the resultant selection set. Many 
drafters do not completely understand that when they ‘pick’ an item(s) in a drawing 
using their pointing device, they are creating what is called a selection set. Once a 
selection set is created, it can be manipulated in different ways. 

Direct selection
This is the simplest method of selecting an entity, just pick it with the left button 
of the mouse. The entity is highlighted (in a magenta color) and its properties are 
shown in the Properties box window at the left of screen. Note that selections can 
be made with out responding to a command prompt. 

Tip; If you do not like the pick color, a global setting can be used to alter it.

Window selection
You can use a Window-inside or Window-Crossing option to select more than one 
entity at the same time. The way a selection rectangle is formed  - the direction 
in which you define the points of the rectangle (left-to-right or right-to-left) 
determines which type of window you create - inside or crossing. This will greatly 
influence entities that are gathered in the election set. These two methods of 
selecting entities are explained below. 

Selecting entities by window-inside
Start gCADPlus, choose File>New and insert a symbol from 
the library. After the symbol is in the drawing, select it, 
right click and copy to make a group of three similar to 
that shown. Click a point in a drawing below and to the left 
of a group of (say) 3 symbols as shown below. Click to the 
right (and up) to select a second point such that all three 
symbols are totally within the selection box. 

Result: All three symbols are selected.

Tip: Improving your ability to manipulate selection sets can definitely assist your 
CAD productivity. Facility with selection sets is essential if you want be be able 
to confidently (an efficiently) use many of the edit commands such as the ERASE, 
OFFSET, MOVE, COPY, STRETCH, and BLOCK commands.

Using a Crossing Window
Select a point somewhat  higher up on the right and somewhat 
lower down on the left as shown. This creates a crossing 
window. This time, any entity crossing the window will be 

Example 1: Pick bottom left and 
top right

Result: Three entities selected.

Example 2: Smaller rectangle - 
only one entity is wholly within 
the pick area so is selected. 
Result, one entity selected.
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selected. Close gCADPlus.

Tip: A window inside box is indicated by a continuous line around the selection box while a crossing  window is 
indicated by a dashed line.

Selection can also be effected via the Tools menu - several different options are available here.

Example 3: Pick a point 
top right (Point A), then 
a point bottom left (point 
B).

This makes a so-called 
crossing window and 
all three entities are 
selected.

Making selection options from the Tools drop menu.
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More on the value of the Properties box 

No matter how you work, the Properties box is a useful aid when selecting 
entities. As each entity is selected, its name appears in a drop list in the 
Properties box at the left of screen. As shown in the figure, a single pick provides 
information in the box about the entity - its type, x and y coordinates, layer, color 
etc. in this case, a rectangle is selected.

When several entities are selected, the Properties box changes its appearance 
and tells you the total number selected. Shown below where the box tells us that 
several entities have been selected. It is possible to scroll down the list of entities 
and display information on each in turn. In the figure below, a line has been 
selected from a list . Five entities and their properties are now listed.

Toggle the operation of the shift key with a 
button in the Properties box.

Change the response to the shift key with 
global properties setting.
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The importance of the Shift and Control keys

 (and Global Settings) when selecting entities

Under normal operation, when you select (pick) and entity, its color changes to 
magenta to indicate selection. When the next entity is selected, it too is highlighted. 
Both the original entity and the new one stay highlighted as do additional entities 
selected. If you have several entities selected (perhaps a crossing window has 
inadvertently selected an unwanted entity), it is possible to hold down the shift key 
and click on the errant entity. It is then removed from the selection set and changes 
color. This ‘shift to remove‘ is the default gCADPlus setting; it can be changed if 
required. 

The control key can also be used to good effect when manipulating selection sets. 
Hold it down while a selection set is active and it will enable drawing commands to 
continue.

The Control>click sequence on an entity will start the command used to create 
that particular entity. Hold Control and click on a piece of text to start the text 
command. 

The remaining two icons adjacent to the Using Shift button have no effect. 

Note that the shift/click response is dependent on the gCADPlus global settings. 
See the section in this chapter for information for information about making 
permanent changes to gCADPlus’s behavior.

This movie illustrates the use of the Control key click combination to start a 
command.

Noun/verb vs. ve rb/noun selection

If you start (say) the ERASE command (perhaps using the E shortcut) and then 
pick (select) an entity such as a circle, you are using the verb/noun selection 
system -  ERASE (the verb) CIRCLE (the noun). However, rather than issuing 
the command first and then responding to it by selecting entities, gCADPlus also 
allows the use of verb/noun - selection system. ‘Pick’ the entity simply by clicking 
on it (the noun) and then issuing the command (verb). Either system can be used, it 
is your choice. 

Accurately place pavers and planting in a gCADPlus design.
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Understanding the gCADPlus coordinate system

In gCADPlus, when a command prompts for a point, you can use the pointing device (your mouse) to specify 
a point by clicking, or you can enter a coordinate value on the command line. Coordinates may be entered as 
either Cartesian or polar coordinates.

We show how a combination of relative and polar coordinate systems can be used to make a base landscape 
plan

In this movie, we show how to draw a paver 800 mm by 600 mm using the different coordinate systems 
described below.

Cartesian coord inates
A Cartesian coordinate system has three axes, X, Y, and Z. When you enter coordinate values, you indicate a 
point’s distance (in units) and its direction (+ or -) along the X, Y, and Z axes relative to the coordinate system’s 
point of origin where all coordinate values are zero (0,0,0). Negative values on the X plane are left of the point 
of origin, and positive values on the X plane are to the right of the point of origin. Negative values on the Y 
plane are below the point of origin and positive values on the Y plane are above it. 

Polar coordinates
Polar coordinates use a distance and a fixed angle to locate a point.

With both Cartesian and polar coordinates, you can enter absolute coordinates based on the point of origin 
(0,0,0), or relative coordinates based on the last point specified.

Entering Cartesian coordinates
To use a coordinate to specify a point, enter an X value and a Y value separated by a comma (X,Y). gCADPlus 
does not require the use of the 3rd dimension, so it can be ignored even though a value for the Z plane will be 0 
- the coordinate set will appear as: (X,Y,Z). The X value is the positive or negative distance, in units, along the 
horizontal axis. The Y value is the positive or negative distance, in units, along the vertical axis. 

Absolute coordinate values are based on the origin (0,0), where the X and Y axes intersect. Use an absolute 
coordinate when you know the precise X and Y values of the point coordinate. For example, the coordinate 3,4 
specifies a point 3 units along the X axis and 4 units along the Y axis from the origin.

Relative coordinate values are based on the last point entered. Use a relative coordinate when you know the 
position of a point in relation to the previous point. To specify a relative coordinate, precede the coordinate 
with an @ symbol. For example, the coordinate @3,4 specifies a point 3 units along the X axis and 4 units 
along the Y axis from the last point specified.

The example at right draws a line beginning at a point with an X value of -2, a Y value of 1, and an endpoint at 
3,4. Pressing ENTER at the To Point prompt ends the command.
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Relative coordinates

The example at right draws a line whose endpoint is 5 units in the X direction and 0 units in the Y direction 
from the start point at the absolute coordinate -2,1. Pressing ENTER at the next To Point prompt ends the 
command. The end result is the same as the first example.

Polar coordinates

To enter a polar coordinate, enter a distance and an angle separated by an angle bracket (<). For example, 
to specify a point that is at a distance of 1 unit from the previous point and at an angle of 45 degrees, enter 
@1<45.

Tip: By default, angles increase in the counterclockwise direction and decrease in the clockwise direction. To 
move clockwise, enter a negative value for the angle. For example, entering 1<315 is the same as entering 1<-
45.

Polar coordinates are either absolute (measured from the origin) or relative to the previous point. To specify a 
relative coordinate, precede the coordinate with an @ symbol.

The example above shows a line drawn with polar coordinates (using the default angle direction setting). 
Pressing ENTER at the Next To Point prompt ends the command.
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Relative polar coordinates

The example at right shows a line drawn with relative polar coordinates. Pressing ENTER at the Next To Point 
prompt ends the command.

Also you can specify direction angle by mouse position relative to last entered point. In this case, you specify 
only distance value in the command line, and gCADPlus will use the coordinates of the point which are placed 
at specified distance from the last entered point along a direction to cursor position.
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Drafting Settings

A variety of precision tools are available in gCADPlus to help you produce quick, accurate drawings without performing tedious 
calculations. Although all your work is based on a coordinate system, you can establish settings that cause you to snap to locations on the 
screen, to specified locations on objects, or to points relative to other locations or objects.

Drafting settings can be reached via the Tools drop down menu, by right clicking in the drawing editor and choose Drafting Settings or 
by clicking on a toolbar icon. The three tabs available in the Drafting Settings command are shown below viz: Grid, Polar Tracking and 
Object Snap

Grid
The grid is a pattern of equidistant dots that extends over the drawing. Using the grid is similar to placing a sheet of grid paper under 
a transparent drawing. The grid serves two purposes; first, it can help you align objects and visualize the distances between them; and, 
second, the grid can be used as a snap device, or frame that entities may drape themselves on. The grid makes coordinate points “visible” 
and gCADPlus allows you to set cursor snap to the grid nodes. The cursor will then move exactly from node to node as you move the 
mouse.

At any time you can turn the grid visibility on/off by pressing F7, or turn grid snapping on/off by pressing F9. This can also be effected by 
clicking on the word GRID in the status line. To use a grid, do one of the following:

• Choose Tools> Drafting Settings.

• Right click on the screen and select Drafting Aids and the Grid tab.

• Select Grid from a toolbar.

Tip: The grid can be a useful aid when applying dimensioning.

Polar Tracking and the ORTHO mode
There are often occasions where designers require lines to be at 90 degrees (orthogonal) to one another. 
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Object snaps

Object snaps (entity snaps) can be used at any time the program asks you to nominate a point. Use an entity snap to locate the new entity 
accurately at a point on a properly defined geometric point on an existing entity. For example you might start a new line at the precise 
center of a circle and use an entity (object) snap to do that. Used wisely, entity snaps can take all the hard work out of drafting. Certainly, 
one should avoid zooming in on points and placing the start (or center) of a new entity by eye - let the software work for you, not the other 
way around.

Putting it another way, entity snaps enable you to quickly select exact geometric points on existing entities without having to know the 
exact coordinates of those points. With entity snaps, you can select (say) the end point of a line or arc, the center point of a circle, the 
intersection of any two entities, or any other geometrically significant position whenever the software asks for a point location. The 
location does not even have to be an entity. You even use entity snaps to draw entities that are tangent or perpendicular to an existing entity.

You can work with entity snaps in one of two ways:

• Enable a running entity snap that remains in effect until you turn it off by choosing an entity snap when no other command is 
active or,

• Enable a one-time entity snap for a single selection by choosing an entity snap when another command is active. You can also use 
a one-time entity snap to override a running entity snap.

When using entity snaps, the program recognizes only visible entities or visible portions of entities. You cannot snap to entities on layers 
that have been turned off or to the blank portions of dashed lines.

When you specify one or more entity snaps, an entity snap target box is added to the cross-hairs. In addition, an icon appears adjacent to 
the cross-hair indicating the active entity snap. When you select an entity, the program snaps to the snap point closest to the center of the 
target box.

The following snap modes are available;

Center, Near, End, Mid, Node (point), Grip (Quadrant), Tangent, Perpendicular, InsertionPoint, Intersection.

The flyover cursor can also operate and provide an appropriate marker when the geometric point has been found.

Tip: Do take some time to become comfortable with entity snaps settings and the various methods of using them; unless you have a sound 
understanding of their operation, they can be counterproductive.

Chapter 4 contains detailed discussion and examples of the use of entity snaps.
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Function keys

F1 loads the Help file, F2 toggles ORTHO on/off, F3 toggles turns object snap, F7 toggles grid, F8 toggles POLAR tracking, F9 turns snap 
to the underlying electronic grid on and off

Formal design based on a very 
large circle. Parc St Pierre - 
Amiens (France).
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Tools menu

It is possible to change a large number of environmental variables that apply to individual drawings. The Tools menu is discussed at length 
in Chapter 11, but one option - background color will be discussed here as many beginners want to change the background color of the 
drawing editor as a first step. Background color is found under Tool>Drawing parameters

We recommend using the switch on the View drop down menu as a quick way of making this change. Leave the model space background 
black when you anticipate an extended drafting session to reduce eyes strsin. Then, when you switch from the model to a layout or paper 
view, it is immediately obvious which space you are in so there is no danger of inserting a entities in the wrong space.

Configuring Toolbars 

Beginners often ask about toolbars. gCADPlus is capable of displaying a number of toolbars. Each toolbar can float and be positioned at 
any desired position on the screen. A typical arrangement  is shown in the figure below.

The number of icons displayed on an individual  toolbar is a function of the screen resolution of your computer system. The wider the 
screen, the more icons (with concomitant links to gCADPlus commands) that can be displayed on a given toolbar. 
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More on coordinate systems

In common with other CAD software like AutoCAD, Vectorworks, MicroStation etc., gCADPlus works with a coordinate system. Looking 
at the figure below, positive X is to the right in the drawing editor and positive Y up. Entities can be placed into specific coordinate position 
and the database keeps track of the position and stores a new set of coordinate values, even if the entity is moved.

This movie discusses the coordinate system used by gCADPlus. We show how to draw line of accurate length using pairs of coordinates 
(called Cartesian coordinates) and draw lines of defined length at different angles.

Using Cartesian coordinates in CAD drawings.
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Beginners often have some difficulty understanding the different coordinate systems available in gCADPlus.

This movie explains the use of absolute and relative Cartesian coordinate systems along with absolute and relative polar coordinate 
systems using a typical landscape design file using metric units.

We show how to draw lines of required length in the landscape plan shown 
above.

https://youtu.be/QUAR8idtAQo
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The BLOCK and BLOCK related commands

Quite soon once users begin to use gCADPlus, they ask about the possibility of making their own symbols and re-using these and other 
grouped entities in drawings. In common with AutoCAD, gCADPlus use BLOCKS to accomodate this need.

Several commands are used to manage the creation, selection and insertion of blocks in the gCADPlus environment viz.  

• The BLOCK command itself takes a group of entities and combines them to make a single entity

• The BLOCKS command activates a dialog box to help manage blocks already in a drawing or to add an external drawing from a 
disk location.

• The INSERT command is used to select an existing block already associated (loaded) with the current drawing and stamp a copy 
into the design. For more information on the insert command, see the section in these notes under “I”.

Each of these ccommands an be activated in a number of different ways - from toolbar icons, drop down menus or by typing at the 
keyboard.

The BLOCK command is 
used to combine entities 
to make a single entity

The BLOCKS command 
is used to insert symbols. INSERT command.

BLOCKs command 
found on toolbar

How to make a block.

Re-using blocks in other drawings.
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The BLOCK command in the gCADPlus environment creates a block. Using blocks to stamp copies of (say) a new plant symbol that you 
have designed, is much more efficient in terms of drawing file size and managing operations such as zoom and pan than using copies of 
symbols made from groups of elements. 

Although we often think of a symbol for a plant species as a block, the command can be used to group all types of entities.

The related BLOCKS command is used to access blocks that are already present in the drawing. These may have been made earleir in 
the drafting session or imported from the gCADPlus symbol library. Even though not necessarily used in the design, blocks may ‘stay on 
the shelf’ ready for later insertion. These unused blocks can bloat a drawing and sometimes make CAD software such as gCADPlus (and 
AutoCAD) slow and difficult to use. The PURGE command removes this excess baggage and the drawing more easily managed.

So why use blocks?
A landscape plan made by copying the block to create the plan is much smaller in file size and will zoom and pan more quickly than 
one made by copying entities If, as is commonly needed, you need to move a symbol, it is much easier to select a block than pick all the 
entities that make up a symbol. That is especially the case when symbols overlap one another. The figure below shows a typical symbol 
for a plant species. The top symbol is composed of several elements such as polylines, but these have been combined into a single named 
entity - a block. The lower symbol looks identical, but it is made up of individual entities. Blocks have names and if tagged and used to 
indicate specific species, help bring landscape CAD drafting alive. This aspect is dealt fully in chapter 9 of this guide.

A block is a single 
entity. Copying a block 
is much more efficient 
than copying a group of 
entities
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