Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Rahul Gera

Pages: 1 2 3 [4] 5 6
46
SAP Message Server configuration using Liquid UI Server:

Sample SAPgui Connection:



Sample SAPPROXY.INI:

[control]
proxycount=1

[Proxy1]
ListenPort=3210                                                             // (Liquid UI Client Instance/Port Number)
TargetServer=/M/<MessageServer-STRING>/S/32<SAP Server Service Port Number>/G/<SAP Server Group>    // (SAP Server Host Name or IP Address)
GuiXT=10


M    ->   Stands for Message Server      Eg: Juneau   ->   Message Server Name
S    ->   Stands for Service Port Number
G    ->   Stands for Group Name         Eg: DESIGNER   ->   Name of the Group

Note: Service Port Number is found in "services" file at below path on Machine Configured with Message Server
        C:\Windows\System32\drivers\etc

Sample SAPgui Connection after Liquid UI Server configuration:



47
SAP Application Server configuration using Liquid UI Server:

Sample SAPgui Connection:



Sample SAPPROXY.INI:

[control]
proxycount=1

[Proxy1]
ListenPort=3210                                                             // (Liquid UI Client Instance/Port Number)
TargetServer=<APPLICATION-SERVER-IP>                     // (SAP Server Host Name or IP Address)
TargetServerPort=32<SAP Server Instance Number>      // (SAP Server Port)
GuiXT=10

Sample SAPgui Connection after Liquid UI Server configuration:



48
Purpose: To Enable Screen Modifications on a pop up screen, when executing in a function.

syntax: enable("executescreenscript");
 
Liquid UI Script:
**********************************************************************
////////////////////////////////// SAPLSMTR_NAVIGATION.E0100 /////////////////////////////////////
**********************************************************************



      onUIEvents['/3']={"fcode":"?","process":backtoHome};
      onUIEvents['/15']={"fcode":"?","process":backtoHome};


**********************************************************************
////////////////////////////////// Input Script (or) Function ///////////////////////////////////////////
**********************************************************************


function backtoHome(){
   
   //Display Equipment : General Data
   onscreen 'SAPLSMTR_NAVIGATION.0100'
   clearscreen();
   enter('/o'); //Overview of Sessions Popup

   onscreen 'RSM04000_ALV_NEW.2000'
   enable("executescreenscript");
   
}


**********************************************************************
////////////////////////////////// RSM04000_ALV_NEW.E2000 /////////////////////////////////////
**********************************************************************

   
   clearscreen();
   title("Exit Transaction?");
   text('P[Cancel]','@02@No');
   text('P[Continue]','@01@Yes');
   text([1,2],"@1A@Changes made would not be saved");
   text([2,6],"Do you want to exit?");
   windowsize([3,3,55,8]);

49
Purpose: Increase or Decrease or Change SAP Screen Font Size in Liquid UI for iOS.

Steps to follow to perform the desired on Liquid UI iOS App:

Step 01: Login to any SAP server or Demo Server.
Step 02: Tap on the right bottom corner of the Liquid UI screen on the iOS device, on SAP Server name.
Step 03: A menu pop's up, which has Font Selection.
Step 04: Tap on Font Selection item, which opens a window.
Step 05: Select the desired Font from the list, and Tap OK.
Step 06: The pop up window closes and the Font on the Screen changes.

See the attached for screenshots

50
Purpose: To clear the Transaction and Input Field Entry from Liquid UI iOS App cache.

Steps to Clear the Transaction Entry Cache:

Step 01: Start Liquid UI for iOS App on the iOS device.
Step 02: Connect to any SAP Server from the connection list.
Step 03: Tap on the Transaction Entry field, and input a character.
              Eg: "/".
Step 04: A list of entries show up on the screen. (Refer to Image 1 Below)
Step 05: Tap and Swipe left on any desired entry. (Refer to Image 2 Below)
Step 06: There will be an option to delete the entry.
Step 07: Tap on "Delete", and the entry is deleted from the cache.

Check the below screenshots
Image 1                                                                               Image 2
   


Steps to Clear the InputField Entry Cache:

Step 01: Start Liquid UI for iOS App on the iOS device.
Step 02: Connect to any SAP Server from the connection list.
Step 03: Navigate to desired Transaction.
Step 04: Tap on the InputField, and perform a space or backspace.
Step 05: A list of entries show up on the screen. (Refer to Image 3 Below)
Step 06: Tap and Swipe left on any desired entry. (Refer to Image 4 Below)
Step 07: There will be an option to delete the entry.
Step 08: Tap on "Delete", and the entry is deleted from the cache.


Check the below screenshots
Image 3                                                                               Image 4
   

51
SAP Table Scroll

Usage: This example is to create the logic to scroll SAP table to read and write data from the SAP table in VA01 transaction.

Liquid UI Script:
pushbutton([TOOLBAR],'TableScroll','?',{'process':tableScroll});

function tableScroll() {
   onscreen 'SAPMV45A.4001'
      // Table Scroll begins here   
      absrow = 1;
      relrow = 1;

      // Fetch the table attributes
      gettableattribute("T[All items]", {"firstvisiblerow":"FVisRow", "lastvisiblerow":"LVisRow", "lastrow":"LastRow"});

      if(FVisRow==1) {
       goto new_row;
      }
      // Scroll to the absolute row
      enter("/ScrollToLine=&V[absrow]", {"table":"T[All items]"});
         
   new_screen:;
    onscreen 'SAPMV45A.4001'
         // Refetch table attributes, in case they might of changed
        gettableattribute("T[All items]", {"firstvisiblerow":"FVisRow", "lastvisiblerow":"LVisRow", "lastrow":"LastRow"});
        // Reset the relevant row
        relrow = 1; // reset the relative row with a new screen
      new_row:;
      if(absrow>LVisRow){
         // end of visible table screen?
         enter("/ScrollToLine=&V[absrow]", {"table":"T[All items]"});
         goto new_screen;
      }
      if(absrow>LastRow){
         // end of the table?
         goto end_of_table;
      }
        set("V[z_va01_mat]","&cell[All items,Material,&V[relrow]]");
      println('0000000000000000000000000000000000 z_va01_mat:'+z_va01_mat+':');
      if(z_va01_mat == 'L-60F') {
         set('cell[All items,Order Quantity,&V[relrow]]','506');
      }
         
      // Increment out counters
      absrow++;
      relrow++;
      goto new_row;

      end_of_table:;
      // Scroll back to the top of the table
      enter("/ScrollToLine=1", {"table":"T[All items]"});
}

52
Purpose:
To identify the message number, message type, and message id of the SAP server message.

The system variables "_msgno", "_msgtype" and "_msgid" can be used to find the details of the SAP message, and further to condition Liquid UI scripts.

For the below example, displayed in VA01 transaction.

Liquid UI Code:
---------------------------------------------------------------------------------
Script File Name: SAPMV45A.E4001.sjs
---------------------------------------------------------------------------------


onUIEvents["Enter"]= {'fcode':"/0",'process':z_message};

function z_message()  {
enter();
onerror
   if(_message){
      println("Message: "+_message);
      println("Message Type: "+_msgtype);
      println("Message Number: "+_msgno);
      println("Message ID: "+_msgid);
     }      
  }

53
Developer Toolkit (Designer and Workbench) / Designer SY1 Files collection
« on: September 08, 2017, 04:26:03 PM »
Purpose: To collect SY1 files, from user's machine using Liquid UI Designer.

Scenario: When Liquid UI Engineers need to debug an issue with elements and Fields on SAPgui screens.

http://updates.guixt.com/secured/LUIDesignerSetup.exe

Steps to collect Designer SY1 files:
Step 1: Provide the credentials and download Liquid UI Designer Set up executable file.
Step 2: Install the Set Up file, with administrative privileges.
            Right Click on Set up executable and select "Run as Administrator".
Step 3: After the install, please specify a directory1 path in GuiXT.SJS file.
            Location of GuiXT.SJS file
            C:\Program Files\SAP\FrontEnd\SAPgui              --> 32 Bit Machine
            C:\Program Files (x86)\SAP\FrontEnd\SAPgui     --> 64 Bit Machine
Step 4: Open SAPGui, navigate to desired T-Code.
            Make sure that "Activate GuiXT" is checked on SAPGui.
Step 5: Navigate to Liquid UI Designer Installed folder.
Step 6: Execute Designer.exe file with administrative privileges (for the first time).
            Right Click on Set up executable and select "Run as Administrator".
Step 7: Files with extensions .SY1 with ProgramName (DOT) Dynpro Number are generated.
.
.
.
.

See the attachment for screenshots

54
Purpose: To create a connection on Liquid UI Client (iOS/Android) using Liquid UI License Management Portal.

Pre-Requisites:
1. LMP Account Administrator account creation for the Company.

Steps to Create a SAP connection on LMP
Step  1:  Login to the LMP Administrator Account corresponding to Company.
Step  2:  On Dashboard, Click on the Company/Account, that was assigned to the Admin Account.
Step  3:  In the Account Administration, Click and Select "SAP Connections".
Step  4:  On the pop up, select "Create Connection".
Step  5:  On "Add Connections" pop up, SAP Connection information can be populated in the fields.
Step  6:  After the corresponding fields are populated, Click on "Add Connection".
Step  7:  Pop up can be closed and go back to "SAP Connections"pop up box
Step  8:  The newly created SAP connection entry will be displayed.
Step  9:  Select the "Check Box", that is corresponding to the connection, and Click "Update Connection List".
Step 10: Adding Users to the Company/Account, will generate the License with the SAP connection
Step 11: And an email will be sent out from LMP to the user's email address that was created (Step 10).
Step 12: On the Liquid UI Client, once the license is applied, the SAP Connection also appears.

55
Pre-requisites:
The Liquid UI App license should be applied.

Sample SAPgui Connection:




Sample LIQUID Connections:

iOS Connection:



Android Connection:

56
Purpose:
Configuration of Liquid UI web Server to Connect to SAP R/3 Server.

Sample SAPgui Connection:



In Config.JS file the below line need to added/modified, to connect to SAP Server

const R3_SERVER_NAME   = "/H/<APPLICATION-SERVER/IP>/S/32<Instance-PORT>"

const DEF_WEBPORT_BASE   = g_arArgs['_PORT']!=void 0?g_arArgs['_PORT']:"88";      // portnumber

In browser address, use the following url,
http://<serverhostname/IPAddress>:<portnumber>/GuiXT4Web/logon.gsp#

57
Purpose: To use Windows Mobile Left Screen button as Liquid UI Mobile Function keys.

Liquid UI Mobile Profile Setting:
1. On the First Screen of Logon, Click on "NEW".
2. Click on "Profile Management.."
3. On the next screen click on "New..." or select the Profile (if any exists) and click "Edit...".
4. On the "Profile / Logon Setting" Screen.
5. Goto "Misc." and set "Enable soft keys" checkbox and select "Left key acts as" to be "F4" from dropdown.
6. Click "OK", if there is no other setting change.
.
.
.
.
See attached document for step by step screenshots

58
Purpose: To Land on a Desired Transaction on Liquid UI Mobile, after initial Login.

Liquid UI Mobile Profile Setting:
1. On the First Screen of Logon, Click on "NEW".
2. Click on "Profile Management.."
3. On the next screen click on "New..." or select the Profile (if any exists) and click "Edit...".
4. On the "Profile / Logon Setting" Screen.
5. Set "Start Transaction Code" to the Desired Transaction Code.
    Eg: VA01, MM01, LM01, VA21...etc..,
6. Click "OK", if there is no other setting change.
.
.
.
.
See attached document for step by step screenshots

59
Purpose: To change Liquid UI iOS table control to Dynamic Table Control.

Perquisites:
1.   Installation of Liquid UI app on the iOS device.
2.   Connection to SAP R/3 Server configured on Liquid UI iOS app.

Steps to change Liquid UI iOS table control to Dynamic Table Control:
Step 1: Navigate to Settings on iOS device.
Step 2: Scroll to "GuiXT Liquid UI" settings.
Step 3: There will be "Dynamic Table Control" entry in Settings.
Step 4: Tap the "switch" to turn ON Dynamic Table Control setting.
Step 5: Navigate to the Table of your requirement.
Step 6: Table Control is changed and the scrolling is smooth.

.
.
.
see the attached for screenshots.
Below screenshots give an example of table control in VA01/VA02 transaction codes.

60
Purpose:
To identify the cursor position [row,column] if the user has placed the cursor in a table cell.
The system variables "_tabrow" and "_tabcol" can be used to find the cursor position for the row and column, and further to read data from or write data to that position.

For the below example, table displayed in VA01/VA02 transaction.
The cursor position can be identified, when cursor is placed in one of the table cells:

Liquid UI Code:
---------------------------------------------------------------------------------
Script File Name: SAPMV45A.E4001.sjs
---------------------------------------------------------------------------------

pushbutton([TOOLBAR],'Find Position',{'process':readCursorPosition});

function readCursorPosition(){
        // Put cursor in the table cell, to find out its position
        set('V[z_rowcol]','['+_tabrow+','+_tabcol+']');
        println('Value:' + z_rowcol);
}

Pages: 1 2 3 [4] 5 6