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Practice Workbook 

 

        NCDOT Civil Geometry 

 
 
 
 
About this Practice Workbook... 
◼ This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to quickly jump to any section in the file. 

You may have to turn on the bookmark function in your PDF viewer, such as Adobe Reader. 

◼ The dataset used throughout this Getting Started guide uses English units.. 

◼ This training uses the NCDOT_Roadway WorkSpace and the Civil Geometry WorkSet installed. It is very important that you select the 

correct WorkSpace and WorkSet when working the exercises in this course. 

◼ The OpenRoads Modeling Workflow is used throughout this course. 

◼ The theme of this workbook is modeled from the Bentley Institute and some of the context contained in its Getting Started Guides.  

◼ This workbook was written with the release of OpenRoads Designer 10.03.00.43 (Update 3). 

◼ This workbook has been updated for OpenRoads Designer 10.07.00.56 (2019 Release 1) 

 

Have a Question? Need Help?  

 
If you have questions while taking this course, submit them to RoadwaySupport@ncdot.gov 
 
Oak Thammavong | NCDOT Roadway Design Unit   



Copyright © 2019 NCDOT DO NOT DISTRIBUTE – Printing for student use is permitted 3 

OPENROADS DESIGNER GEOMETRY OVERVIEW 

 
OpenRoads Designer Geometry is a dynamic, interactive and rules-based approach to geometry. Civil Geometry or geometric rule-based 
elements are created intelligently as the tools are used and elements are constructed. 
 
Rule-based elements provide Design Intent that builds associations and relationships between civil elements. Object information (how, where, 
and by what method it was created) is stored with the object to insure the original intent is retained and honored in the design. If an element is 
modified, any related elements will recreate themselves based on these stored relationships. 
 
All geometric data is stored directly in the dgn file and can be easily edited and reviewed via the drag handles, dynamic dimensions, text 
manipulators, etc. 
 
 

COURSE OVERVIEW 

 
In this course you will be creating the horizontal and vertical alignments for R-2635C (I-540 Western Wake Expressway 1997 original design). 
Using the OpenRoads Designer Geometry tools, you will learn how to create, edit, annotate and review geometric elements. You will also learn 
how to attach an existing terrain model and aerial imagery as well as define 2D and 3D views. 
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OpenRoads Designer Geometry Course Workflow 

 
 
1. Select WorkSpace & WorkSet. 
 
2. Create 2D dgn file. 
 
3. Create Horizontal Alignment 

a. Set Active Feature Definition. 

b. Create Horizontal Elements: Lines and Arcs. 

c. Complex Horizontal Elements together. 

d. Define Stationing. 

e. Table Editor 

f. Create and Review Geometry Report. 

g. Annotate Geometry (as needed). 
 
4. Attach Existing Terrain Model and Set as Active Terrain Model. 
 
5. Define 2D & 3D Views. 
 
6. Review Design File Models. 
 
7. Create Vertical Alignment 

a. Define Profile Model View. 

b. Create Vertical Elements: Lines and Curves. 

c. Complex Vertical Elements together. 

d. Edits: Civil AccuDraw vs. Table Editor 

e. Set Active Profile. 

f. Create and Review Geometry Report. 
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EXERCISE 1: SELECT THE WORKSPACE & WORKSET, CREATE A NEW DESIGN FILE AND REVIEW THE RIBBON 
INTERFACE 

In this exercise, you will learn how to select the proper workspace and workset, create a new 2D dgn file and review the ribbon interface. 

 

Skills Taught 

 
❖ Selecting a WorkSpace and WorkSet 

 
❖ Create a Master 2D Alignment dgn file 
 
❖ Reference the 3D Existing Terrain Model and Make it the Active Surface 

 
❖ Review the Ribbon Interface 

 
❖ Review File and Folder Structure for ORD WorkSet 
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Select the WorkSpace and WorkSet and Creating a New 2D Design File 

In this section, you will create a new 2D dgn file. When working with OpenRoads Designer Geometry always start in 2D. 

 

1. Start the software by double-clicking on the desktop icon. 

2. Set the WorkSpace and WorkSet 

The WorkSpace and WorkSet define standards that are used by the software. The WorkSpace and WorkSet used for this training are 
installed locally on the C:\ drive. 

a. Select NCDOT_Roadway from the WorkSpace menu. 

b. Select Civil Geometry from the WorkSet menu. 

 

 

 

 

 

3. Create a new 2D dgn file. 

a. Select New File. 

b. Browse to C:\NCDOT Training\Roadway\Civil Geometry\dgn\Alignment or other folder where you unzipped the dataset files. 

c. Set the Seed to Seed2D - English Design.dgn. 

d. Create a new file named r2635c_rdy_alg.dgn. 
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Review the Ribbon Interface 

  

1. Select the OpenRoads Modeling workflow from the pick list in the upper left corner if it is not already active. 

 
 
 
 
 
 
 
 

The ribbon menu will change to OpenRoads Modeling tools. The tools are organized 

into categories on the ribbon tabs. 
 

 
 
 

Home - Common tools such as Attributes, Explorer, Attach Reference Tools, Models, Level Display and Element Selection. 

 

Terrain - Element selection and terrain modeling tools. 

 

Geometry - Element selection, Civil AccuDraw and geometry tools. 

 

Site Layout – Parking Lot, Pad, Pathway, Grading Proposed 
 
Corridors - Element selection, superelevation and corridor modeling tools. 

 

Model Detailing - Element selection, Civil Cells and 3D tools (Linear Templates, Surface Templates, etc.).  
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Drawing Production - Element selection, saved views, notes, text, annotations, and plans production (cross section, plan, and profile) tools. 

Drawing - Commonly used MicroStation drawing tools. To the complete set of MicroStation tools change the active workflow to Drawing, 

Modeling (3D only) or Visualization (3D only). 

View - Commonly used view control tools. 

NCDOT_Roadway – Common Roadway tools (future), such as RD_DSN, View Rotate, and VBA & MDL apps. 

2. Click on each of the Ribbon tabs and notice how each tab has a different set of tools. 
Also, notice the tools to the right of the OpenRoads Modeling (Quick Access ToolBar) drop down list. Tools such as Create New File, Open 
File, Save Settings, Compress File, Undo, Redo, Print, Explorer and Properties can be found here. 
 

3. Save Settings. 
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Reference Existing 3D Terrain Model and Set as Active 

 

1. Attach r2635c_rdy_etm.dgn as a reference. 

a. Under the Home tab and Primary tools, Click on Attach Tools and select Reference. 

 

The References dialog will now appear as shown above. You use this dialog to attach reference files to dgn files. 
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   b. In the References dialog, Click on Tools and choose Attach. 
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c. The Attach Reference dialog will appear, browse to the location of r2635c_rdy_etm.dgn in the Existing folder and select it. 

 

d. Change the Attachment Method to Coincident World and then Click Open to attach the file as a reference. 
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   e. Close the Reference dialog. 

   f.  Click the Fit view icon so you can see all of the graphics in the design file. 

   g. Locate and select the existing terrain boundary (dashed black shape). 

   h. From the context menu, select Set As Active Terrain Model. 

 

 

 

   g. Note the creation of a new Default-3D model being reference to this active 2D file. 
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Review File and Folder Structure for Alignments Workset (GPK replacement) 
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EXERCISE 2: CREATING HORIZONTAL GEOMETRY 

Skills Taught 

❖ Create existing centerline from survey data using Best Fit options: 

▪ Make Complex Element 

▪ Complex by Edges 

▪ Make Single Element 

 
❖ Define the start stationing of the horizontal alignment 

 
❖ Create horizontal geometry report 

 

❖ Review the geometric elements with OpenRoads Model Explorer 
 

❖ Create horizontal geometric elements using the Place Line Between Points and Simple Arc tools 

 
❖ Combine geometric elements into a complex element to create the horizontal alignment 

 

❖ Create proposed centerline using Complex by PI, Auto Annotate, and AASHTO Design Standards 

 

❖ Annotate horizontal alignments 

 
❖ Create non-centerline civil geometry features, such as the edge of travel, paved shoulder, and curb & gutter 

 

❖ Stations, Offsets. Tapers, Transitions, and Civil AccuDraw 

 

❖ Station, Offset, and Direction with Analyze Point tool. 

 

❖ Create simple and 3-center curves to AASHTO specifications  

 

❖ Use Civil Cells from basic drafting to complex interchange design alignments 

 

❖ Use “Civil” Labels 
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Best Fit – Make Complex Element 

 
In this section, you will create a best fit existing centerline of the road using survey data. The imported survey data is a series of points of the 

existing centerline joined together as a single line string element. The line string can be 3D or 2D. The Make Complex Element option will 

automatically generate a best fit existing centerline based on the parameters provided. 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg_y11 - Exist1 Bestfit by Complex.dgn in the Alignment folder.  

 

2. Zoom in the area of Jenks Road (Y11). The existing centerline line string (yellow dotted line) is on Old_Level_51. 
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3. Set a Feature Definition to be used with your geometric elements. 

 
Feature Definitions are used to control symbology, annotation, and various other properties that are applied to the geometric elements. The 

feature definitions are used to: 
 

❖ Define what the geometric elements are. What is being modeled such as curb, centerline, edge of pavement, etc. 

❖ Control symbology in various views, including capability to define differing symbology in plan, profile, and 3D spaces 

❖ Define terrain modeling attributes (spot, break line, void, etc.) 

❖ Define surface display characteristics 

Feature Definitions are defined and stored in a dgn library (.dgnlib) delivered with the WorkSpace. 

a. Open the Feature Definition Toggle Bar tool by going to Geometry > General Tools > Standards > Feature Definition Toolbar. 
 

 

 

 

Use Active Feature Definition the feature definition selected in the toggle bar is active. Otherwise select the active feature 

definition with the civil geometry command dialog box.  

Match Feature Definition graphically select the element to match its feature definition and populate the toggle bar. 

Create 3D Automatically create the best fit profile or quick profile transition if the existing terrain is present and active. 

Use Feature Definition Template use corridor modeling template assigned with the alignment feature definition. 

Auto Annotate automatically annotate horizontal alignment during the creation. 

Chain Commands connect each PI in a chain or draw each tangent at a time. 

Persist Snaps persist snap rules into geometry elements during creation (default on). 

Rule Deactivation do not apply civil geometry rules during creation. 
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b. Turn on Use Active Feature Definition 

 

c. Set the active feature to Alignment\Exist\ALG_Centerline-Exist by clicking on the down 

arrow. 

 

4. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Define by Best 
Fit. 

 

5. When the Create Best Fit Horizontal toolbox appears set it as follows: 
 

▪ Best Fit: Make Complex Element  

▪ Envelope: 1  

▪ Radius Rounding: 5 

▪ Include Spirals: Disable  

▪ Force Symmetrical Spirals: Disable 

▪ Spiral Length Rounding: Disable 

▪ Default Radius: 800 

▪ Feature Definition: Use Active Feature 

▪ Name: EY11 

 

 
 
 
 
 
 
 
 

6. Data point to accept the heads-up display prompt Make Complex Element. 
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7. When prompted to Locate Linear Object click on the line string on the left side of screen to start stationing the existing centerline from west 

to east. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

a. Data point to accept Best Fit Parameters: Envelope 1.0000. 

b. Data point to accept Best Fit Parameters: Radius Rounding 5.0000. 

c. Data point to accept Best Fit Parameters: Include Spirals No. 

d. Data point to accept Best Fit Parameters: Default Radius 800.0000. 
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Note the width of the envelope defines the space needed to fit the alignment through. The wider the width, the lesser the number of curves that 
will be required.   

 

 

 

 

 

 

 

 

 

 

8. Graphically select the best fit alignment and with the context menu, select Properties to review the parameters used to generate it. You can 

change the parameters in this dialog box after the best fit alignment has been placed. Change the Envelope width from 1.0 to 0.5. 
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9. Currently the horizontal best fit alignment does not have any rules associated with it. To complete the procedure, the last step is to Convert 
to Horizontal Rule from the context menu.   

 

 

 

 

10. The horizontal alignment has a civil geometry rule which is both editable and dynamic. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note that if you have chosen the wrong feature definition, you do not have to delete and re-create the new chain. Simply use the Set Feature 

Definition command or change it in the Properties dialog box.   
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11. By default, the beginning of the alignment is station 0+00.00. To define the start station of the horizontal alignment, go to Geometry > 
Horizontal > Modify > Start Station. 

 

 

 

 

 

 

 

 

 

 

a. When prompted to Locate Element, select the best fit horizontal alignment.  

b. When prompted for the Start Distance, you can either key in 0.00 (beginning location of the stored horizontal alignment) or graphically 

move to any point along the alignment. Data point to accept this distance from the beginning of the alignment. 

c. When prompted for the Start Station, enter 10+00. Data point to accept this starting station. 

Note that the starting station 10+00.00 can be anywhere along the horizontal alignment. It does not have to be at the beginning of the 

alignment. 
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12. To create a horizontal geometry report, from the context menu select Horizontal Geometry Report. 

 

 

 

 

 

 

 

 

 

 

 

 

Note that the Precision and Format of the reported values can be set by 

going to the report menu Tools > Format Options. 
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13. The horizontal alignment can also be viewed and inspected in the OpenRoads Model window. Go to Home > Primary > Explorer > 
OpenRoads Model (tab).  

a. Each alignment can be easily be located by the Zoom function. 

 

 

 

 

 

 

 

 

 

b. Isolate and Clear Isolate can turn everything on or off, highlighting just the selected alignment. 
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Best Fit – Complex By Edges 

 

In this section, you will create a best fit existing centerline of the road using the left and right existing edge of pavement. The Complex by Edge 

option will automatically generate a best fit existing centerline based on the parameters provided. 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg_y11 – Exist2 Bestfit by Edges.dgn in the Alignment folder.  

2. Zoom in the area of Jenks Road (Y11). The existing edge of pavement line strings (yellow dash line) are on Old_Level_3. 

3. Set a Feature Definition to be used with your geometric elements. 

 

a. Open the Feature Definition Toggle Bar tool by going to Geometry > General Tools > 
Standards > Feature Definition Toolbar. 

b. Turn on Use Active Feature Definition 

c. Set the active feature to Alignment\Exist\ALG_Centerline-Exist by clicking on the down 

arrow. 

4. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Define by Best Fit. 

 

5. When the Create Best Fit Horizontal toolbox appears  
    set it as follows: 
 

▪ Best Fit: Complex By Edges  

▪ Envelope: 1  

▪ Radius Rounding: 5 

▪ Include Spirals: Disable  

▪ Force Symmetrical Spirals: Disable 

▪ Spiral Length Rounding: Disable 

▪ Default Radius: 800 

▪ Feature Definition: Use Active Feature 

▪ Name: EY11  
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6.  Data point to accept the heads-up display prompt Complex By Edges. 

 

7. When prompted to Locate Primary Edge Object click on the left yellow dash line string on Old_Level_3 which represent the             left 

existing edge of pavement.  

 

8. When prompted to Locate Secondary Edge Object click on the right yellow dash line string on Old_Level_3 which represent the right 

existing edge of pavement.  

 

a. Data point to accept Best Fit Parameters: Envelope 1.0000. 

b. Data point to accept Best Fit Parameters: Radius Rounding 5.0000. 

c. Data point to accept Best Fit Parameters: Include Spirals No. 

d. Data point to accept Best Fit Parameters: Default Radius 800.0000. 

9. From the context menu, select Properties to review the parameters used to generate it. You can change the parameters in this dialog box 

after the best fit alignment has been placed. 
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10. Convert to Horizontal Rule from the context menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11. Save Settings. 
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Best Fit – Make Single Element 

 
In this section, you will create a best fit existing centerline of the road using survey data. The imported survey data is a series of points of the 

existing centerline joined together as a single line string element. The line string can be 3D or 2D. the line string has been broken into groups 

separating the anticipated tangent sections from the “curve” visually. The Make Single Element option will then automatically generate a single 

best fit tangent section at a time. Once all of the tangent sections for the alignments are stored, the place Simple Arc  command can be used to 

fit an arc between two tangents. 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg_y11 – Exist3 Bestfit by Single.dgn in the Alignment folder. 

 

2. Zoom in the area of Jenks Road (Y11). The existing centerline line string (yellow dotted line) is on Old_Level_51. Note the breaks in the 

centerline line string where the anticipate separation of the curve and tangent sections. 
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3. Turn on Use Active Feature Definition and set the active feature to Alignment\Exist\ALG_Centerline-Exist. 

 

 

 

 

4. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Define by Best Fit. 

 

5. When the Create Best Fit Horizontal toolbox appears set it as follows: 
 

▪ Best Fit: Make Single Element  

▪ Feature Definition: Use Active Feature  

▪ Name: EY11_TAN1 

 

6. Data point to accept the best fit option Make Single Element. 
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7. When prompted to Locate Linear Object click on the line string on the left side of screen as the first tangent section. 
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8. Select the line string on the right side of the screen as the second tangent section. Name this 

feature definition EY11_TAN2. 

 

9. After the two tangents are in place, create a horizontal curve between tangent lines using the 

Simple Arc tool. 

 

a. From the ribbon menu select Geometry > Arcs > Arc Between Elements > Simple Arc. 

b. Name the curve EY11_CUR1. 

c. Following the heads up prompts, locate and select first tangent element (EY11_TAN1) 

d. Locate and select second tangent element (EY11_TAN2). 

e. Define the arc Radius by snapping to the line string near the center of the curve.  

f. Set the Trim/Extend option to Both and Left-click to trim or extend both tangent elements. 
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Use Complex By Elements tool to create the existing horizontal alignment for Jenks Road (Y11). 

a. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Complex By Element. 

b. When the Complex By Element toolbox appears set it as follows: 

a. Method: Automatic 

b. Maximum Gap: 0.10 

c. Name: EY11 

c. Following the heads up prompt, locate and select first tangent element (EY11_TAN1). Be sure to select the element near the beginning 

of the tangent section. Left-click to accept and the alignment will be created. 
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Proposed Alignment - Horizontal Geometry for Jenks Road (-Y11-) 

 
In this section, you will be creating the proposed horizontal alignment for Jenks Road. You will first define the tangents between PI points and 

then add the horizontal curve. 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg_y11.dgn in the Alignment folder. 

 

2. Zoom in the area of Jenks Road (Y11).  

 

3. Turn on Use Active Feature Definition and set the active feature to Alignment\Component\ALG Component Tangent. 

 

 

 

4. Prior to creating geometry, review the Civil Formatting options 

for the design file. Civil Formatting is used to control the 

formatting and precision of OpenRoads Designer design file 

settings. Coordinate format and precision, as well as Station 

format and precision, can be adjusted here.  

 

Select File > Settings > File > Design File Settings > Civil 

Formatting. 
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5. Create the tangent lines between known PI points. Use the PI point numbers as a guide. From the ribbon menu select Geometry > 

Horizontal > Lines > Line Between Points. 

6. When the Line Between Points toolbox appears set it as follows: 
 

▪ Distance: Disable 

▪ Line Direction: Disable  

▪ Feature Definition: Used Active Feature 

▪ Name: Y11_TAN1 

 

7. Snap to the center of circle near PI 1 and Left click to accept. 
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8. Snap to the center of circle near PI 2 and Left click to accept. 

The heads up prompt changes and gives you the option to key in the distance and/or direction as needed. Pressing the Right arrow or Left 

arrow on your keyboard will toggle between Distance and Line Direction input fields. You can manually enter a distance and direction, then 

Enter to lock in the values. The PI points will determine the distance and direction in this exercise. 
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A Note About Snaps and Design Intent: 

When you snap to elements OpenRoads Designer remembers how you snapped to elements and what type of snap was used. Thus, a 

relationship exists between the elements. This is an example of Design Intent. 

Design Intent builds associations and relationships between civil elements. Object information (how, where, and by what method it was 

created) is stored with the object to insure the original intent is retained and honored in the design. This is a very important concept to 

remember as you work with OpenRoads Designer Geometry. 

Persist Snaps is turned on by default. If you do not want the Design Intent to persist with the snaps, then it can be turned off here.  

 

 

 

 

9. Select the Element Selection tool. The Element Selection tool is used to select elements so 

they can be edited or manipulated with other commands. 

 

10. Set the Element Selection tool to the individual mode by selecting the Individual and New 

icons in the Element Selection tool setting window. 

a. Select the line you just created. 

Recall, geometric elements are rule-based elements that provide Design Intent. Notice the line has a distance and direction associated with it. 
The distance and direction represent the rules associated to the element. 
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Also, note the Drag Handles as well as the Text Manipulators (direction/distance) attached to the line. These provide the ability to quickly 

modify the line. If you need to modify the distance and/or direction you can simply click on distance/direction Text Manipulators and key in new 

values in the edit fields. You can use the Drag Handles to trim/extend, rotate or move the line. 

General Description of Text Manipulators, Edit Fields, and Drag Handles. 

 

 

 

 

 

b. Hover your cursor over the beginning point of the line, the Drag Handle arrows will appear as well as the center point snap indicator.  

 

 

 

 

 

 

The Drag Handle arrows give you the ability to dynamically adjust the end point of the line. By selecting the Drag Handle arrows, you can 

extend or trim the line and also change the location of the end point. 

The center snap indicator shows that the beginning point of the line was placed by snapping to the center of the circle. This is an example 

of Design Intent. A relationship exists between the beginning point of the line and the circle. Be aware, if the circle is moved the line will 

move. If the circle is deleted the relationship will be removed but the line will remain. This is an important concept to understand with 

regards to snaps. 
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Manipulator settings (size, font, color, and transparency) are controlled through the user preferences. 

File > Settings > User > Preferences > View Options - Civil. 
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c. Next, Hover your cursor over the line for a few seconds. A Context Sensitive Menu will appear giving you access to other tools related 

to the element. Context Menus appear if you hover your cursor over OpenRoads Designer elements or objects. 

 

 

d. Select the Properties tool and review the properties of the line.  

Note that the line can be edited within the Properties dialog. Depending on how it was 

created, rules applied or if it is in a reference file, the Length, Direction, Start Point, End 

Point, Feature Name and Feature Definition can all be modified within this dialog if 

needed. Editable fields are in bold dark text while non-editable fields are grayed-out. 

e. Left-click anywhere in the view to de-select the line. 

11. Continue placing tangent line. 

a. Name Y11_TAN2. 

b. Snap to the end point of the first tangent line to place the start point of the second 

tangent line. 

c. Left-click to accept 

d. Left-click near the center of the circle at PI 3 to complete placing the tangent line between PI 2 and PI 3. 

e. Right-click to complete.  

 

Chain Commands tool on the Feature Definition Toggle Bar - When the Chain Commands tool is enabled, the next element is automatically 
connected to the previous element (chain) without having to select the start point each time.  
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12. Create horizontal curves between tangent lines using the Simple Arc tool.  

a. Set the active feature to Alignment\Component\ALG Component Curve. 

b. From the ribbon menu select Geometry > Horizontal > Arcs > Arc Between Elements > Simple Arc. 

c. Name Y11_CUR. 

d. Following the heads up prompts, locate and select first tangent element (line between PI 1 and PI 2). 

e. Locate and select second tangent element (line between PI 2 and PI 3). 

f. Define the arc Radius as 2000, press Enter to lock the value and Left-click to accept. 

g. Set the Trim/Extend option to Both and Left-click to trim both tangent elements. 

NOTE: In lieu of using the heads up prompts, you can also key in values in the dialog box but you still need 

to Left-click to accept the values entered. Only the feature definition and name is not editable from the heads up prompts for this tool. 
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Loop (Arc) option is referring to a smaller minor arc (default) or the bigger major arc (loop). Also be aware of the quadrant the arc is being 

placed base on the cursor location during placement. 
 
If the radius is changed, then the curve will update with the new radius and the tangent lines adjust automatically to maintain their relationship 
with the curve. This is another example of Design Intent and the rules and relationships that exist between civil geometry elements. 
OpenRoads Designer remembers that the original curve was placed between the two tangents and when the radius value changed the 
geometry adjusted itself to maintain the geometric relationship. 
 

13. Use Complex By Element tool to create horizontal alignment for Jenks Road (Y11). 

 

a. Set the active feature to Alignment\Prop\ALG_Centerline Minor Roadway. 

b. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Complex By Element. 

c. When the Complex by Element toolbox appears set it as follows: 

▪ Method: Automatic 

▪ Maximum Gap: 0.10 

▪ Name: Y11 

14. Following the heads up prompt, locate and select first tangent element (line between PI 1 and PI 2). Be sure to select the element near the 

beginning of the alignment and indicated by direction of the arrow. Left-click to accept and the alignment will be created. 
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15. By default, the beginning of the alignment is station 0+00.00. To define the start station of the horizontal alignment, go to Geometry > 
Horizontal > Modify > Start Station. 

 

 

 

 

 

 

 

 

 

 

a. When prompted to Locate Element, select the Y11 alignment.  

 

b. When prompted for the Start Distance, enter 0.00  
 

c. When prompted for the Start Station, enter 10+00.  

 

d. Data point to accept this starting station. 

 

16. Prior to annotating the horizontal alignment, verify the active annotation scale. From the ribbon menu select Drawing > Annotation Scales > 

Annotation Scale Lock. It should set to 1”=50’. 
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17. From the ribbon menu select Drawing Production > Annotations > Element Annotation > Annotate Element.   

18. Select the alignment and Right-click (Reset) to complete. 

The alignment is now annotated. The annotation is also dynamic and associated to the alignment. Any changes made to the alignment will 

update the annotation. 

The annotation is defined by an Annotation Group which is associated with the Feature Definition ALG_Centerline Minor Roadway. The 

text size is controlled by the Annotation Scale Lock. 
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Proposed Alignment - Horizontal Geometry for I-540 Western Wake Expressway (-L-) 

 
In this section, you will be creating the proposed horizontal alignment for I-540 (-L-) using AASHTO Design Standards. 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg_l.dgn in the Alignment folder. 

2. Zoom in the area of I-540 (-L-).  

3. Turn on Use Active Feature Definition, Auto Annotate, and set the active feature to Alignment\Prop\ALG_Centerline. 

 

 

 

Note that the Chain Commands toggle does not have to be turned on since we will be using the Complex By PI command, which automatically 

creates (complex) each tangent section as part of overall chain, not individual elements. 

4. Open the Design Standards Toolbar tool by going to Geometry > General Tools > Standards > 
Design Standards Toolbar. 

 
 
 

5. Turn on Active Design Standards and set the Design Standards from the original design criteria of 

the proposed highway.   
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DESIGN STANDARDS 

Design standards should be used throughout the design of your project. It ensures that you are meeting minimal standards, generally based on 

design speed. They can also be based on type of roadway, and other geometric or design characteristics. 

Design standards are developed for both horizontal and vertical, and are stored in DGNLibs. Design Standards can be used to maintain 

required curvature and other horizontal and vertical alignment checks when performing geometric layouts. They work at two levels: 

▪ Provide values for the element creation tools (for example, minimum radius and transition lengths in horizontal geometry, maximum 
slopes, and K values for vertical geometry). 
 

▪ Check the suitability of complex elements (for example, check for kinks in both horizontal and vertical geometry). 

Horizontal Geometry Standards 

Number of Lanes Rotated – Min. radius same for both, 2011 AASHTO Table 3-8 thru 3-12b. Checks superelevation runoff length 2011 

AASHTO Table 3-17b 

▪ 2 Lane – 1 lane rotated for dual lane undivided roadway 
▪ 4 Lane – 2 lanes rotated for divided highway 

eMax – maximum superelevation rate tables 

Design Speed (usually 5 mph more than posted speed) 

Vertical Geometry Standards – Sight distance and K values, different on crest, same on 

sag, 2011 AASHTO Table 3-34 thru 3-36 

Stopping Sight Distance (default) – sight distance required to stop for stationary object 

or vehicle moving in the same direction 

 Passing Sight Distance – sight distance required to pass a moving vehicle while 

crossing the centerline permitted to oncoming traffic. Only common to dual lane rural 

roads.  
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6. Use Complex By PI tool to create the proposed horizontal alignment for I-540 (-L-). 

a. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Complex By PI. 

b. Turn off Active Design Standards 

With the Active Design Standards on the values for the curve radius and spiral length will revert back to default state. We just need to 

turn it on initially for preliminary numbers. The Set Design Standards command can be used after the placement of the horizontal 

alignment. 

c. When the Complex By PI toolbox appears following the heads up prompt. Snap to the center of PI 1 thru PI 9. Beginning at PI 2 enter 
the radius and spiral length written next to it. Use the left and right arrow keys to access the spiral length field and change it if 
necessary.  

Hint: Snap to the center of the PI first then enter the radius and spiral lengths. The Enter key locks the values in place. Keep the 

Complex By PI dialog box open to display the current values being entered for each PI. 
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7.  Re-station the horizontal alignment to start station 305+00.00 at PI 1. Geometry > Horizontal > Modify > Start Station.  

 

 

 

 

 

 

8. Since most plan annotations will occur in the DSN or other label dgn files, we can remove the annotations from the ALG dgn file. Remove 

the annotation by going to Drawing Production > Annotations > Element Annotation > Remove Element Annotation. Select the horizontal 

and Right-click to remove the annotation. 
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Alignment Table Editor  
 

Starting with Update 3, alignment geometry can also be edited in a table format. The Table Editor is a tabular view into the ruled geometry in 

the design file. The geometry can be modified graphically or by the Table Editor simultaneously in order for the rules to be synchronized and 

maintained.  
 

This tool can be found under Geometry > Horizontal > Complex Geometry > Table Editor.  

 

In addition, by Right-clicking on the table a new PI can be inserted before or after the selected row. The selected PI row can also be deleted. 
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Collection of Project Alignments – Master ALG dgn File 

 

After all of the project alignments have been created, we need to reference them to our master ALG dgn file created at the beginning of this 

course. This file can serve as a replacement for GEOPAK GPK files, which will contain mostly project alignment information.   

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg.dgn in the Alignment folder. 

2. Attach all proposed ALG files as reference using Coincident World as the Attachment Method. 

3. Save Settings. 
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Creating DSN File 2D Geometry 

 

In this section, you will be creating some common 2D geometry based off the horizontal alignments, such as edge of travel, pave shoulders, 

curb and gutter, simple and 3-center curves at intersections. You will also be trained how to use common taper and transition tools. 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_dsn.dgn in the Design folder. 

2. Attach r2635c_rdy_alg.dgn in the Alignment folder as reference using Interactive as the Attachment Method. 

3. Turn on Live Nesting and set Nesting Depth of 1.  
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4. Inspect the referenced file containing all of the project alignments. 

 

 

5. Set As Active Terrain Model and turn the level of the existing terrain model off (Off by Element).  

  



Copyright © 2019 NCDOT DO NOT DISTRIBUTE – Printing for student use is permitted 51 

The proposed mainline -L- (I-540) has these default widths (‘) typical section. 

▪ Median Width: 78 

▪ Inside Shoulder Width: 12 

▪ Outside Shoulder Width: 12 

▪ Pavement Width: 36 (3 lanes each side) 

 
6. Create the paved shoulder and edge of travel (EOT) geometry based off the horizontal alignment -L-. 

a. In the Feature Definition Toggle Bar turn on Use Active Feature Definition and select the feature definition Linear > Pavement > 

Road_Paved Shoulder Inside. This should appear blue in color onscreen. 

 

 

 

 

b. Go to Geometry > Horizontal > Offsets and Tapers > Single Offset Entire Element. 
 

 
 
 
 
 
 
 
 
 
 
 

d. When the Single Offset Entire Element toolbox appears set the following:  

▪ Offset: 27 

▪ Use Spiral Transitions: Enable 
▪ Mirror: Enable 
▪ Remove Offset Rule: Disable 
▪ Feature Definition: Use Active Feature 
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Use Spiral Transitions – The copied spiral element results as a spiral (clothoid) element if turned on. If turned off, then the copied 

spiral element results in a series of short lines. 
 

e. When prompted to Locate Element, select the horizontal alignment -L- 

 

▪ Note the default Locate Element option is to select the entire 

horizontal alignment (complex). 
 
 
 
 
 

 
▪ If you want to select an individual element (spiral, curve, or tangent) 

and not the entire alignment, press Alt on the keyboard to be 

presented with this option. 
   
 
 
 
 
 
 
 

f. Left click to accept the 27’ offset. Note that the offset is automatically adjusted to a negative or positive value depending on the cursor 

relative to the selected horizontal alignment (arrow). 
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g. Left click to accept the Mirror option Yes. 

h. Change the active feature definition to Linear > Pavement > Road_Edge of Travel Inside. This should appear gray in color onscreen. 

 

 

 

 

i. Set the following in the Single Offset Entire Element toolbox:  

▪ Offset: 39  

▪ Use Spiral Transitions: Enable 
▪ Mirror: Enable  
▪ Remove Offset Rule: Disable 
▪ Feature Definition: Use Active Feature 

 

j. When prompted to Locate Element, select the horizontal alignment -L 

k. Left click to accept the 39’ offset. 

l. Left click to accept the Mirror option Yes. 
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Note that we do not have to always use the centerline as the geometry to offset. Once a geometry element (with rules) have been 

created from the offset command, you can use that element to create another offsetting element, without the Mirror option. 

m. Change the active feature definition to Linear > Pavement > Road_Edge of Travel Outside. This should appear gray in color onscreen. 

 

 

 

 

n. Set the following in the Single Offset Entire Element toolbox:  

▪ Offset: 36 

▪ Use Spiral Transitions: Enable 
▪ Mirror: Disable 
▪ Remove Offset Rule: Disable 
▪ Feature Definition: Use Active Feature 

 

o. When prompted to Locate Element, select the inside right edge of travel. 

p. Left click to accept the 36’ offset. Make sure the cursor is to right of the EOT. 

q. Left click to accept the Mirror option No. 
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r. Repeat steps n thru p for the left outside edge of travel. This time male sure the cursor is to the left of the EOT 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

s. Repeat steps l thru q for the right and left outside paved shoulders. Remember to change the feature definition to Linear > Pavement > 
Road_Paved Shoulder Outside and with an offset of 12’. 
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7. For stations, offsets, tapers, and transition we will do this in another DSN file. Click on File to gain access to the Backstage and  Browse for 

r2635c_rdy_dsn_y8 example.dgn in the Design folder. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

In the beginning of -Y8- (US 64), there is a 60’ paved shoulder taper from 10’ to 12’. There is also adding a lane taper for 200’. Two 

options are available to achieve this. The first method uses the basic tools, while the second method uses the same tools with Civil 
Accudraw. This section demonstrate that it is not necessary to learn Civil Accudraw, however it can be useful in certain situations.  
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8. 60’ paved shoulder taper, using the basic tools. 

  

a. Turn on Use Active Feature Definition and Match the feature definition for Road_Paved Shoulder Outside.  

 
 
 
 
 
 
 
 
 

b. Go to Geometry > Horizontal > Offsets and Tapers > Single Offset Partial. 
 
 
 
 
 
 
 
 
 
 
 

c. Set the following in the Single Offset Partial toolbox:  
 

▪ Offset: 10 

▪ Use Spiral Transitions: Enable 
▪ Mirror: Disable 
▪ Remove Offset Rule: Disable 
▪ Lock To Start: Enable 
▪ Lock To End: Disable 

▪ Length: 100 

▪ Feature Definition: Use Active Feature 
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d. When prompted to Locate Element, select the right 

outside paved shoulder. 
 

e. Left click to accept the 10’ offset. 

 

f. Left click to accept the Length 100. 

 

g. Left click to accept the Mirror option No. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

h. Go to Geometry > Horizontal > Offsets and Tapers > Variable Offset Taper.  
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i. Set the following in the Single Offset Partial toolbox: 

 

▪ Start Offset: 10 

▪ End Offset: 12 

▪ Mirror: Disable 
▪ Lock To Start: Disable 
▪ Lock To End: Disable 

▪ Length: 60 

▪ Feature Definition: Use Active Feature 
 

j. When prompted to Locate Element, select the right outside paved shoulder. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

k. Before accepting the second prompt to accept the Start Offset, Snap to end of the paved shoulder line previous created. 
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l. Left click to accept the Start Offset 10’. 

 

m. Left click to accept the End Offset 12’. Make sure the cursor is in front of the snap point and not the back (-60’), and toward the 

outside of the edge of travel and not the inside (-12). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

n. Left click to accept the Mirror option No. 

 

o. Use the Microstation Trim To Intersection tool under Drawing > Modify.  
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9. 200’ lane taper, using the basic tools and Civil Accudraw. 

a. Match the active feature definition for Road_Edge of Travel Outside. 

b. Go to Geometry > General Tools > Civil Toggles > Civil Accudraw. 

c. Enable Civil Accudraw Toggle (first icon) to expand the toolbox. 

d. Select the Station-Offset command. 

 

 

 

e. Depress the letter “O” (set origin) on the keyboard. Note the prompt in the lower left corner of the screen. 

 

 

 

f. Left click on the -Y8- horizontal alignment to set as the baseline origin to use. 

g. Go to Geometry > Horizontal > Offsets and Tapers > Variable Offset Taper. 

h. Set the following in the Single Offset Partial toolbox: 

▪ Start Offset: 0  

▪ End 11Offset: 12 

▪ Mirror: Disable 
▪ Lock To Start: Disable 
▪ Lock To End: Disable 

▪ Length: 200 

▪ Feature Definition: Use Active Feature 

Note: Make sure the Feature Definition is set to Use Active Feature. If it is set to No Feature 

Definition, then deactivate and reactivate the Use Active Feature Definition icon.  
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i. When prompted to Locate Element, select the right outside edge 

of travel 

  

j. Notice now you have the Civil Accudraw Station and Offset key-in 

fields displayed. You can switch the focus between the heads up 

prompt and Civil Accudraw fields by depressing the Tab key. 

 

 

 

 

 

k. As an option, by deactivating and reactivating the Civil Accudraw Toggle, the default focus can be changed to the Civil Accudraw fields 

and place it to the bottom.  
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l. Before accepting the heads up prompt Start Offset, key-in 1196.65 in the Station field and Enter to lock it. 

 

m. Left click to accept the Start Offset 0’. 

n. Left click to accept the End Offset 12’. 

o. Left click to accept the Mirror option No. 

 

 

 

 

 

 

 

 

 

p. Match the feature definition for Road_Paved Shoulder Outside 

q. Go to Geometry > Horizontal > Offsets and Tapers > Single Offset Entire Element.  

r. Set the following in the Single Offset Entire Element toolbox:  

▪ Offset: 12 

▪ Use Spiral Transitions: Enable  
▪ Mirror: Disable 
▪ Feature Definition: Use Active Feature 

 

s. Left click to accept the Offset 12’. 

t. Left click to accept the Mirror option No. 
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u. Use the Microstation Trim To Intersection tool under Drawing > Modify to trim the outside paved shoulder. 

 

 

 

 

 

 

 

v. Use the Microstation Trim To Intersection tool under Drawing > Modify to trim the outside edge of travel. 
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w. Use the Single Offset Partial tool to provide a 150’ full paved shoulder line. Ideally snapping to the end of the paved shoulder line is 

preferred. This seems to causes crashes however. Set the Offset to 24, Length of 150, and snap one of the dimension lines instead. 

 

 

 

 

 

 

 

 

 

 

x. Repeat the same steps for the outside edge of travel.  
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Civil Analysis – Analyze Point 
 

The Analyze Point Tool can be used to show the point Station, Offset, and Direction information from an alignment. It works for both the 

horizontal and vertical geometry elements. 
 

Home > Model Analysis and Reporting > Civil Analysis > Analyze Point  
 

After selecting the tool, Left-click on the horizontal alignment to show the point (cursor) location information.  
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Using Civil Cells and “Civil” Labels 

 

Civil Cells can be used to draft common 2D and 3D features such as edge of travel, paved shoulders, curb and gutter, bridges, driveway turn 

outs, curve radius returns at intersections, and much more. They can also be used to generate the horizontal alignments of an interchange. 

Some specialized Civil Cells can also be used to model a 3D gore area. “Civil” Labels can be used to label the geometry of the element which 

maintaining the original design intent. 

Create the edge of travel and curb and gutter geometry for -Y9- (Green Level Church Road) and -Y11- (Jenks Road). Both Roadways are a 2’-

6” curb and gutter section with an 18’ lane width on each side of the centerline. 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_dsn_y9y11 example.dgn in the Design folder. 

2. Using Civil Cells, create the non-centerline geometry elements for -Y9- and -Y11-. 

a. Go to Model Detailing > Civil Cells > Place Civil Cell. 

b. In the Place Civil Cell dialog box, Click on the ellipses to select Roadway_CivilCells_Geometry.dgnlib > Dual Lane Curb and Gutter.  OK.  

 
c. When prompted Locate Reference Element: 

ROAD CENTERLINE, select the horizontal 

alignement -Y9-. 
 

d. When prompted Selects Element to View 

Alternatives, Right- Click to skip. 

 

e. Left-Click to accept Civil Cell placement. 

f. Continue using the same command for -Y11-. 
 

View Alternatives is a way to reverse the direction 

(as indicated by an arrow) of the reference 
elements. It is intended to place a civil cell on the 
opposite side or direction the civil cell was 
originally created in.  
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3. Adjust for the 18’ pavement width on each side of 

the centerline for both roadways. Make sure to 
adjust the width at middle of the complex. Each 
complex geometry has a beginning, ending, and 
middle manipulators. Adjusting the values at the 
beginning or ending results in a taper, rather than a 
constant width.  
 

4. Drop the civil cell by going to Model Detailing > 
Civil Cells > Drop Civil Cell and select any part of the 

civil cell.  
 

 
 
 
 

 

5. Match the feature definition Road_Edge of Travel 
Outside. 

 

6. On the left of -Y9- at the intersection with -Y11-, create a simple curve radius return. The dimension of the simple curve comes from the 

2011 AASHTO Table 9-15, Edge of Traveled-Way Deigns for Turns at Intersections-Simple Curve Radius with Taper. 

Two inputs are required for table lookup; the angle of turn (intersection angle) and the vehicle type being evaluated.  

At a 90° angle and vehicle type SU-40 (Single Unit Truck), option is a simple curve with an 80’ 

radius or a 45’ radius curve with a 4’ offset and a 10:1 taper.  

a. Go to Geometry > Horizontal > Arcs > Arc Between Elements > Simple Arc. 

b. Set the following in the Simple Arc toolbox:  

▪ Trim/Extend: Both  

▪ Radius: 80  

▪ Loop: Disable 
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c. Select the two outside edge of travel to construct a simple arc. 

 

 

 

 

 

 

 

 

d. Let’s now try the simple curve with offset and taper options. Undo the previous operation.  

 

e. Go to Geometry > Horizontal > Arcs > Arc Between Elements > Taper Arc Taper. 

f. Set the following in the Arc Between Elements toolbox:  

▪ Trim/Extend: Both  

▪ Radius: 45  

▪ Loop: Disable 

▪ Back Taper Method: Ratio-Offset  

▪ Back Taper Offset: 4  

▪ Back Taper Ratio: 10:1  

▪ Ahead Taper Method: Ratio-Offset  

▪ Ahead Taper Offset: 4  
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▪ Ahead Taper Ratio: 10:1  

 

g. Select the two outside edge of travel to construct an arc between elements. 

 

 

 

 

 

 

h. Repeat the steps for the curb and gutter. Match the feature definition and the radius should be 43. 
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For the right side of the intersection, let’s try evaluating a WB-67 at 90°. Table 9-16 Edge-of-Traveled-Way Designs for Turns at Intersections-

Three Centered Curves recommends a 440-65-440 with a 10’ symmetrical offset.  

7. Place 3 Center Curves:  

a. Match the feature definition Road_Edge of Travel Outside. 

b. Go to Geometry > Horizontal > Arcs > Arc Between Elements > 3 Center Arc. 

c. Set the following in the 3 Center Arc toolbox:  

▪ Trim/Extend: Both  

▪ Radius: 65  

▪ Loop: Disable 

▪ Back Transition Type: Curve 

▪ Back Transition Method: Offset 

▪ Back Transition Radius: 440 

▪ Back Transition Offset: 10  

▪ Ahead Transition Type: Curve 

▪ Ahead Transition Method: Offset 

▪ Ahead Transition Radius: 440 

▪ Ahead Transition Offset: 10  
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d. Select the two outside edge of travel to construct a 3 center arc between elements.  

 

 

 

 

 

 

 

 

e. Repeat the steps for the curb and gutter. Match the feature definition and the radii should be 438-63-438. 
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8. Place Civil Cells for Drop and Radius type driveways. To place driveway civil cells, the back of the driveway with a desired width must 

first be created. In addition, graphically selecting the curb and gutter and edge of travel as reference elements, the full driveway is then 
automatically generated.  
 

a. Turn on Use Active Feature Definition 

and Set the active feature to Linear\Civil 
Cell\CC_Construction Class Driveway 
Back. 

b. Anywhere near the beginning of -Y11- on 

the right side of the road, draw the back of 

a 16’ driveway using Geometry > 
Horizontal > Single Offset Partial tool. 

Offset this line 12’ from the Edge of Travel. 

c. Go to Model Detailing > Civil Cells > Place 
Civil Cell. 
 

d. Select Roadway_CivilCells.dgnlib > 
Driveway Drop Type. 

 

e. Select the following Reference Elements in 

this order.  

1. BACK OF DRIVEWAY (1/3) 
2. ROAD CURB AND GUTTER (2/3) 
3. ROAD EDGE OF TRAVEL (3/3) 

  



Copyright © 2019 NCDOT DO NOT DISTRIBUTE – Printing for student use is permitted 74 

9. On the opposite side of the road, place a Radius type driveway.  

 

a. Turn on Use Active Feature Definition and Set the active feature to Linear\Civil Cell\CC_Construction Class Driveway Back. 

b. Anywhere near the beginning of -Y11- on the left side of the road, draw the back of a 16’ driveway using Geometry > Horizontal 
> Single Offset Partial tool. Offset this line 12’ from the Edge of Travel. 

c. Go to Model Detailing > Civil Cells > Place Civil Cell. 
 

d. Select Roadway_CivilCells.dgnlib > Driveway Radius Type. 

 

e. Select the following Reference Elements in this order.  

1. BACK OF DRIVEWAY (1/3) 
2. ROAD CURB AND GUTTER (2/3) 
3. ROAD EDGE OF TRAVEL (3/3) 

f. By default, the civil cells were created on the right side of the road. To place the same civil cell on the left side, Click on the 

arrow to reverse the direction of the reference element when prompted Select Elements to View Alternatives. Do this for both 

BACK OF DRIVEWAY and ROAD CURB AND GUTTER. 
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10. Place a Civil Cell of a Single Bridge in a DSN file: 

 

a. Draw the beginning and ending of bridge limit lines. Turn on Use Active Feature Definition and Set the active feature to 

Linear\Civil Cell\CC_Construction Class Bridge Limits.  
 

b. Go to Geometry > Horizontal > Lines > Line From Element > By Angle From Element. 
 

c. Set the following in the By Angle From Element toolbox:  

 

▪ Skew: 90  

▪ Start Distance: 100 

 

d. When prompted Locate Element, select the centerline -Y11-. 
 

e. When prompted Enter Start Point, DP near station 19+00 for the beginning of the bridge. 

 

f. Left-Click to accept the Skew of 90 and Start Distance of 100 on the right side of the road. 

 
The civil cells for bridges were designed with the limit lines drawn from the right to left side of the road. This is very important 
since most civil cells “limit lines” are drawn with this convention. It is sometime necessary to reverse the direction of the limit 

lines (View Alternatives) so that the civil cells appear to be placed correctly. 

 

g. When prompted Enter End Distance, key-in 

100 and Enter to lock the value. Left-Click to 

accept. 
 

h. Draw the end of the bridge limit line near 

station 22+00.  
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i. Go to Model Detailing > Civil Cells > Place Civil Cell. 
 

j. Select Roadway_CivilCells.dgnlib > Bridge Single. 

 

k. Select the following Reference Elements in this order.  

1. BRIDGE BEGIN LIMIT (1/5) 
2. BRIDGE END LIMIT (2/5) 
3. ROAD CENTERLINE (3/5) 
4. ROAD EDGE OF TRAVEL RIGHT (4/5) 
5. ROAD EDGE OF TRAVEL LEFT (5/5) 
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l. Adjust the bridge rail offset from the Edge of Travel; 7.5’ right and 3’ left. 

 

m. Use the bridge limit lines to move the beginning station 19+37 and ending station 22+02. Use Civil AccuDraw. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

n. Adjust the bridge beginning skew 101° and ending skew 108°. 
 

o. Trim the red curb and gutter lines at approach slabs. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Copyright © 2019 NCDOT DO NOT DISTRIBUTE – Printing for student use is permitted 78 

 
 

p. Use “Civil” Labels to annotate the bridge limits. Go to Drawing Production > Notes > Place Label. 
 

q. Select the cell _Lbl_Pln_Begin Approach Slab Preliminary in the 

Place Label Settings toolbox and set the following settings. 

  

r. When prompted to Identify Element, select the -Y11- centerline to 

define the chain name and station properties. 
 

s. When prompted to Select Point Location, Snap to the beginning of the 

approach slab. 
 

t. Place the label to the left of the approach slab.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

u. Repeat the same steps for the labels -Lbl_Pln_Begin Bridge 
Preliminary, -Lbl_Pln_End Bridge Preliminary, and _Lbl_Pln_ 
Approach Slab.    
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11. Use Civil Cells to place horizontal geometry for an interchange.  

 

a. Click on File to gain access to the Backstage and Browse for r2635c_rdy_dsn_interchange.dgn in the Design folder. 

 

b. Go to Model Detailing > Civil Cells > Place Civil Cell. 
 

c. Select Roadway_CivilCells_Interchange.dgnlib > Loop.  

 

d. Starting in Quadrant A, select the following Reference Elements in this order.  

 

1. OUTSIDE EDGE OF TRAVEL LOOP ENTRANCE (1/2)  
2. OUTSIDE EDGE OF TRAVEL LOOP EXIT (2/2) 

The convention used to select the EOT as Reference Elements is based on traffic flow, which is consistent with the stationing. In 

Quadrant A, the loop entrance is the EOT on -Y8- and the loop exit is the EOT on -CD_SB-.   
 

e. When prompted View Alternatives reverse the direction of the 

Reference Elements as needed.  

 

f. Repeat the steps for Quadrant B, C, and D. 

 

g. Lastly place a civil cell Ramp Angular Exit in Quadrant A.  

 
 
Adjustments to the geometry such as lengths, angles, radii, widths, etc. can be 

made after the civil cells are placed. Use the manipulators for both Primary and 

Construction Class elements (blue dashed thin lines).   
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EXERCISE 3: CREATING VERTICAL GEOMETRY 

In this exercise, you will learn how to create vertical geometry and alignments using the vertical civil geometry tools. 

Skills Taught 

❖ Define and review Profile Model Views 

❖ Create an existing or proposed ground profile from a terrain model surface: 

▪ Quick Profile From Surface 
▪ Profile From Surface 
▪ Set Terrain Model 

❖ Create a proposed profile from a terrain model using Best Fit Profile options: (not working in Update 3) 

▪ Make Complex Element 
▪ Make Single Element 

❖ Project Profiles: 

▪ Project Profile To Element 
▪ Project Profile Range To Element 
▪ Project Extended Profile 

❖ Profile Intersection Point 

❖ Create vertical geometric elements using the Place Line Between Points and Parabola Between Elements tools 

❖ Combine geometric elements into a Complex Element to create the Vertical Alignment 

❖ Create proposed centerline using Complex by PI, Auto Annotate, and AASHTO Design Standards (minimum K method) 

❖   Create Ditch Grades  

❖ Create Vertical Alignment Report 
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Define Profile Model View 

 
In this section, you learn to define a profile view. Prior to creating vertical geometry, you must first define a profile model 
view to display the vertical geometry. 
 

 

1. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg_y11.dgn in the Alignment folder. 

 

2. Maximize View 1 by clicking the maximize view icon in the view window. 

 
 
 
 
 

3. Click the Window Area icon in the top of the view window and zoom in the limits of -Y11-.  
 

4. Click the Element Selection tool.  

 

5. Select the horizontal alignment. Hover your cursor over the alignment until the context sensitive menu appears. 

 
 
 

 

6. Select the Open Profile Model icon, the heads up display will prompt you to select or open a view.  

 
 
 

7. Open View 4 from the views toggle menu at the bottom of the screen. Profiles can be displayed in any view. 
 

8. Click inside of the View 4 window. View 4 is now defined as the profile model view. Only 1 model view can be active at a time. 

 

9. Alternatively, you can Right-click in View 1 and hold down the right 

mouse button to access special View Control tools. Select View Control > 2 

Views Plan/Profile.  
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Review Profile Model Views Properties 

 
In this section, you learn about the properties and settings for the Profile Model Views. 

 
Profile Model Views 

 
While working with horizontal and vertical geometry, it is important to keep in mind the following fundamentals: 
 

▪ A profile must have an associated horizontal alignment. 

▪ A horizontal alignment can have one or more and profile model views opened.   

▪ A horizontal alignment has one and only one profile model.  

▪ A profile model corresponds to one and only one horizontal alignment. 

▪ A profile model can (and usually does) define multiple profiles, e.g. mainline profile with multiple ditch grades. 

▪ Only one profile can be set to active at any given time. 

▪ If the profile for parallel or intersecting horizontal alignments needs to be seen in relationship to the profile, then use the project profile 
commands. 
 

▪ Profile annotation (layout) does not usually occur in the Profile View Model. It occurs in the drawing models with a defined Annotation 
Group.  
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The Profile Model View has some unique characteristics: 

 
▪ Associated horizontal alignment name is in the title bar of the view.    

▪ Elevation labels on left edge of the view. 

▪ Station labels along bottom of the view. 

▪ Coordinates are station, elevation instead of X, Y. 

▪ The background colors indicate curvature of the horizontal alignment. 

• Normal Background = Tangent 

• Cyan Background = Curve 

• Magenta Background = Spiral 

▪ Civil AccuDraw is profile aware and adjusts its function accordingly. 

▪ When using the vertical commands, the cursor gives simultaneous feedback of location both in plan and profile. 

 

The Profile Model View also has easy access to most of the Vertical Geometry Tools right from the view window.  
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Vertical Exaggeration can be adjusted either via View Attributes or Shift+Mouse Wheel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Horizontal Exaggeration can be adjusted with Ctrl+Mouse Wheel.  
 

Zoom with Mouse Wheel. 
 
 

The profile formatting and precision can be adjusted through the Design 
File Settings (backstage) > Civil Formatting. 
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Generate Profile from Terrain Model Surface 

 
In this section, you learn how to generate profiles from a terrain model surface and the horizontal alignment. Note that the terrain model can be 
existing or proposed. 
 
1. Continue in r2635c_rdy_alg_y11.dgn. 

 

2. Select the Quick Profile From Surface tool from the Profile Model View pulldown menu.  

  

Optional: Although not required, you can key-in the Feature Name of the existing ground profile, e.g. EY11. 

 

Depending if Plan View 1 or Profile View 4 is Active, the heads-up prompt will display either Locate Reference Element or Locate Reference 
Element, respectively. 

 

a. If prompted Locate Reference Element, select the horizontal alignment -Y11- in View 1. 

 

b. When prompted Locate Reference Surface, select the existing terrain model boundary (white dashed) in View 1. 

 

c. Right-Click to complete. 

 

d. In View 4, click Fit View. You should now see the existing ground profile (white/black dashed line).  

 
 
 
 
 
 
 
 
 
 

 

e. Using the Element Selection tool and Context Menu, delete the existing ground 

profile from View 4.  
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Another tool to generate a ground profile from a terrain model is the Profile From Surface tool. It is similar to the Quick Profile From Surface 
tool, but has more settings and options to give more flexibility to the tool. For example, you can create a profile for part of an element or set of 
elements by specifying the start and end distance. You also have options for horizontal and vertical offsets. These options are not available in 

the Quick Profile From Surface tool. However, some settings are adjustable in the profile element Properties. 

 

3. Go to Geometry > Vertical > Profile Creation > Profile From Surface.  

 

a. When prompted Locate First Element To Profile, Select the horizontal alignment -Y11- in View 1. 

 

b. When prompted Locate Next Element to Profile, Right-Click to complete. 

 

c. When prompted Locate Reference Surface, select the existing terrain model boundary in View 1.  

 

d. Right-Click to complete. 

 

e. When prompted Start Distance, depress ALT to lock to the beginning of the horizontal 

alignment. DP to accept. 

 

f. When prompted End Distance, depress ALT to lock to the end of the horizontal alignment. DP 

to accept. 
 

g. When prompted Point Selection, select All and DP to accept. 

 

h. When prompted Profile Adjustment, select None and DP to accept. 

 

i. When prompted Draping Option, select Triangle and DP to accept. 

 

j. When prompted Horizontal Offsets, key-in 0 (zero) and Enter to lock this value. DP to 

accept. 
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k. When prompted Vertical Offsets, key-in 0 (zero) and Enter to lock this value. DP to accept. 

 

l. Using the Element Selection tool and Context Menu, delete the existing ground profile from View 4.  

 
 
 
 
 

 

Point Selection (horizontal alignment) 

 
◼ All – the entire element is used for elevation determination 
◼ Vertices – elevations are computed only at the vertices of the element 
◼ Ends – elevations are computed only at the end points of the element 
◼ Centroid – elevation is computed only at the centroid 

 

Point Adjustment 
 

◼ None – no adjustment is performed 
◼ Minimum – of the points used in previous step, select the minimum elevation and use this value for the entire profile 
◼ Maximum – of the points used in previous step, select the maximum elevation and use this value for the entire profile 

 

Draping Option (terrain model) 

 
◼ Triangles – determine an elevation at every point where the element crosses a triangle leg 
◼ Break lines – determine an elevation only when element crosses a break line 

 

Horizontal Offset – distance from horizontal alignment 

 

Vertical Offset – distance from vertical alignment 
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The most common use for setting an Active Terrain Model is for existing ground. Among other purposes, defining an active Terrain Model 
serves to automatically draw the existing ground in the profile model and is the target for side slopes which do not otherwise specify a target 
surface. 
 
 

Using the Element Selection tool and Context Menu, select the existing terrain boundary and Set As Active Terrain Model in View 1.  

 

 
 
 
 
 
 
 
 
 

Alternatively, you can go to Terrain > Edit > Set Active.  
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Defining Vertical Geometry 

 
In this section, you will be creating the vertical alignment for Jenks Rd (-Y11-) and I-540 (-L-). The vertical alignments are 

made up of tangents and vertical curves. There are two basic methods to defining the vertical geometry; Profile Complex By Elements and 

Profile Complex By PI. 
 
1. Continue in r2635c_rdy_alg_y11.dgn. The focus should be on View 4 (profile model view). 

 

2. Prior to placing profile elements ensure the Active Feature Definition is set to Alignment > Component > ALG Component Tangent on the 

Feature Definition Toggle Bar.  
 
 
 
 
 
 
 

3. Click the Chain Commands tool on the Feature Definition Toggle Bar. Similar to horizontal geometry, when the Chain Commands tool is 

enabled the next element is automatically connected to the previous element without having to select the start point each time.  
 

4. Activate Civil AccuDraw for precision input with civil geometry. Civil AccuDraw will be used to place profile elements by station and 

elevation. 
 

5. Create tangent lines from VPI to VPI. Click the Delta-Elevation icon on the Civil AccuDraw toggle bar.  

 
 
 
 
 
 

a. Go to Geometry > Vertical > Lines > Profile Line Between Points.  
 

b. Move your cursor into View 4. Notice the heads up prompts for Station and dZ (delta-elevation). These are the Civil AccuDraw input 

fields. 
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c. In the Station field key in 1000 and press ENTER. Notice the station value is now locked. 

 
 
 
 
 
 
 

d. When the focus is in the dZ field, press the letter O on the keyboard. Then Snap to the beginning of the existing ground profile line. 

 
 
 
 
 
 
 
 
 
 
 

e. The focus should have reverted back to the Station field. Tab once to put the focus back to the dZ field. Key in 0.25 and Enter to 

lock the offset of VPI #1 to 3” above the existing pavement (resurfacing depth). 
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f. DP to accept.  

 

Without Civil AccuDraw, Profile Line Between Points (tangent) can be create using the standard Length and Slope values. You still 

have access to these fields and can use them to create the tangent by clicking on the Tab and Arrow keys to cycle through the various 

fields and between Civil AccuDraw and the normal Heads-up Prompt. However, the remaining intermediate VPIs can be created by 

Stations and Elevations using Civil AccuDraw.  

 
 
 
 
 
 
 
 
 
 
 

g. Click the Elevation icon on the Civil AccuDraw toggle bar.  

 
 
 
 
 
 

 

h. For VPI #2, in the Station field key in 1115 and press ENTER. 

 

i. In the Z field key in 368.12 and press ENTER. DP to accept.  
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j. Repeat the steps for VPI #3 (20+10, 402.48), #4 (28+50, 408.20), and #5 (31+10, 412.14). 

 

k. For the last VPI #6, tie back to existing pavement at station 34+33.16 with a 3” resurfacing depth. 

 
 
 
 
 
 
 
 
 
 
 

l. DP to accept and Right click to complete the Chain Commands. 

 

6. Once all of the tangent lines have been created, construct the vertical curves between them. We can deactivate Civil AccuDraw for this 

procedure. 
 
 
 
 
 

a. Set active feature definition to Alignment > Component > ALG Component Curve. 

 

b. Go to Geometry > Vertical > Curves > Profile Curve Between Elements > Parabola Between Elements.  

 

c. Following the heads up prompts, at VPI #2 select the first tangent line and when prompted select second tangent line. Be sure to 

keep your cursor above the tangent lines to ensure a sag curve will be created. 
 

d. Following the heads up prompts, in the Length field key in 220 and press ENTER to lock the value. 

 

e. Left-click to move to the next prompt. 

 

f. Set the Trim/Extend option to Both and Left-click to complete the command. 

 

g. Repeat the steps for VPI #3 (300’ Crest), #4 (200’ Sag), and #5 (300’ Crest).  
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Note that the vertical curve can be defined by either Length or K Value. 

 

Vertical Curve Types  

 
◼ Parabola – symmetric parabolic curve 
◼ Asymmetric – asymmetric parabolic curve  
◼ Circular – simple curve defined by radius 

 
7. Group the Jenks Road vertical geometry elements into a single complex element to create the vertical alignment.  

 

a. Set active feature definition to Alignment > Prop > ALG Centerline Minor Roadway. 

 

b. Go to Geometry > Vertical > Complex Geometry > Profile Complex By Elements tool. 

 

c. Following the heads up prompts, select the first tangent line near the beginning and then Left click to accept it. 

 

◼ Method: Automatic 

◼ Maximum Gap: 0.10 

◼ Name: Y11 

 

d. Left click to accept and create the complex profile element. 
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a. Set the newly designed profile as the Active Profile. 

 

b. Select the Element Selection tool.  

 

a. Select the complex profile element and hover your cursor over it until the context sensitive menu appears. 

 
 
 

 

b. Select the Set Active Profile tool. The newly designed vertical alignment will now be the active vertical alignment associated with 

the horizontal alignment. A relationship now exists between the horizontal and vertical geometry. Be aware that deleting the 
horizontal geometry or dropping the horizontal geometry will impact the vertical geometry.  

 

NOTE: Whenever you set the active profile, a 3D alignment feature will automatically be displayed in 3D. 

 
 

9. Create the Vertical Geometry Report. 
 

a. Select the Element Selection tool.  

 

b. Select the complex profile element and hover your cursor over it until the context sensitive menu appears. 

 

c. Select the Profile Report tool.  

 

d. Review the report, adjust the report formatting as needed. 

 

e. Close the report window. 
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Profile Complex By PI 
 

10. Click on File to gain access to the Backstage and Browse for r2635c_rdy_alg_l.dgn in the Alignment folder. 

 

11. Hold down the right mouse button, and select View Control > 2 Views Plan/Profiles. 

 

12. Set the profile of -L- in View 4. 

 

13. Set active feature definition to Alignment > Prop > ALG Centerline.  

 

14. Open the Design Standards Toolbar tool by going to Geometry > General Tools > Standards > Design Standards Toolbar. 
 

15. Set the following Active Design Standards:  

 

4 Lane\10% Super\70 MPH 

Stopping Sight Distance 

 

16. Turn on Civil AccuDraw and set it to Elevation (Z) mode. 

 
 
 
 
 

17. Go to Geometry > Vertical > Complex Geometry > Profile Complex By PI tool.  

 
18. Set the following in the Complex Element By PI toolbox: 

 
Vertical Curve Parameter: Enable  
Curve Length: Disable  
Slope: Disable  

Vertical Curve Type: Parabola 

Feature Definition: Use Active Feature  

Name: L 
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K Values 

 
K=L/A 
 
K = Rate of vertical curvature per 1% change in grade (unitless) 
L = Length of vertical curve (ft) 
A = Algebraic difference between exit and entrance grades | g2 - g1 | (%) 
 

By enabling Vertical Curve Parameter, the K Factor is used for each Crest and Sag vertical curve. The Vertical Curve Length is manually later 

rounded up to an even whole number, increasing the K Factor slightly, in the final steps. The K Values were based off Stopping Sight Distance 

(SSD), not the Passing Sight Distance (PSD), previously set with Design Standards. 

 

19. Using the following Table and the VPI information in View 4, Enter the Stations and Elevations.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
* Use engineering judgement. This manual preference is to round up to an even 50’ with a minimum of 15’ difference. More conservative 

rounding should be used for bridge and sub-regional tier projects. For curb sections when K is greater than 167 and the design speed is greater 

than 65 mph there is a threshold known as the “Drainage Maximum” and susceptible to hydroplaning (2011 AASHTO 3-156).   

VP
I 

Station Elevation 
Crest 

or 
Sag 

K 
Factor 

(70 
mph) 

Design 

VC Length 
Calculated 

VC Length 
Design* 

1 305+00.00 327.91     

2 311+58 318.18 S 181 458.23 500 

3 341+80 350.00 S 181 297.73 350 

4 356+00 388.31 C 247 870.58 900 

5 397+50 354.00 S 181 249.24 300 

6 415+00 363.63 C 247 603.64 650 

7 440+00 316.29 S 181 505.72 550 

8 473+25 346.23 C 247 391.17 450 

9 513+00 319.07 S 181 304.67 350 

10 549+20 355.27 C 247 448.91 500 

11 597+35 315.91 S 181 218.07 250 

12 625+00 326.62 C 247 549.89 600 

13 637+23 304.13 S 181 847.48 900 

14 659+50 367.45 C 247 1201.01 1250 

15 675+20 335.75 S 181 861.21 900 

16 685+77.70 364.72     
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20. Use the Profile Table Editor to round up the vertical curve Length.  
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21. Set as the Active Profile. 

 
 
 
 
 
 
 
 
 

22. Create a Report of the new profile.  

 
 
 
 
 
 
 

23. Review various types of report.  
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Profile Intersection Point 

 
In this section, you learn how to display the intersection of another profile as point. 

 
1. Continue in r2635c_rdy_alg_l.dgn. The focus should be on View 1 (plan view). 

 

2. Reference file r2635c_rdy_alg_y11.dgn. This file should have the active profile Y11.  

 

3. Go to Geometry > Vertical > Profile Creation > Profile Intersection Point.  
 

4. Following the heads-up display, when prompted to Locate Element to Show Intersection select the horizontal alignement -L-. 
 

5. When prompted to Locate Element Which Intersects select the horizontal alignement -Y11-. 
 

6. Right click to complete. A purple point near station 370+70 elevation 402 should appear in profile View 4. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. Select the intersection point to view its properties or delete it.  
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Special Drainage Ditch Profiles 

 
There are numerous methods of developing special ditch profiles and a variety of tools are supported. Most ditch profiles are developed with 

station and elevation information while not require vertical curves. Standard procedure calls for Profile Line Between Points in conjunction with 

Civil AccuDraw to enter station and elevation (or slope) information. A simpler preferred method is to use Profile Complex By PI and re-adjust 

the stations and elevations afterward (civil geometry). For Head and Tail ditches, one option is to utilize a horizontal element and develop the 

profile using any of the methods we’ve already learned. To display the ditch profile overlaid on the roadway centerline, we can use the Project 
Profile tool. Since most Special Lateral Ditches are based off the stationing of the roadway centerline, we can simply draw them in the same 

Profile Model View.  

 
1. Continue in r2635c_rdy_alg_l.dgn. The focus should be on View 4 (profile model view). 

 

2. Set the Active Feature Definition to Linear > Profiles > Profile_Special Ditch Right. 
 

3. Go to Geometry > Vertical > Complex Geometry > Profile Complex By PI.  
 

4. Set the following in the Complex Element By PI toolbox: 
 

Vertical Curve Parameter: Disable  

Curve Length: 0 

Slope: Disable  

Vertical Curve Type: Parabola 

Feature Definition: Use Active Feature  

Name: D_L-RT (alternative: RT_L-LAD_311+00-312+50) 

 

5. Zoom in the area around 311+00 and roughly draw three VPIs just below the 

proposed profile. 
 

6. Using Civil Geometry adjust each VPI to the exact Station and Elevation as listed below: 

   VPI STATION ELEVATION GRADE % 

1 311+00 315.99  

2 311+50 315.50 -0.9800 

3 312+50 315.78 +0.2800 
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7. Repeat the steps for Profile_Special Ditch Left. Each VPI Station and Elevation are listed below. 

 
 
 
 
 
 
 
 

 
 

Note the color scheme for Red is for Right side ditch and 

Lavender for Left side ditch. 

 
 

 
 

8. For demo purposes, after attaching the Alignment DGN file in Corridor Modeling the 

ditch profiles are now available in the Point Control dialog box. 

 
 
 

 

  

VPI STATION ELEVATION GRADE % 

1 311+50 315.58  

2 312+50 315.13 -0.4500 

3 313+50 315.82 +0.6900 
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Assessment 

 
1. True or False: Civil Geometry elements can be manipulated and edited. 

2. Which is NOT a Civil geometry tool? 

A. Set Active Profile 

B. Place SmartLine 

C. Define By Best Fit 

D. Complex by PI 

3. How can you use a Design Standard for geometry elements? 

A. Select the desired design standard first, then place the civil geometry element. 

B. All civil geometry elements automatically have design standards. 

C. Set Design Standard to a previously drawn geometry element. 

D. A and C. 

4. Civil cells can contain: 

 A. 2D geometry. 

 B. 3D geometry and surfaces. 

 C. Microstation unruled elements. 

 D. All of the above. 

5. True or False: The master Alignment (ALG) DGN file has all of the project horizontal and vertical alignments created in the file.  

*Bonus Question: Oak is a great instructor and deserves a raise.  
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Answer 

 

1. Correct Answer: True. Elements are easily manipulated by clicking on the element to display the element handlers. Then the element can 

be adjusted by clicking on the edit field and changing the value, or by selecting one of the graphic manipulators and dynamically moving. 

 

2. Correct Answer: B. Place SmartLine is a MicroStation tool, not a Civil Geometry tool. 

 

3. Correct Answer: D. Design Standards can be assigned before or after placement. 

 

4. Correct Answer: D. Civil cells can contain 2D and 3D geometry and surfaces as well as basic Microstation elements. 

 

5. Correct Answer: False. The master ALG DGN file should contain no alignments, but rather reference them. 

*Extra Credit: True 

 

 

 

 

  



Copyright © 2019 NCDOT DO NOT DISTRIBUTE – Printing for student use is permitted 104 

Glossary 

 
2D Point Feature   Contains no elevation (Z). 2D Point Features are defined and stored in plan model. 
 
3D Geometry 3D geometry is created in 3D model by mathematically combining the horizontal and vertical geometry to create 3D 

elements. These 3D geometry elements in turn define a design model. 
 
3D Model  This is created and managed automatically. User can interact with it but this is not usually required. The mathematical 

combination of Plan Geometry and Profile Geometry is stored in the 3D model. 
 
3D Point Feature   3D points can be defined in plan model or 3D model. They are stored in 3D model but represented in both plan and 3D. 
 
Active Object   The current object to which is added all geometry which is created. 
 
Active Profile  Of the multiple possible profiles for an element, the active profile is the one used for design. The active profile is combined 

with the horizontal geometry to build a 3D element which is used in the 3D model. 
 
Active Terrain Model One terrain model can be designated as “Active”. The active terrain model is the one used to display “existing ground”; in 

other words, the one which displays automatically in a profile model when it is opened. The active terrain model is also the 
one which is targeted by side slopes unless the template defines a different target by name. 

 
ALG  A legacy (proprietary) InRoads file containing coordinate geometry information, superelevation, and alignment information 

for a specific geometry project. 
 
Alignment    A linear feature which serves the special purpose of defining the centerline or baseline of a roadway. 
 
Apply Linear Template Applies a corridor template along a feature while hiding some of the complexity of creating a corridor. 
 
Apply Surface Template  Applies a corridor template to a terrain model for the purpose of creating components (such as pavement layers) under the 

terrain model. 
 
Arc Definition  Curve definition method generally used in roadway applications. The radius R is used to define the curve and is defined by 

the equation R=5729.58/D where the degree of curvature D is the central angle subtended by a 100‐foot arc. Set in the 
Design File Settings > Civil Formatting under Radius Settings. See also Chord Definition. 

 
Aspect  An angular measure of the direction that the face of a surface is oriented. The format of the value is dependent on angular 

settings in the DGN file. 
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Base Geometry  In many instances the geometry element will be trimmed. The original (or base), untrimmed element is always preserved as 
it is the storage for the rule. 

 
Boundary (Terrain Model) Used to constrain the external boundary of the terrain model. No triangles are created outside the boundary. In addition, 

any point data outside the boundary is ignored. 
 
Break Line  A surface feature consisting of a collection of spatial coordinates that have an implied linear relationship. No triangle side 

(in the triangulated surface) can cross over a break line. 
 
Break Void  A closed area of missing or obscured data that uses the elevations of each vertex, while the void lines between successive 

void coordinates are inserted as break lines. Therefore, break voids change the slope and elevations of the TIN surface. 
 
Cardinal Points  One of the points used to define the geometry of an alignment. Cardinal points include PC, PT, PI, and CC points for 

horizontal geometry and VPC, VPI and VPT for vertical geometry. 
 
Centroid (triangle)   Geometric center of a triangle in a terrain model. 
 
Chord Definition  Curve definition method generally used in railway applications. The radius R is used to define the curve, and is defined by 

the equation R=50/SIN(0.5*D) where the degree of curvature D is the central angle subtended by a 100‐foot chord. See also 
Arc Definition. 

 
Civil Cell  Used as a mechanism to preconfigure commonly used complex geometric layouts. These layouts will commonly be stored 

in DGNLIB files for reuse across multiple projects but it is possible and sometimes useful to store directly in an active DGN 
file for use in that single location. The civil cell will contain horizontal geometry and can also contain the vertical geometry. 

 
Civil Message Center  Used to display a continuous updating log of Civil messages, including warnings and errors. As errors and warnings are 

resolved, they are removed from the list. New messages are added whenever the conditions warrant. Most messages 
relate to civil geometry, superelevation, and corridor modeling. 

 
Civil Template  A civil design concept used most often for corridor modeling but also has other applications. The Civil Template defines the 

cross‐sectional shape of the object being modeled. This cross‐section is then “extruded along” a 3D geometry element to 
form the final model. The corridor template can create or target features such as road edges. The result is the creation of a 
corridor. 

 
Clipping Reference  Clipping allows you to remove areas of overlap when working with multiple corridors in a single surface. For example, in a 

corridor intersected by a crossing roadway, clipping would be used to remove all overlapped features within the 
intersection. 
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Complex Terrain Model  A terrain model created by merging or appending two or more terrain models. 
 
Context Toolbox  When an element is selected, hovering over the element provide a heads‐up and context sensitive toolbar which pops up at 

the cursor. This toolbar provides a few of the most commonly used tools which operate on the element selected element 
type. The first tool in this toolbar is always Quick Properties. 

 
Contour    A linear symbol representing points of equal elevation relative to a given datum. 
 
Contour, Isopach  Contours of a delta terrain model which represent cut and fill values as contours, not elevations. A positive contour 

represents fill, while a negative contour is cut. 
 
Contour, Major  The primary elevation line indicating a specific elevation in a surface model. Usually major contours are drawn with a 

heavier line weight or using a different color. Elevation text labels are usually drawn in association with major contours. 
 
Contour, Minor  A secondary elevation line indicating a specific elevation in a surface model. Minor contours are often drawn without 

special color or weight indexing and without elevation text labels. 
 
Corridor    A civil object used for modeling a roadway and is automatically managed by the corridor modeling tools. 
 
Cross Section Model DGN models (extracted perpendicular to defined horizontal geometry) with special station elevation coordinates defined 

and other specialized capabilities such as view exaggeration. Cross section stations match the interval in the template drop 
when a corridor is used as the basis. When horizontal geometry is utilized, the left/right offsets and interval are user‐
defined. 

 
Curve Stroking  Stroking is the process of automatically adding shots to the terrain model or corridor by interpolating new shots from the 

curved sections of the data. This distance is used to interpolate new shots along the curved element in corridor processing 
and applying linear templates. This value is used as a perpendicular minimum distance from chords generated along the 
arc. Chords are drawn along the arc and the perpendicular distance is measured from the middle of each chord to the arc. If 
this distance is larger than the Curve Stroking, the process is repeated with a shorter chord length. This process is repeated 
until the end of the curve is reached. The flatter the curve, the fewer number of points will be calculated. The steeper the 
curve, the greater number of points that will be calculated. 

 
DDB File    GEOPAK file (Design DataBase) which contains features definitions, associated symbology and annotation settings. 
 
Delta Terrain Model A surface containing data derived from the difference in elevation between two terrain models or a terrain model and a 

plane. 
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Dialog  The tool settings box for the active command. The dialog shows all available options for a command. For most civil 

commands, most of the time, the dialog can be hidden and ignored since the user is given all necessary instruction and 
inputs by way of the cursor prompt. The dialog is necessary for configuring command customizations. 

 
Drape     The process of vertically projecting elements onto a surface so that the element elevations are defined by the surface. 
 
Drape Void  A closed area of missing or obscured data where the void coordinates are not included in the triangulation. Voids are 

inserted post triangulation. The void coordinates and lines are draped on the TIN surface. Even though a user must provide 
an elevation for the Drape Void vertices, the user elevations are changed to the elevation of the TIN surface at the XY Drape 
Void coordinate position. 

 
Element Template  MicroStation concept which allows preconfigured definitions for symbology and other miscellaneous display of 

MicroStation elements and civil features. 
 
End Condition   A specialized component of a corridor template which provides information tie into active surface. 
 
End Condition Exception Used to modify the behavior of an end condition solution without requiring the use of additional template drops. When an 

end condition exception is added, it must be edited to change its behavior. 
 
Explorer    MicroStation's interface for browsing elements in a DGN file. Extended by civil to accommodate specialized civil needs. 
 
Export to Native  Option to automatically or manually push horizontal and vertical geometry into native products (InRoads ‐ ALG, MX ‐ PSS 

and GEOPAK ‐ GPK). Applies only to SS3 and SS4. 
 
Feature  A Feature is anything that can be seen or located and is a physical part of your design, representing a real world thing. A 

feature’s definition is one of its properties. At any given time in the design process, the feature will have a Horizontal 
Geometry, a Vertical Geometry, 3D Geometry or a combination to define its location. 

 
Feature Definition  Used to define options when creating features. These are the items which are created in advance, usually used across 

multiple projects and define symbology, annotation and quantities. The feature definition is assigned (usually) in the plan 
model and profile/3D feature definitions follow from there. 

 
Feature Name   Each Feature can have a name. 
 
Gap     When a feature is trimmed the part(s) which are invisible on the base geometry. 
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GPK     A legacy (proprietary) GEOPAK database containing coordinate geometry information. 
 
Graphical Filter  Using in developing terrain models, an automated way of storing search settings for graphic elements when creating terrain 

models using 3D element. A graphical filter can be created for each feature (i.e., spots, breaks, voids) then the filters can be 
defined as a Graphical filter group. 

 
Heads Up Prompt   Command instructions are given in a heads up and dynamic prompt which floats at the cursor. 
 
Horizontal Geometry  The elements which define the horizontal layout of the design. These elements are 2D elements even if the DGN model is 

3D. Horizontal Geometry may be points, lines, arcs, spirals, splines or any combination in a complex element. 
 
Interval    When a feature is trimmed the part(s) which are visible on the base geometry. 
 
Island     Closed area used to place within a void, i.e., islands in the middle of rivers, lakes, etc. 
 
Key Station    Additional station added to the corridor to force processing at the particular location. 
 
LIDAR  (Light Detection And Ranging) is an optical scanning technology which scans ground and other physical features to produce 

a 3D model. 
 
Linear Feature  In plan model, composed of lines, arcs, spirals, splines or combinations of these. In profile model, composed of lines, 

parabola, splines or combinations of these. 
 
Linear Stroking  Stroking is the process of automatically adding shots to the terrain model or corridor by interpolating new shots from the 

linear sections of the data. Linear stroking is measured along the element. Interpolated vertices are added whenever the 
distance between the vertices is greater than the linear stroking value (in master units). 

 
Manipulators  The heads up, on‐screen editing interface. Only the most common properties are presented in manipulators. Manipulators 

are in two types: graphical and text 
 
Overlay Vertical   Within Corridor Model, tool used to develop a vertical geometry (based on milling and overlay parameters) and apply to  
Adjustment   the corridor. 
 
Parametric Constraints  Used to set up constraint value overrides for specified station ranges. 
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Plan Model  The usual DGN model, used for laying out horizontal geometry. Best practices will dictate that this is a 2D DGN model but 
3D DGN model can be used. This is where geometric layouts and corridor definitions are kept. The geometric layouts are 
not only alignments but also edges, parking, striping, sidewalks, etc. 

 
 
Point Features  Defined by a single X, Y (Z optional) location. A point need not be a feature. It may be defined as a non‐featurized point by 

way of AccuDraw, Civil AccuDraw, Snap or a data point. Non featurized points are used to control the construction of Linear 
Features. 

 
Point Cloud  A set of vertices in a 3D coordinate system and these vertices are defined the by X, Y and Z coordinates. Point clouds are 

usually created by 3D scanners. These devices measure a large number of points on the surface of an object and output a 
point cloud as a data file. The point cloud represents the visible surface of the object that has been scanned or digitized. 

 
Point Control  Used to modify the behavior of points in a template. These controls take precedence (they override) over existing 

constraints on the point. 
 
 
PSS File    MX file (Plans Style Set) which provides the graphical representation for the MX string features. 
 
Reference Element   The rule for some geometry is a calculation from another element. This other element is the reference element. 
 
Secondary Alignment Used to modify the direction of cross section processing. By default, as any given station, the cross section is created 

orthogonal to the main alignment/feature. If a secondary alignment exists, then that portion of the cross section which lies 
outside the secondary alignment will be orthogonal to the secondary alignment instead of the main alignment. 

 
SEP File / Method   Uses the superelevation settings which originated in GEOPAK. 
 
SMD File  GEOPAK file (Survey Manager Database) which contains survey features definitions and associated element and textual 

settings. 
 
Spot Elevation  A set of X, Y, Z coordinates representing a point on the terrain model surface. There is no implied relationship between 

regular points. 
 
SRL File / Method   Uses the superelevation settings which originated in MX 
 
Superelevation Lane  The closed area defined by the superelevation tools used for the limits of transition calculations and pivoting location. 
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Superelevation Section Area along a horizontal geometry element, where superelevation will be calculated. 
 
Target Aliasing  Used to create the desired results when working with multiple surfaces without having to edit the template from the 

template library. Target aliases can also be used so that one corridor can target the solution of another corridor. 
 
Template Drop   An area (usually defined by station limits) along a corridor to which a specific template is applied. 
 
Template Library   A file that stores definitions for templates, generally with an ITL file extension. 
 
Template Transition   The transition indicator occurs in the corridor between templates of differing names. 
 
Terrain Model   A three‐dimensional DGN element defined by spots, break lines, voids, holes, contours to model a surface on the earth. 
 
Tooltips    When hovering the cursor over an element or a handle, a tooltip is shown which gives explanatory information. 
 
Trace Slope  Upstream ‐ The indicated path follows the steepest ascent from a user‐defined point through the terrain model terminating 

at a high point or the edge of the terrain model. Downstream ‐ The indicated path follows the steepest descent from a 
user‐defined point through the terrain model terminating at a low point or the edge of the terrain model. 

 
Vertical Alignment   A linear feature in profile model which serves the special purpose of defining the elevations of an alignment. 
 
Vertical Geometry  The elements which define the vertical layout of a corresponding horizontal geometry element. These vertical elements are 

2D and are stored in a profile model. 
 
Void  Closed shape to demarcate areas of missing data or obscure areas. No point or break data located within the void area is 

utilized and no triangles are created inside the void areas. The Void coordinates are included in the triangulation and void 
lines between successive void coordinates are inserted as drape lines on the surface. Therefore, they do not change the 
slope or elevations of the surface. 

 
Watershed  Defined by either a low point within the terrain model or a low edge point along the terrain model edge, it's the closed area 

wherein all water would drain to the low point. 
 
XIN File    InRoads file which contains features definitions, associated styles, annotation, and other settings. SS2 and earlier versions.  


