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1. Intro and resources

• Free program (developed by SIL). Windows and 
Linux.

• Latest stable release is 8.3.12 (March 2018) 
http://software.sil.org/fieldworks/

• Primarily designed for creation of a lexicon, and 
interlinear glossing of texts with reference to 
the lexicon. Relational database, XML.

• Various other functions

http://software.sil.org/fieldworks/


1. Intro and resources

• Some training materials can be found at https://lingtran.net/Flex
• Demo movies and specific resources can be found under Help within 

FLEx.
• Training movies are also at 

http://downloads.sil.org/FieldWorks/Movies/Demo%20Movies.html
• To understand more of the conceptualisation of lexicography FLEx is 

based on, see Help > Resources > Introduction to Lexicography (by 
Ron Moe)

• Many discussions on the FLEx Google Group may help with issues you 
encounter: https://groups.google.com/forum/#!forum/flex-list

https://lingtran.net/Flex
http://downloads.sil.org/FieldWorks/Movies/Demo%20Movies.html
https://groups.google.com/forum/#!forum/flex-list


2. Setting up a database from scratch

• Open FLEx directly from the start menu/desktop; Create a new project
• Name the project, and select ‘vernacular’ and ‘analysis’ writing 

systems (‘vernacular’ can be looked up under ‘Define New’ – choose 
‘Lopit’ if you want, the provided sample data is for Lopit)

• Writing systems are important to consider – you can have a number of 
different writing systems within a project. Writing systems in FLEx are 
a combination of language and script properties. So, each language 
being used needs to be specified as a separate writing system, but 
there can also be multiple writing systems for the same language (e.g. 
for multiple orthographies or scripts).





2. Setting up a database from scratch

• After clicking ok, there will be a pop-up asking whether you want the 
project to include anthropological categories – up to you.

• Writing systems can be changed any time under Tools > Configure > Set Up 
Writing Systems (though it’s good to try to get it right early on)

• See Help > Resources > Technical Notes on Writing Systems for more info
• Once your new project is created, it is automatically saved, probably 

somewhere like C:\ProgramData\SIL\FieldWorks\Projects\
• You can change the default location for projects under File > Project 

Management > Project Locations and Sharing. When navigating to open 
your project, the .fwdata file within the project folder is the one you want. 
Associated files (e.g. configuration settings) are stored separately in here.





3. Entering new lexical items

• In the bottom-left, you should see that you are in Lexicon mode. In 
the top-left, you should also be in Lexicon Edit.

• Click Insert > Entry to add a new entry. In the window that pops up, 
you should (minimally) enter a lexeme form and a gloss. The default 
morpheme type is ‘stem’, but change this if you are entering e.g. 
grammatical morphemes. You can choose a part of speech under 
Category - there are options from a pre-set list but you may find you 
need to create custom categories for your project (these categories 
can also be found by going to the Grammar tab in the bottom-left and 
selecting Category Edit from the top-left).



3. Entering new lexical items

For example, enter
LEXEME: himo
GLOSS: nose
CATEGORY: Noun

Ok, and then another:
LEXEME: mesi
GLOSS: noses
CATEGORY: Noun



4. Adding more detail to lexical items

• If we want to add e.g. a distinction between plural and singular nouns for 
part of speech entries, we can go to Grammar mode and Category Edit and 
then, with ‘Noun’ highlighted, go to Insert > Subcategory, then click ‘The 
category I need is not shown..’ at the bottom. Add one with the name 
‘Noun Plural’ and abbreviation ‘n pl’, and another with ‘Noun Singular’, ‘n 
sg’. Then, go back to Lexicon mode and select the new category for each 
entry via the Grammatical Info drop-down menu in the right-hand pane.

• The display on the right will show you the minimal information you have 
entered. To see the full range of possible fields, tick Show Hidden Fields. 
Note that FLEx groups various fields together based on relatedness. Tip: If 
you drag the invisible border between the row headers and their entries 
almost all the way to the left, it will show you which/if MDF codes are used 
for the various FLEx fields.







4. Adding more detail to lexical items

• Different fields are associated with different writing systems. If you 
click on the left of each header, you can configure the writing systems 
for each field. If the one you want doesn’t show up as an option, it’s 
because the division between ‘vernacular’ and ‘analysis’ still applies, 
and you just need to go to Set Up Writing Systems and add e.g. the 
writing system you use for the ‘vernacular’ as an option under 
‘analysis’ as well. This could be useful e.g. if you want to have 
definitions in the relevant language as well as in English, or if you 
want to specify a writing system that uses a phonetic font, and takes 
an IPA keyboard as input, for pronunciations.



4. Adding more detail to lexical items

• Citation form: If you want to use a different CITATION FORM for the lexeme, 
for dictionary purposes, enter it here. If nothing is entered the LEXEME FORM
will be shown as headword.

• Definition: For dictionary display purposes, FLEx will use the gloss if there is 
nothing in the DEFINITION field, or otherwise use the full definition. E.g. for 
‘nose’, add a definition: ‘protrusion on face for drawing in air’.

• Pronunciation: (need to ‘Show hidden fields’) May not be required for your 
purposes; I normally use IPA here, with e.g. tone diacritics. For now just 
enter ‘ximo’ and ‘mesi’ in these fields. Note that extra fields such as 
LOCATION now show up, and things like CV PATTERN and TONE, which can later 
be populated under Bulk Edit Entries using Regular Expressions. 





4. Adding more detail to lexical items

• Location: This can be used to enter dialect information, and also to 
get around having to select a dialect/variant as ‘primary’ and have 
everything else entered as variants of that (But note: the most recent 
versions of FLEx now include a DIALECT LABELS main field which is 
better-suited). If you click in the LOCATION field, a small box will pop up 
on the right – this indicates that the field can only be populated from 
a controlled list. If you click it, and then click Edit the Locations List, 
you will be taken to Lists mode, and the Locations tab. Click Insert > 
Location name, and type ‘Dorik’ in the location name fields, and ‘Drk’ 
in the abbreviation fields. Add another – ‘Ngabori’ and ‘Ngb’.







4. Adding more detail to lexical items

• Reversals: Back to Lexicon tab – note that REVERSAL ENTRIES are listed 
within each sense. If you have already entered a lot of lexical data, 
these can be added, at least to start with, using Bulk Edit Entries and 
copying across glosses. You can enter as many reversals as you like for 
each sense. Add ‘nose’ and ‘snout’ manually for both entries (hit 
enter after ‘nose’, then click after the faint grey line that appears to 
enter ‘snout’).

• Reversals can also be viewed and edited under the Reversal Indexes
tab as well as Bulk Edit Reversal Entries in the top-left. (We can talk 
more about bulk editing later if there is time.)





4. Adding more detail to lexical items

• Semantic Domains: FLEx comes with a large set of semantic domains 
included (see http://semdom.org/v4/1 for details, also under Lists > 
Semantic Domains). If you click the SEMANTIC DOMAINS field in the right 
pane, it also requires list content, but if you are somewhat familiar 
with the domains, you can also start typing to bring up the relevant 
options. Start typing ‘head’, and then click to select 2.1.1 (for both 
entries). You can have multiple semantic domains – start typing 
‘breathe’ and then click to select 2.2.1. If you then click on Classified 
Dictionary in the top-left, you will see what is covered.  

http://semdom.org/v4/1




4. Adding more detail to lexical items

• Bibliography or Source – these fields can be used for audio/text reference, 
or note about which person provided the info. Note that there is a 
BIBLIOGRAPHY field both within and external to individual senses.

• Various other fields which may be useful for your purposes – ETYMOLOGY, 
SCIENTIFIC NAME, EXAMPLE, etc. Custom fields can also be added under 
Tools>Configure>Custom Fields, though this should only be done with 
careful consideration of their purpose in the database.

• Now you have data in extra fields, but those fields don’t all show up in the 
main window. Go to Tools > Configure > Columns to choose what you want 
to see, in what order. Select REVERSALS on the left, click Add to copy across, 
then press arrow buttons to reorder highlighted field if needed. Add 
SEMANTIC DOMAINS too.









5. Importing lexical data, from e.g. Toolbox

• FLEx can import Standard Format Lexicon data (File > Import)
• However, if you want to import Toolbox data, you will probably need to do 

some tidying up of the data (using Regular Expressions) to ensure that the 
fields you have used map as well as they can to FLEx, and to check for 
inconsistencies.

• Best resource to begin with is Help > Resources > Technical Notes on SFM 
Database Import, especially pages 19-20, which explain which MDF fields 
correspond to which FLEx fields, and importantly, which part of the lexical 
entry it goes with (seeing as things are bundled together).

• Note that for some fields, FLEx will only accept entries from a finite list (e.g. 
as for pronunciation location, earlier), so if you are importing data for 
those fields, you need to make sure the list entries are set up beforehand



5. Importing lexical data, from e.g. Toolbox

• Try a simple import with the file 01_lpx_import.db, found at 
bit.ly/FLEx2020 . File>Import>Standard Format Lexicon, then click 
Next under ‘Overview and backup’ (but note: in other circumstances 
you should definitely make a backup before importing new data), 
select the file under File and Settings, then Next, click Next under 
language mapping, then stop at ‘Content mapping’ – fields in red will 
need checking, otherwise data in these fields won’t be imported.

http://bit.ly/FLEx2020






5. Importing lexical data, from e.g. Toolbox

• The field \ph needs a writing system associated with it. Select this 
row, click Modify, and change Language Descriptor in the drop-down 
menu to Vernacular (which will be fine in this case). Click ok.

• We need to map \plo, the ‘pronunciation location’, to the correct 
field. Click Modify, untick Default – Import residue auto, go through 
list until you find Pronunciation Location, also change the Language 
Descriptor to English, click OK, Next. (FLEx will automatically save a 
mapping file for future use). Click Next again on Key markers (will 
matter in some cases but not here – these tell FLEx which fields 
indicate a new bundle of grouped fields), Next, Next again on 
Character Mapping, then Generate Report (have a look, then close), 
then Next, Finish.











5. Importing lexical data, from e.g. Toolbox

• Explore the imported data a bit, and think about how you might want 
to handle relationships between entries – this will depend on your 
project and language. In our project, for a language with largely 
unpredictable number marking, we have e.g. entered plurals as 
‘complex forms’ of the singular, and then in the entry for the plural, 
decided whether it needs to display as a separate headword with the 
box ‘Show minor entry’. We also linked between dialectal variants 
using customised cross-references, which are edited under Lexical 
Relations in Lists mode. There is also a list Variant Types, which can be 
customised to your requirements. 











6. Searching, sorting and filtering

• Each column displayed in Lexicon or Bulk Edit modes can have various 
sorts and filters applied. You can change the A-Z sorting by simply 
clicking in the header for each column to switch, but if you click the 
drop-down arrow and go to ‘Filter For’ you can do more. You can also 
tick ‘Match for Regular Expression’, and if you then click the arrow on 
the right of the text box, it will show you some of the basic 
commands, with more complex examples under ‘Regular Expressions 
Help’.





6. Searching, sorting and filtering

• This is very useful for working with the data and finding patterns. You 
can add custom fields if there other things you’d like to see emerge 
from your lexical database, e.g. we have used custom fields for 
number marking morphemes and number marking type, which 
helped to identify some patterns in what has been assumed to be a 
completely irregular system.

• Filtering for blanks helps you to identify where data is missing, and 
filtering via ‘Choose’, where it shows up (e.g. for Semantic Domains) 
allows you to select items from set lists.





6. Searching, sorting and filtering

• The sort and filter functions are very useful for bulk editing – for 
example, if we want to sort by all items without a reversal entry, and 
then automatically copy across from the gloss field to the reversal 
field (or perform more sophisticated edits, to populate e.g. CV 
patterns).

• Always make a back-up before doing any bulk edits!







7. Backing up / restoring projects

• Backing up can be done within FLEx – go to File > Project 
Management > Back-up this Project. It will store backups in a 
separate folder (in the main FLEx folder), bundled into a .fwbackup
file.

• If you need to restore a project from a .fwbackup file, choose ‘Restore 
a project from a backup file’ when opening FLEx from the Start menu.

• FLEx automatically saves at regular intervals, but always good to make 
frequent backups, especially during periods of intensive work on the 
database.





8. Texts and glossing

• It is now possible to export Elan-transcribed texts as .flextext, import 
these into FLEx, do interlinear glossing, and then export the enriched 
files and import them back to Elan.

• The best guide is the set of materials at: 
http://www.mpi.nl/tools/elan/tp/how-to/ELAN-FLEx-ELAN.zip

• The Elan template needs to formatted a specific way to be read into 
FLEx – if you have any intention of using both pieces of software, you 
should set up your Elan template early on and use it consistently.

http://www.mpi.nl/tools/elan/tp/how-to/ELAN-FLEx-ELAN.zip




8. Texts and glossing

• You can also directly type/copy in new texts, if they are based on 
written material only.

• To try this, select the Texts and Words pane in the bottom-left. If 
there are no existing texts, it will automatically start and new one and 
confirm the writing system. Give the text a title up the top, in the field 
for the Lopit writing system – ‘Ikudo ho hiwaru’ (English: ‘The squirrel 
and the leopard’). (More metadata can be added in the Info view.)





8. Texts and glossing

• Open the file 02_text_to_copy.txt (bit.ly/FLEx2020) and copy 
the lines of text into the Baseline view, which you should already be in.

• Now go to the Analyze view – we can see that some glossing has been 
automated (highlighted in blue until it has been checked). There are 
gaps – in these cases, we need to edit morpheme breaks. (If time, we 
can do this now.)

• We can add free translations beneath the glossed lines – copy from 
03_translation.txt

http://bit.ly/FLEx2020








8. Texts and glossing

• Go back to the Baseline view and add another line, ‘Ojo hiwaru de 
ikudo “Ee”. Go back to Analyze, and you should find that everything 
but the last word has been glossed.

• You can add this last word to the lexicon via Create New Entry in the 
pop-up menu third line – decapitalise it for the lexicon, and add the 
English gloss as ‘yes’.







9. Export possibilities

• In Lexicon mode, under Dictionary, you will see what the dictionary 
currently looks like, with any sorts or filters that have been applied.

• The display of main entries, minor entries etc. is endlessly 
customisable under Tools > Configure > Dictionary (but it can take a 
lot of trial and error to find the optimal display). If you are ordering 
how the fields will display, remember that various fields are grouped 
together – only the higher-level groupings can be reordered freely, 
and then other fields can be reordered within those.

• The Reversal Indexes can also be configured, with more limited 
options







9. Export possibilities

• Under File > Export, there are various options for exporting full or 
filtered lexical data, e.g. as XML.

• To export for presentation purposes, e.g. printing, you need to install 
Pathway http://software.sil.org/pathway/

• Using this, you can export directly to pdf, for sharing drafts etc, or to 
e.g. Open Office for further formatting. Various ‘styles’ are available, 
and can be modified.

• You can also export to a format that can be used with SIL’s Dictionary 
App Builder – see https://software.sil.org/dictionaryappbuilder/

http://software.sil.org/pathway/
https://software.sil.org/dictionaryappbuilder/






9. Export possibilities

• Interlinear texts can also be exported. If you are using an Elan-FLEx-
Elan workflow, select the FLEXTEXT format.

• It is recommended that you thoroughly test your workflow with one 
short text first to make sure your Elan template has been formatted 
correctly and the data is preserved between the programs





Now – short break, then open session for practical work and questions
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